Асинхронный режим передачи (ATM) : ATM to Frame Relay Interworking

Взаимодействие служб Frame Relay с ATM (FRF.8 - режим трансляции)

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Функция межсетевого взаимодействия служб Frame Relay (FR) и ATM позволяет устанавливать соединение между конечными пользователями FR и ATM. Это основывается leavingcisco.comна соглашении по реализации Форума Frame Relay (FRF.8), которое указывает, что конечная станция FR может связаться с Конечной станцией ATM при условии, что существует маршрутизатор, выполняющий спецификации, данные в FRF.8 в программном обеспечении между с двумя окончаниями станции.

В этом документе представлен пример конфигурации взаимодействия FR со службой ATM с помощью FRF.8 (режим трансляции) на LightStream 1010. Эта конфигурация также работает на Catalyst 8510 MSR и 8540 MSR.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основываются на Cisco релиз 12.0 IOS� (3c) W5 (9).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/10409/frf8.gif

Параметры формирования трафика FR, которые использовались в этом примере конфигурации в маршрутизаторе 1:

  • Согласованная скорость передачи данных (CIR) = 64 Кбит/с

  • Согласованный пакет (Bc) = 8000

  • Превышение объема блока данных (Be) = 8000

Примечание: Для подробного объяснения о том, как устранить неполадки соединений Frame Relay Traffic Shaping, обратитесь к командам показа для Frame Relay Traffic Shaping.

Конфигурации

Эти конфигурации используются в данном документе:

Примечание: Эти конфигурации содержат информацию, важную только для Frame Relay к ATM Service Interworking.

Маршрутизатор 1
controller E1 5/0 
 channel-group 30 timeslots 1-31 
! 
interface Serial5/0:30 
 ip address 12.12.12.2 255.255.255.0 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF. It should match the switch.
 
 no fair-queue 
 frame-relay traffic-shaping

!--- Enabling FR traffic shaping on this interface.
          
 frame-relay class test-iwf 
 frame-relay map ip 12.12.12.1 123 broadcast 
! 
map-class frame-relay test-iwf 
 no frame-relay adaptive-shaping

!--- Traffic shaping parameters configured.

 frame-relay cir 64000 
 frame-relay bc 8000 
 frame-relay be 8000

Коммутатор ATM
frame-relay connection-traffic-table-row index 123 64000 
8000 128000 8000 vbr-nrt 123 
! 
controller E1 4/0/0 
 clock source free-running 
 channel-group 30  timeslots 1-31 
! 
interface Serial4/0/0:30 
 no ip address 
 no ip directed-broadcast 
 encapsulation frame-relay IETF

!--- The FR encapsulation used is IETF.

 no arp frame-relay 
 frame-relay intf-type dce

!--- Interface type is dce, because it is providing clocking.

 frame-relay pvc 123 rx-cttr 123 tx-cttr 123 service translation 
 interface  ATM0/0/0 0 123 

!--- This command makes the translation from          
!--- Frame Relay to ATM PVC 123.

Router-2
interface ATM2/0.123 point-to-point 
 ip address 12.12.12.1 255.255.255.0 
 no ip directed-broadcast 
 pvc 0/123

!--- Configured ATM PVC 0/123 with traffic shaping and          
!--- oam-pvc management enabled.
 
 vbr-nrt 163 81 49 
 broadcast 
 oam-pvc manage 
 encapsulation aal5snap

Параметры формирования трафика на маршрутизаторе 2 могут быть получены из таблицы трафика Подключения по Frame Relay на Коммутаторе ATM (см. раздел).

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • показать интерфейс локального управления ретрансляции кадров

  • show frame-relay map

  • show frame-relay pvc

  • атм show atm vc interface 0/0/0

  • Connection-traffic-table-row show frame-relay

  • show atm connection-traffic-table

  • show frame-relay interface resource serial 4/0/0:30 all-information

Выходные данные, показанные ниже, являются результатом ввода вышеупомянутых команд на устройствах, показанных в схеме сети. Выходные данные показывают, что сеть функционирует исправно.

Маршрутизатор 1

Примечание: При подключении маршрутизатора Cisco к сторонней линии связи рекомендуется использовать интерфейс локального управления (LMI) инженерной группы по развитию интернета (IETF). Следует учитывать, что LMI — это оборудование Cisco, а Frame Relay — это оборудование DTE, поскольку оно получает сигнал синхронизации от коммутатора.

Router1# show frame-relay lmi 
 
LMI Statistics for interface Serial5/0:30 (Frame Relay DTE) LMI TYPE = CISCO
  Invalid Unnumbered info 0             Invalid Prot Disc 0
  Invalid dummy Call Ref 0              Invalid Msg Type 0
  Invalid Status Message 0              Invalid Lock Shift 0
  Invalid Information ID 0              Invalid Report IE Len 0
  Invalid Report Request 0              Invalid Keep IE Len 0
  Num Status Enq. Sent 1222             Num Status msgs Rcvd 1222
  Num Update Status Rcvd 0              Num Status Timeouts 2

Чтобы проверить, что dlci включены и сопоставлены соответствующему адресу IP, используется команда show frame-relay map.

Router1# show frame-relay map 

Serial5/0:30 (up): ip 12.12.12.1 dlci 123(0x7B,0x1CB0), static,
              broadcast,
              IETF, status defined, active

Для проверки статуса pvc Frame Relay используйте команду show frame-relay pvc . В выходных данных ниже мы видим, что Это активно.

Router1# show frame-relay pvc 
 
PVC Statistics for interface Serial5/0:30 (Frame Relay DTE)
 
              Active     Inactive      Deleted       Static
  Local          1            0            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0
 
DLCI = 123, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0:30
 
  input pkts 786           output pkts 549          in bytes 742312    
  out bytes 684503         dropped pkts 6           in FECN pkts 0         
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0         
  in DE pkts 0             out DE pkts 0         
  out bcast pkts 1          out bcast bytes 608       
  pvc create time 03:25:16, last time pvc status changed 03:09:30

Коммутатор ATM

Примечание: Термин "ATM-PX/Y/Z" относится к псевдоинтерфейсу.

ATMswitch# show atm vc interface atm 0/0/0
Interface         VPI  VCI   Type   X-Interface      X-VPI X-VCI Encap  Status 
ATM0/0/0          0    5     PVC    ATM2/0/0          0    43    QSAAL  UP
ATM0/0/0          0    16    PVC    ATM2/0/0          0    35    ILMI   UP
ATM0/0/0          0    101   PVC    ATM0/1/0          0    101          UP
ATM0/0/0          0    102   PVC    ATM0/1/0          0    102          UP
ATM0/0/0          0    123   PVC    ATM-P4/0/0        30   155          UP

Для отображения Frame Relay к подключениям по каналу ATM в коммутаторе используйте команду Connection-traffic-table-row show frame-relay, как показано ниже:

ATMswitch# show frame-relay connection-traffic-table-row 
Row            cir      bc     be      pir      fr-atm Service-category    ATM Row
                                            
100           64000   32768   32768   64000            vbr-nrt              100       
123           64000   8000    8000    128000           vbr-nrt              123       


ATMswitch# show atm connection-traffic-table 
Row      Service-category    pcr        scr/mcr       mbs         cdvt
1            ubr          7113539        none                     none
2            cbr              424                                 none
3            vbr-rt           424         424          50         none
4            vbr-nrt          424         424          50         none
5            abr              424           0                     none
6            ubr              424        none                     none
10           cbr            50000                                 none
11           cbr             1000                                 none
12           cbr            11700                                 none
100          vbr-nrt           81          81-0        50         none
123          vbr-nrt          163          81-0        49         none 
<-- (*)

2147483645*  ubr                0        none                     none
2147483646*  ubr                1        none                     none
2147483647*  ubr          7113539        none                     none

(*) При создании строки таблицы трафика для соединения с поддержкой Frame Relay, следует ассоциировать индекс строки таблицы ATM, где параметры формирования трафика ATM автоматически вычисляются с помощью спецификаций межсетевого широкополосного интерфейса (B-ICI) версии 2.0 (см. формулы).

ATMswitch# show frame-relay interface resource serial 4/0/0:30 all-information 
Encapsulation: FRAME-RELAY
Resource Management configuration:
    Input queues (PAM to switch fabric):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Output queues (PAM to line):
       Discard threshold: 87% vbr-nrt, 87% abr, 87% ubr
       Marking threshold: 75% vbr-nrt, 75% abr, 75% ubr
    Overflow servicing for VBR: enabled
  Available bit rates (in bps):
     1920000 vbr-nrt RX, 1920000 vbr-nrt TX
     1920000 abr RX,     1920000 abr TX
     1920000 ubr RX,     1920000 ubr TX
    Overbooking: disabled
Resource Management state:  Allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX
  Actual allocated bit rates (in bps):
     64000 vbr-nrt RX, 64000 vbr-nrt TX
     0 abr RX,     0 abr TX
     0 ubr RX,     0 ubr TX

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 10409