Протокол IP : Serial Tunnel (STUN)

Руководство по протоколу BSC и последовательному туннелированию блоков (BSTUN)

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ разработан, чтобы помочь вам настраивать и использовать протокол канального уровня Бинарной синхронной связи (BSC) и Блочное Последовательное туннелирование (BSTUN) на маршрутизаторах Cisco. Это также помогает вам устранять проблемы, которые могли бы произойти.

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем:

  • Понятия Бинарных синхронных связей (BSC).

  • Основное представление основных данных, обрабатывающих принципы.

Используемые компоненты

Сведения в этом документе основываются на Cisco IOS?? программное обеспечение с набором функций IBM.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Обзор системы

Рисунки 1 и 2 показывают, как существующая ссылка BSC между двумя устройствами может быть реконфигурирована для использования маршрутизаторов Cisco. Это предоставляет то же логическое соединение без любых изменений к существующим устройствам BSC.

Рисунок 1 - существующая настройка BSC

bsc_guide_1.gif

Рисунок 2 - настройка BSC с маршрутизаторами Cisco

bsc_guide_2.gif

Маршрутизаторы Cisco транспортируют все блоки BSC между этими двумя устройствами, с помощью Блочного Последовательного туннелирования (BSTUN) инкапсуляция. Для каждого блока BSC, который получен от линии, байты адреса и служебные байты добавлены для создания кадра BSTUN, тогда BSTUN используется для отправки к маршрутизатору правильного места назначения.

Конфигурация BSC/BSTUN

На чистом маршрутизаторе выполните эти команды в заказе, в котором они перечислены.

Глобальные команды

[никакой] IP-адрес bstun peer-name

IP-адрес определяет адрес, которым это Одноранговое телефонное соединение BSTUN известно другим Одноранговым телефонным соединениям BSTUN, которые используют транспорт TCP.

Примечание: Если адреса TCP/IP используются в инструкциях маршрута, эта команда должна быть настроена в Cisco IOS Software Release ранее, чем Выпуск 11.3 или это должно быть настроенный.

[no] bstun protocol-group group-number {bsc | Bsc-local-ack | adplex | adt-опрашивает | Adt-poll-select | Adt-vari-poll | diebold | async-generic | mdi}

Это - команда global для соединения номеров группы к именам протокола. Group-number является десятичным целым числом между 1 и 255. bsc | Bsc-local-ack | adplex являются предопределенными ключевыми словами протокола BSTUN. Для получения дополнительной информации обратитесь к Определению Группы протоколов в Настройке Последовательный Туннель и Блочный Последовательный Туннель.

Выбор типа группы важен, чтобы определить, использовать ли passthru или локальное подтверждение (local-ack).

Примечание: Эта команда должна всегда настраиваться.

Команды интерфейса

encapsulation bstun

Это - интерфейсная команда, которая настраивает функцию BSTUN на определенном последовательном интерфейсе. Эта команда должна быть настроена на интерфейсе перед дальнейшим BSTUN, или команды BSC настроены для этого интерфейса.

[no] bstun group group-number

Это - интерфейсная команда, которая определяет Группу "BSTUN", которой принадлежит этот интерфейс. Каждый поддерживающий BSTUN интерфейс на маршрутизаторе должен быть размещен в ранее определенную Группу "BSTUN". Пакеты только перемещаются между поддерживающими BSTUN интерфейсами, которые находятся в той же группе. Group-number является десятичным целым числом между 1 и 255.

Номер группы уже определил, выполняет ли этот интерфейс local-ack или passthru.

[no] bsc mode

Вот список некоторых основных опций. Для полного списка обратитесь к Настройке параметров двоичной синхронной передачи данных на последовательном интерфейсе в Настройке Последовательный Туннель и Блочный Последовательный Туннель

Никакие кадры не приняты или переданы, пока режим не настроен для одних из этих параметров настройки:

  • конкуренция — Это устанавливает ссылку BSC, которая связана с последовательным интерфейсом, чтобы быть для станции BSC "точка-точка". Только 3780, и только в режиме Passthru.

  • состязательный virtual-address — Сначала доступный в программном обеспечении Cisco IOS версии 11.3. Используемый с набираемой конкуренцией, чтобы позволить несколькам удаленных устройств использовать тот же интерфейс в маршрутизаторе конечного хоста.

  • состязательный набором таймаут — Сначала доступный в программном обеспечении Cisco IOS версии 11.3. Используемый в маршрутизаторе конечного хоста для конкуренции. Позволяет несколькам удаленных устройств мультиплексировать по тому же физическому интерфейсу.

  • основной — Определяет это, маршрутизатор действует как основной конец ссылки BSC и что подключенное устройство или устройства являются подчиненными станция BSC.

  • вспомогательный это, маршрутизатор действует как дополнительное окончание ссылки BSC и что подключенное удаленное устройство является станцией управления BSC (такой как процессор интерфейсной части [FEP] или другое основное устройство).

Если эта команда не будет настроена тогда, то протокол линии связи на интерфейсе не работает, и интерфейс не будет работать.

Настройка маршрутизации TCP

В этой конфигурации система транспортировки является TCP/IP. Это может работать на основе любого из физических средств связи, по которым может работать TCP/IP.

[никакой] bstun route весь IP-адрес tcp

[никакой] IP-адрес tcp количества address address bstun route

IP-адрес совпадает с IP-адресом, который задан в peer-name маршрутизатора - партнера.

Конфигурация последовательного маршрута

В этой конфигурации туннель использует Cisco составляющий собственность транспорт. Это намного быстрее, чем TCP/IP, но пробегается через последовательный интерфейс только.

[no] bstun route all interface serial interface-number

[никакой] цифровой интерфейс address address bstun route последовательный interface-number

Конфигурация прямой транзитной пересылки Frame Relay

В этой конфигурации туннель использует оригинальную форму серийной инкапсуляции по Frame Relay, который работает с такой скоростью, как последовательные маршруты.

[никакой] цифровой интерфейс address address bstun route последовательное количество dlci dlci interface-number

Выполните эту команду на Интерфейсе Frame Relay:

[no] frame-relay map dlci-number bstun

Прямая конфигурация локального подтверждения приема Frame Relay

Эта конфигурация использует Управление логическим Каналом (LLC), введите 2 (LLC2) по Инкапсуляции Frame Relay, чтобы дать локальное подтверждение и от начала до конца открыть сеанс контроль. Ключевое слово lsap должно быть включено; в противном случае инкапсуляция пойдет как passthru.

[никакой] цифровой интерфейс address address bstun route последовательный lsap lsap количества dlci dlci interface-number

Выполните эту команду на Интерфейсе Frame Relay:

[no] frame-relay map dlci-number llc2

Примечание: Для получения дополнительной информации обратитесь к Определению, Как Кадры Переданы в Настройке Последовательный Туннель и Блочный Последовательный Туннель.

Конфигурация Passthru

Почему транзитная пересылка?

Транзитная пересылка является основным туннелирующим режимом. Каждый кадр, который передан между устройствами, передан, неизменен через туннель BSTUN. Порядковый номер и аппаратный адрес добавлены, чтобы гарантировать, что задержки через сеть не влияют на операцию протокола. Прибытие последних опросов или сигналов конца передачи (EOT) могло значительно разрушить существующий сеанс.

Когда использовать транзитную пересылку

Транзитная пересылка должна использоваться при этих обстоятельствах:

  • Данные, которые передаются, не имеют явного кадра подтверждения передаваемым для подтверждения целостности данных.

  • Протокол не чист 3270.

  • Пользователь хочет сквозные возможности подключения устройства, и задержки сети являются маленькими.

Конфигурация Local-Ack

Почему Local-Ack?

Local-ack удаляет издержки передачи всех управляющих фрейм по туннелю. Когда хост передает первый опрос к контрольному модулю, кадр специального управления передан по туннелю для начала удаленного опроса того аппаратного адреса. Как только удаленное устройство указывает, что произошло, управляющий фрейм передается узловому маршрутизатору, чтобы сказать ему отвечать на опросы. Когда удаленное устройство выключается, индикация передается по туннелю, чтобы сказать узловому маршрутизатору больше не отвечать на опросы.

Когда использовать Local-Ack

Local-ack может использоваться при этих обстоятельствах:

  • 3270 BiSync (двоичная синхронная передача данных) используются.

  • Задержка сети вызывает превышение времени ожидания сеанса BiSync (двоичная синхронная передача данных).

  • Дополнительный трафик по глобальной сети (WAN) является проблемой.

Опции Local-Ack

[no] bsc pause time

Эта команда задает период времени между запуском одного цикла опроса и следующим. Значение по умолчанию равняется 30 (т.е. 30 десятых частей или 3 секунды).

Когда существуют только один или два контроллера на интерфейсе BiSync (двоичная синхронная передача данных), это - хорошая идея настроить эту команду. Это эффективно замедляет опрос и выделяет больше циклов ЦПУ подключенному устройству.

[no] bsc poll-timeout time

Это наборы команд таймаут для опроса или выбирает последовательность в модулях десятых частей секунды; значение по умолчанию равняется 30 (т.е. 30 десятых частей, или 3 секунды).

Самое маленькое значение времени определено скоростью подключенного устройства, и это более интересно в конце хоста. Если хост, который ведет маршрутизатор, уменьшит свой таймаут до наименьшего возможного значения, то будет повышение производительности, когда отказали некоторые устройства.

[no] bsc retries retry-number

Это наборы команд количество повторных попыток для попытки перед устройством считают мертвым. Диапазон равняется 1 - 100; по умолчанию является 5 повторными попытками.

Значение "no bsc servlim"

Эта команда задает servlim (активный по сравнению с неактивным соотношением значений опроса конечной станции) значение. Диапазон равняется 1 - 50; значение по умолчанию — 3.

[no] bsc spec-poll

Эта команда говорит хосту обрабатывать определенные опросы как общие опросы. Используйте эту команду, когда вы будете работать с Тандемными хостами.

Для дополнительных сведений обратитесь к Настройке параметров двоичной синхронной передачи данных на последовательном интерфейсе в Настройке Последовательный Туннель и Блочный Последовательный Туннель.

Настройка конфликта

Почему конкуренция?

Конкуренция является 3780 вариантами BiSync (двоичная синхронная передача данных). Нет никаких адресов модуля управления. Устройства связаны точка-точка. Обычно удаленное устройство набирает в центральное место расположения и предполагает, что не существуют никакие другие устройства.

Когда использовать конкуренцию

Используйте конкуренцию только при использовании дистанционного ввода заданий (RJE), 3780, и 2780 протоколов. Как только вы определили конкуренцию, гарантируйте, что оба конца настроены для использования конкуренции.

Если вы не уверены, то выполняете эти шаги:

  1. Настройте основной "bsc".

  2. Включите пакет BSC отладки.

  3. Заставьте подключенное устройство начать опрашивать.

Сообщения с 1 bytes 2D указывают на конкуренцию. Любые байты перед 2D не 3780.

Приоритеты

При сравнении со всем другим трафиком, который пробегается через Магистраль глобальной сети, трафик BiSync (двоичная синхронная передача данных) является очень маленьким и легко затопляемый другим трафиком. Потеря кадров в BiSync (двоичная синхронная передача данных) требует длинного интервала восстановления, который с готовностью очевиден до конца устройства. Для уменьшения этой проблемы приоритизация трафика BiSync (двоичная синхронная передача данных) рекомендуется. Можно расположить по приоритетам трафик или с приоритетами BSTUN или с настраиваемой организацией очереди.

  • Постановка в очередь с установлением приоритетa является средством маршрутизации, в котором кадры в очереди вывода интерфейса расположены по приоритетам на основе различных характеристик, таких как размер пакета или тип интерфейса.

    Организация очереди приоритетного вывода позволяет администратору сети определять четыре приоритета трафика??? высокий, обычный, средний, и низко??? на данном интерфейсе. Поскольку трафик входит в маршрутизатор, он назначен на одну из этих четырех очередей вывода. Пакеты на очереди наивысшего приоритета переданы сначала. Когда та очередь пустеет, трафик на следующей очереди наивысшего приоритета передан и т.д. Этот механизм гарантирует, что во время перегрузки данные с наивысшим приоритетом не становятся задержанными трафиком с меньшим приоритетом. Однако, если трафик, передаваемый данному интерфейсу, превышает пропускную способность того интерфейса, трафик с меньшим приоритетом может испытать значительные задержки.

    Например, при создании IP более высоким приоритетом, чем IPX на последовательных соединениях глобальной сети (WAN) трафик BSC в TCP/IP использует преимущества факта, что IP передается с более высоким приоритетом.

  • Настраиваемая организация очереди позволяет клиенту резервировать процент полосы пропускания для указанных протоколов. Клиенты могут определить до десяти очередей вывода для обычных данных и дополнительную очередь для системных сообщений, таких как сообщения поддержки активности LAN (пакеты маршрутизации не назначены на очередь системы). Сервис маршрутизаторов Cisco каждая очередь последовательно: они передают конфигурируемый процент трафика на каждой очереди, прежде чем они перейдут к следующему. При использовании настраиваемой организации очереди можно гарантировать, что критически важным данным всегда назначают определенный процент от пропускной способности, в то время как также обеспечена прогнозируемая пропускная способность для другого трафика.

    Для обеспечения этой функции маршрутизаторы Cisco определяют, сколько байтов должно быть передано от каждой очереди, на основе интерфейсной скорости и настроенного процентного значения. Когда расчетное количество байтов от данной очереди было передано, маршрутизатор завершает передачу текущего пакета и переходит следующей очереди. В конечном счете каждая очередь обслуживается в порядке круговой очереди.

Обратитесь к Настройке Последовательный Туннель и Блочный Последовательный Туннель, и обратитесь к Решению Который Политика Организации очереди Использовать в Обзоре управления перегрузками сети.

[no] priority-list list-number protocol bstun queue [gt | размер пакета lt] [обращается к группе "BSTUN" bsc-адрес]

Выполните команду глобальной кофигурации priority-list protocol bstun для установления приоритетов помещения в очередь BSTUN на основе заголовка BSTUN. Не выполните форму команды для возвращения к обычным приоритетам.

[никакой] custom-queue-list [список]

Список является целым числом (1 - 16), который представляет количество настраиваемого списка очереди.

Конфигурация Keepalive

[no] bstun remote-peer-keepalive interval

Эта команда включает пакеты Keepalive Однорангового телефонного соединения BSTUN. Это отправляет запрос к узлу каждый раз, когда узел был тих для дольше, чем период интервала времени. Любой кадр перезагружает часы, не просто пакеты Keepalive. Значение по умолчанию — 30 секунд.

[no] bstun keepalive-count number

Когда это количество пакетов Keepalive пропущено последовательно, соединение BSTUN переведено в нерабочее состояние. Значение по умолчанию — 3.

Когда использовать пакеты Keepalive

Пакеты Keepalive полезны для защиты против туннельных простоев при выполнении local-ack и TCP/IP. Туннель переводит интерфейс в нерабочее состояние только, когда сигнал получен от удаленного. Если туннель не работает, "no signal" (сигналы отсутствует) когда-либо получаются.

В passthru это не необходимо, потому что требуется сквозное подключение.

команды "debug"

[no] debug bstun event group

Эта команда позволяет вам отлаживать соединения BSTUN и статус. Когда включено, это вызывает показ сообщений что установление show connection и общее состояние.

[никакой] размер буфера группы группы пакета BSTUN отладки displayed-bytes-size

Эта команда позволяет вам debug packet, который перемещается посредством ссылок BSTUN.

отображенный размер в байтах размера буфера группы группы [no] debug bsc packet

Эта команда позволяет вам отлаживать кадры, которые перемещаются через функцию BSC.

[no] debug bsc packet

Эта команда позволяет вам отлаживать кадры, которые перемещаются через функцию BSC. Это отслеживает все интерфейсы, которые настроены с количеством Группы "BSTUN".

[no] debug bsc event group

Эта команда позволяет вам отлаживать события, которые происходят в функции BSC. Если номер группы опущен, то он отслеживает все интерфейсы, которые настроены с количеством Группы "BSTUN".

команды "show"

show bstun

Эта команда отображает текущий статус BSTUN.

This peer: 10.10.20.108
 *Serial5 -- interface for ATM: R1710V421 (group 3 [bsc])
route  transport  address      state       rx_pkts   tx_pkts     drops
C2    TCP         10.10.10.107 open        655630    651332      0
 Serial6 -- interface for SEC: MST012  (group 2 [bsc])
route  transport  address      state       rx_pkts   tx_pkts   drops
C2     TCP        10.10.10.107 open        649385    644001      0

Проверка для этих проблем:

  • Государственный closed.

  • Отбрасывания.

  • Низкое количество пакетов.

    Примечание: Низкое количество пакетов не всегда указывает на проблемы. При выполнении local-ack количество состоит только из фреймов данных, который значительно меньше, чем фактическое количество кадров, которые переданы от хоста.

show bsc

Эта команда отображает текущий статус BSC.

В транзитной пересылке

BSC pass-through on Serial5:
Output queue depth: 0.
HDX enforcement state: IDLE.
Frame sequencing state: SEC.
Tx-Active: Idle. Rx-Active: False.
Tx Counts: 670239 frames(total). 670239 frames(data). 9288816 bytes.
Rx Counts: 651332 frames(total). 651332 frames(data). 651332 bytes.

Проверка для этих проблем:

  • Если HDX enforcement state застревает в состоянии кроме IDLE, то может быть проблема с подключенным устройством или с этим маршрутизатором. Это обычно указывает, что не отвечает устройство. Включите отладку события BSC. Если вы видите много сообщений no response from remote, первая проверка, что устройство активировано, то проверяет дуплекс. Если нет никаких сообщений и никакого последующего восстановления, то событие выполнения передачи было потеряно, и дефект был найден, что это может потенциально быть катастрофически.

  • Frame sequence state говорит вам который блок конечных состояний (FSM) проверить.

  • Если Rx-Active застревает в True, это указывает, что что-то плохо произошло с аппаратными средствами. Выполните закрытый и затем не закрытый для сброса интерфейса. Если это не работает, повторно загружает маршрутизатор.

В Local-Ack

BSC local-ack on Serial0:
Secondary state is CU_Idle.
Control units on this interface:

      Poll address: 40. Select address: 60 *CURRENT-CU*
      Current active device address is: 40.
      State is Active.
      Tx Counts: 87228 frames(total). 11 frames(data). 87353 bytes.
      Rx Counts: 87271 frames(total). 5 frames(data). 436312 bytes.

Total Tx Counts: 87228 frames(total). 11 frames(data). 87353 bytes.
Total Rx Counts: 174516 frames(total). 5 frames(data). 523557 bytes.

Если state застревает в TCU_Down, это указывает, что что-то вынуждает тот интерфейс остаться на второй год. Проверьте синхронизацию и режим BSC и гарантируйте, что ничто не не работает административно. Иногда, закрывающая команда, придерживавшаяся командой no shut, запускает интерфейс снова.

В целом

  • output queue depth, больше, чем 1, указывает на отставание на интерфейсе. Проверьте, что полудуплекс настроен должным образом.

  • Out of SYN-hunt mode означает или что интерфейс не работает или что был отключен получатель. Это, которое применяется к Rx-Active также, применяется здесь.

серийный номер show interface

Эта команда полезна для наблюдения счетчиков, которые привязаны к тому последовательному интерфейсу.

Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

Примечание: Любые ошибки означают проблемы.

Проверка для этих проблем:

  • aborts указывает на плохую передачу.

  • Кадры ignored являются кадрами, которые нарушают протокол синхронной передачи двоичных данных.

  • giants указывает или что MTU является слишком маленьким или последовательность BiSync (двоичная синхронная передача данных), плохо.

  • overrun указывает на нехватку ресурса ЦПУ.

  • CRC указывает на повреждение по линии (шумный или другой).

При использовании кабель DTE, и линия, кажется, выключается часто, или передачи отказывают, но получает, работают, то вы, возможно, должны были бы выполнить команду ignore-dcd. Это может быть проверено с анализатором протокола. Когда DCE передает, Перенесенные данные обнаруживают (DCD) повышены. Когда это заканчивается, DCD понижен так маршрутизатор, который не в состоянии ответить.

  • Hardware is CD2430 указывает на чипсет Усика.

  • Hardware is HD64570 указывает на чипсет Hitachi.

Hitachi использует символьные прерывания и созданное из программного обеспечения формирование кадров. Это не обрабатывает DCD хорошо. Усик использует прерывания кадра. Кадры созданы в ucode. Это имеет опции для игры с DCD. Важно, когда вы отлаживаете, что вы знаете тип интерфейса, потому что существуют некоторые различия между ними.

line protocol должен быть up. Если протокол линии связи не, то проверьте, что настроен режим BSC.

Serial5 is up, line protocol is up
  Hardware is CD2430 in sync mode
 MTU 265 bytes, BW 4 Kbit, DLY 20000 usec, rely 255/255, load 1/255
  Encapsulation BSTUN, loopback not set
    Half-duplex enabled.
      cts-delay 0 millisec
      dcd-txstart-delay 100 millisec
      dcd-drop-delay 100 millisec
      transmit-delay 0 millisec
      Errors - 0 half duplex violation
   Last input 10:27:12, output 1:07:12, output hang never
   Last clearing of "show interface" counters 4d11
   Output queue 0/40, 0 drops; input queue 0/75, 0 drops
   5 minute input rate 0 bits/sec, 0 packets/sec
   5 minute output rate 0 bits/sec, 0 packets/sec
      3223346 packets input, 3223356 bytes, 0 no buffer
      Received 0 broadcasts, 0 runts, 0 giants
      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
      3242346 packets output, 45259079 bytes, 0 underruns
      0 output errors, 0 collisions, 8 interface resets, 0 restarts
      0 output buffer failures, 0 output buffers swapped out
      4 carrier transitions
      DCD=up DSR=up DTR=up RTS=down CTS=down

Как устранять неполадки протокола IBM Bisync

Использование конечного автомата (FSM) для транзитной пересылки

Гарантируйте выполнение passthru. Необходимо найти, что придерживается корректный блок конечных состояний (FSM).

Посмотрите на сообщения отладки события. Существует два FSM для прохождения через. HDX-FSM является конечным автоматом принудительного полудуплексного режима. Это ведут независимо от того, настроена ли линия полнодуплексный или полудуплекс. Это пытается гарантировать, что очередь передачи маршрутизатора не становится накопившейся со старыми данными. FS-FSM гарантирует, что поздно структурирует через сеть, не уничтожают установленные сеансы.

Для определения, где посмотреть перейдите прямо к состязательному FSM, если настроена конкуренция. В противном случае посмотрите на состояние, в которое это следует за состоянием IDLE. Если вы видите SEC, посмотрели на вторичный FSM последовательности кадров. Если вы видите PRI, посмотрели на основной FSM последовательности кадров.

BSC: Serial6: HDX-FSM event: RXV old_state: PND_RCV. new_state: IDLE.
BSC: Serial6: FS-FSM event: SDI EOT old_state: SEC. new_state: IDLE.
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: FS-FSM event: NDI BID old_state: IDLE. new_state: SEC.
BSC: Serial6: New Address(C2) New NS(01)
BSC: Serial6: HDX-FSM event: TX old_state: IDLE. new_state: PND_COMP.
BSC: Serial6: HDX-FSM event: CmpOTH old_state: PND_COMP. new_state: PND_RCV.
BSC: Serial6: SDI: Data (1 bytes): 37
BSC: Serial6: HDX-FSM event: RXV old_state: PND_RCV. new_state: IDLE.

При рассмотрении таблицы вы видите вводы на левой части, и вы видите состояния на вершине. Каждая запись в столбце имеет форму {затем сообщают, действие}, действие сделано сначала, тогда переход происходит.

Как использовать FSM Local-Ack

Гарантируйте выполнение local-ack. Команда show bsc говорит вам, является ли интерфейс poller или опрошенным. От этого используйте соответствующий FSM ОТСУТСТВИЯ.

Типичные неполадки

Передача данных 3780 в конфигурацию 3270 и наоборот

caution Внимание.  :  Не делайте этого. Это не работает надежно.

Настроена маршрутизация к неверному узлу

Вы настроили все, и ничто не происходит. Вы включаете пакет BSC отладки на удаленном маршрутизаторе и ничего не видите. Вы тогда включаете пакет BSTUN отладки и все еще ничего не видите. На данном этапе включите debug bstun event; вы, вероятно, все еще ничего не видите. Вернитесь к маршрутизатору конца хоста и включите debug bstun event. Необходимо теперь видеть несколько сообщений, которые указывают на плохое соединение.

Config Bad Group Numbers

Когда любой конец туннеля настроен с количеством другой группы, это наблюдается. Данные или двигаются потоком из неверного интерфейса или сброшены на уровне BSTUN.

Local-ack и номера группы passthru не смешиваются. Гарантируйте, что определения protocol-group являются непротиворечивыми по всей сети. Устройства, которые выполняют конкуренцию (3780) также, должны быть на количестве другой группы от 3270.

Тандемные хосты

21:55:18: BSC: Serial4: SDI-rx: Data (5 bytes): C7C740402D
21:55:19: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:19: BSC: Serial5: SDI-tx: Data (5 bytes): C2C240402D
21:55:21: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:21: BSC: Serial4: SDI-rx: Data (5 bytes): C7C740402D
21:55:22: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:22: BSC: Serial5: SDI-tx: Data (5 bytes): 404040402D
21:55:24: BSC: Serial4: SDI-rx: Data (1 bytes): 37

Тандемы не повинуются строгим 3270 условным обозначениям. Они делают весь свой опрос с определенными опросами, который вызывает проблему для FSM ОТСУТСТВИЯ по умолчанию. Чтобы заставить тандемы работать должным образом, настройте bsc spec-poll на интерфейсе BSC secondary.

Разница между полнодуплексной и полудуплексной связью

Просто перепутать полнодуплексный и полудуплекс.

  • Полный дуплекс может передать данные одновременно между посылающей станцией и принимающей станцией.

  • Полудуплекс может передать данные только в одном направлении за один раз между посылающей станцией и принимающей станцией.

Посмотрите раздел по команде show bsc для получения дополнительной информации.

Если вы имеете анализатор протокола или доступный коммутационный бокс, подключаете анализатор в системе без маршрутизаторов.

  • Если RTS или CTS изменяют сигнал, то у вас есть полудуплекс; еще это - полный дуплекс.

  • Если DCD, кажется, изменяется много, и линия идет вверх и вниз или остается на второй год, у вас мог бы быть переключающийся DCD.

Примечание: В то время как удаленный маршрутизатор является полудуплексом, и наоборот, основной маршрутизатор может быть полным дуплексом. Это отдельные физические линии, и управляющие сигнал от интерфейсов не транспортируются по туннелю.

Примеры BSC и BSTUN

Пример ответа при отсутствии устройств (No Device)

Это - пример двух интерфейсов на дополнительном маршрутизаторе: один local-ack и другой passthru. Ни один не получает ответ от удаленного. Как только вы видите, что опросы входят в дополнительный маршрутизатор, необходимо определить то, что происходит в удаленном конце.

21:55:18: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:19: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:19: BSC: Serial5: SDI-tx: Data (5 bytes): C2C27F7F2D
21:55:21: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:21: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:22: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:22: BSC: Serial5: SDI-tx: Data (5 bytes): 40407F7F2D
21:55:24: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:24: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:25: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:25: BSC: Serial5: SDI-tx: Data (5 bytes): C2C27F7F2D
21:55:27: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:27: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D
21:55:28: BSC: Serial5: SDI-tx: Data (1 bytes): 37
21:55:28: BSC: Serial5: SDI-tx: Data (5 bytes): C2C27F7F2D
21:55:30: BSC: Serial4: SDI-rx: Data (1 bytes): 37
21:55:30: BSC: Serial4: SDI-rx: Data (5 bytes): C7C77F7F2D

При рассмотрении удаленного конца в случае passthru вы видите, что кадры проникают через туннель, но подключенное устройство все еще тихо.

BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: NDI: Data (4 bytes): C2C00037

Затем, определите, неисправно ли подключенное устройство или имеет ли маршрутизатор плохой передатчик: включите отладку событий.

BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: FS-FSM event: NDI BID old_state: IDLE. new_state: SEC.
BSC: Serial6: New Address(C2) New NS(01)
BSC: Serial6: HDX-FSM event: TX old_state: IDLE. new_state: PND_COMP.
BSC: Serial6: HDX-FSM event: CmpOTH old_state: PND_COMP. new_state: PND_RCV.
BSC: Serial6: Response not received from remote
BSC: Serial6: HDX-FSM event: T/O old_state: PND_RCV. new_state: IDLE.
BSC: Serial6: NDI: Data (4 bytes): C2C00037
BSC: Serial6: FS-FSM event: NDI EOT old_state: SEC. new_state: IDLE.
BSC: Serial6: HDX-FSM event: TX old_state: IDLE. new_state: PND_COMP.
BSC: Serial6: HDX-FSM event: CmpEOT old_state: PND_COMP. new_state: IDLE.
BSC: Serial6: NDI: Data (8 bytes): C24100C2C27F7F2D
BSC: Serial6: FS-FSM event: NDI BID old_state: IDLE. new_state: SEC.
BSC: Serial6: New Address(C2) New NS(01)

От следа придерживайтесь HDX-FSM. Если это застревает в состоянии PND_COMP, передатчик отказывает. Вероятно, имеет место, что не предоставляются никакие часы. Как вы можете видеть в выходных данных предыдущего примера, состояние PND_RCV достигнуто, и вы видите Response not received from remote, который указывает или к плохому, получают или неактивное устройство.

Пример сетевых задержек

Это - пример задержек сети в среде виртуальной многоотводной линии:

BSC: Serial0: NDI: Data (5 bytes): C703001061
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): 404040402D
BSC: Serial0: NDI: Data (4 bytes): 40C00037
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37

!--- Output suppressed.

BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C4C4C4C42D

Здесь существует проблема, потому что C4 не ответил своевременно:

BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C5C5C5C52D
BSC: Serial0: NDI: Data (4 bytes): C5C00037
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C7C7C7C72D

Снова, это потеряно. Посмотрите далее, и вы видите, что проблема становится немного хуже:

BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): 404040402D
BSC: Serial0: NDI: Data (4 bytes): 40C00037
BSC: Serial0: SDI: Data (1 bytes): 37
BSC: Serial0: Discard SDI: Data (1 bytes): 37
BSC: Serial0: SDI: Data (5 bytes): C1C1C1C12D

EOT для C7 внезапно появился снова. Сбросьте от того EOT для восстановления с этого; следующий фрейм является EOT для C1.

В данном примере кадры от сети поступают поздно и из последовательности. Это вызывает большое число оставшихся без ответа опросов в хосте. Решение, в этом случае, состоит в том, чтобы настроить local-ack.

Примеры конфигурации BSC и BSTUN

Схема сети

Эта схема является примером конфигурации сайта, который выполняет и 3270 и 3780 терминалов bisync.

/image/gif/paws/5316/bsc_guide_3.gif

Конфигурации

Та схема использует эти конфигурации:

Центральный
hostname central
!
bstun peer-name 10.10.10.107
bstun protocol-group 1 bsc
bstun protocol-group 2 bsc
bstun protocol-group 44 bsc-local-ack
!
interface Serial0
 description EFTPOS host
 no ip address
 encapsulation bstun
 no keepalive
 full-duplex
 clockrate 19200
 bstun group 1
 bsc contention 1
 bstun route all tcp 10.10.10.108
!
interface Serial2
 description WAN-ppp backbone
 ip address 10.10.10.107 255.255.255.0
 encapsulation ppp
 clockrate 2000000
!
interface Serial3
 description WAN-hdlc
 ip address 10.10.20.107 255.255.255.0
 bandwidth 2000
 no keepalive
 clockrate 2000000
!
interface Serial4
 description ATM Host
 no ip address
 encapsulation bstun
 no keepalive
 full-duplex
 bstun group 44
 bsc secondary
 bstun route all tcp 10.10.20.108
!
interface Serial5
 description ATM host
 no ip address
 encapsulation bstun
 no keepalive
 bstun group 2
 bsc secondary
 bstun route address C2 tcp 10.10.20.108
!
end

Удаленный 1
hostname remote1
!
bstun peer-name 10.10.10.108
bstun protocol-group 1 bsc
bstun protocol-group 44 bsc-local-ack
!
interface Serial0
 description EFTPOS 1
 no ip address
 encapsulation bstun
 no keepalive
 full-duplex
 clockrate 19200
 bstun group 1
 bsc char-set ebcdic
 bsc contention
 bstun route all tcp 10.10.10.107
!
interface Serial1
 description ATM 3
 no ip address
 encapsulation bstun
 no keepalive
 bstun group 44
 bsc char-set ebcdic
 bsc primary
 bstun route address 40 tcp 10.10.10.107
!
interface Serial3
 description WAN -ppp
 ip address 10.10.10.108 255.255.255.0
 encapsulation ppp
!
end

Удаленные 2
hostname remote2
!
!
bstun peer-name 10.10.20.108
bstun protocol-group 2 bsc
bstun protocol-group 44 bsc-local-ack
bstun protocol-group 10 bsc-local-ack
!
interface Serial0
 description WAN-hdlc
 ip address 10.10.20.108 255.255.255.0
 bandwidth 2000
 no keepalive
!
interface Serial5
 description ATM 1
 mtu 265
 encapsulation bstun
 clockrate 19200
 bstun group 44
 bsc char-set ebcdic
 bsc primary
 bstun route address C2 tcp 10.10.10.107
!
interface Serial6
 description interface for ATM 2
 mtu 265
 encapsulation bstun
 clockrate 19200
 bstun group 2
 bsc char-set ebcdic
 bsc primary
 bstun route address C2 tcp 10.10.10.107
!
ip route 10.10.10.0 255.255.255.0 10.10.20.107
!
end

Ссылки

Общая информация - бинарная синхронная связь, IBM Systems Reference Library, GA27-3004-2.

IBM 3274: Главе 4: удаленный BSC операций.

IBM 3275: Главе 9.

Команды BSTUN на документации Cisco CDROM (доступный онлайн в Последовательном Туннеле и Блочных Последовательных Командах Tunnel).

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 5316