Cервисы организации сетевого доступа к приложениям : Cisco Cache Engines серии 500

Пример настройки политики перенаправления трафика протокола WCCP для Cisco 500 серии Cache Engine

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации, который демонстрирует, как установить перенаправление политик Версии протокола 2 подключения к веб-кешу (WCCPv2) в Cache Engine series Cisco 500. В этом примере конфигурации вы используете команду table-map в BGP - конфигурации и сопоставление метки WCCP атрибута внешней записи в таблицу маршрутизации для классификации пакетов с атрибутами Протокола BGP, привязанными к источнику или IP - адресу назначения пакета.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Маршрутизатор Cisco 7513, который выполняет Cisco Выпуск ПО IOS� 12.0 (14) S

  • Cisco Cache Engine 550, который выполняет Cisco Cache Software Release 2.3

  • Маршрутизатор Cisco 2600, который выполняет программное обеспечение Cisco IOS версии 12.0

  • Web-серверы Windows NT

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

См. Cisco Technical Tips Conventions для получения информации об условных обозначениях в документации.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/12658/wwcp_2_policy.gif

Только трафик, который перемещается в целевой PC2 (который принадлежит AS30) перенаправлен к Cache Engine, в то время как другой трафик Автономной системы (AS) (RouterD, http server 3.3.3.3 в AS33) не.

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор А
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/1
ip address 172.17.241.27 255.255.255.0
!
router bgp 10
bgp log-neighbor-changes
network 2.2.2.0
network 172.17.241.0
redistribute connected
neighbor 2.2.2.1 remote-as 20

Маршрутизатор В
!
ip wccp web-cache password ww policy destination 60
ip cef distributed
!
interface Serial0/0
ip address 1.1.1.2 255.255.255.0
no ip directed-broadcast
!
interface Ethernet5/0
ip address 2.2.2.1 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect in
ip route-cache same-interface
!
router bgp 20
table-map dst
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip classless
!
access-list 1 permit 3.0.0.0 0.255.255.255
route-map DST permit 10
match ip address 1
set ip wccp 60
!
route-map DST permit 20

Маршрутизатор C
!
interface Serial0/0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface Ethernet5/0
ip address 3.3.3.1 255.255.255.0
no ip directed-broadcast
!
router bgp 30
network 3.3.3.0
redistribute connected
neighbor 1.1.1.2 remote-as 20
neighbor 1.1.1.2 send-community
neighbor 1.1.1.2 route-map setcomm out
neighbor 3.3.3.3 remote-as 33
!
ip classless
ip bgp-community new-format
!
access-list 1 permit 77.0.0.0 0.255.255.255
route-map setcomm permit 10
match ip address 1
set community 4433:1050
!
route-map setcomm permit 20
!

Маршрутизатор D
!
interface Ethernet0
ip address 3.3.3.3 255.255.255.0
!
router bgp 33
bgp log-neighbor-changes
network 33.33.33.0
redistribute connected
neighbor 3.3.3.1 remote-as 30
!
ip classless
ip http server

Связанные команды

Можно настроить примеры маршрутизатора к этим сценариям:

table-map

Используйте команду table-map для изменения политики WCCP от назначения к источнику. Трафик, который перенаправлен, теперь представлен каждым запросом HTTP с IP - адресом источника, заданным в src route-map.

!
router bgp 20
table-map src
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip wccp web-cache password WW policy source 60
!
access-list 1 permit 172.0.0.0 0.255.255.255
route-map src permit 10
match ip address 1
set ip wccp 60
!
route-map src permit 20
!

match as-path

Измените условие, которое применяет метку WCCP к Маршрутам объявленный по BGP. В конфигурации RouterC метка WCCP применена к маршрутам BGP, которые принадлежат отдельному сообществу 4433:1050. Можно использовать команду match as-path для выбора других критериев в RouterB, таких как as-path.

ip as-path access-list 121 permit ^30$
!
route-map setlist permit 10
match as-path 121
set ip wccp 60
!

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 12658