Cервисы организации сетевого доступа к приложениям : Cisco LocalDirector серии 400

Настройка многоузловой балансировки нагрузки на LocalDirector

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Cisco объявил о конце продажи для Cisco LocalDirector. Для получения дополнительной информации обратитесь к LocalDirector Бюллетени окончания продаж серии 400.


Содержание


Введение

LocalDirector использует Cisco Appliance Server Architecture (CASA) для существования в Многоузловом распределении нагрузки (MNLB) среды. В среде MNLB LocalDirector имеет конфигурацию Диспетчера обслуживания. Маршрутизаторы Cisco имеют Конфигурации агента пересылки. Диспетчер обслуживания определяет распределение нагрузки для Агентов переадресации. Диспетчер обслуживания базирует это определение на информации от реальных серверов. Эта производительность сети увеличений настройки и масштабируемость, и также добавляют распределение нагрузки с классификацией приложений.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Эта конфигурация разрабатывалась и проверялась с использованием этих версий программного и аппаратного обеспечения:

  • Версия 3.1.3 программного обеспечения Localdirector

  • Cisco выпуск ПО IOS� 12.0

  • LocalDirector 430

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

config_mnlb-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Настройка диспетчера служб (LocalDirector)
: Saved

: LocalDirector 430 Version 3.1.3 
syslog output 20.3 
no syslog console 
hostname cisco-ld 
no shutdown ethernet 0 
shutdown ethernet 1 
shutdown ethernet 2 
no shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 auto 
interface ethernet 2 auto 
interface ethernet 3 100full 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure 0 
no secure 1 
no secure 2 
no secure 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
ping-allow 3 
ip address 172.16.9.25 255.255.255.0 
route 172.16.10.0 255.255.255.0 172.16.9.5 1 
route 172.16.8.7 255.255.255.255 172.16.9.7 1 
route 172.16.8.8 255.255.255.255 172.16.9.8 1 
route 0.0.0.0 0.0.0.0 172.16.9.1 1 
no rip passive 
failover ip address 172.16.9.26 
failover 
telnet 172.16.0.0 255.255.0.0 
virtual 10.10.10.100:0:0:tcp is 
virtual 10.10.10.110:0:0:tcp is 
redirection 10.10.10.100:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
redirection 10.10.10.110:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
real 172.16.10.3:0:0:tcp is 
real 172.16.10.4:0:0:tcp is 
real 172.16.10.5:0:0:tcp is 
real 172.16.10.6:0:0:tcp is 
bind 10.10.10.100:0:0:tcp 172.16.10.3:0:0:tcp 
bind 10.10.10.100:0:0:tcp 172.16.10.5:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.4:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.6:0:0:tcp 

Конфигурация агента пересылки (маршрутизатор Cisco)
Building configuration... 

Current configuration: 

! 
version 12.0 
service timestamps debug uptime 
service timestamps log uptime 
service password-encryption 
! 
hostname router-a 
! 
ip subnet-zero 
no ip domain-lookup 
! 
ip cef distributed 
ip casa 172.16.8.7 224.0.1.2 
 forwarding-agent 1637 
! 
! 
process-max-time 200 
! 
interface Channel0/0 
 description RD0713 DE10 SYSF 9910 SYSJ 
 ip address 172.16.10.1 255.255.255.0 
 ip directed-broadcast 
 ip route-cache same-interface 
 no keepalive 
 claw DD10 00 172.16.10.3 TCPIP CIPTCP TCPIP TCPIP 
 claw DE10 00 172.16.10.5 TCPIP CIPTCP TCPIP TCPIP 
 claw DF10 00 172.16.10.4 TCPIP CIPTCP TCPIP TCPIP 
 claw DG20 00 172.16.10.6 TCPIP CIPTCP TCPIP TCPIP 
! 
interface Channel0/2 
 no ip address 
 no ip directed-broadcast 
 no keepalive 
 shutdown 
! 
interface FastEthernet1/0/0 
 ip address 172.16.9.7 255.255.255.0 
 no ip redirects 
 no ip directed-broadcast 
 ip route-cache flow 
 no ip route-cache distributed 
 ip igmp join-group 224.0.1.2 
 no ip mroute-cache 
 full-duplex 
 no mop enabled 
 standby use-bia 
 standby priority 105 preempt 
 standby ip 172.16.9.6 
 standby track Channel0/0 
! 
router rip 
 version 2 
 redistribute static 
 network 172.16.0.0 
! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.9.1 
no ip http server 
! 
line con 0 
line aux 0 
line vty 0 4 
! 
end

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Перед запуском команд отладки обратитесь к разделу Важные сведения о командах отладки.

  • debug ip casa affinities — Включает отладки для Подобий CASA.

  • debug ip casa packets — Включает отладки для Пакетов CASA.

  • debug ip casa wildcards — Включает отладки для Универсальных символов CASA.

  • show ip casa affinities — Статистика Показов о близостях.

  • show ip casa oper — Сведения о функционировании системы Показов.

  • show ip casa stats — Статистическая информация Показов.

  • show ip casa wildcard — Отображает информацию о сходствах со строкой-маской.

Для получения дополнительной информации о командах MNLB на LocalDirector обратитесь к Набору функций MNLB для LD: Справочник по командам.

Пример отладочных выходных данных

Эти выходные данные от команды debug ip casa affinities:

Router# debug ip casa affinities
16:15:36:Adding fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:    flags = 0x2, appl addr = 10.10.3.2, interest = 0x5/0x100
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0
16:15:36:Adding fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:    flags = 0x2, appl addr = 0.0.0.0, interest = 0x3/0x104
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12616