Многопротокольная коммутация по меткам (MPLS) : Механизм MPLS over ATM

MPLS VPN через ATM: с OSPF на абонентской стороне (без области 0)

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Когда Протокол OSPF присутствует на абонентской стороне без области 0, этот документ предоставляет пример конфигурации VPN Многопротокольной коммутации по меткам (MPLS) по ATM.

Функция Виртуальной частной сети (VPN), когда используется с MPLS, позволяет нескольким узлам прозрачно соединять через сеть поставщика услуг. Одна сеть поставщика услуг может поддерживать несколько различных IP-сетей VPN. Любая из этих сетей для пользователей является частной сетью, отделенной от других сетей. В пределах сети VPN с каждого узла могут быть переданы IP-пакеты на другой узел этой же сети.

Предварительные условия

Требования

Каждая сеть VPN связана с одним или более коммутируемым или пересылаемым экземпляром (VRF). VRF состоит из таблицы IP-маршрутизации, производной таблицы Cisco Express Forwarding (CEF) и набора интерфейсов, использующих таблицу передачи.

Маршрутизатор поддерживает отдельную маршрутизацию и таблицу CEF для каждого VRF. С этим информация не может быть передана вне VPN, но та же подсеть может использоваться в нескольких VPN без проблем дублирования IP-адресов.

Маршрутизатор, который использует Протокол BGP, распределяет информацию о Маршрутизации VPN с расширенными сообществами (группа узлов) BGP.

Для получения дополнительной информации в отношении распространения обновлений через VPN, обратитесь к этим URL:

Версии аппаратного и программного обеспечения

Эти буквы представляют различные типы маршрутизаторов и используемых коммутаторов:

  • P : Центральный маршрутизатор поставщика

  • PE - маршрутизатор на стороне поставщика

  • CE – маршрутизатор на границе клиента

  • C : Клиентский маршрутизатор

Мы разработали и протестировали конфигурацию с этими версиями программного и аппаратного обеспечения:

  • Граничные маршрутизаторы провайдеров:

    • Программное обеспечение: Cisco Выпуск ПО IOS� 12.1 (3) T. Функции MPLS VPN появляются в релизе 12.0 (5) T. OSPF как протокол маршрутизации PE-CE появляется в релизе 12.0 (7) T.

    • Аппаратные средства: Cisco 3660 или 7206 маршрутизаторов. Для получения дополнительной информации других аппаратных средств можно использовать, обратиться к MPLS Разработки для руководства ATM.

  • Граничные маршрутизаторы клиентов: Используйте любой маршрутизатор, который в состоянии обмениваться сведениями о маршрутизации с его Периферийным маршрутизатором.

  • P-маршрутизаторы и коммутаторы: Функция интеграции MPLS VPN находится только на краю сети MPLS, так используйте любой Коммутатор с поддержкой MPLS. В примере конфигурации облако MPLS составлено из 8540 MSR и LightStream 1010. При использовании LightStream 1010, мы рекомендуем использовать версию программного обеспечения WA4.8d или выше. Можно также использовать другие коммутаторы ATM, такие как Cisco BPX 8650 или MGX 8850 в базовой сети ATM.

Условные обозначения

Эта схема показывает типичную конфигурацию, которая использует эти условные обозначения:

/image/gif/paws/10472/mpls_ospf4.gif

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Информация об общих сведениях о протоколе OSPF

Традиционно, тщательно разработанная сеть OSPF состоит из магистральной области (область 0) и много областей, связанных с этой магистралью через пограничный маршрутизатор области (ABR).

С магистралью MPLS для VPN с OSPF на клиентском узле сети можно представить третий уровень в иерархии Модели OSPF. Этот третий уровень называют супермагистралью MPLS VPN.

В простых случаях супермагистраль MPLS VPN объединена со стандартной областью 0 магистралей. Это означает, что нет никакого area 0 backbone на сети заказчика, так как супермагистраль MPLS VPN играет ту же роль как area 0 backbone. Это показано на следующей схеме:

/image/gif/paws/10472/mpls_ospf1.gif

Эта схема иллюстрирует эту информацию:

  • Маршрутизаторы границы поставщика (PE) являются маршрутизаторами граничного маршрутизатора автономной системы (ASBR) и ABR.

  • Маршрутизаторы абонентской границы (CE) являются простыми маршрутизаторами OSPF.

  • Информация VPN транспортируется через расширенные сообщества (группа узлов) BGP от PE до других PE и повторно внедрена в области OSPF как Вся сеть (тип 3) описания локального состояния соединениий (LSA).

Супермагистраль MPLS VPN также позволяет клиентам использовать множественную область 0 магистралей на их узлах. Каждый узел может иметь отдельную область 0, пока он связан с супермагистралью MPLS VPN. Результат совпадает с с разделенной областью 0 магистралями. Это показано на следующей схеме:

/image/gif/paws/10472/mpls_ospf2.gif

В этом случае эти вещи происходят:

  • Периферийные маршрутизаторы являются ABR и Граничными маршрутизаторами автономной системы.

  • Маршрутизаторы CE являются маршрутизаторами ABR.

  • LSA, которые содержат информацию VPN, транспортируются с расширенными сообществами (группа узлов) BGP от PE до других PE. Во Всей сети (тип 3) LSA информация транспортируется между PE и CEs.

Этот пример конфигурации основывается на первой показанной настройке. Можно найти пример конфигурации, который использует вторую настройку в MPLS VPN по ATM: с OSPF на абонентской стороне (с областью 0).

Информация от протокола OSPF транспортируется с Расширенными атрибутами сообщества BGP (которые включают тот, который определяет сеть OSPF). Каждая VPN должна иметь свой собственный процесс OSPF. Для определения этого можно использовать эту команду:

router ospf <process ID> vrf <VPN routing/forwarding instance name>

Процедура конфигурации

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/10472/mpls_ospf3.gif

Эта процедура настройки конфигурации также описывается в документации Cisco IOS ("Виртуальные частные сети MPLS").

Первая часть процедуры настройки

Убедитесь, что режим ip cef включен. При использовании Маршрутизатора Cisco 7500 необходимо гарантировать, что включен распределенный ip cef. На PE, как только MPLS установлен, выполняют эти задачи:

  1. Создайте один VRF для каждой VPN, связанной с командой ip vrf <VPN routing/forwarding instance name>. Когда вы делаете это:

    • Укажите правильный отличительный признак маршрута, который используется для данной виртуальной частной сети (VPN). Это используется для расширения IP-адреса так, чтобы можно было определить VPN, которой он принадлежит.

      rd <VPN route distinguisher>
      
    • Задайте свойства импорта и экспорта для расширенных сообществ BGP. Они используются для фильтрации процесса экспорта и импорта.

      route-target [export|import|both] <target VPN extended community> 
      
      
  2. Настройте сведения о переадресации для интерфейсов respectives с этой командой:

    ip vrf forwarding <table name>
    

    Не забудьте устанавливать IP-адрес после того, как вы сделаете это.

  3. Зависящий от протокола маршрутизации PE-CE, который вы используете, необходимо теперь сделать один или больше из них:

    • Настройте статические маршруты:

      ip route vrf vrf-name prefix mask [next-hop-address]
                                        [interface {interface-number}] 
      
      
    • Настройте RIP с этой командой:

      address-family ipv4 vrf <VPN routing/forwarding instance name>
      

      Выполнив эти действия, введите обычные команды настройки конфигурации RIP.

      Примечание: Применимо только к интерфейсам продвижения для текущего VRF.

      Примечание: Необходимо преобразовать правильные данные BGP в данные RIP. Когда вы делаете это, также не забудьте задавать метрику, которая используется.

    • Задайте сведения о соседях BGP.

    • Настройте OSPF с новой командой IOS:

      router ospf <process ID> vrf <VPN routing/forwarding instance name>
      

      Примечание: Применимо только к интерфейсам продвижения для текущего VRF.

      Примечание: Необходимо преобразовать правильные данные BGP в данные OSPF. Когда вы делаете это, также не забудьте задавать метрику, которая используется.

      Примечание: Как только вы приписываете процесс OSPF VRF, этот номер процесса всегда используется для этого определенного VRF. Этот параметр применяется, даже если он не указан в командной строке.

Вторая часть процедуры настройки

Настройка BGP между PE маршрутизаторами. Существует несколько способов настроить BGP, такой как использование рефлектора маршрута или методов конфедерации. Метод, используемый здесь – непосредственная конфигурация соседнего устройства – является самым простым и наименее масштабируемым.

  1. Объявите различных соседей.

  2. Введите name> маршрутизации/экземпляра VRF <VPN VRF ipv4 address-family для каждого подарка VPN в этом Периферийном маршрутизаторе. Выполните один или больше этих шагов по мере необходимости:

    • Перераспределите данные статической маршрутизации.

    • Перераспределение данных RIP-маршрутизации.

    • Перераспределение данных OSPF-маршрутизации.

    • Активируйте Соседние BGP узел с Маршрутизаторами CE.

  3. Введите режим ввода адресов типа vpnv4 и выполните эти задачи:

    • Активируйте соседей.

    • Укажите необходимость использования расширенного сообщества. Данное действие является обязательным.

Конфигурации

Примечание: Только соответствующие части выходных данных включены здесь.

Alcazaba
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!         
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.10 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 150.150.0.1 255.255.255.0
 no ip mroute-cache
!
interface ATM4/0
 no ip address
 no ip mroute-cache
 atm sonet stm-1
 no atm ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 150.150.0.0 0.0.0.255 area 1
 network 222.0.0.0 0.0.0.255 area 1
!
router bgp 1
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Kozel
!
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.30 255.255.255.255
!         
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 69.69.0.1 255.255.255.252
 no ip mroute-cache
 tag-switching ip
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 tag-switching
 ip address 11.0.0.6 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 11.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 69.69.0.0 0.0.0.255 area 3
 network 222.0.0.0 0.0.0.255 area 3
!
router bgp 1
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.11 remote-as 1
 neighbor 223.0.0.11 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.11 activate
 neighbor 223.0.0.11 send-community extended
 exit-address-family
!

Быстрый
!
interface Loopback0
 ip address 222.0.0.1 255.255.255.255
!
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!         
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 7.7.7.7 0.0.0.0 area 1
 network 150.150.0.0 0.0.0.255 area 1
 network 222.0.0.1 0.0.0.0 area 1
!

Pivrnec
!
interface Loopback0
 ip address 222.0.0.3 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/1
 ip address 69.69.0.2 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 3
 network 69.69.0.0 0.0.0.255 area 3
 network 222.0.0.3 0.0.0.0 area 3
!

Проверка

Команды "show"

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • маршрутизация <VPN show ip route vrf или name> экземпляра VRF

  • маршрутизация <VPN VRF show ip bgp vpnv4 или name> экземпляра VRF <B.C.D>

  • Номер ID <process show ip ospf>

  • Номер ID <process show ip ospf> интерфейс

  • Номер ID <process show ip ospf> база данных

  • маршрутизация <VPN show tag-switching forwarding-table vrf или name> экземпляра VRF

Эта команда показывает VRF для определенной VPN в Периферийном маршрутизаторе:

Alcazaba#show ip route vrf vpn1
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
B       69.69.0.0 [200/0] via 223.0.0.21, 00:19:39
     222.0.0.0/32 is subnetted, 4 subnets
B       222.0.0.30 [200/0] via 223.0.0.21, 00:19:39
C       222.0.0.10 is directly connected, Loopback1
B       222.0.0.3 [200/11] via 223.0.0.21, 00:20:39
O       222.0.0.1 [110/11] via 150.150.0.2, 00:20:59, Ethernet1/1
     6.0.0.0/32 is subnetted, 1 subnets
B       6.6.6.6 [200/11] via 223.0.0.21, 00:20:39
     7.0.0.0/32 is subnetted, 1 subnets
O       7.7.7.7 [110/11] via 150.150.0.2, 00:21:00, Ethernet1/1
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.0.0 is directly connected, Ethernet1/1

Можно также отобразить информацию BGP для определенного VRF с командой show ip bgp vpnv4 vrf. Результаты PE-PE из внутреннего BGP (IBGP) обозначены буквой "i".

Alcazaba#show ip bgp vpnv4 vrf vpn1
BGP table version is 21, local router ID is 223.0.0.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:101 (default for vrf vpn1)
*>i6.6.6.6/32       223.0.0.21              11    100      0 ?
*> 7.7.7.7/32       150.150.0.2             11         32768 ?
*>i69.69.0.0/30     223.0.0.21               0    100      0 ?
*> 150.150.0.0/24   0.0.0.0                  0         32768 ?
*> 222.0.0.1/32     150.150.0.2             11         32768 ?
*>i222.0.0.3/32     223.0.0.21              11    100      0 ?
*> 222.0.0.10/32    0.0.0.0                  0         32768 ?
*>i222.0.0.30/32    223.0.0.21               0    100      0 ?

Можно проверить подробные данные записи. Для показа этого признак маршрута "1:101".

Alcazaba#show ip bgp vpnv4 vrf vpn1 6.6.6.6
BGP routing table entry for 1:101:6.6.6.6/32, version 28
Paths: (1 available, best #1, table vpn1)
  Not advertised to any peer
  Local
    223.0.0.21 (metric 4) from 223.0.0.21 (223.0.0.21)
      Origin incomplete, metric 11, localpref 100, valid, internal, best
      Extended Community: RT:1:101 OSPF RT:3:2:0

Alcazaba#show ip bgp vpnv4 vrf vpn1 7.7.7.7
BGP routing table entry for 1:101:7.7.7.7/32, version 20
Paths: (1 available, best #1, table vpn1)
  Advertised to non peer-group peers:
  223.0.0.21 
  Local
    150.150.0.2 from 0.0.0.0 (223.0.0.3)
      Origin incomplete, metric 11, localpref 100, weight 32768, valid, sourced, best
      Extended Community: RT:1:101 OSPF RT:1:2:0

Команда show ip route на Маршрутизаторе CE является основными средствами проверить таблицы маршрутизации:

rapid#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
O IA    69.69.0.0 [110/11] via 150.150.0.1, 00:20:25, FastEthernet0/1
     222.0.0.0/32 is subnetted, 4 subnets
O IA    222.0.0.30 [110/11] via 150.150.0.1, 00:20:25, FastEthernet0/1
O       222.0.0.10 [110/11] via 150.150.0.1, 00:21:46, FastEthernet0/1
O IA    222.0.0.3 [110/21] via 150.150.0.1, 00:21:25, FastEthernet0/1
C       222.0.0.1 is directly connected, Loopback0
     6.0.0.0/32 is subnetted, 1 subnets
O IA    6.6.6.6 [110/21] via 150.150.0.1, 00:21:25, FastEthernet0/1
     7.0.0.0/24 is subnetted, 1 subnets
C       7.7.7.0 is directly connected, Loopback2
     10.0.0.0/22 is subnetted, 1 subnets
C       10.200.8.0 is directly connected, FastEthernet0/0
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.0.0 is directly connected, FastEthernet0/1
S    158.0.0.0/8 is directly connected, Null0

Команды OSPF

Можно использовать все команды show ip ospf. Когда вы сделаете это, не забудьте указывать на ID процесса. Мы отметили большинство важных частей выходных данных ниже в курсивном тексте.

LSA OSPF типа 9, 10 и 11 (также известный как Непрозрачные LSA) используются к трафику инженера.

Команды для периферийного маршрутизатора

Alcazaba#show ip ospf 2
 Routing Process "ospf 2" with ID 222.0.0.10
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Connected to MPLS VPN super backbone
 It is an area border and autonomous system boundary router
 Redistributing External Routes from,
    bgp 1, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area 1
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 7. Checksum Sum 0x420BE 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Alcazaba#show ip ospf 2 interface
Loopback1 is up, line protocol is up 
  Internet Address 222.0.0.10/32, Area 1 
  Process ID 2, Router ID 222.0.0.10, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Ethernet1/1 is up, line protocol is up 
  Internet Address 150.150.0.1/24, Area 1 
  Process ID 2, Router ID 222.0.0.10, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:07
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 2, maximum is 3
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

Alcazaba#show ip ospf 2 database
 
            OSPF Router with ID (222.0.0.10) (Process ID 2)
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1364        0x80000013 0x7369   3
222.0.0.10      222.0.0.10      1363        0x80000002 0xFEFE   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      1363        0x80000001 0xEC6D  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      1328        0x80000001 0x4967  
69.69.0.0       222.0.0.10      1268        0x80000001 0x2427  
222.0.0.3       222.0.0.10      1328        0x80000001 0xEEF7  
222.0.0.30      222.0.0.10      1268        0x80000001 0x7B5A  

Команды для маршрутизатора CE

rapid#show ip ospf interface
FastEthernet0/1 is up, line protocol is up 
  Internet Address 150.150.0.2/24, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State BDR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:04
  Index 2/2, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.10  (Designated Router)
  Suppress hello for 0 neighbor(s)
Loopback0 is up, line protocol is up 
  Internet Address 222.0.0.1/32, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Loopback2 is up, line protocol is up 
  Internet Address 7.7.7.7/24, Area 1 
  Process ID 1, Router ID 222.0.0.1, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host

rapid#show ip ospf database
 
       OSPF Router with ID (222.0.0.1) (Process ID 1)
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1350        0x80000013 0x7369   3
222.0.0.10      222.0.0.10      1350        0x80000002 0xFEFE   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      1351        0x80000001 0xEC6D  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      1316        0x80000001 0x4967  
69.69.0.0       222.0.0.10      1256        0x80000001 0x2427  
222.0.0.3       222.0.0.10      1316        0x80000001 0xEEF7  
222.0.0.30      222.0.0.10      1256        0x80000001 0x7B5A  

Alcazaba#show tag-switching forwarding-table vrf vpn1
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
24     Aggregate   222.0.0.10/32[V]  0                                  
25     Aggregate   150.150.0.0/24[V] 0                                  
27     Untagged    7.7.7.7/32[V]     1710       Et1/1      150.150.0.2  
28     Untagged    222.0.0.1/32[V]   0          Et1/1      150.150.0.2

Метки MPLS

Можно проверить стек меток, используемый для отдельного маршрута:

Alcazaba#show tag-switching forwarding-table vrf vpn1 6.6.6.6 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
None   2/41        6.6.6.6/32        0          AT4/0.1    point2point  
        MAC/Encaps=4/12, MTU=4466, Tag Stack{2/41(vcd=10) 16}
        000A8847 0000A00000010000

Вывод отладки

Вот выборка от информации об отладке обмена маршрутами. Это показывает, как импортирован отдельный маршрут.

Alcazaba#debug ip bgp vpnv4 import
Tag VPN import processing debugging is on
*Aug  5 05:10:09.283: vpn: Start import processing for: 1:101:222.0.0.3
*Aug  5 05:10:09.283: vpn: Import check for vpn1; flags mtch, impt
*Aug  5 05:10:09.283: vpn: Import for vpn1 permitted; import flags mtch, impt
*Aug  5 05:10:09.283: vpn: Same RD import for vpn1
*Aug  5 05:10:09.283: vpn: 1:101:222.0.0.3 (ver 29), imported as:
*Aug  5 05:10:09.283: vpn: 1:101:222.0.0.3 (ver 29)
*Aug  5 05:10:09.287: VPN: Scanning for import check is done.

Тестирование выходных данных

Можно теперь использовать эхо-запрос для тестирования этого, все прекрасно:

Pivrnec#ping 7.7.7.7      
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

Команда traceroute отображает эти выходные данные:

Pivrnec#traceroute 7.7.7.7
 
Type escape sequence to abort.
Tracing the route to 7.7.7.7
 
  1 69.69.0.1 0 msec 0 msec 0 msec
  2 150.150.0.1 0 msec 0 msec 20 msec
  3 150.150.0.2 0 msec 0 msec * 

Хосты MLPS не здесь, потому что они не видят IP - заголовок. MPLS размещает, только проверяют входящую метку или интерфейс и затем передают его.

Операция на поле IP Time To Live (TTL) только выполнена на граничном LSR. Показанный счетчик переходов является меньше, чем фактический счетчик переходов.


Дополнительные сведения


Document ID: 10472