Многопротокольная коммутация по меткам (MPLS) : Механизм MPLS over ATM

MPLS CoS через ATM: Мульти-VC TBR (с использованием CAR)

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Класс обслуживания Многопротокольной коммутации по меткам (CoS MPLS) механизм является функцией, которая выполняет дифференцированные сервисы по ATM. Это позволяет сети ATM обрабатывать другие пакеты на основе EXP (экспериментальное) поле (также названный CoS) заголовка MPLS, который имеет те же свойства и который может быть сопоставлен с IP precedence.

0                   1                   2                   3
0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|               Label                   | EXP |S|      TTL      |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Этот документ объясняет, как использовать этот механизм в базовой сети MPLS, которая получает пакеты IP (без набора битов приоритета) из других источников.

Предварительные условия

Tagged Bit Rate мультивиртуального канала (TBR Multi-VC)

TBR Multi-VC использует другие пути и новые классы сервиса для поддержки другого способа обращения по ATM. Этот метод состоит максимум из четырех параллельных Помеченных виртуальных каналов (LVC) (или "Tag VC" в старой терминологии) и сопоставляет с CoS MPLS. Эта таблица показывает сопоставление по умолчанию:

Тип помеченного виртуального канала Класс обслуживания IP-тип сервисов
Доступный 0 0,4
Стандарт 1 1,5
Premium 2 2,6
Контроль 3 3,7

Каждый Маршрутизатор с коммутацией меток (LSR) имеет много VC (от один до четыре), который соответствует для того же назначения или "с несколькими виртуальными каналами". Эти параллельные LVC установлены восходящим краевым маршрутизатором с протоколом распределения меток.

Для поддержки LVC на уровне коммутатора четыре новых категории CoS были представлены. Их называют классами Tagged Bit Rate (TBR) и являются максимально эффективными сервисами (как с традиционной неуказанной скоростью передачи данных (UBR)). Они могут быть настроены таким же образом. Т.е. могут быть изменены их относительные веса или пределы их порогов.

Класс обслуживания ATM Forum CoS Относительный вес класса Помеченный виртуальный канал
CBR 2 Не применимо
VBR-RT 2 8
VBR-NRT 3 1
ABR 4 1
UBR 5 1
TBR_1 (WRR_1) 1 1 Доступный
TBR_2 (WRR_2) 6 2 Стандарт
TBR_3 (WWR_3) 7 3 Premium
TBR_4 (WWR_4) 8 4 Контроль

Примечание: Новые категории CoS полужирным.

Механизм

Граничный LSR устанавливает поле MPLS CoS с Согласованной скоростью доступа (CAR) на корректном входном интерфейсе. CAR может быть настроен для действия в соответствии с договором или любым другим определенным правилом. LSR в краю сети ATM помещает в очередь ячейки, которые содержат пакет в корректной очереди (доступный, стандартный, премиальный, или контроль), зависящий от Сопоставления CoS. Ячейки тогда передают транзитом через сеть ATM MPLS с тем же LVC. Результат состоит в том, что в любом LSR ATM ячейки проходят лечение на CoS:

  • На CoS Обслуживание очередей на основе равнодоступности (WFQ) пропорционально Относительным Весам Класса.

  • Когда очереди заполняются (подобный Взвешенному произвольному раннему обнаружению (WRED)), на CoS Weighted Early Packet Discard (WEPD) является методом для отмены от пакетов.

В результате для LS1010 и 8540MSR, это на поведение CoS эмулировано на организацию очереди VC.

Пространство VC

CoS MPLS поддерживает стандартные слияния VC. Для использования меньшего количества VC можно уменьшить используемый LVC (от четыре до два, например). Обратитесь к CoS MPLS по ATM: Сопоставление CoS для примера конфигурации.

Тема количества VC затронута в Разработке MPLS для ATM: Определение размеров Пространства VC MPLS Label.

Версии аппаратного и программного обеспечения

При разработке и тестировании этой конфигурации использовались следующие версии программного и аппаратного обеспечения:

Граничный LSR

  • Программное обеспечение - Cisco Выпуск ПО IOS� 12.1 (3) T; Функция нескольких виртуальных каналов появилась в программном обеспечении Cisco IOS версии 12.0(5)T.

  • Аппаратные средства - маршрутизаторы Cisco 7200 с PA-A1.

Примечание: Эта функция только работает с 7200 Cisco и 7500 с PA-A1.

Базовый LSR ATM

  • Программное обеспечение - Любой выпуск ПО, который поддерживает MPLS; последние версии рекомендуются.

  • Аппаратные средства - LS1010 и 8540MSR.

Примечание: Организация очереди функциональной карты per-flow (FC-PFQ) является обязательной для LS1010.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/10469/mpls_cos_atm1.gif

Процедура конфигурации

Этот документ использует эту процедуру настройки:

  1. Для устанавливания четырех LVC по умолчанию (с сопоставлением по умолчанию), добавьте эту инструкцию к конфигурации подчиненного интерфейса ATM граничных LSR:

    tag-switching atm multi-vc
    
  2. Параллельные LVC, установленные автоматически на коммутаторах ATM. Для классификации пакетов используйте CAR (сошлитесь на Документацию по CAR) установить Экспериментальное поле заголовка MPLS к желаемому значению. Данный пример устанавливает Из-за всех входящих пакетов на Ethernet 1/1 интерфейс к 1 (и устанавливает карту со "стандартом"):

    interface Ethernet1/1
     rate-limit input 8000 1500 200 conform-action set-mpls-exp-transmit 1 exceed-action set-mpls-exp-transmit 1
    
  3. Можно также выполнить управление трафиком и установить CoS в 2 (сопоставьте с "премией") для трафика, который соответствует и 0 (сопоставляют с "доступным") для трафика, который превышает:

    interface Ethernet1/1
     rate-limit input 64000 8000 16000 conform-action set-mpls-exp-transmit 2 exceed-action set-mpls-exp-transmit 0
    

    Примечание: Можно также использовать команду tag-switching atm vpi 2-4, но это не является обязательным для определения, какие идентификаторы виртуального тракта (VPI) используются для MPLS.

    Примечание: Не забудьте настраивать ip cef (ip cef, распределенный на Cisco 7500) на обычной конфигурации маршрутизаторов.

Примеры конфигураций

Эти конфигурации используются в данном документе:

Быстрый
 !
 interface Loopback0
  ip address 223.0.0.12 255.255.255.255
 !
 interface Loopback2
  ip address 7.7.7.7 255.255.255.0
 !
 !
 interface FastEthernet0/1
  ip address 150.150.0.2 255.255.255.0
  duplex auto
  speed auto
 !
 !
 router ospf 1
  network 7.7.7.7 0.0.0.0 area 0
  network 150.150.0.0 0.0.0.255 area 0
  network 223.0.0.0 0.0.0.255 area 0
 !      

Alcazaba
 !
 ip cef
 !
 !
 interface Loopback0
  ip address 223.0.0.3 255.255.255.255
 !
 interface Loopback1
  ip address 1.1.1.1 255.255.255.255
 !
 interface Ethernet1/1
  ip address 150.150.0.1 255.255.255.0
  rate-limit input 64000 32000 64000 conform-action set-mpls-exp-transmit 2 
  exceed-action set-mpls-exp-transmit 1
  no ip mroute-cache
 !
 !
 interface ATM4/0
  no ip address
  no ip mroute-cache
  no atm ilmi-keepalive
 !
 interface ATM4/0.1 tag-switching
  ip address 10.0.0.13 255.255.255.252
  tag-switching atm multi-vc
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 router ospf 1
  network 1.1.1.1 0.0.0.0 area 0
  network 10.0.0.0 0.0.0.255 area 0
  network 150.150.0.0 0.0.0.255 area 0
  network 223.0.0.3 0.0.0.0 area 0
 !

Capri
 !
 interface Loopback1
  ip address 223.0.0.6 255.255.255.255
  no ip directed-broadcast
 !
 !
 interface ATM3/0/2
  ip address 10.0.0.14 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 interface ATM3/1/2
  ip address 10.0.0.10 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 router ospf 2
  network 10.0.0.0 0.0.0.255 area 0
  network 223.0.0.6 0.0.0.0 area 0
 !

Goldorak
 !
 interface Loopback0
  ip address 223.0.0.2 255.255.255.255
  no ip directed-broadcast
 !
 interface ATM0/1/0
  ip address 10.0.0.9 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 2-4
  tag-switching ip
 !
 !
 interface ATM0/1/3
  ip address 11.0.0.1 255.255.255.252
  no ip directed-broadcast
  tag-switching atm vpi 5-7
  tag-switching ip
 !
 !
 router ospf 1
  network 10.0.0.0 0.0.0.255 area 0
  network 11.0.0.0 0.0.0.255 area 0
  network 223.0.0.2 0.0.0.0 area 0
 !

Ischia
 !         
 ip cef
 !
 interface Loopback0
  ip address 223.0.0.11 255.255.255.255
 !
 interface Loopback1
  ip address 2.2.2.2 255.255.255.255
 !
 !
 interface ATM3/0.158 tag-switching
  ip address 11.0.0.2 255.255.255.252
  tag-switching atm multi-vc
  tag-switching atm vpi 5-7
  tag-switching ip
 !
 router ospf 1
  log-adjacency-changes
  network 2.2.2.2 0.0.0.0 area 0
  network 11.0.0.0 0.0.0.255 area 0
  network 223.0.0.11 0.0.0.0 area 0
 !

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Команды "show"

На LSR маршрутизатора:

  • show tag-switching forwarding-table

  • подробность покажите таблицу пересылки коммутации на основе тэгов

На коммутаторе ATM:

  • show tag-switching atm-tdp bindings

  • <interface> show atm vc interface <vci/vpi>

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Образец команды show output

Для проверки с несколькими виртуальными каналами на граничном LSR, традиционная команда show tag-switching forwarding-table может использоваться. Для специфической проверки дескриптора виртуальной цепи (VCD) или идентификатора виртуального тракта/виртуальный идентификатор канала (VPI/VCI), команда должна быть определенной для назначения и должна закончиться подробностью слова.

Alcazaba#show tag-switching forwarding-table
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
16     Untagged    7.7.7.0/24        0          Et1/1      150.150.0.2  
17     Untagged    10.0.0.0/16       0          Et1/1      150.150.0.2  
18     Untagged    158.0.0.0/8       0          Et1/1      150.150.0.2  
19     Untagged    223.0.0.12/32     0          Et1/1      150.150.0.2  
20     Untagged    7.7.7.7/32        570        Et1/1      150.150.0.2  
21     Multi-VC    10.0.0.8/30       0          AT4/0.1    point2point  
25     Multi-VC    2.2.2.2/32        0          AT4/0.1    point2point  
32     Multi-VC    223.0.0.2/32      0          AT4/0.1    point2point  
34     Multi-VC    223.0.0.6/32      0          AT4/0.1    point2point  
36     Multi-VC    11.0.0.0/30       0          AT4/0.1    point2point  
37     Multi-VC    223.0.0.11/32     0          AT4/0.1    point2point 

Alcazaba#show tag-switching forwarding-table 2.2.2.2 32 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
25     Multi-VC    2.2.2.2/32        0          AT4/0.1    point2point  
        available 2/61(882), standard 2/62(883), premium 2/63(884), control 2/64(885), 
        MAC/Encaps=4/8, MTU=4470, Tag Stack{Multi-VC}
        04F48847 004F4000
    Per-packet load-sharing 

На любом LSR ATM можно также сопоставить другие VC от одного интерфейса до другого (с командой show tag-switching atm-tdp bindings) с их соответствующими классами сервиса (show atm vc interface <ATM-интерфейс> <vpi> команда <vci>).

Capri#show tag-switching atm-tdp bindings
 Destination: 2.2.2.2/32
    Transit ATM3/0/2 2/61 Active -> ATM3/1/2 2/69 Active, CoS=available
    Transit ATM3/0/2 2/62 Active -> ATM3/1/2 2/70 Active, CoS=standard
    Transit ATM3/0/2 2/63 Active -> ATM3/1/2 2/71 Active, CoS=premium
    Transit ATM3/0/2 2/64 Active -> ATM3/1/2 2/72 Active, CoS=control
 Destination: 10.0.0.8/30
    Tailend Switch ATM3/0/2 2/97 Active -> Terminating Active, CoS=available
    Tailend Switch ATM3/0/2 2/98 Active -> Terminating Active, CoS=standard
    Tailend Switch ATM3/0/2 2/99 Active -> Terminating Active, CoS=premium
    Tailend Switch ATM3/0/2 2/100 Active -> Terminating Active, CoS=control
[...]
Capri#show atm vc interface atm3/0/2 2 63
 
Interface: ATM3/0/2, Type: oc3suni 
VPI = 2  VCI = 63
Status: UP
Time-since-last-status-change: 02:07:24
Connection-type: TVC(O) 
Cast-type: multipoint-to-point-output
Packet-discard-option: enabled
Usage-Parameter-Control (UPC): pass
Wrr weight: 2
Number of OAM-configured connections: 0
OAM-configuration: disabled
OAM-states:  Not-applicable
Cross-connect-interface: ATM3/1/2, Type: oc3suni 
Cross-connect-VPI = 2 
Cross-connect-VCI = 147
Cross-connect-UPC: pass
Cross-connect OAM-configuration: disabled
Cross-connect OAM-state:  Not-applicable
Threshold Group: 9, Cells queued: 0
Rx cells: 0, Tx cells: 0
Tx Clp0:0,  Tx Clp1: 0
Rx Clp0:0,  Rx Clp1: 0
Rx Upc Violations:0, Rx cell drops:0
Rx pkts:0, Rx pkt drops:0
Rx connection-traffic-table-index: 63998
Rx service-category: WRR_3 (WRR Bit Rate)
Rx pcr-clp01: none
Rx scr-clp01: none
Rx mcr-clp01: none
Rx      cdvt: 0 (from default for interface)
Rx       mbs: none
Tx connection-traffic-table-index: 63998
Tx service-category: WRR_3 (WRR Bit Rate)
Tx pcr-clp01: none
Tx scr-clp01: none
Tx mcr-clp01: none
Tx      cdvt: none
Tx       mbs: none

В примерах конфигурации все пакеты, которые соответствуют, переданы премиальным LVC. Все пакеты, которые превышают правило CAR, переданы стандартным LVC. В этих первых выходных данных стандартная команда ping сделана и повторилась 158 раз:

rapid#ping        
Protocol [ip]: 
Target IP address: 2.2.2.2
Repeat count [5]: 158
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 158, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (158/158), round-trip min/avg/max = 1/1/5 ms

Можно проверить, проходят ли все пакеты через премиальный LVC с командой show atm vc на граничном LSR как в примере выходных данных. В этой выборке премиальные выходные данные VCD 884.

Alcazaba#show atm vc 884
ATM4/0.1: VCD: 884, VPI: 2, VCI: 63
UBR, PeakRate: 155000
AAL5-MUX, etype:0x8847, Flags: 0x40C84, VCmode: 0x0
OAM frequency: 0 second(s)
InARP DISABLED
InPkts: 0, OutPkts: 158, InBytes: 0, OutBytes: 17064
InPRoc: 0, OutPRoc: 0
InFast: 0, OutFast: 158, InAS: 0, OutAS: 0
Giants: 0
OAM cells received: 0
OAM cells sent: 0
Status: UP
Tag VC: local tag: 0

Можно также проверить любой коммутатор ATM с командой <vpi/vci> <interface> интерфейса трафика show atm vc. В этой выборке каждый ping - пакет транспортируется в трех ячейках: 158*3 = 474 ячейки.

Capri#show atm vc traffic interface atm 3/0/2 2 63
Interface    VPI     VCI      Type      rx-cell-cnts     tx-cell-cnts
ATM3/0/2     2       63        TVC(O)             0                0
ATM3/0/2     2       63        TVC(I)           474                0

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10469