Многопротокольная коммутация по меткам (MPLS) : Механизм MPLS over ATM

Многопротокольная коммутация на основе меток (MPLS) через ATM без мультиплексирования VC

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ иллюстрирует сеть Многопротокольной коммутации по меткам (MPLS) с ATM. Так как слияние VC не используется, существует один VC, выделенный на маршрут, как определено префиксом в таблице маршрутизации.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco Выпуск ПО IOS� 12.0 или позже для MPLS на Guilder и Damme.

  • Эта настройка использует один коммутатор ATM, который используется в качестве маршрутизатора с коммутацией меток (LSR). В данном примере это - Catalyst 8540MSR. Это может также быть LS1010. Cisco рекомендует версию программного обеспечения WA4.8d или позже LS1010. Любое программное обеспечение на 8540MSR достаточно.

  • Технология CEF должна быть включена на маршрутизаторах, которые выполняют MPLS/Коммутацию на основе тэгов. В данном примере Guilder и Damme являются 3600 Cisco. Если 7500 используются, распределенный ip cef должен быть включен.

Примечание: Несмотря на то, что не требование, этот документ использует VPI 2, 3, или 4 для всех Tag VC в данном примере.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/10467/mpls_basic2.gif

Примечание: Интерфейсы обратной связи были установлены на всех маршрутизаторах/LSR. Их не показывают в схеме сети ради простоты.

Конфигурации

Эти конфигурации используются в данном документе:

Pound
!         
interface Loopback0
 ip address 100.100.0.1 255.255.0.0
 no ip directed-broadcast
!         
interface Ethernet0/1
 ip address 123.123.0.2 255.255.0.0
 no ip directed-broadcast
!         
router ospf 1
 network 100.100.0.0 0.0.255.255 area 1.1.1.1
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
!

Guilder
!
ip cef
!
interface Loopback0
 ip address 102.102.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/1
 ip address 123.123.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface ATM1/0.1 tag-switching
 ip address 129.129.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 102.102.0.0 0.0.255.255 area 0.0.0.0
 network 123.123.0.0 0.0.255.255 area 1.1.1.1
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

Capri (8540MSR)
!
interface Loopback0
 ip address 103.103.0.1 255.255.0.0
 no ip directed-broadcast
!
interface ATM3/0/0
 ip address 128.128.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
interface ATM3/0/3
 ip address 129.129.0.2 255.255.0.0
 no ip directed-broadcast
 no ip route-cache cef
 no atm ilmi-keepalive
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 103.103.0.0 0.0.255.255 area 0.0.0.0
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
 network 129.129.0.0 0.0.255.255 area 0.0.0.0
!

Damme
!
ip cef
!
interface Loopback0
 ip address 104.104.0.1 255.255.0.0
 no ip directed-broadcast
!
interface FastEthernet0/0
 ip address 125.125.0.1 255.255.0.0
 no ip directed-broadcast
 duplex auto
 speed 10
 tag-switching ip
!
interface ATM1/0
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc 0/16 ilmi
 !        
 pvc 0/5 qsaal
 !
!
interface ATM1/0.2 tag-switching
 ip address 128.128.0.1 255.255.0.0
 no ip directed-broadcast
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 network 104.104.0.0 0.0.255.255 area 0.0.0.0
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
 network 128.128.0.0 0.0.255.255 area 0.0.0.0
!

Lira
!
interface Loopback0
 ip address 101.101.0.1 255.255.0.0
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 125.125.0.2 255.255.0.0
 no ip directed-broadcast
!
router ospf 1
 network 101.101.0.0 0.0.255.255 area 2.2.2.2
 network 125.125.0.0 0.0.255.255 area 2.2.2.2
!

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show tag-switching forwarding-table Tag Forwarding Information Base (TFIB).

  • show tag-switching atm-tdp bindings — Показывает динамическую информацию о маркировке ATM.

  • покажите атм интервала коммутации на основе тэгов [международное количество], подробность — Показывает детализированную поинтерфейсную информацию о коммутации на основе тэгов.

Эти выходные данные показывают, что таблица маршрутизации завершена на Guilder:

Guilder#show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

 

Gateway of last resort is not set

 

     102.0.0.0/16 is subnetted, 1 subnets

C       102.102.0.0 is directly connected, Loopback0

     103.0.0.0/32 is subnetted, 1 subnets

O       103.103.0.1 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

     100.0.0.0/32 is subnetted, 1 subnets

O       100.100.0.1 [110/11] via 123.123.0.2, 23:45:47, Ethernet0/1

     101.0.0.0/32 is subnetted, 1 subnets

O IA    101.101.0.1 [110/13] via 129.129.0.2, 23:13:01, ATM1/0.1

O    128.128.0.0/16 [110/2] via 129.129.0.2, 23:14:31, ATM1/0.1

C    129.129.0.0/16 is directly connected, ATM1/0.1

     125.0.0.0/16 is subnetted, 1 subnets

O IA    125.125.0.0 [110/12] via 129.129.0.2, 23:13:08, ATM1/0.1

     123.0.0.0/16 is subnetted, 1 subnets

C       123.123.0.0 is directly connected, Ethernet0/1

     104.0.0.0/32 is subnetted, 1 subnets

O       104.104.0.1 [110/3] via 129.129.0.2, 23:14:32, ATM1/0.1

Проверьте префикс к сопоставлению меток и виртуальных каналов с командой show tag-switching forwarding-table.

Guilder#show tag-switching forwarding-table 

Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    

tag    tag or VC   or Tunnel Id      switched   interface              

26     Untagged    100.100.0.1/32    570        Et0/1      123.123.0.2  

27     2/33        103.103.0.1/32    0          AT1/0.1    point2point  

28     2/34        128.128.0.0/16    0          AT1/0.1    point2point  

29     2/35        104.104.0.1/32    0          AT1/0.1    point2point  

30     2/37        125.125.0.0/16    0          AT1/0.1    point2point  

31     2/38        101.101.0.1/32    0          AT1/0.1    point2point 

На Capri (LSR ATM), можно проверить TVC для маршрутизации привязки с командой show tag atm-tdp bindings. Один TVC используется для каждой записи таблицы маршрутизации.

Capri#show tag atm-tdp bindings 

 Destination: 103.103.0.0/16

    Tailend Switch ATM3/0/0 2/34 Active -> Terminating Active

    Tailend Switch ATM3/0/3 2/34 Active -> Terminating Active

 Destination: 129.129.0.0/16

    Tailend Switch ATM3/0/0 2/35 Active -> Terminating Active

 Destination: 101.101.0.1/32

    Transit ATM3/0/3 2/33 Active -> ATM3/0/0 2/36 Active

 Destination: 104.104.0.1/32

    Transit ATM3/0/3 2/35 Active -> ATM3/0/0 2/37 Active

 Destination: 125.125.0.0/16

    Transit ATM3/0/3 2/36 Active -> ATM3/0/0 2/38 Active

 Destination: 128.128.0.0/16

    Tailend Switch ATM3/0/3 2/37 Active -> Terminating Active

 Destination: 102.102.0.1/32

    Transit ATM3/0/0 2/53 Active -> ATM3/0/3 2/33 Active

 Destination: 100.100.0.1/32

    Transit ATM3/0/0 2/54 Active -> ATM3/0/3 2/34 Active

 Destination: 123.123.0.0/16

    Transit ATM3/0/0 2/55 Active -> ATM3/0/3 2/35 Active

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10467