Асинхронный режим передачи (ATM) : Эмуляция LAN (LANE)

Образец настройки для эмуляции LAN

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ иллюстрирует, как настроить сервисы Эмуляции LAN (LANE) и клиенты на маршрутизаторах Cisco, Коммутаторах Catalyst и ATM.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/10457/lane_config1.gif

В той настройке:

  • Router1 и Router2 являются маршрутизаторами Cisco 4500 рабочий Cisco Выпуск ПО IOS� 12.1 (4). Оба действия как Клиенты эмуляции LAN (LEC).

  • LightStream 1010 выполняет программное обеспечение Cisco IOS версии 12.0(10)W5(18b). Это действует как Сервер настройки эмуляции ЛВС (LECS).

  • Коммутатор Ethernet является Catalyst 5000 с Выводом LANE в slot4. Этот Вывод LANE действует как LEC и как сервер широковещательных и неизвестных сообщений LANE (LES/BUS).

  • Сервисы LANe были настроены согласно Рекомендациям по эмуляции локальных сетей.

  • Были настроены две эмулированных локальных сети (ELAN): тестовая стремительность и тест-elan2.

  • Router1 имеет LEC в каждом ELAN. Коммутатор Ethernet имеет LEC в тесте-elan2. Router2 и LightStream 1010 имеют LEC в тестовой стремительности.

  • На Коммутаторе Ethernet виртуальная локальная сеть, VLAN2, связана протестировать-elan2.

  • Router1 отвечает за выполнение маршрутизации между этими двумя ELAN.

Это - логическая настройка:

lane_config2.gif

Конфигурации

Эти конфигурации используются в данном документе:

Примечание: Только части команд настройки, которые относятся к LANE, включены.

LightStream 1010

!--- Output suppressed.

atm lecs-address-default 47.0091.8100.0000.0060.705a.8f01.0060.705a.8f05.00

!

lane database test

  name test-elan server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.01
  name test-elan2 server-atm-address 47.0091810000000060705A8F01.00E0B00B7031.02
!
interface atm2/0/0
 no ip address
 no ip directed-broadcast
 lane config auto-config-atm-address
 lane config database test
!
interface atm2/0/0.2 multipoint
 ip address 20.0.0.2 255.255.255.0
 no ip directed-broadcast
 lane client ethernet test-elan

!--- Output suppressed.

Тест LANE database определяет адрес точки доступа к сетевым услугам (NSAP) LES/BUS для каждого ELAN. Эти адреса в конфигурации LightStream 1010 указывают к Выводу LANE Коммутатора Ethernet:

lane-blade# show lane default

interface atm0:
LANE Client:        47.0091810000000060705A8F01.00E0B00B7030.**
LANE Server:        47.0091810000000060705A8F01.00E0B00B7031.**
LANE Bus:           47.0091810000000060705A8F01.00E0B00B7032.**
LANE Config Server: 47.0091810000000060705A8F01.00E0B00B7033.00

Примечание:  ** представляет количество подинтерфейса байтов в шестнадцатеричном формате.

Примечание: Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Как только вы определили LANE database, примените его на основной интерфейс LECS с помощью команды имени базы данных базы данных конфигурации "LANe". Это - пояснение трех команд, которые настроены на LECS:

  • Адрес точки доступа к сетевой службе (NSAP) атма lecs-address-default — Определяет, какой адрес коммутатор объявляет как являющийся NSAP LECS к его присоединенным устройствам через Протокол ILMI. В этом случае настроенным адресом является Адрес точки доступа к сетевой службе (NSAP), назначенный на интерфейс ATM0 LightStream 1010. Выполните команду show lane default для получения этого адреса:

    LightStream 1010# show lane default
    
    interface ATM2/0/0:
    LANE Client:        47.0091810000000060705A8F01.0060705A8F02.**
    LANE Server:        47.0091810000000060705A8F01.0060705A8F03.**
    LANE Bus:           47.0091810000000060705A8F01.0060705A8F04.**
    LANE Config Server: 47.0091810000000060705A8F01.0060705A8F05.00
    

    Примечание:  ** представляет количество подинтерфейса байтов в шестнадцатеричном формате.

  • конфигурация линии auto-config-atm-address — Указывает, отвечает ли LECS на настройки вызова, сделанные к его реальному Адресу точки доступа к сетевой службе (NSAP).

  • имя базы данных базы данных конфигурации "LANe" — Определяет, какого LANE database LECS использует.

Как только вы применили конфигурацию выше к основному интерфейсу, LECS произошел и активный.

Проверка состояния LECS

Выполните команду show lane config для проверки Статуса LECS:

LightStream 1010# show lane config

LE Config Server ATM2/0/0 config table: test
Admin: up State: operational
LECS Mastership State: active master
list of global LECS addresses (49 seconds to update):
47.0091810000000060705A8F01.0060705A8F05.00
ATM Address of this LECS: 47.0091810000000060705A8F01.0060705A8F05.00 (auto)
 vcd  rxCnt  txCnt  callingParty
  46      1      1  47.0091810000000060705A8F01.00E0B00B7031.01 LES test-elan 0 active
  62      1      1  47.0091810000000060705A8F01.00E0B00B7031.02 LES test-elan2 0 active
ATM Address of this LECS: 47.007900000000000000000000.00A03E000001.00 (well known)
cumulative total number of unrecognized packets received so far: 0
cumulative total number of config requests received so far: 608
cumulative total number of config failures so far: 601
    cause of last failure: no configuration
    culprit for the last failure: 47.009181000000FFFF705A8F01.0050E2030602.01
Маршрутизатор 1

!--- Output suppressed.

interface ATM0

 no ip address
 pvc 0/5 qsaal
 !
 PVC 0/16 ilmi
 !
 no ATM ilmi-keepalive
!
interface ATM0.2 multipoint
 ip address 20.0.0.1 255.255.255.0
 lane client ethernet test-elan
!
interface ATM0.3 multipoint
 ip address 21.0.0.1 255.255.255.0
 lane client ethernet test-elan2
!
router rip
 network 20.0.0.0
 network 21.0.0.0

!--- Output suppressed.

Проверка состояния LEC

Выполните эти команды для проверки состояния LEC:

  • show lane client [количество interface atm [.subinterface-количество]]

    router1# show lane client interface atm 0.2
    
    LE Client ATM0.2  ELAN name: test-elan  Admin: up  State: operational
    Client ID: 2                 LEC up for 18 hours 9 minutes 42 seconds
    ELAN ID: 0
    Join Attempt: 1
    Known LE Servers: 1
    HW Address: 0060.837b.b3a2   Type: ethernet             Max Frame Size: 1516
    ATM Address: 47.0091810000000060705A8F01.0060837BB3A2.02
     VCD  rxFrames  txFrames  Type       ATM Address
       0         0         0  configure  47.0091810000000060705A8F01.0060705A8F05.00
       5         1        47  direct     47.0091810000000060705A8F01.00E0B00B7031.01
       6       145         0  distribute 47.0091810000000060705A8F01.00E0B00B7031.01
       7         0      4567  send       47.0091810000000060705A8F01.00E0B00B7032.01
       8     10221         0  forward    47.0091810000000060705A8F01.00E0B00B7032.01
  • show atm ilmi-status — Проверяет, зарегистрировал ли клиент должным образом его Адрес точки доступа к сетевой службе (NSAP) через ILMI.

    router1# show atm ilmi-status
    
    Interface : ATM0 Interface Type : Private UNI (User-side)
    ILMI VCC : (0, 16) ILMI Keepalive : Disabled
    ILMI State:       UpAndNormal
    Peer IP Addr:     10.200.10.47    Peer IF Name:     ATM0/0/0
    Peer MaxVPIbits:  8               Peer MaxVCIbits:  14
    Active Prefix(s) :
    47.0091.8100.0000.0060.705a.8f01
    End-System Registered Address(s) :
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.02(Confirmed)
    47.0091.8100.0000.0060.705a.8f01.0060.837b.b3a2.03(Confirmed)

    Сошлитесь на эти документы для получения дополнительной информации о команде show atm ilmi-status:

Маршрутизатор 2

!--- Output suppressed.

interface ATM1

 no ip address
 PVC 0/16 ilmi
 !
 PVC 0/5 qsaal
 !
 no ATM ilmi-keepalive
!
interface ATM1.2 multipoint
 ip address 20.0.0.3 255.255.255.0
 lane client ethernet test-elan
!
router rip
 network 20.0.0.0

!--- Output suppressed.

Вывод LANE коммутатора Ethernet

!--- Output suppressed.

interface ATM0

 ATM preferred phy A
 atm PVC 1 0 5 qsaal
 ATM PVC 2 0 16 ilmi
 no ATM ilmi-keepalive
!
interface ATM0.1 multipoint
 lane server-bus ethernet test-elan

!--- Configuration of the Bus.

!
interface ATM0.2 multipoint
 lane server-bus ethernet test-elan2
!
interface ATM0.3 multipoint
 lane client ethernet 2 test-elan2

!--- Output suppressed.

Команда имени ELAN lane server-bus ethernet настраивает это устройство как LES/BUS для ELAN, названного именем ELAN.

Примечание: Может только быть одна шина сервера на многоточечного подчиненного интерфейс.

Дополнительные команды

Это некоторые полезные команды для использования при настройке LANE. Необязательно для использования этих команд для осуществления LANE.

О клиенте LECS

interface ATM2/0/0
  no ip address
  no ip directed-broadcast
  lane config fixed-config-atm-address
  lane config auto-config-atm-address
  lane config config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane config database test
  • lane config fixed-config-atm-address — Указывает, что LECS отвечает на настройки вызова, сделанные к хорошу известному адрес NSAP. Хорошо известное адрес NSAP 47.007900000000000000000000.00A03E000001.00.

  • NSAP atm-address config конфигурации линии — Указывает, что LECS также отвечает на настройки вызова, сделанные к настроенному Адресу точки доступа к сетевой службе (NSAP) 47.0091.8100.0000.0060.705a.8f01.0000.0000.0001.01.

На сервере эмуляции локальных сетей (LES)

interface ATM0.1 multipoint
  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane bus-atm-address 47.0091810000000060705A8F01.000000000003.01
  lane server-bus ethernet test-elan
  • NSAP lane config-atm-address — Вынуждает LES/BUS соединиться с LECS с адресом NSAP, вместо того, чтобы использовать адрес LECS, изученный из ILMI.

  • NSAP lane server-atm-address и NSAP lane bus-atm-address — Позволяют вам статически настраивать Адрес точки доступа к сетевой службе (NSAP) LES и ШИНЫ соответственно.

Обратитесь к Адресам ATM Жесткого кодирования для LES/LEC/ШИНЫ/LECS для получения дополнительной информации.

В LEC

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0
  lane fixed-config-atm-address
  lane client ethernet test-elan

interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane config-atm-address 47.0091810000000060705A8F01.000000000001.01
  lane client ethernet test-elan
  interface ATM1.2 multipoint

  ip address 20.0.0.3 255.255.255.0

  lane server-atm-address 47.0091810000000060705A8F01.000000000002.01
  lane client ethernet test-elan
  • lane fixed-config-atm-address — Вынуждает LEC соединиться с LECS с помощью хороша известного адрес NSAP, вместо того, чтобы использовать Адрес точки доступа к сетевой службе (NSAP) LECS, изученный из ILMI.

  • NSAP lane config-atm-address — Вынуждает LEC соединиться с LECS с адресом NSAP, вместо того, чтобы использовать адрес LECS, изученный из ILMI.

  • NSAP lane server-atm-address — Вынуждает LEC непосредственно соединиться с LES с адресом NSAP, не соединяясь с LECS сначала.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10457