Технологии LRE и xDSL : Симметричная DSL с высокоскоростной передачей данных (G.SHDSL)

Настройка встречного CPE через порты G.SHDSL

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ показывает простейшую конфигурацию для настройки двух последовательно соединеннных через Multirate Symmetric High-Speed Digital Subscriber Line (G.SHDSL) порты маршрутизаторов. Это описывает, как маршрутизатор G.SHDSL Cisco₩½ может быть настроен для работы as�a Устройства DSL Центрального офиса (CO), которое завершает соединение от другого удаленного устройства CPE G.SHDSL.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • 828 Customer Premises Equipment (CPE) рабочая Cisco Выпуск ПО IOS� 12.2 (8) T1

  • 2612 маршрутизаторов рабочее программное обеспечение Cisco IOS версии 12.2(8)T

  • 2612 маршрутизаторов с помощью Интерфейсной карты WAN (WIC)-1SHDSL

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/25900/dsl_cpe_config1.gif

Конфигурации

Эти конфигурации используются в данном документе:

Примечание: В этой конфигурации 828 А настроены с типом оборудования "CO ", который моделирует сигнализацию от CO. В то время как 2612 с WIC G.SHDSL настроен с типом оборудования «CPE»."

DSL5-828A (CPE Cisco 828, действующий как CO)
DSL5-828A#show run
Building configuration...

Current configuration : 769 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DSL5-828A
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Dialer0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!         
dialer-list 1 protocol ip permit
!
line con 0
 stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

DSL4-2612A (Маршрутизатор Cisco 2612, действующий как CPE)
dsl4-2612a#show run
Building configuration...

Current configuration : 927 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dsl4-2612a
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0/0
 ip address 172.16.1.2 255.255.255.0
 shutdown
 half-duplex
!         
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Dialer0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
!
mgcp profile default
!         
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Справочник по командам

В этом разделе содержится информация об измененных командах. Все другие команды, используемые с этой функцией, задокументированы в публикации Справочника по командам программного обеспечения Cisco IOS версии 12.2.

Измененные команды

  • тип оборудования DSL

  • dsl linerate

  • dsl operating-mode (g.shdsl)

тип оборудования DSL

Выполните команду dsl equipment-type в режиме ATM-интерфейса для настройки ATM-интерфейса DSL для функционирования как оборудование CO или CPE. Используйте эту команду с параметром no для восстановления типа оборудования по умолчанию.

  • dsl equipment-type {компания | cpe}

  • никакой dsl equipment-type

Описания синтаксиса для этих команд:

  • компания — Настраивает ATM-интерфейс DSL для функционирования как оборудование CO.

  • cpe — Настраивает ATM-интерфейс DSL для функционирования как CPE.

Настройки по умолчанию

ATM-интерфейс DSL функционирует как CPE.

Интерфейсный командный режим

Интерфейс ATM для WIC G.SHDSL был встроен в следующие версии ПО Cisco IOS:

  • 12.2 (4) XL — на Маршрутизаторах серии Cisco 2600

  • 12.2 (8) T — на серии Cisco 2600 и Маршрутизаторах серии Cisco 3600

Инструкции по использованию

Эта команда настройки применяется к конкретному ATM-интерфейсу. Необходимо задать ATM-интерфейс перед выдачей этой команды. ATM-интерфейс должен также быть в состоянии завершения работы перед выдачей этой команды. Данный пример показывает, как настроить ATM-интерфейс DSL 1/1 для функционирования как оборудование CO.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 1/1 
Router(config-if)#dsl equipment-type co 

Router(config-if)#end 
Router# clear interface atm 0/1 

Router#

Связанные команды

  • dsl linerate скорость линии для ATM-интерфейса DSL.

  • dsl operating-mode (g.shdsl) — Задает рабочий режим ATM-интерфейса DSL.

dsl linerate

Выполните команду dsl linerate в режиме ATM-интерфейса для определения скорости линии для ATM-интерфейса DSL. Используйте эту команду с параметром no для восстановления скорости линии по умолчанию.

  • dsl linerate {кбит/с | автоматический}

  • никакой dsl linerate

Описания синтаксиса для этих команд:

  • кбит/с — Задает скорость линии в килобитах в секунду для ATM-интерфейса DSL. Допустимые записи равняются 72, 136, 200, 264, 392, 520, 776, 1032, 1160, 1544, 2056, и 2312.

  • автоматический — Настраивает ATM-интерфейс DSL для автоматического обучения для оптимальной скорости линии путем согласования с Умножителем доступа DSL дальнего конца (DSLAM) или WIC.

Настройки по умолчанию

ATM-интерфейс DSL автоматически синхронизирует свою скорость линии с DSLAM дальнего конца или WIC.

Интерфейсный командный режим

Интерфейс ATM для WIC G.SHDSL был встроен в следующие версии ПО Cisco IOS:

  • 12.2 (4) XL — на Маршрутизаторах серии Cisco 2600

  • 12.2 (8) T — на серии Cisco 2600 и Маршрутизаторах серии Cisco 3600

Инструкции по использованию

Эта команда настройки применяется к конкретному ATM-интерфейсу. Необходимо задать ATM-интерфейс перед выдачей этой команды. ATM-интерфейс должен также быть в состоянии завершения работы перед выдачей этой команды. Данный пример показывает, как настроить ATM-интерфейс DSL 0/1 для работы в скорости линии 1040 кбит/с:

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/1 
Router(config-if)#dsl linerate 1040 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router# 

Связанные команды

  • тип оборудования DSL ATM-интерфейс DSL для функционирования как оборудование CO или CPE.

  • dsl operating-mode (g.shdsl) — Задает рабочий режим ATM-интерфейса DSL. Используйте эту команду с параметром no для восстановления рабочего режима по умолчанию.

dsl operating-mode (g.shdsl)

Выполните команду ATM-интерфейса dsl operating-mode для определения рабочего режима DSL для ATM-интерфейса. Используйте эту команду с параметром no для восстановления рабочего режима по умолчанию.

  • dsl operating-mode gshdsl симметричное приложение {| B}

  • никакой dsl operating-mode

Описания синтаксиса для этих команд:

  • gshdsl — Настраивает ATM-интерфейс DSL для работы в режиме высокой скорости мультискорости на G.991.2 ITU.

  • симметричный — Настраивает ATM-интерфейс DSL для работы в симметричном режиме на G.991.2 ITU.

  • приложение {| B} — Задает региональные рабочие параметры. Войдите для Северной Америки и B для Европы. По умолчанию является A.

Настройки по умолчанию

Рабочий режим по умолчанию является G.SHDSL симметричное приложение A.

Интерфейсный командный режим

ATM-интерфейс для WIC G.SHDSL был представлен в программном обеспечении Cisco IOS версии 12.1(3) X и интегрировался в эти Cisco IOS Software Release.

  • 12.2 (2) T — на Маршрутизаторах серии Cisco 1700

  • 12.2 (4) XL — на Маршрутизаторах серии Cisco 2600

  • 12.2 (8) T — на серии Cisco 2600 и Маршрутизаторах серии Cisco 3600

Инструкции по использованию

Эта команда настройки применяется к конкретному ATM-интерфейсу. Необходимо задать ATM-интерфейс перед выдачей этой команды. ATM-интерфейс должен также быть в состоянии завершения работы перед вводом этой команды. Данный пример показывает, как настроить ATM-интерфейс DSL 0/0 для работы в режиме G.SHDSL.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/0 
Router(config-if)#dsl operating-mode gshdsl symmetric annex A 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router#

Связанные команды

  • тип оборудования DSL ATM-интерфейс DSL для функционирования как оборудование CO или CPE.

  • dsl linerate скорость линии для ATM-интерфейса DSL.

Проверка

Необходимо видеть, что эти выходные данные идут через сеанс консоли. Выполните команду term mon, если вы - Telneted в маршрутизаторы, для просмотра консольных сообщений.

00:51:25: %GSI-6-RESET: Interface ATM0/0, bringing up the line. 
It may take several seconds for the line to be active. 
00:52:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
00:52:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
00:52:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
00:52:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
00:52:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up 

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • show running-config текущую конфигурацию и просматривает статус для всех контроллеров.

  • слот/порт show controllers atm — Статистика контроллера ATM представлений.

  • show atm vc статус Постоянной виртуальной цепи (PVC).

  • show dsl interface atm — Просматривает статус модема G.SHDSL

  • show interface atm — Просматривает статус ATM-интерфейса.

Это - пример выходных данных от команды show atm vc. Удостоверьтесь, что активные PVCs подключены.

dsl4-2612a#show atm vc 
           VCD /                                        Peak  Avg/Min Burst 
Interface  Name         VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts 
0/0        1              0    35  PVC    SNAP     UBR    2304                UP 
0/0        2              8    35  PVC    MUX      UBR    2304                UP

Это - пример выходных данных от команды show dsl interface atm. Если линия не работает, оператор Line is not active. Some of the values may not be accurate. появляется. Можно также проверить, корректны ли тип оборудования и конфигурация рабочего режима для приложения.

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Data (0x1) 
 Received SNR:           39 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5 

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

Line is not active. Some of the values printed may not be accurate. 
 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Idle (0x0) 
 Received SNR:           38 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5

Если вы неспособны пропинговать через канал ATM, проверить, что ATM-интерфейсом является UP/UP путем запуска команды show interface для ATM-интерфейса на обоих маршрутизаторах. Выполните команду show interface atm для просмотра статуса ATM-интерфейса. Удостоверьтесь, что слот ATM, порт и протокол линии связи подключены, как показано в примере.

DSL5-828A#show interfaces atm0 
ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Globespan G.SHDSL module) 
  MTU 1500 bytes, sub MTU 1500, BW 2312 Kbit, DLY 80 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation ATM, loopback not set 
  Encapsulation(s): AAL5, PVC mode 
  10 maximum active VCs, 2 current VCCs 
  VC idle disconnect time: 300 seconds 
  Last input never, output 00:00:08, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: None 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     261 packets input, 11170 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     264 packets output, 11388 bytes, 0 underruns 
     0 output errors, 0 collisions, 2 interface resets 
     0 output buffer failures, 0 output buffers swapped out

Устранение неисправностей

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • debug atm events — Определяет связанные события ATM, поскольку они генерируются.

  • debug atm errors, какие интерфейсы испытывают затруднения.

Это - информация о примере отладки от ATM-интерфейса, выполняя отладки, перечисленные в этом разделе, и подключаясь к сети (имейте в виду, что могло бы потребоваться 30 секунд или больше для канала для подъема).

01:07:15: ATM0/0 dslsar_1a_reset: PLIM type is 19, Rate is 2304Mbps 
01:07:15: ATM0/0 dslsar_1a_shutdown: state=4 
01:07:15: dslsar disable ATM0/0 

01:07:15: %GSI-6-RESET: Interface ATM0/0, bringing up the line.
It may take several seconds for the line to be active. 
01:07:15: Resetting ATM0/0 
01:07:15:  dslsar_1a_config(ATM0/0) 
01:07:15:  dslsar_1a_enable(ATM0/0) 
01:07:15: ATM0/0: dslsar_init(825AD084,FALSE) 
01:07:15: dslsar disable ATM0/0 

01:07:16: ATM0/0 dslsar_init: DSLSAR TXRX disabled 

01:07:16: ATM0/0 dslsar_1a_enable: restarting VCs: 0 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 1, vc = 0x82A17BE0adb->flags = 0x4800C 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 2, vc = 0x82A1863Cadb->flags = 0x4800C 
dsl4-2612a# 
dsl4-2612a# 
01:07:16: %SYS-5-CONFIG_I: Configured from console by console 
01:07:19: dslsar disable ATM0/0 

01:08:03: ATM0/0 dslsar_MatchSARTxToLineSpeed(): usbw 2304, clkPerCell 6360 prev_clkPerCell 9702 
01:08:03: ATM0/0 dslsar_update_us_bandwidth(): upstream bw =2304 Kbps 
01:08:09:  dslsar_periodic: ENABLING DSLSAR 

01:08:09: dslsar enable ATM0/0 

01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:1 vpi:0 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 1, vpi 0, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 2304, tbds_per_tsi = 15, max_pkt_len = 4470, 
max_tx_time = 1862ATM0/0 last_address 0x12E14 

01:08:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:2 vpi:8 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 2, vpi 8, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
01:08:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
01:08:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
01:08:11:  dslsar_atm_lineaction(ATM0/0): state=4 
01:08:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
01:08:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

Дополнительные сведения


Document ID: 25900