Протокол IP : Протокол OSPF

Выбор пути LSA типа 5 в зависимости от адреса пересылки

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ призван продемонстрировать механизм выбора пути OSPF, когда маршрутизатор получает два объявления описаний локального состояния соединений (LSA) типа 5 для данной внешней сети. В данном примере для одного объявления LSA задан нулевой адрес пересылки (0.0.0.0), а для другого — ненулевой.

Предварительные условия

Требования

Ознакомление с этим документом требует наличия следующих знаний:

  • Основные IP-маршрутизации

  • Основные понятия и термины протокола маршрутизации OSPF

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям программного и аппаратного обеспечения.

  • Маршрутизаторы Cisco 2503

  • Cisco Выпуск ПО IOS� 12.2 (24a) работающий на всех маршрутизаторах

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Как эстафетный адрес типа 5 LSA может повлиять на выбор пути

Адреса пересылки, не заданные для обеих LSA

Следующая топология показывает, как адрес пересылки в объявлениях о состоянии канала (LSA) пятого типа в протоколе OSPF влияет на выбор маршрута для LSA пятого типа.

/image/gif/paws/25493/type5_lsa_01.gif

В схеме выше, все маршрутизаторы, кроме Маршрутизатора 8, выполняют OSPF в области 0. В целях этого документа конфигурации маршрутизатора 3 и Маршрутизатор 4 являются самыми важными, потому что они - граничный маршрутизатор автономной системы (ASBR), генерирующие тип 5 LSA. Как показано ниже, маршрутизаторы 3 и 4 имеют статический маршрут к сети 200.200.200.0 255.255.255.0, которая перераспределяется в OSPF.

Маршрутизатор 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Маршрутизатор 4
interface Ethernet0
 ip address 172.16.3.4 255.255.255.0
!
interface Serial0
 ip address 172.16.7.4 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.7.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Примечание: Маршрутизатор 3 и Маршрутизатор 4 не включают сеть 172.16.3.0 255.255.255.0 в процессе OSPF; поэтому, типу 5 LSA, генерируемых обоими маршрутизаторами, установили адреса пересылки в 0.0.0.0

В данном примере Маршрутизатор 5 может использоваться для просмотра внешних LSA. Для просмотра внешних LSA выполните команду show ip ospf database external на Маршрутизаторе 5. Вывод данной команды приводится ниже.

Маршрутизатор 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 1514
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000030
  Checksum: 0x93C0
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 1922
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000027
  Checksum: 0x83D4
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

То, что вы видите выше, – это адреса пересылки для LSA типа 5, созданные маршрутизаторами 3 и 4 и настроенными на 0.0.0.0. В этом случае LSA, которые должен быть установлен в таблице маршрутизации маршрутизатора 5 определятся через сравнение метрик к ASBR, генерирующим LSA. Путем запуска команды show ip ospf border-routers на Маршрутизаторе 5 вы видите метрики, которые Маршрутизатор 5 имеет для ASBR. Вывод данной команды приводится ниже.

Маршрутизатор 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 14
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 14
router-5#

Как показано выше, 64 метрика Маршрутизатора 5 для достижения ASBR 172.16.3.3, в то время как метрика для достижения ASBR 172.16.7.4 равняется 74; поэтому, Маршрутизатор 5 выбирает LSA, генерируемый ASBR 172.16.3.3 для размещения в его таблицу маршрутизации (показанный ниже).

Маршрутизатор 5
router-5# 
show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.2.3, 19:59:25, Serial0
     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 19:59:25, Ethernet0
C       172.16.2.0 is directly connected, Serial0
router-5#

Набор адресов для пересылки устанавливается для одного LSA, но не для других

Такая же топология, как приведенная выше, используется в этой части документа. Конфигурация маршрутизатора 4 также остается без изменений, однако конфигурация маршрутизатора 3 изменилась - в нее вошла сеть 172.16.3.0 255.255.255.0 в области 0 процесса OSPF. Конфигурацию Маршрутизатора 3 показывают ниже с изменением, выделенным полужирным.

Маршрутизатор 3
interface Ethernet0
 ip address 172.16.3.3 255.255.255.0
 ip ospf cost 15
!
interface Serial0
 ip address 172.16.2.3 255.255.255.0
!
router ospf 7
 redistribute static subnets
 network 172.16.2.0 0.0.0.255 area 0
 network 172.16.3.0 0.0.0.255 area 0
!
ip route 200.200.200.0 255.255.255.0 172.16.3.8

Результатом приведенных выше изменений конфигурации стало то, что тип 5 LSA, созданный маршрутизатором 3, теперь свой адрес пересылки установил на IP-адрес маршрутизатора 8, как показано в приведенной ниже срезке базы данных маршрутизатора 5.

Маршрутизатор 5
router-5# show ip ospf database external

            OSPF Router with ID (172.16.6.5) (Process ID 7)

                Type-5 AS External Link States

  Routing Bit Set on this LSA
  LS age: 270
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.3.3
  LS Seq Number: 80000033
  Checksum: 0x5138
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 172.16.3.8
        External Route Tag: 0

  Routing Bit Set on this LSA
  LS age: 258
  Options: (No TOS-capability, DC)
  LS Type: AS External Link
  Link State ID: 200.200.200.0 (External Network Number )
  Advertising Router: 172.16.7.4
  LS Seq Number: 80000029
  Checksum: 0x7FD6
  Length: 36
  Network Mask: /24
        Metric Type: 2 (Larger than any link state path)
        TOS: 0
        Metric: 20
        Forward Address: 0.0.0.0
        External Route Tag: 0

router-5#

Ниже можно увидеть, что LSA типа 5, созданный маршрутизатором Router 3, имеет адрес пересылки 172.16.3.8, в то время как LSA типа 5, созданный маршрутизатором Router 4, сохраняет адрес пересылки 0.0.0.0.

В этом случае LSA, который будет установлен в таблице маршрутизации Маршрутизатора 5, определен путем сравнения метрики Маршрутизатора 5 с ASBR (Маршрутизатор 4), который генерировал LSA с адресом пересылки 0.0.0.0 к метрике Маршрутизатора 5 для достижения адреса пересылки 172.16.3.8, который был установлен для LSA, генерируемого ASBR (Маршрутизатор 3).

Для наблюдения метрик к ASBR выполните команду show ip ospf border в Маршрутизаторе 5. Результаты приводятся ниже.

Маршрутизатор 5
router-5# show ip ospf border-routers

OSPF Process 7 internal Routing Table

Codes: i - Intra-area route, I - Inter-area route

i 172.16.7.4 [74] via 172.16.6.6, Ethernet0, ASBR, Area 0, SPF 15
i 172.16.3.3 [64] via 172.16.2.3, Serial0, ASBR, Area 0, SPF 15
router-5#

В вышеупомянутых выходных данных метрика к Маршрутизатору 4 равняется 74. Это по сравнению с метрикой Маршрутизатора 5 для достижения адреса пересылки 172.16.3.8, который может быть замечен использующий команду show ip route 172.16.3.8. Результат выполнения данной команды приведен ниже.

Маршрутизатор 5
router-5# show ip route 172.16.3.8
Routing entry for 172.16.3.0/24
  Known via "ospf 7", distance 110, metric 79, type intra area
  Last update from 172.16.2.3 on Serial0, 00:30:49 ago
  Routing Descriptor Blocks:
  * 172.16.2.3, from 172.16.3.3, 00:30:49 ago, via Serial0
      Route metric is 79, traffic share count is 1

router-5#

Так, метрика для достижения Граничного маршрутизатора автономной системы 4, который равняется 74, по сравнению с метрикой для достижения адреса пересылки 172.16.3.8 (генерируемый Маршрутизатором 3), который равняется 79. Поэтому LSA, установленный в таблице маршрутизации, является LSA, генерируемым Маршрутизатором 4, как показано в выходных данных Маршрутизатора 5 show ip route ниже.

Маршрутизатор 5
router-5# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

O E2 200.200.200.0/24 [110/20] via 172.16.6.6, 00:35:14, Ethernet0
     172.16.0.0/24 is subnetted, 4 subnets
C       172.16.6.0 is directly connected, Ethernet0
O       172.16.7.0 [110/74] via 172.16.6.6, 00:35:14, Ethernet0
C       172.16.2.0 is directly connected, Serial0
O       172.16.3.0 [110/79] via 172.16.2.3, 00:35:14, Serial0
router-5#

Когда метрика перераспределенного маршрута от множественных ASBR равна, как проиллюстрировано в документе, адрес пересылки изменяет поведение типа 5 выборов пути LSA. Когда маршрутизатор получает два, вводят 5 LSA тому же назначению с набором адресов пересылки на обоих LSA, маршрутизатор делает сравнение на основе метрики к адресам пересылки. LSA с адресом пересылки, который предлагает меньшую метрику, размещен в таблицу маршрутизации.

Если метрика перераспределенных маршрутов является другой, маршрутизаторы предпочитают маршрут с наименьшей метрикой а не наименьшей метрикой к адресу пересылки.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 25493