Протокол IP : Протокол BGP

Настройка функции максимального числа префиксов BGP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ содержит сведения по настройке и устранению неполадок возможности максимального префикса протокола граничного шлюза (BGP).

Характеристика получения максимального префикса BGP позволяет вам управлять, сколько префиксов может быть получено от соседнего узла. По умолчанию эта функция позволяет маршрутизатору отключить узел, когда число полученных префиксов от этого узла превысит заданный предел Maximum-Prefix. Эта функция обычно используется для узлов внешнего BGP, но может быть применена к внутренним Одноранговым соединениям по протоколу BGP также.

Характеристика получения максимального префикса полезна, когда в изменении политики ограничения исходящего трафика на удаленном пиринговом сайте маршрутизатор начинает получать больше маршрутов, чем память маршрутизатора может взять. Если это то же маршрутизатор взаимодействует с BGP и также выполняет важные функции маршрутизации в сети, эти издержки могли оказаться плохими. Проблема BGP могла разрушить подключение внутренней сети. С командой neighbor maximum-prefix возможно защитить маршрутизатор с этой ситуацией.

Когда вы запланируете использовать эту функцию, рассмотрите эти ключевые вопросы:

  • Знайте, сколько маршрутов удаленный маршрутизатор равноправного информационного обмена BGP обычно передает.

  • Установите порог немного выше, чем количество префиксов BGP ожидало быть полученным во время нормальных работ.

  • Знайте, что действие берет в случае, если удаленное Одноранговое соединение по протоколу BGP передает больше префиксов, чем ожидаемые. Доступные действия могли или быть должны перевести сеанс в нерабочее состояние и подавить отношение Соседнего BGP узел, пока вы не используете clear ip bgp x. x . x . x дают команду или, альтернативно, чтобы только регистрировать предупреждающее сообщение.

Примечание: Усовершенствование к этой функции представлено в Cisco Выпуск ПО IOS� 12.0 (22) S и 12.2 (15) T. Усовершенствование позволяет пользователю автоматически восстанавливать сеанс с равноправным участием, который был переведен в нерабочее состояние, потому что превышено настроенное Ограничение максимального префикса. Когда эта опция активирована, никакое вмешательство от оператора сети не требуется. Для получения дополнительной информации сошлитесь на Сеанс Перезапуска BGP После Ограничения максимального префикса.

Предварительные условия

Требования

Cisco рекомендует, чтобы у читателей данной документации было основное понимание этой информации:

Раздел Реализации BGP Руководства IP - конфигурации Cisco IOS, релиза 12.2

Раздел BGP - конфигурации BGP Настройки

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

Маршрутизаторы Cisco серии 2500 на Cisco выпуски ПО IOS� 12.2 (27)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Обратитесь к Cisco Feature Navigator (только зарегистрированные клиенты) для определения, какие версии программного обеспечения Cisco IOS можно использовать с этой функцией.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Синтаксис команды, используемый для настройки Характеристики получения максимального префикса BGP:

neighbor {ip-address | peer-group-name} maximum-prefix 
maximum [threshold] [restart restart-interval] [warning-only]

Где:

  • максимум — Представляет максимальное число префиксов, позволенных от соседнего узла.

  • threshold — Дополнительное целое значение, которое задает в том, какое максимальное значение процента настроено. Маршрутизатор начинает генерировать предупреждающее сообщение. Значения располагаются в диапазоне от 1 до 100 процентов, значение по умолчанию - 75 процентов.

    Например, если настроенное максимальное значение равняется 20 и порогу 60, маршрутизатор генерирует предупреждающие сообщения, когда количество полученных маршрутов BGP от соседнего узла превышает 60 процентов из 20 (12) маршруты.

    restart-interval — Дополнительный Временной интервал (в минутах), что восстановлен сеанс с равноправным участием. Диапазон с 1 до 65535 минут.

    когда Ограничение максимального префикса превышено, вместо того, чтобы завершить сеанс с равноправным участием, только для предупреждения — (дополнительный) Позволяет маршрутизатору генерировать сообщение журнала.

Для лучше иллюстрирования использования рассмотрите данный пример:

neighbor 10.1.1.1 maximum-prefix 3000

!--- Drops the peering to 10.1.1.1 when 
!--- more than 3000 prefixes are received.


neighbor 10.1.1.1 maximum-prefix 3000 warning-only

!--- Logs a warning message when the peer sends 
!--- more than 3000 prefixes.


neighbor 10.1.1.1 maximum-prefix 3000 50

!--- Logs a warning message at 1500 and drops the 
!--- peering  when over 3000 prefixes are sent.


neighbor 10.1.1.1 maximum-prefix 3000 50 warning-only

!--- Initially warns at 1500 and re-warns 
!--- (different message) at 3000 prefixes received.
!---  However, the BGP Peer is not disconnected.

Примечание: Для просмотра дополнительных сведений о командах, применяемых в этом документе, ,используйте Средство поиска команд IOS Command Lookup Tool(только зарегистрированные клиенты).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/25160/bgp-maximum-prefix-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Определение максимального числа префиксов для выдачи только предупреждающего сообщения при превышении порога

Когда количество префиксов, полученных от Router_A, превышает пороговый набор, в Конфигурации только с предупреждением и максимальным префиксом Router_B настроен для регистрации только предупреждающего сообщения. Конфигурация обоих маршрутизаторов находится как показано в этой таблице. Заметьте присутствие ключевого слова только для предупреждения, настроенного с соседней командой.

Маршрутизатор А Маршрутизатор В
hostname Router_A
! 
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Serial0 
 ip address 192.168.1.1 255.255.255.252
!
interface Serial1
 ip unnumbered Loopback0 
! 
router bgp 200
 no synchronization
 bgp router-id 10.0.0.1
 bgp log-neighbor-changes
 neighbor 192.168.1.2 local-as 100
 neighbor 10.0.0.2 remote-as 300
 neighbor 10.0.0.2 ebgp-multihop 2
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 version 4
 no auto-summary
!
ip route 10.0.0.2 255.255.255.252 Serial1
hostname Router_B 
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.252
!
interface Ethernet0 
 ip address 10.0.1.1 255.255.255.0 
!
interface Serial0
 ip unnumbered Loopback0
! 
router bgp 300
 no synchronization
 bgp router-id 10.0.0.2
 bgp log-neighbor-changes
 neighbor 10.0.0.1 remote-as 200
 neighbor 10.0.0.1 ebgp-multihop 2
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 version 4
 neighbor 10.0.0.1 maximum-prefix 10 80 warning-only

!--- Enables warning message logging when the number 
!--- of BGP routes learned from neighbor 
!--- 10.0.0.1 exceeds eight. 

 no auto-summary
!
ip route 10.0.0.1 255.255.255.252 Serial0

Показ и результаты выполнения команды debug в разделе Сверения и Устранения неполадок этого документа сообщают, что действительно происходит на Router_B каждый раз, когда количество префиксов, полученных от Router_A, превышает пороговый набор.

Определение максимального числа префиксов для разрыва отношений с окружением при превышении порога

Когда количество префиксов, полученных от Router_A, превышает пороговый набор, в Maximum-Prefix, настроенном для перевода в нерабочее состояние конфигурации отношений соседей, Router_B настроен для генерации предупреждающих сообщений. Когда предел максимального числа префиксов превышен, Router_B также настроен для перевода в нерабочее состояние Соседнего BGP узел. Конфигурация обоих маршрутизаторов находится как показано в таблице. Заметьте отсутствие набора ключевого слова только для предупреждения с соседней командой.

Маршрутизатор А Маршрутизатор В
hostname Router_A
! 
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
!
interface Serial0 
 ip address 192.168.1.1 255.255.255.252
!
interface Serial1
 ip unnumbered Loopback0 
! 
router bgp 200
 no synchronization
 bgp router-id 10.0.0.1
 bgp log-neighbor-changes
 neighbor 192.168.1.2 local-as 100
 neighbor 10.0.0.2 remote-as 300
 neighbor 10.0.0.2 ebgp-multihop 2
 neighbor 10.0.0.2 update-source Loopback0
 neighbor 10.0.0.2 version 4
 no auto-summary
!
ip route 10.0.0.2 255.255.255.252 Serial1
hostname Router_B 
!
interface Loopback0
 ip address 10.0.0.2 255.255.255.252
!
interface Ethernet0 
 ip address 10.0.1.1 255.255.255.0 
!
interface Serial0
 ip unnumbered Loopback0
! 
router bgp 300
 no synchronization
 bgp router-id 10.0.0.2
 bgp log-neighbor-changes
 neighbor 10.0.0.1 remote-as 200
 neighbor 10.0.0.1 ebgp-multihop 2
 neighbor 10.0.0.1 update-source Loopback0
 neighbor 10.0.0.1 version 4
 neighbor 10.0.0.1 maximum-prefix 10 80

!--- This forces the neighbor session to tear down  
!--- when the BGP learned routes from 
!--- the neighbor exceeds 10.

 no auto-summary
!
ip route 10.0.0.1 255.255.255.252 Serial0

Показ и результаты выполнения команды debug в Verifiy и Troubleshoot разделяют отчёт, что действительно происходит на Router_B каждый раз, когда количество префиксов, которые это получает от Router_A, превышает пороговый набор.

Проверка и устранение неполадок

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Синтаксис команды и настройки по умолчанию функции, использованной в этом документе, доступны в странице Command BGP.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

Maximum-Prefix Warning-Only

Обратите внимание на это количество:

  • Максимально согласованных префиксов: 10

  • Порог предупреждения: 80 процентов (восемь)

Пока количество принятых префиксов не становится выше, чем пороговый набор, восемь, никакие сообщения не зарегистрированы. Как только количество маршрутов BGP, изученных от соседнего узла 10.0.0.1, превышает пороговый предел восемь, Router_B регистрирует это сообщение. Когда девять префиксов передаются, эта ситуация моделируется:

%BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0) reaches 9, max 10

Если ситуация ухудшается и превышает набор количества Maximum-Prefix 10, то журналы маршрутизатора это сообщение. Когда 12 префиксов передаются, эта ситуация моделируется:

%BGP-3-MAXPFXEXCEED: No. of prefix received from 10.0.0.1 (afi 0): 11 exceed limit 10 

Когда вы активируете , debug ip bgp updates in , вы в состоянии получить более внимательное рассмотрение в том, что происходит. Однако не используйте эту команду в продуктивной среде с несколькими тысячами префиксов. Изображенная ситуация состоит в том, что Router_B уже имеет установленный пиринг. Шесть префиксов были объявлены к Маршрутизатору B Router_A. Теперь три дополнительных префикса объявлены одноранговым Router_A.

Router_B# debug ip bgp updates in
*Mar 12 07:31:18.944: BGP(0): 10.0.0.1 rcvd UPDATE w/ attr: nexthop 10.0.0.1, or
igin i, metric 0, path 200
*Mar 12 07:31:18.948: BGP(0): 10.0.0.1 rcvd 10.0.1.0/24...duplicate ignored
*Mar 12 07:31:18.952: BGP(0): 10.0.0.1 rcvd 10.0.2.0/24...duplicate ignored
*Mar 12 07:31:18.960: BGP(0): 10.0.0.1 rcvd 10.0.3.0/24...duplicate ignored
*Mar 12 07:32:20.224: BGP(0): 10.0.0.1 rcvd 10.0.4.0/24...duplicate ignored
*Mar 12 07:32:20.228: BGP(0): 10.0.0.1 rcvd 10.0.5.0/24...duplicate ignored
*Mar 12 07:32:20.232: BGP(0): 10.0.0.1 rcvd 10.0.6.0/24...duplicate ignored
*Mar 12 07:34:19.768: BGP(0): 10.0.0.1 rcvd 10.0.7.0/24
*Mar 12 07:34:19.772: BGP(0): 10.0.0.1 rcvd 10.0.8.0/24
*Mar 12 07:34:19.780: BGP(0): 10.0.0.1 rcvd 10.0.9.0/24
*Mar 12 07:34:19.780: 
%BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0
) reaches 9, max 10

*Mar 12 07:34:19.792: BGP(0): Revise route installing 1 of 1 route for 10.0.7.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 07:34:19.796: BGP(0): Revise route installing 1 of 1 route for 10.0.8.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 07:34:19.804: BGP(0): Revise route installing 1 of 1 route for 10.0.9.0/
24 -> 10.0.0.1 to main IP table

Router_B#show ip bgp neighbor 10.0.0.1
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 10.0.0.1
  BGP state = Established, up for 00:13:22
  Last read 00:00:21, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
    IPv4 MPLS Label capability:
  Received 930 messages, 0 notifications, 0 in queue
  Sent 919 messages, 1 notifications, 0 in queue
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 30, neighbor version 30
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0
  9 accepted prefixes consume 432 bytes
  Prefix advertised 0, suppressed 0, withdrawn 0, maximum limit 10 (warning-only
)
  Threshold for warning message 80%

  Connections established 2; dropped 1
  Last reset 00:29:13, due to BGP Notification sent, update malformed
  Message received that caused BGP to send a Notification:
    FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
    003C0200 00001940 01010040 02040201
    00C84003 040A0000 01800404 00000000
    180A000A 180A000B 180A000C
  External BGP neighbor can be up to 2 hops away.
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Local host: 10.0.0.2, Local port: 15668
Foreign host: 10.0.0.1, Foreign port: 179

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x3A46EB54):
Timer          Starts    Wakeups            Next
Retrans            18          0             0x0
TimeWait            0          0             0x0
AckHold            22          9             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss: 2047376434  snduna: 2047376784  sndnxt: 2047376784     sndwnd:  16035
irs:  821061364  rcvnxt:  821062116  rcvwnd:      16188  delrcvwnd:    196

SRTT: 279 ms, RTTO: 500 ms, RTV: 221 ms, KRTT: 0 ms
minRTT: 24 ms, maxRTT: 384 ms, ACK hold: 200 ms
Flags: higher precedence, nagle

Datagrams (max data segment is 536 bytes):
Rcvd: 33 (out of order: 0), with data: 22, total data bytes: 751
Sent: 29 (retransmit: 0, fastretransmit: 0), with data: 17, total data bytes: 349



Router_B#show ip bgp summary
BGP router identifier 10.0.0.2, local AS number 300
BGP table version is 30, main routing table version 30
9 network entries and 9 paths using 1341 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 36/101 prefixes, 36/27 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4   200     932     921       30    0    0 00:15:08        9

Предположим, что ситуация ухудшается и что Router_A передает три дополнительных префикса, который увеличивает общее число до 12.


Router_B# debug ip bgp updates in
*Mar 12 07:39:21.192: BGP(0): 10.0.0.1 rcvd UPDATE w/ attr: nexthop 10.0.0.1, origin i, metric 0, path 200
*Mar 12 07:39:21.196: BGP(0): 10.0.0.1 rcvd 10.0.10.0/24
*Mar 12 07:39:21.200: %BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0) reaches 10, max 10
*Mar 12 07:39:21.208: BGP(0): 10.0.0.1 rcvd 10.0.11.0/24
*Mar 12 07:39:21.212: %BGP-3-MAXPFXEXCEED: No. of prefix received from 10.0.0.1 (afi 0): 11 exceed limit 10
*Mar 12 07:39:21.216: BGP(0): 10.0.0.1 rcvd 10.0.12.0/24
*Mar 12 07:39:21.228: BGP(0): Revise route installing 1 of 1 route for 10.0.10.0/24 -> 10.0.0.1 to main IP table
*Mar 12 07:39:21.236: BGP(0): Revise route installing 1 of 1 route for 10.0.11.0/24 -> 10.0.0.1 to main IP table
*Mar 12 07:39:21.240: BGP(0): Revise route installing 1 of 1 route for 10.0.12.0/24 -> 10.0.0.1 to main IP table

Router_B# show ip bgp neighbors 10.0.0.1
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 10.0.0.1
  BGP state = Established, up for 00:19:56
  Last read 00:00:56, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(old & new)
    Address family IPv4 Unicast: advertised and received
    IPv4 MPLS Label capability:
  Received 937 messages, 0 notifications, 0 in queue
  Sent 925 messages, 1 notifications, 0 in queue
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 33, neighbor version 33
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0
  12 accepted prefixes consume 576 bytes
  Prefix advertised 0, suppressed 0, withdrawn 0, maximum limit 10 (warning-only)
  Threshold for warning message 80%

  Connections established 2; dropped 1
  Last reset 00:35:47, due to BGP Notification sent, update malformed
  Message received that caused BGP to send a Notification:
    FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
    003C0200 00001940 01010040 02040201
    00C84003 040A0000 01800404 00000000
    180A000A 180A000B 180A000C
  External BGP neighbor can be up to 2 hops away.
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Local host: 10.0.0.2, Local port: 15668
Foreign host: 10.0.0.1, Foreign port: 179

Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)

Event Timers (current time is 0x3A4CEA98):
Timer          Starts    Wakeups            Next
Retrans            24          0             0x0
TimeWait            0          0             0x0
AckHold            29         16             0x0
SendWnd             0          0             0x0
KeepAlive           0          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0

iss: 2047376434  snduna: 2047376898  sndnxt: 2047376898     sndwnd:  15921
irs:  821061364  rcvnxt:  821062290  rcvwnd:      16014  delrcvwnd:    370

SRTT: 290 ms, RTTO: 376 ms, RTV: 86 ms, KRTT: 0 ms
minRTT: 24 ms, maxRTT: 384 ms, ACK hold: 200 ms
Flags: higher precedence, nagle

Datagrams (max data segment is 536 bytes):
Rcvd: 40 (out of order: 0), with data: 29, total data bytes: 925
Sent: 42 (retransmit: 0, fastretransmit: 0), with data: 23, total data bytes: 463
Router_B#show ip bgp summary
BGP router identifier 10.0.0.2, local AS number 300
BGP table version is 33, main routing table version 33
12 network entries and 12 paths using 1788 bytes of memory
1 BGP path attribute entries using 60 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 39/101 prefixes, 39/27 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4   200     939     927       33    0    0 00:21:28       12

Как вы можете видеть от показанного примера, отношения Соседнего BGP узел поддерживаются, даже если соседний маршрутизатор передает больше префиксов, чем политика позволяет. Результат состоит в том, что только предупреждающее сообщение зарегистрировано Router_B. Других действий маршрутизатор router_B не предпринимает.

Префикс максимума настроен так, чтобы закрывать сеанс, если порог превышает предельное значение

Начальные состояния, требуемые для этого случая, должны иметь Соседний BGP узел и выполнение и с шестью префиксами, передаваемыми Router_A Router_B. Как замечено в примере, когда Router_A объявляет больше префиксов (например, 9), выходные данные команд отражают точно, что было уже замечено для случая, где Router_B настроен, чтобы просто регистрировать предупреждающее сообщение. Если вы увеличиваете количество передаваемых префиксов и заставляете Router_A дать объявление 12, Router_B закрывает отношения соседей с Router_A.


Router_B# debug ip bgp updates in
*Mar 12 08:03:27.864: BGP(0): 10.0.0.1 rcvd UPDATE w/ attr: nexthop 10.0.0.1, or
igin i, metric 0, path 200
*Mar 12 08:03:27.868: BGP(0): 10.0.0.1 rcvd 10.0.1.0/24...duplicate ignored
*Mar 12 08:03:27.876: BGP(0): 10.0.0.1 rcvd 10.0.2.0/24...duplicate ignored
*Mar 12 08:03:27.880: BGP(0): 10.0.0.1 rcvd 10.0.3.0/24...duplicate ignored
*Mar 12 08:03:27.884: BGP(0): 10.0.0.1 rcvd 10.0.4.0/24...duplicate ignored
*Mar 12 08:03:27.892: BGP(0): 10.0.0.1 rcvd 10.0.5.0/24...duplicate ignored
*Mar 12 08:03:27.896: BGP(0): 10.0.0.1 rcvd 10.0.6.0/24...duplicate ignored
*Mar 12 08:03:27.900: BGP(0): 10.0.0.1 rcvd 10.0.7.0/24
*Mar 12 08:03:27.908: BGP(0): 10.0.0.1 rcvd 10.0.8.0/24
*Mar 12 08:03:27.912: BGP(0): 10.0.0.1 rcvd 10.0.9.0/24
*Mar 12 08:03:27.916: %BGP-4-MAXPFX: No. of prefix received from 10.0.0.1 (afi 0
) reaches 9, max 10
*Mar 12 08:03:27.924: BGP(0): 10.0.0.1 rcvd 10.0.10.0/24
*Mar 12 08:03:27.932: BGP(0): 10.0.0.1 rcvd 10.0.11.0/24
*Mar 12 08:03:27.932: %BGP-3-MAXPFXEXCEED: No. of prefix received from 10.0.0.1
(afi 0): 11 exceed limit 10
*Mar 12 08:03:27.940: %BGP-5-ADJCHANGE: neighbor 10.0.0.1 Down BGP Notification
sent
*Mar 12 08:03:27.940: %BGP-3-NOTIFICATION: sent to neighbor 10.0.0.1 3/1 (update
 malformed) 0 bytes  FFFF FFFF FFFF FFFF FFFF FFFF FFFF FFFF 0060 0200 0000 1940
 0101 0040 0204 0201 00C8 4003 040A 0000 0180 0404 0000 0000 180A 0001 180A 0002
 180A 0003 180A 0004 180A 0005 180A 0006 180A 0007 180A 0008 180A 0009 180A 000A
 180A 000B 180A 000C
*Mar 12 08:03:28.024: BGP(0): Revise route installing 1 of 1 route for 10.0.7.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.032: BGP(0): Revise route installing 1 of 1 route for 10.0.8.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.036: BGP(0): Revise route installing 1 of 1 route for 10.0.9.0/
24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.044: BGP(0): Revise route installing 1 of 1 route for 10.0.10.0
/24 -> 10.0.0.1 to main IP table
*Mar 12 08:03:28.148: BGP(0): no valid path for 10.0.1.0/24
*Mar 12 08:03:28.152: BGP(0): no valid path for 10.0.2.0/24
*Mar 12 08:03:28.156: BGP(0): no valid path for 10.0.3.0/24
*Mar 12 08:03:28.156: BGP(0): no valid path for 10.0.4.0/24
*Mar 12 08:03:28.160: BGP(0): no valid path for 10.0.5.0/24
*Mar 12 08:03:28.164: BGP(0): no valid path for 10.0.6.0/24
*Mar 12 08:03:28.168: BGP(0): no valid path for 10.0.7.0/24
*Mar 12 08:03:28.168: BGP(0): no valid path for 10.0.8.0/24
*Mar 12 08:03:28.172: BGP(0): no valid path for 10.0.9.0/24
*Mar 12 08:03:28.176: BGP(0): no valid path for 10.0.10.0/24
*Mar 12 08:03:28.184: BGP(0): nettable_walker 10.0.1.0/24 no best path
*Mar 12 08:03:28.188: BGP(0): nettable_walker 10.0.2.0/24 no best path
*Mar 12 08:03:28.192: BGP(0): nettable_walker 10.0.3.0/24 no best path
*Mar 12 08:03:28.196: BGP(0): nettable_walker 10.0.4.0/24 no best path
*Mar 12 08:03:28.200: BGP(0): nettable_walker 10.0.5.0/24 no best path
*Mar 12 08:03:28.204: BGP(0): nettable_walker 10.0.6.0/24 no best path
*Mar 12 08:03:28.208: BGP(0): nettable_walker 10.0.7.0/24 no best path
*Mar 12 08:03:28.212: BGP(0): nettable_walker 10.0.8.0/24 no best path
*Mar 12 08:03:28.212: BGP(0): nettable_walker 10.0.9.0/24 no best path
*Mar 12 08:03:28.216: BGP(0): nettable_walker 10.0.10.0/24 no best path



Router_B# show ip bgp summary
BGP router identifier 10.0.0.2, local AS number 300
BGP table version is 87, main routing table version 87

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.0.1        4   200     965     948        0    0    0 00:02:24 Idle (PfxCt)

Router_B# show ip bgp neighbors 10.0.0.1
BGP neighbor is 10.0.0.1,  remote AS 200, external link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Idle
  Last read 00:02:43, hold time is 180, keepalive interval is 60 seconds
  Received 965 messages, 0 notifications, 0 in queue
  Sent 948 messages, 2 notifications, 0 in queue
  Default minimum time between advertisement runs is 30 seconds

 For address family: IPv4 Unicast
  BGP table version 87, neighbor version 0
  Index 1, Offset 0, Mask 0x2
  Route refresh request: received 0, sent 0, maximum limit 10
  Threshold for warning message 80%

  Connections established 2; dropped 2
  Last reset 00:02:43, due to BGP Notification sent, update malformed
  Message received that caused BGP to send a Notification:
    FFFFFFFF FFFFFFFF FFFFFFFF FFFFFFFF
    00600200 00001940 01010040 02040201
    00C84003 040A0000 01800404 00000000
    180A0001 180A0002 180A0003 180A0004
    180A0005 180A0006 180A0007 180A0008
    180A0009 180A000A 180A000B 180A000C

  Peer had exceeded the max. no. of prefixes configured.
  Reduce the no. of prefix and clear ip bgp 10.0.0.1 to restore peering
  External BGP neighbor can be up to 2 hops away.
  No active TCP connection

Примечание: Используйте эту команду для восстановления одноранговой возможности:

Router_B# clear ip bgp 10.0.0.1

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 25160