Протокол IP : IPv6

Туннель IPv6 через сеть IPv4

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (11 ноября 2015) | Отзыв


Содержание


Введение

В этом документе представлен пример конфигурации для туннелирования сетей и трафика протокола маршрутной информации (RIP) IPv6 и протокола граничного шлюза (BGP) IPv6 через существующую сеть IPv4. Описанный способ позволяет подключать узлы IPv6 по существующим магистральным каналам IPv4.

Туннелирование наложения инкапсулирует пакеты IPv6 в Пакетах IPV4 для доставки по инфраструктуре IPv4. Это подобно тому, как вы создаете туннель универсальной инкапсуляции маршрутизации (GRE) для транспортировки трафика Межсетевого пакетного обмена (IPX) через IP - сеть. В туннельном головном узле пакет IPv6 инкапсулируется в Пакет IPV4 и передается к удаленному назначению туннеля. Это - то, где заголовок Пакета IPV4 разделен, и пакет оригинала IPv6 передан далее в облако IPv6.

Это пять методов туннелирующего трафика IPv6:

  • Туннелирование IPv6 вручную

  • Автоматические совместимые с IPv4 туннели

  • GRE

  • Автоматический 6to4 туннели

  • Туннели Протокола адресации автоматического туннеля внутрисайта (ISATAP)

Основное различие в этих методах туннелирования является методом, в котором источник и место назначения туннеля определены. В этом документе ручной и Автоматический IPv4 описаны Совместимые типы туннеля. Обратитесь к Осуществлению Туннелирования для IPv6 для получения информации о других методах туннелирования и их характеристиках.

Примечание: Туннели наложения уменьшают максимальный размер передаваемого блока данных (MTU) интерфейса на 20 октетов. Это предполагает, что основной заголовок Пакета IPV4 не содержит необязательные поля. Сети, которая использует туннели наложения, трудно устранить неполадки. Поэтому наложите туннели, которые соединяются, отдельные сети IPv6 нельзя рассмотреть как заключительную сетевую архитектуру IPv6. Использование туннелей наложения нужно рассмотреть как метод перехода к сети, которая поддерживает и IPv4 и стеки протоколов IPv6, или просто стек протоколов IPv6.

Предварительные условия

Требования

Cisco рекомендует ознакомиться с IPv6 перед попыткой этой конфигурации. Обратитесь к Осуществлению Адресации IPv6 и Основного подключения для получения информации о IPv6.

Используемые компоненты

Сведения в этом документе основываются на Маршрутизаторах серии Cisco 36XX, которые выполняют Cisco Выпуск ПО IOS� 12.3 (13).

Примечание: Любая аппаратная платформа, которая поддерживает программное обеспечение Cisco IOS версии 12.2(2)T или 12.0 (21) ST и позже также поддерживает IPv6.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/25156/ipv6tunnel.gif

Настройки (ручной режим IPv6)

Конфигурация вручную настроенных туннелей для IPv6 очевидна. Это требует определенной спецификации туннельного источника IPv4 и туннельного назначения IPv4. Единственный недостаток того, когда вы используете этот способ, является суммой администрирования, которое необходимо выполнить, когда растет количество туннелей.

Этот документ использует эти конфигурации для режима руководства IPv6:

R1-IPv6 (маршрутизатор Cisco 3640)
R1-ipv6#show run
Building configuration...
 
Current configuration : 916 bytes
!
version 12.3
hostname R1-ipv6
!
boot system flash 
logging buffered 4096 debugging
!
ip subnet-zero
ip cef
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Ethernet0/1
 no ip address
 ipv6 address 2000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone 
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
!
end

R2-IPv6-IPv4 (маршрутизатор Cisco 3640)
R2-ipv6-ipv4#show run
Building configuration...
 
Current configuration : 1079 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
ip subnet-zero
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::1/112
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel destination 192.34.1.4
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!--- In some cases, user would require a Data License  
!--- in order to issue "tunnel mode ipv6ip"


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R3-IPv4 (маршрутизатор Cisco 2621)
R3-ipv4#show run
Building configuration...
 
Current configuration : 865 bytes
!
version 12.3
!
hostname R3-ipv4
!
!
memory-size iomem 15
ip subnet-zero
!
!
interface Serial0/0
 ip address 192.23.1.3 255.255.255.0
!
interface Serial0/1
 ip address 192.34.1.3 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
line con 0
line aux 0
line vty 0 4
!
!
end

R4-IPv4-IPv6 (маршрутизатор Cisco 3640)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1413 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 ipv6 address 3000::2/112
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel destination 192.23.1.2
tunnel mode ipv6ip

!--- Configures Manual tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
ip classless
!
ipv6 router rip 6bone
!         
!
line con 0
line aux 0
line vty 0 4
 login
!
!
end

R5-IPv6 (маршрутизатор Cisco 7500)
R5-ipv6#show run
Building configuration...
 
Current configuration : 1001 bytes
!
version 12.3
!
hostname R5-ipv6
!
ip subnet-zero
ip cef distributed
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Ethernet1/2
 no ip address
 ipv6 address 4000:1:1:1:1:1:1:1112/112
 ipv6 rip 6bone enable
!
!
ip classless
!
ipv6 router rip 6bone
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 login
!
!
end

Конфигурации (автоматический совместимый с IPv4 режим)

Конфигурации для R1, R3 и R5 совпадают с примерами режима руководства IPv6. Изменяются только конфигурации маршрутизаторов R2 и R4. При настройке совместимого с IPv4 туннеля явно не задавайте IPv4 address назначения туннеля. Назначение туннеля автоматически вычислено от адреса следующего маршрутизатора IPv6 IPv6 route. Для обеспечения маршрута по такому туннелю протокол маршрутизации с определением адреса явного соседа, таким как BGP или статичный, требуется. В этом случае необходимо использовать IPv4 совместимый IPv6 address в качестве IPv6 address Соседнего BGP узел или адреса следующего маршрутизатора статического маршрута.

Эти примеры используют последовательный интерфейс на R2 и R4 как совместимый с IPv4 IPv6 address. Тот же сериал является точкой начала туннеля. Например, IPv4 address 192.23.1.2 на R2 S0/0 преобразован в:: 192.23.1.2 в нотации IPv6. Этот адрес используется в качестве IPv6 address Однорангового соединения по протоколу BGP и BGP next-hop. В конце концов, маршруты BGP IPv6 перераспределены в RIP IPv6 так, чтобы удаленные концы сети получили информацию.

Этот метод туннелирования в настоящее время осуждается. Cisco рекомендует использовать метод туннелирования ISATAP IPv6. Обратитесь к Туннелям ISATAP для получения дополнительной информации об этом способе.

Примечание: Автоматический режим IPv6 снимает необходимость настраивать назначение туннеля.

R2-IPv6-IPv4 (маршрутизатор Cisco 3640)
R2-ipv6-ipv4#show run
Building configuration...
Current configuration : 1394 bytes
!
version 12.3
!
hostname R2-ipv6-ipv4
!
!
ip subnet-zero
!
!
!
ipv6 unicast-routing
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial0/0
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial0/0
 ip address 192.23.1.2 255.255.255.0
 clockrate 64000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
!
router ospf 1
 log-adjacency-changes
 network 192.23.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.34.1.4 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.34.1.4 activate
 neighbor ::192.34.1.4 next-hop-self
 network 2000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!         
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
line con 0
line aux 0
line vty 0 4
 login
line vty 5 15
 login
!
!
end

R4-IPv4-IPv6 (маршрутизатор Cisco 3640)
R4-ipv4-ipv6#show run
Building configuration...
 
Current configuration : 1697 bytes
!
version 12.3
!
hostname R4-ipv4-ipv6
!
ip subnet-zero
!
!
no ip domain-lookup
!
ipv6 unicast-routing
!
!
!
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 rip 6bone enable
 tunnel source Serial1/5
tunnel mode ipv6ip auto-tunnel

!--- Configures Automatic IPv4 compatible tunnel.


!
!
interface Serial1/5
 ip address 192.34.1.4 255.255.255.0
 clockrate 64000
!
!
interface Ethernet3/0
 no ip address
 half-duplex
 ipv6 address 4000:1:1:1:1:1:1:1111/112
 ipv6 rip 6bone enable
!
router ospf 1
 log-adjacency-changes
 network 192.34.1.0 0.0.0.255 area 0
!
router bgp 100
 no synchronization
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor ::192.23.1.2 remote-as 100
 no auto-summary
 !
 address-family ipv6
 neighbor ::192.23.1.2 activate
 neighbor ::192.23.1.2 next-hop-self
 network 4000:1:1:1:1:1:1:0/112
bgp redistribute-internal

!--- The show run command along with the 
!--- redistribute bgp command allows BGP to redistribute the
!--- IPv6 routes learned through the tunnel from the other site.


 exit-address-family
!
ip classless
!
ipv6 router rip 6bone
redistribute bgp 100 metric 2
!
!
!         
line con 0
line aux 0
line vty 0 4
 login
!
!
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • ping — Определяет, активен ли удаленный хост или неактивен, и задержка приема-передачи в связи с хостом.

  • show ipv6 route — Проверяет, существует ли маршрут на IPv6.

  • show bgp ipv6 — Проверяет, работает ли BGP.

  • show bgp ipv6 summary – отображает сводные данные о BGP, работающей на IPv6.

  • show ipv6 int tunnel 0 — Проверяет, что туннель произошел на IPv6 и проверяет MTU, настроенный на интерфейсе.

Проверка выходных данных команд для ручного режима IPv6

От R1 пропингуйте IPv6 address на R5, чтобы проверить, транспортирует ли туннель IPv6 через сеть IPv4.

R1-ipv6#ping ipv6 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 72/72/72 ms 
R1-ipv6#

От R5 пропингуйте IPv6 address на R1.

R5-ipv6#ping  2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms 
R5-ipv6#

Результаты команды проверки для автоматического режима IPv6

Проверьте доступность удаленной сети IPv6 через туннель с помощью эхо-теста.

R1-ipv6#ping 4000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 4000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/69/72 ms 
R1-ipv6# 
R5-ipv6#ping ipv6 2000:1:1:1:1:1:1:1112 
Type escape sequence to abort. 
Sending 5, 100-byte ICMP Echos to 2000:1:1:1:1:1:1:1112, timeout is 2 seconds: 
!!!!! 
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/70/72 ms 
R5-ipv6#

Если эхо-запрос отказывает, посмотрите на таблицу маршрутизации IPv6, чтобы проверить, существует ли маршрут. Проверьте таблицу маршрутизации с другой стороны также. Маршрут в конечном маршрутизаторе, таком как R5 и R1, должен быть изучен как Маршрут RIP. Этот маршрут перераспределен от BGP в RIP в R2 и R4. R2 и R4 - то, где туннель завершается, и BGP, взаимодействующий, настроен.

R5-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
R   ::/96 [120/2] 
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
R   2000:1:1:1:1:1:1:0/112 [120/3]
     via FE80::230:80FF:FEF3:4731, Ethernet1/2
L   4000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet1/2
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet1/2
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R5-ipv6#

Если удаленная сеть IPv6 не находится на конечном маршрутизаторе, проверьте маршрутизатор, где завершается туннель.

R4-ipv4-ipv6#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   ::192.34.1.4/128 [0/0] 
     via ::, Tunnel0
C   ::/96 [0/0] 
     via ::, Tunnel0
B   2000:1:1:1:1:1:1:0/112 [200/0]
     via ::192.23.1.2, Null
L   4000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, Ethernet3/0
C   4000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet3/0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R4-ipv4-ipv6#

В связи с тем, что для обмена информации между двумя разными сетями IPv6 используется IPv6 BGP, проверьте, чтобы BGP был включен и работал.

R4-ipv4-ipv6#show bgp ipv6 
BGP table version is 3, local router ID is 192.34.1.4 
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure 
Origin codes: i - IGP, e - EGP, ? - incomplete 
   Network          Next Hop            Metric LocPrf Weight Path 
*>i2000:1:1:1:1:1:1:0/112 
                    ::192.23.1.2                  100      0 i 
*> 4000:1:1:1:1:1:1:0/112 
                    ::                                 32768 i 
R4-ipv4-ipv6#show bgp ipv6 summary 
BGP router identifier 192.34.1.4, local AS number 100 
BGP table version is 3, main routing table version 3 
2 network entries and 2 paths using 394 bytes of memory 
2 BGP path attribute entries using 120 bytes of memory 
0 BGP route-map cache entries using 0 bytes of memory 
0 BGP filter-list cache entries using 0 bytes of memory 
BGP activity 2/8 prefixes, 2/0 paths, scan interval 60 secs 
Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd 
::192.23.1.2    4   100      24      24        3    0    0 00:19:00        1 
R4-ipv4-ipv6# 
R4-ipv4-ipv6#show ipv6 int tunnel 0 
Tunnel0 is up, line protocol is up 
  IPv6 is enabled, link-local address is FE80::C022:104 
  Global unicast address(es): 
    ::192.34.1.4, subnet is ::/96 
  Joined group address(es): 
    FF02::1 
    FF02::2 
    FF02::9 
    FF02::1:FF22:104 
  MTU is 1480 bytes 
  ICMP error messages limited to one every 100 milliseconds 
  ICMP redirects are enabled 
  ND DAD is not supported 
  ND reachable time is 30000 milliseconds 
  Hosts use stateless autoconfig for addresses. 
R4-ipv4-ipv6#

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

  • show ipv6 route — Проверяет, существует ли маршрут на IPv6.

  • show ip ospf neighbor – отображает идентификатор маршрутизатора, его приоритет и состояние соседнего маршрутизатора. Кроме того, эта команда отображает период времени, остающийся, что маршрутизатор ждет для получения пакета приветствия Протокола OSPF от соседнего узла прежде, чем объявить соседний узел вниз. Это также отображает IP-адрес интерфейса, к которому этот соседний узел напрямую подключается и интерфейс, на котором окружение OSPF формирует смежность.

  • show ipv6 interface brief — Проверяет, что произошел туннельный интерфейс.

  • show interfaces tunnel 0 — Проверяет, что настроенное назначение туннеля известно в таблице маршрутизации.

  • show ipv6 rip — Информация о RIP IPv6 Показов.

  • show ipv6 protocols — Отображает статус протокола маршрутизации IPv6.

Если эхо-запрос к удаленным сбоям сети IPv6, проверьте, что Ipv6 route изучен через RIP IPv6.

R1-ipv6#show ipv6 route 
IPv6 Routing Table - 6 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1112/128 [0/0] 
     via ::, Ethernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, Ethernet0/1
R   3000::/112 [120/2]
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
R   4000:1:1:1:1:1:1:0/112 [120/3] 
     via FE80::202:B9FF:FECB:D281, Ethernet0/1
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R1-ipv6#

Проверьте на R2, что получение маршрутов IPv6 RIP выполняется с интерфейса Tunnel0.

R2-ipv6-ipv4#show ipv6 route 
IPv6 Routing Table - 7 entries 
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP 
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea 
Timers: Uptime/Expires 
L   2000:1:1:1:1:1:1:1111/128 [0/0] 
     via ::, FastEthernet0/1
C   2000:1:1:1:1:1:1:0/112 [0/0] 
     via ::, FastEthernet0/1
L   3000::1/128 [0/0] 
     via ::, Tunnel0
C   3000::/112 [0/0] 
     via ::, Tunnel0
R   4000:1:1:1:1:1:1:0/112 [120/2]
     via FE80::230:80FF:FEF3:4701, Tunnel0
L   FE80::/10 [0/0] 
     via ::, Null0
L   FF00::/8 [0/0] 
     via ::, Null0
R2-ipv6-ipv4#

Если существуют проблемы с подключением, сначала проверяют, что сеть IPv4 неповреждена. Кроме того, проверьте окружение OSPF adjacenciesand, что существуют маршруты к IPv4 address, который является точкой начала туннеля удаленного туннельного интерфейса. Затем проверьте, что можно пропинговать между точками начала туннеля с эхо-запросом IPv4.

R2-ipv6-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:36    192.23.1.3      Serial0/0 
R2-ipv6-ipv4# 
R3-ipv4#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
1.1.1.1           1   FULL/  -        00:00:30    192.34.1.4      Serial0/1 
192.23.1.2        1   FULL/  -        00:00:35    192.23.1.2      Serial0/0 
R3-ipv4# 
R4-ipv4-ipv6#show ip ospf neighbor 
Neighbor ID     Pri   State           Dead Time   Address         Interface 
192.23.1.3        1   FULL/  -        00:00:35    192.34.1.3      Serial1/5 
R4-ipv4-ipv6#

На R2 проверьте, что туннельный интерфейс IPv6 произошел и что вы можете IPv6 пропинговывать удаленную точку начала туннеля с совместимым с IPv4 IPv6 address. Если туннельный интерфейс не работает, проверьте, что настроенное назначение туннеля известно в таблице маршрутизации. Эта проблема находится в сегменте сети, работающем по протоколу IPv4, поскольку конечная точка туннеля не указана в таблице маршрутизации.

R2-ipv6-ipv4#show ipv6 interface brief 
FastEthernet0/0            [up/up] 
    unassigned 
Serial0/0                  [up/up] 
    unassigned 
FastEthernet0/1            [up/up] 
    2000:1:1:1:1:1:1:1111 
Tunnel0                    [up/up] 
    3000::1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show interfaces tunnel 0 
Tunnel0 is up, line protocol is up 
  Hardware is Tunnel 
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation TUNNEL, loopback not set 
  Keepalive not set 
  Tunnel source 192.23.1.2 (Serial0/0), destination 192.34.1.4 
  Tunnel protocol/transport IPv6/IP, key disabled, sequencing disabled 
  Tunnel TTL 255 
  Checksumming of packets disabled 
  Last input 00:00:09, output 00:00:19, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue :0/0 (size/max) 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     3119 packets input, 361832 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     3117 packets output, 361560 bytes, 0 underruns 
     0 output errors, 0 collisions, 0 interface resets 
     0 output buffer failures, 0 output buffers swapped out 
R2-ipv6-ipv4#

Если существуют все еще проблемы с Ipv6 route, и сеть IPv4 проверена, необходимо проверить Конфигурацию RIP IPv6.

R2-ipv6-ipv4#show ipv6 rip 
RIP process "6bone", port 521, multicast-group FF02::9, pid 111 
     Administrative distance is 120.  Routing table is 0 
     Updates every 30 seconds, expire after 180 
     Holddown lasts 180 seconds, garbage collect after 120 
     Split horizon is on; poison reverse is off 
     Default routes are not generated 
     Periodic updates 176, trigger updates 1 
R2-ipv6-ipv4# 
R2-ipv6-ipv4#show ipv6 protocols 
IPv6 Routing Protocol is "connected" 
IPv6 Routing Protocol is "static" 
IPv6 Routing Protocol is "rip 6bone" 
  Interfaces: 
    FastEthernet0/1 
    Tunnel0 
  Redistribution: 
    Redistributing protocol rip 6bone

Убедитесь, что таймеры одинаковы, если не используете настройки по умолчанию. В данном примере по умолчанию используется на всех маршрутизаторах RIP IPv6. Проверьте конфигурацию, чтобы убедиться, что все выключенные RIP интерфейсы конфигурированы правильно. Проверьте также, что то же самое имя процесса RIP одинаково по всей сети. При необходимости можно посмотреть выходные данные команды debug ipv6 rip. Как со всеми отладками, внимание должно использоваться для не перегрузки буфера входа через консоль и ЦПУ.

Сводка

Этот документ демонстрирует, как туннели могут использоваться для IPv6 и IPv4 для сосуществования в той же сети. Это могло бы быть необходимо во времена перехода. Одна вещь помнить о конфигурациях IPv6 состоит в том, что с RIP IPv6, не используются инструкции сети. IPv6 RIP включен глобально и каждый интерфейс принимает участие в RIP и включен для IPv6 RIP. В примере IPv6 BGP раздел автоматического туннеля требует использования набора команд семейства адресов ipv6 для ввода операторов BGP.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 25156