Голосовая связь : H.323

Конфигурация и устранение неполадок службы телефонии Cisco IOS (ЕГО)

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (12 ноября 2015) | Отзыв


Содержание


Введение

Служба телефонии Cisco IOS (ITS), раньше известная как Кнопочный переключатель IP, является решением для обработки вызова IP-телефонии, интегрированным в Cisco программное обеспечение IOS�, которое помещается в архитектуру Cisco для Голоса, Видео и Итегрированных данных (AVVID). Основная идея – обеспечить минимальный набор характеристик переключения PBX/ключ для небольшого количества IP-телефонов, непосредственно подключенных к голосовому шлюзу. Cisco ITS можно разворачивать в тех случаях, когда в филиале компании нет WAN или же подключение к WAN осуществляется через спутниковые каналы связи.

Cisco ITS целесообразен в ситуациях, где клиент хотел бы добавить сервис телефонии на таком узле, обязательно не требуя всех характеристик телефонии, найденных в Сisco CallManager. Данный документ содержит описание развертывания ITS в примерной сети.

Примечание: Cisco ITS не является тем же, и при этом функциями не является то же как функция Survivable Remote Site Telephony (SRST), которая использована в сочетании с Сisco CallManager.

Предварительные условия

Требования

Прежде чем использовать эту конфигурацию, убедитесь, что выполняются следующие условия:

  • Знакомство с версией 2.01 сервиса телефонии Cisco IOS.

  • Основное понимание основных принципов TCP/IP, таких как IP-адресация, DHCP, Протокол NTP, TFTP и HTTP

  • Основное понимание основных принципов программного обеспечения Cisco IOS, таких как конфигурация интерфейса командной строки (CLI)

  • Основное понимание Передачи голоса по IP (VoIP) основные принципы, такие как настройка точек вызова, голосовых портов и качества обслуживания (QoS)

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Программное обеспечение Cisco IOS версии 12.2(8)T или позже, с минимумом IP Plus (IP/VOX Плюс на серии 1700) набор функций. Данный документ предполагает наличие поддержки Cisco ITS 2.0 в программном обеспечении Cisco IOS.

  • Cisco 3660 шлюз с Выпуском ПО IOS 12.2 (11) T с набором функций IP PLUS используется в примере конфигурации, невзирая на то, что большая часть IAD 2400, 1700, маршрутизаторы серии 2600, 3600 и 3700 в настоящее время применимы. Проверьте примечания Cisco IOS Software Release для получения информации о поддержке программного обеспечения и текущей версии.

  • Cisco ITS 2.0.3 программных пакета использовался в данном примере. Можно загрузить эту связку (bundle) от Загрузки программного обеспечения: Cisco CallManager Express/ITS и SRST (только зарегистрированные клиенты).

  • Если максимальное число телефонов и Составных имен (DN) для платформы должно быть настроено, для поддержки Cisco ITS рекомендуется иметь максимальное количество памяти для каждой платформы, особенно.

  • В данном примере коммутатор Catalyst 3500 Series XL используется в качестве коммутатора филиала компании. Настройте отдельные VLAN для речи и данных по качеству и соображениям безопасности.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Схема сети

В данном документе используется сетевая установка, показанная на следующей схеме.

/image/gif/paws/25100/config_troubleshoot_its1.gif

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

Таблица ниже задает информацию о передаче речи и данных через отдельные VLAN. Это также задает сеть и интерфейсные адреса и порты.

Цель VLAN ] Сеть Интерфейс Интерфейсный адрес
Данные 50 10.1.50.0/24 Fa 0/0. 50 10.1.50.1/24
Речь 150 10.1.150.0/24 Fa 0/0. 150 10.1.150.1/24

Маршрутизатор Cisco ITS является 3660 рабочим программным обеспечением Cisco IOS версии 12.2(11)T с набором функций IP Plus. Файлы Cisco ITS должны быть загружены в .tar или формате .zip от Загрузки программного обеспечения: Cisco CallManager Express/ITS и SRST (только зарегистрированные клиенты).

После того, как извлеченный, каждый файл должен быть передан флэш-памяти маршрутизатора через TFTP. Не стирайте флэш-память каждый раз после копирования отдельного файла. Ниже приводится распечатка файлов, найденных в Cisco ITS 2.0.3 (не, все эти файлы необходимы).

Имя файла Описание
P003G302.bin Нагрузка телефона, которая будет использоваться с Cisco ITS для IP-телефона Cisco 7910. Для версии ОС, загружаемой на телефон, есть отдельные заметки о выпуске, где описываются некоторые исправления предыдущих версий. (Требуемый)
P004G302.bin Нагрузка телефона, которая будет использоваться с Cisco ITS для IP-телефона Cisco 7960. Для версии ОС, загружаемой на телефон, есть отдельные заметки о выпуске, где описываются некоторые исправления предыдущих версий. (Требуемый)
admin_user.html Веб-страница администратора для настройки системы
ephone_admin.html Веб-страница администрирования телефона.
normal_user.html Пользователь (неадминистративный) веб-страница для администрирования телефонов для передачи и других функций.
telephony_service.html Веб-страница верхнего уровня, которую каждый пользователь посещает, чтобы установить настройки телефонов или настроить систему как администратор. Дополнительно
logohome.gif
en_dest_busy.au Пример звукового приглашения для занятого дополнительного номера. Используется в сценарии its_Cisco.2.0.0.tcl.
en_dest_unreachable.au Пример звуковой подсказки для недостижимого расширения. Используется в сценарии its_Cisco.2.0.0.tcl.
en_disconnect.au Типовая звуковая подсказка для разъединенного или незарегистрированное расширения. Используется в сценарии its_Cisco.2.0.0.tcl.
en_enter_dest.au Пример звуковой подсказки для ввода адреса назначения. Используется в сценарии its_Cisco.2.0.0.tcl.
en_reenter_dest.au Пример звуковой подсказки пользователю повторить ввод пункта назначения. Используется в сценарии its_Cisco.2.0.0.tcl.
en_welcome.au Пример аудио-приглашения в качестве приветствия пользователя. Используется в сценарии its_Cisco.2.0.0.tcl.
its_Cisco.2.0.0.tcl TCL-сценарий для примера автоответчика, используемый для маршрутизации вызовов на добавочный номер. Использует типовые файлы .au, чтобы приветствовать пользователя, приглашение для номера, и направить вызов к необходимому назначению.
music-on-hold.au Образец аудиофайла используется для музыки на удержании.

Следующий файл является также частью файла Cisco-ITS-2.0.3.zip, но не должен быть размещен во флэш-память маршрутизатора ITS.

Имя файла Описание
CiscoIOSTSP.zip Этот Поставщик услуг Интерфейса прикладного программного обеспечения телефонной связи (TAPI) (TSP) был разработан для Cisco ITS и действий как интерфейс между TAPI (часть Операционной системы Windows 2000) и ITS. TSP позволяет основанные на TAPI приложения, такие как Номеронабиратель и ACT! программное обеспечение для обеспечения управления вызовами IP-телефонам на Cisco ITS. Реализация TAPI на Cisco ITS не является полным стеком TAPI, а “TAPI Облегченная” реализация. Это поддерживает следующие функции:
  • Множественные адреса на отдельном канале.
  • Размещение вызовов с помощью набора номера адресной книги из приложения.
  • Ответ или отклонение требований из приложения.
  • Удержание вызовов при помощи экранной популярности.
  • Предоставление доступа к Информации об идентификаторе вызывающего абонента, для приложения.
  • Размещение вызовов в ожидании и коммутация между запросами к другим адресам той же линии.
TSP предоставляет интерфейс, который включает непосредственное дистанционное управление IP-телефоном. Хотя множественные TSP могут работать на том же компьютере, только один IP-телефон может быть привязан к каждому TSP. Поскольку Media Service Provider (MSP) не поддерживается этим TSP, приложения типа Cisco SoftPhone не поддерживаются.

Примечание: TSP, входящий в комплект поставки Cisco CallManager, не поддерживается при использовании ITS.

Конфигурации

Конфигурация VLAN на Catalyst 3500XL

Cisco ITS работает на LAN, где IP-телефоны и Сisco CallManager связаны с голосовыми шлюзами через Коммутаторы Catalyst. Очень важно настроить эти устройства правильно относительно VLANS, которые несут голосовые данные. Этот раздел предоставляет обзор конфигурации Catalyst 3500XL и соответствующего подключения LAN на голосовом шлюзе 3660 маршрутизаторов.

  1. VLAN речи и данных должна быть установлена с коммутатором ненастроенного, как показано в следующем примере:

    Cat3500BranchSwitch# vlan database
    Cat3500BranchSwitch(vlan)# vlan 50 name corporate-data-vlan
    VLAN 50 added:
    Name: corporate-data-vlan
    Cat3500BranchSwitch(vlan)# vlan 150 name corporate-voice-vlan
    VLAN 150 added:
    Name: corporate-voice-vlan
    Cat3500BranchSwitch(vlan)#
    Cat3500BranchSwitch(vlan)# exit
    APPLY completed.
    Exiting....
    Cat3500BranchSwitch#
  2. Следующий пример является примером конфигурации интерфейса между Catalyst 3500XL и 3660 маршрутизаторами:

    interface FastEthernet0/1
     description Port to 3660 (supports Dot1q)
     duplex full
     speed 100
     switchport trunk native 50
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,50,150,1002-1005
     switchport mode trunk
    !
    
  3. Следующий пример является портом, который будет использоваться для телефонного соединения:

    interface FastEthernet0/2
     description DOT1Q port to IP Phone
     switchport trunk encapsulation dot1q
     switchport trunk native vlan 50
     switchport mode trunk
     switchport voice vlan 150
     spanning-tree portfast
    !
    

Для получения дополнительной информации обратитесь к Catalyst 2900 серии XL и коммутаторам Catalyst 3500 Series XL.

Конфигурация VLAN на маршрутизаторе Cisco ITS

Выполните действия ниже для настройки VLAN на маршрутизаторе Cisco ITS.

  1. Первый шаг должен настроить параметры QoS и VLAN на этих 3660 интерфейсах, как показано ниже.

    ! 
    class-map match-all L3-to-L2_VoIP-Cntrl
     match ip dscp af31 
    class-map match-all L3-to-L2_VoIP-RTP
     match ip dscp ef 
    !
    !
    policy-map output-L3-to-L2
     class L3-to-L2_VoIP-RTP
      set cos 5
     class L3-to-L2_VoIP-Cntrl
      set COs 3
    !
    
  2. Теперь примените эту политику к интерфейсу и создайте VLAN.

    interface FastEthernet0/0
     description Catalyst 3500 Branch Office Switch
     no ip address
     no ip mroute-cache
     load-interval 30
     speed 100
     full-duplex
    !
    interface FastEthernet0/0.50
     encapsulation dot1Q 50
     ip address 10.1.50.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    interface FastEthernet0/0.150
     description native subnet 10.1.150.0 voice
     encapsulation dot1Q 150
     ip address 10.1.150.1 255.255.255.0
     service-policy output output-L3-to-L2
    !
    

Для получения дополнительной информации обратитесь к Catalyst 2900 серии XL и коммутаторам Catalyst 3500 Series XL.

Конфигурация сервера DHCP на маршрутизаторе Cisco ITS

Следующий шаг необходим для настройки сервера DHCP на 3660 маршрутизаторах. Вам нужен этот шаг, только если у вас есть внешний сервер DHCP, не, если статически настроены ваши IP-адреса. Пример ниже показов область DHCP для IP-телефонов и для других устройств на другой VLAN.

ip dhcp excluded-address 10.1.50.1 10.1.50.10
ip dhcp excluded-address 10.1.150.1 10.1.150.10
!
ip dhcp pool ip-phones
 network 10.1.150.0 255.255.255.0  

!--- This defines the range of IP addresses to be assigned.

 default-router 10.1.150.1
 option 150 ip 10.1.150.1   

!--- This must be the IP address of the ITS router.  

!
ip dhcp pool Data-clients
 network 10.1.50.0 255.255.255.128
 default-router 10.1.50.1 
 domain-name cisco.com
 dns-server 10.1.50.100 
 netbios-name-server 10.1.50.100 
!

Примечание: Если вы хотите включить DHCP только для определенных устройств, можно создать область DHCP с командой host (вместо сетевой команды, как показано выше). Необходимо также настроить идентификатор клиента и аппаратный адрес для IP-телефона, которому вы хотите дать IP-адрес. Для идентификатора пользователя необходимо задать 01 + MAC-адрес телефона, а в адрес технических средств должен входить MAC-адрес телефона как параметра.

Для получения дополнительной информации обратитесь к серверу DHCP в Cisco IOS.

Конфигурация времени на маршрутизаторе Cisco ITS

Важно проверить правильность установки времени на маршрутизаторе, так как IP-телефоны получают параметр Date/Time (Дата/Время) от маршрутизатора Cisco ITS. Это настоятельно рекомендовано это, вы настраиваете NTP, если это возможно. Задайте часовой пояс и, при необходимости, летнее время, и настройте сервер NTP. Ниже приводится пример.

its-router(config)# clock time EST -5
its-router(config)# clock summer-time EST recurring 
its-router(config)# ntp server 172.18.106.15

За дополнительной информацией о NTP обратитесь к документу "Выполнение основного управления системой".

Конфигурация Cisco ITS на 3660

Основная конфигурация

Следующая конфигурация должна быть введена для настройки Cisco ITS на 3660:

telephony-service
 load 7910 P004G302       

!--- This is the load file minus the .bin extension. 
!--- Only the 7910, 7940/7960, and 7935 IP Phones are supported.


 load 7960-7940 P003G302  

!--- This is the load file minus the .bin extension.

 ip source-address 10.1.150.1 port 2000  

!--- This is the ip address of the Cisco ITS router on the voice subnet.

 max-ephones 48  

!--- This is the total number of phones that will be allowed to register.
!--- The maximum varies by platform and sometimes by software level.


 max-dn 192      

!--- This is the maximum number of directory numbers that can be configured 
!--- on this gateway (maximum varies by platform and sometimes by software level).

 voicemail 52222 

!--- This is the number that will be dialed when the "Messages" 
!--- button is pressed on the phone (optional).

!

Большинство остающихся команд является дополнительным. Единственные обязательные являются операторами "загрузки" (не, все из которых необходимы для всех телефонов), которые являются IP source-address, Max. телефонами ephone и командами max-dn.

Примечание: Маршрутизатор Cisco ITS разработан для работы с файлами загрузки от версий Сisco CallManager ранее, чем 3.1; например, загрузите файлы, которые получают их конфигурацию от файла SEPDEFAULT.cnf, а не от XML-файла. Удостоверьтесь, что эта команда находится в конфигурации:

tftp-server 
  flash:XMLDefault.cnf.xml

Другие опции telephony-service показывают в следующем примере:

Its-router(config-telephony)# telephony-service
its-router(config-telephony)# ? 
  Cisco IOS Telephony Service configuration commands:
  admin-password      define password for admin user
  admin-username      define username for admin user
  date-format         Set date format for IP Phone display 
  default             Set a command to its defaults
  dialplan-pattern    Define E.164 telephone number prefix
  directory           Define directory naming order
  dn-webedit          enable Edit DN through Web
  exit                Exit from telephony-service configuration mode
  ip                  Define IP address and port for Telephony-Service/Fallback
  keepalive           Define keepalive timeout period to unregister IP phones
  load                Select the IP phone firmware load file
  max-conferences     Define max number of 3 party G.711 conferences
  max-dn              Maximum directory numbers supported 
  max-ephones         Define max number of IP phones
  moh                 Define music-on-hold filename
  mwi                 Define IP address and port for MWI Server
  no                  Negate a command or set its defaults
  reset               reset ethernet phone
  time-format         Set time format for IP Phone display 
  time-webedit        enable Edit Time through Web
  timeouts            Define timeout value for IP phone
  transfer-pattern    Define valid call transfer destinations
  url                 Define Ephone URL's
  voicemail           Set the voicemail access number called when the MESSAGES IP
                      phone button is pressed

its-router(config-telephony)#

caution Внимание: Многие изменения к сервису телефонии, такие как изменение даты или формата времени, требуют, чтобы телефоны перезагрузили. Некоторые опции, такие как изменение Max. телефонов ephone или параметров настройки max-dn, требуют полной перезагрузки маршрутизатора. Чтобы сбросить все телефоны, введите следующее:

its-router(config-telephony)# telephony-service
its-router(config-telephony)# reset all

Некоторые из этих опций будут обсуждены в следующих разделах; другие могут быть найдены путем обращения к Версии 2.01 Сервиса телефонии Cisco IOS.

Конфигурация TFTP на маршрутизаторе ITS

Выполните действия ниже для настройки TFTP на маршрутизаторе ITS.

  1. Удостоверьтесь, что все файлы были должным образом переданы флэш-памяти маршрутизатора. По крайней мере, файлы P003G302.bin и P004G302.bin загрузки должны быть загружены. После того, как загруженный, флэш-память должна напомнить следующий пример:

    Its-router# show flash
    System flash directory:
    File Length    Name/status
    1    16084816  c3660-is-mz.122-11.T 
    2    229542    admin_user.html 
    3    42484     en_dest_busy.au 
    4    26376     en_dest_unreachable.au 
    5    14352     en_disconnect.au 
    6    19512     en_enter_dest.au 
    7    17167     en_reenter_dest.au 
    8    17486     en_welcome.au 
    9    4152      ephone_admin.html 
    10   5968      its_Cisco.2.0.0.0.tcl 
    11   29092     logohome.gif 
    12   496521    music-on-hold.au 
    13   35138     normal_user.html 
    14   268008    P003G302.bin 
    15   258360    P004G302.bin 
    16   522       telephony_service.html 
    17   54        SEPDEFAULT.cnf     
    
    !--- This file will not show up until telephony-service is configured.
    
    18   249       XMLDefault.cnf.xml 
    
    !--- This file will not show up until telephony-service is configured.
    
    [17551227 bytes used, 49033349 available, 66584576 total]
    65536K bytes of processor board System flash (Read/Write)
    
    its-router#
    
  2. В конфигурации необходимо позволить IP-телефонам загружать файлы загрузки TFTP от маршрутизатора Cisco ITS. Следует учитывать, что эти имена файлов с учетом регистра символов.

    tftp-server flash:P003G302.bin
    tftp-server flash:P004G302.bin
    tftp-server flash:SEPDEFAULT.cnf
    tftp-server flash:XMLDefault.cnf.xml
    
  3. SEPDEFAULT.cnf и файлы XMLDefault.cnf.xml созданы автоматически, как только выполнены команды telephony-service и ip source-address.

  4. Файл XMLDefault.cnf.xml содержит IP-адрес одного из Портов Ethernet маршрутизатора, к которому должен зарегистрироваться адаптер ATA. Эти файлы являются определенными для маршрутизатора и не могут быть совместно использованы нескольками маршрутизаторов.

Настройка IP-телефона на маршрутизаторе ITS

Выполните действия ниже для настройки IP-телефонов на маршрутизаторе ITS.

  1. Если в данный момент IP-телефоны подключены и получили адрес DHCP, они могут зарегистрироваться на маршрутизаторе Cisco ITS. В них не будут настроены линии. Можно проверить, что телефоны зарегистрированы путем запуска команды show ephone и рассмотрения выходных данных, которые должны напомнить придерживающееся:

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[1] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.10 50568 Telecaster 7960 keepalive 889 max_line 6
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 52397 Telecaster 7960 keepalive 872 max_line 6
    
    
    ephone-3 Mac:0006.D74B.107C TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.12 51116 Telecaster 7960 keepalive 871 max_line 6
    
    
    ephone-4 Mac:0008.E31B.7A8A TCP socket:[5] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.13 50321 Telecaster 7960 keepalive 867 max_line 6
    
    its-router#
  2. Можно теперь установить настройки этих телефонов через CLI или через веб - администрирование. (См. Веб - администрирование Настройки Раздела Маршрутизатор Cisco ITS этого документа.) Некоторая информация о специальной конфигурации доступна для IP-телефона Cisco 7910 в Конфигурации Cisco ITS для 7910 разделов IP-телефона.

    !
    ephone-dn 1
     number 1000
     name George P Burdell
     call-forward noan 52222 timeout 10
     no huntstop
    !
    ! 
    ephone-dn 2
     number 1000
     name George P Burdell
     preference 1
     call-forward busy 52222
     call-forward noan 52222 timeout 10
    !
    !
    ephone-dn 10
     number 1111
     name Helpdesk
     no huntstop
    !
    !
    ephone-dn 11
     number 1111
     name Helpdesk
     preference 1
    !
    !
    ephone-dn 12
     number 1111
     name Helpdesk
     preference 2
    !
    !
    ephone-dn 13
     number 1111
     name Helpdesk
     preference 3
    !
    
  3. Каждый ephone-dn представляет одну линию. Можно назначить линии на множественные телефоны при желании. В данном примере был настроен пользователь, у кого есть расширение 1000 на двух линиях. Линия справочной службы, которая является группой последовательного поиска четырех линий, была добавлена также. Теперь настройте ePhones, которые назначают линии связи реальным телефонным устройствам.

    !
    ephone 1
     username "gpburdell" password letmein
     mac-address 0006.D74B.0F46
     button 1:10 2:11 3:12 4:13 5:1 6:2
    !
    !
    !
    ephone 2
     Mac-address 0006.D74B.1361
     button 1:15 2:10 3:11 4:12 5:13
     speed-dial 1 1000
    !
    
  4. Метки кнопки вернулись к меткам ephone-dn. Выходные данные команды show ephone должны напомнить выходные данные ниже.

    its-router# show ephone
    ephone-1 Mac:0006.D74B.0F46 TCP socket:[3] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.14 52311 Telecaster 7960 keepalive 6 max_line 6
    button 1: dn 10 number 1111 IDLE 
    button 2: dn 11 number 1111 IDLE 
    button 3: dn 12 number 1111 IDLE 
    button 4: dn 13 number 1111 IDLE 
    button 5: dn 1 number 1000 IDLE 
    button 6: dn 2 number 1000 IDLE 
    Username: gpburdell Password: letmein 
    
    
    ephone-2 Mac:0006.D74B.1361 TCP socket:[2] activeLine:0 REGISTERED
    mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:0
    IP:10.1.150.11 50512 Telecaster 7960 keepalive 7 max_line 6
    button 1: dn 15 number 1001 IDLE 
    button 2: dn 10 number 1111 IDLE 
    button 3: dn 11 number 1111 IDLE 
    button 4: dn 12 number 1111 IDLE 
    button 5: dn 13 number 1111 IDLE 
    speed dial 1:1000
    
    its-router#
    Ephone 1 Ephone 2
    Линия 1 1111 Линия 1 1001
    Линия 2 1111 Линия 2 1111
    Линия 3 1111 Линия 3 1111
    Линия 4 1111 Линия 4 1111
    Линия 5 1000 Линия 5 1111
    Линия 6 1000 Линия 6 George P Burdell

  5. Когда вызов входит к 1111, он звонит, пока кто-то не принимает его (никакая настроенная переадресация вызовов). Если ephone-dn 10 (линия 1 на ephone 1 или линии 2 на ephone 2) используется, то следующий вызов к 1111 автоматически переходит к ephone-dn 10, потому что никакой huntstop не настроен, и предпочтение выше (предпочтение по умолчанию 0). Если бы предпочтение было тем же, то обе линии звонили бы.

  6. Если вызов будет размещен в 1000, и никто не берет, то он прокрутится к голосовой почте (расширение 5222 в этой настройке переадресации вызовов). Если ephone-dn 1 используется, следующий вызов направлен к ephone-dn 2. Это вызвано тем, что обычной маршрутизации однорангового телефонного соединения и факта, что не настроен никакой huntstop. Необязательно для имения параметра занято для переадресации в этом случае, пока вы не хотели вызов передать другому DN в целом, когда занятый (например, если 1000 занято, то передают 1001). На ephone-dn 2 необходимо настроить переадресацию вызовов для занятого и никакого ответа, потому что нет никакого другого расширения 1000 с более высоким приоритетом для маршрутизации к (даже если бы было, вам настроили huntstop неявно, таким образом, вызов закончился бы там).

Для получения дополнительной информации о нормальной маршрутизации между одноранговыми узлами обратитесь к Поддержке технологий передачи голосовых сообщений.

Ephone 1 также имеет имя пользователя и пароль для "gpburdell". Это позволит пользователю обращаться и входить к той же telephony_service.html веб-странице и изменять свою передачу (занятый, никакой ответ, все) и быстрые наборы, а также выполнять поиски в локальном каталоге.

Ephone 2 имеет быстрый набор на линии 6. Если та кнопка будет нажата, то 1001 наберет 1000. Сама команда speed-dial не задает кнопку location. Это говорит, в этом случае, что первая свободная линия будет быстрым набором к номеру 1000. Отсутствие настроек в строке 6 указывает на то, что это произойдет. Если бы другой быстрый набор был настроен ("быстрый набор 2 1004", например), то это не генерировало бы ошибку, но это не отобразилось бы, также.

Некоторые другие команды настройки для ephone-dn упомянуты ниже.

its-router(config-ephone-dn)# ?
Ephone DN configuration commands:
  application   The selected application
  call-forward  Define E.164 telephone number for call forwarding
  caller-id     Configure port caller id parameters
  cor           Class of Restriction on dial-peer for this dn
  default       Set a command to its defaults
  description   dn desc, for DN Qualified Display Name
  exit          Exit from ephone-dn configuration mode
  hold-alert    Set Call On-Hold timeout alert parameters
  huntstop      Stop hunting on Dial-Peers
  intercom      Define intercom/auto-call extension number
  loopback-dn   Define dn-tag to create loopback dn pair with this ephone-dn
  mwi           set message waiting indicator options (mwi)
  name          Define dn user name
  no            Negate a command or set its defaults
  number        Define E.164 telephone number 
  paging        set audio paging mode
  preference    Preference for the attached dial-peer for the primary dn number
  translate     Translation rule

its-router(config-ephone-dn)#

Ниже приведены другие команды конфигурирования для ePhones.

Its-router(config-ephone-dn)# ephone 1
its-router(config-ephone)# ?
Ethernet phone configuration commands:
  button        define button to dn map
  default       Set a command to its defaults
  exit          Exit from ephone configuration mode
  Mac-address   define ethernet phone MAC address
  no            Negate a command or set its defaults
  paging-dn     set audio paging dn group for phone
  reset         reset ethernet phone
  speed-dial    Define ip-phone speed-dial number
  username      define username to access ethernet phone from Web
  vm-device-id  define voice-mail id string

its-router(config-ephone)#

caution Внимание: После любого изменения к ephone или ephone-dn, должны быть перезагружены телефоны, к которым применяются изменения. Это может быть сделано под самим ephone с командой reset, или глобально в соответствии с меню конфигурации telephony-service, как описано ранее.

Конфигурация Cisco ITS для 7910 IP-телефонов

В отличие от IP-телефона 7960, эти 7910 имеют только одну кнопку линии. К ожиданию поддержки вызова и передаче по этому телефону, требуются две линии. Для этого телефона можно настроить две линии с одним различающимся именем, как это указано ниже:

ephone-dn  20
 number 1020
 no huntstop
!
!
ephone-dn 21
 number 1020
 preference 1
!
...
ephone 10
 button 1:20 2:21
!

Даже при том, что это два появления линии, не возможно разместить обе из этих линий в ожидании в то же время. Когда основная линия находится в состоянии удержания, нажатие кнопки линии позволяет выбрать вторую линию, после чего можно выполнить второй вызов (или ответить на него). Как только второй вызов подсоединился, нажатие на кнопку удержания удерживает его на линии и присоединяет первичную линию. Повторное нажатие кнопки hold приведет к переключению между основной и дополнительной линией. Нажим кнопки линии снова разъединит в настоящее время связанную сторону.

Веб - администрирование Настройки маршрутизатора Cisco ITS

Чтобы должным образом администрировать сервер Cisco ITS через сеть, а также позволить конечным пользователям администрировать свои телефоны через сеть, следующие файлы должны присутствовать во флэш-памяти:

  • admin_user.html

  • ephone_admin.html

  • logohome.gif

  • normal_user.html

  • telephony_service.html

Для разрешения администрирования веб-страниц через сеть следующие команды глобальной кофигурации должны быть введены:

ip http server
  ip http path flash

Другие команды должны быть введены под разделом конфигурации telephony-service.

telephony-service
 admin-username administrator 

 !--- This sets up the administrator account used to access the web page.

 admin-password cisco  

 !--- This sets up the password for the admin account.

 dn-webedit    

 !--- (optional) This permits the editing of DNs through the web interface.

 time-webedit  

 !--- (optional) This permits editing of the system time through the web interface.

!

Для доступа к маршрутизатору Cisco ITS через сеть укажите браузер к следующему URL:

http://ITSrouter_ipaddr/telephony_service.html

URL является тем же для всех. Другие .html файлы считают внутренними файлами, вызванными веб-страницей телефонии-service.html. Вызов других файлов непосредственно может привести к Ошибкам JavaScript. Пользователи, которые должны использовать веб-страницу, должны быть настроены сначала на ephone, как показано ниже.

ephone 1
 username "gpburdell" password letmein

Пользователь (в данном примере, "gpburdell") может войти и изменить их информацию перенаправления, выполнить поиски по каталогам, и даже настроить их собственные параметры настройки быстрого набора. Существует онлайновая доступная справка, также.

Администраторы могут выполнить телефон, или DN добавляет, удаляет, и изменения, а также некоторые системные изменения. Обратите внимание на то, что могут быть проблемы, если вы настраиваете через сеть, а также командной строкой, потому что веб-страница периодически не опрашивает Конфигурацию программного обеспечения Cisco IOS, ни делает Кнопку Обновить на обновлении браузера эта информация. Фактически, при попытке обновить таким образом, вы выйдете из страницы GUI и видеть “Отказавшее изменение конфигурации, Изменение конфигурации не позволено” коробку сообщения об ошибках. Последние изменения на маршрутизаторе Cisco ITS можно получить только с помощью кнопки Update (Обновить) в главном меню.

От веб-страницы кнопка Write System Configuration заставляет изменения быть сразу записанными в NVRAM. Однако для стандартных пользователей, изменения пишутся каждые 10 минут, пока нет никакого активного сеанса на VTY, консоли и aux линиях.

Примечание: Для Обновления для работы удостоверьтесь, что по крайней мере четыре свободных линии VTY доступны в Cisco ITS, даже при том, что одна свободная линия VTY достаточно для изменений стандартной конфигурации.

Сведения об истории вызовов также доступны администраторам. Сначала это должно быть включенный путем настройки следующим образом:

call-history-mib retain-timer 500
call-history-mib max-size 500

Самое большее 500 записей и 500 минут истории вызова сохранены в таблице MIB.

Можно просмотреть записи вызова путем выбора View System Configuration из GUI после регистрации и затем выбора View Call History Information.

Настройка соединения PSTN на маршрутизаторе Cisco ITS

Предполагая, что маршрутизатор ITS имеет голосовые интерфейсные карты, вы теперь захотите настроить те карты так, чтобы вызовы могли быть размещены в и от IP-телефонов. Это не существенно отличается, чем другие голосовые соединения на маршрутизаторе. Можно думать о телефонах ephone с номерами, которые были назначены на каждого ephone-dn как порты Станции внешнего обмена (FXS) на маршрутизаторах.

Конфигурация прочих возможностей ITS

Конфигурация функции удержания

Одна дополнительная характеристика для внешних абонентов является музыкой в режиме удержания (MoH) / Тон в ожидании (ToH). ToH всегда находится на по умолчанию и не может быть отключен. MoH может быть предоставлен открытой коммутируемой телефонной сети (PSTN) или вызовам по сети G.711, которые размещены в ожидании. Вызовы от IP-телефона до IP-телефона на том же маршрутизаторе ITS, которые размещены в ожидании всегда, слышат только звуковой сигнал ToH. Для MoH, после проверки, что аудио файл существует во флэш-памяти, настраивают следующим образом:

telephony-service
 moh music-on-hold.au

Файл .au или .wav, играемый для MoH, должен быть в u-law G.711 или формате а-закона. Для различения ожидания вызова от ToH тональный сигнал ожидающего вызова слышат как периодические звуковые сигналы с интервалом 10 секунд между звуковыми сигналами. Если существуют составные строки ожидания вызова, только один тон передается каждые 10 секунд. ToH, однако, слышат в периодических интервалах каждых 8 секунд и состоит из трех звуковых сигналов (одиночный тон повторился три раза). ToH берет более высокий приоритет, чем тональный сигнал ожидающего вызова. Если оба тона должны играться в точно то же время, пользователь услышит ToH сначала, то через 8 секунд, другой ToH, и наконец через еще две секунды, тональный сигнал ожидающего вызова.

Как только вызовы размещены в ожидании, существует несколько вариантов, показавших ниже, чтобы передать слышимые уведомления пользователям, которые вызов все еще в ожидании.

Its-router(config-ephone-dn)# hold-alert 15 ?
  idle        alert on-hold originator only if idle
  originator  alert on-hold originator always
  shared      alert all phones that share the line

Односекундное кольцевое предупреждение в заданном интервале (каждые 15 - 300 секунд) может настраиваться, чтобы всегда быть переданным стороне, которая разместила удержанный вызов, или передаваться, только если та сторона простаивающая. Другая опция должна настроить предупреждение, которое будет передаваться всем телефонам, которые совместно используют ту же линию. Настройка по умолчанию не ни для какого предупреждения, независимо от того какой длины вызов был в ожидании.

Конфигурация конференц-связи

Конференц-связь с тремя путями поддерживается, пока стороны являются всеми пользователями G.711, и циркулярные ресурсы доступны. Циркулярные ресурсы настроены следующим образом:

telephony-service
 max-conferences 10

Если одна из сторон на конференции нажмет Hold, то другие две стороны услышат MoH или ToH. Однако они также будут в состоянии говорить друг с другом с музыкой или тоном, играющим в фоновом режиме.

Конфигурация передачи

Возможность передачи входящих вызовов часто требует дополнительной настройки. По умолчанию IP-телефоны Cisco, зарегистрированные в ITS, могут передавать данные другим IP-телефонам, зарегистрированным для того же маршрутизатора ITS. Другие передачи, к PSTN или Адресам назначения VoIP, запрещены. Для включения этих типов передач образцы передачи должны быть настроены под telephony-service следующим образом:

Telephony-service
 transfer-pattern 9.......

Теперь, предполагая, что существует адресуемая точка вызова POTS для маршрутизации вызовов к PSTN, IP-телефон может теперь передать вызовы любому семизначному номеру путем набора номера 9 сначала. Отсутствует возможность получения тонального сигнала готовности линии при использовании ITS.

caution Внимание: Будьте особенно осторожны, когда зависли переводы вызова, которые вошли Отделением междугородной телефонной связи (FXO) порт на маршрутизаторе ITS и вышли другим Портом FXO, потому что это может заставить оба порта оставаться в использовании даже после обеих сторон. См. Понимание проблемы Разъединения FXO. Если ваш поставщик не может поддержать форму управления отключением с FXO, то не позволяйте, возвращается к PSTN.

Чтобы передать или переадресовать вызовы, поступающие от другого получателя VoIP (например, другого маршрутизатора ITS), требуется команда loopback-dn. Это - сложный вопрос вне области этого документа.

Конфигурация внутренней связи

Функция внутренней связи позволяет функцию нажатия к разговору между двумя IP-телефонами. Не поддерживается на совместно используемых линиях, это означает, что ephone-dn, конфигурированный для работы в системе внутренней связи, должен быть связан только с одним IP телефоном.

!
ephone-dn 30
number A1234
name "Intercom"
intercom A4321 label "Office A"
!
!
ephone-dn 31
number A4321
name "Intercom"
intercom A1234 label "Office B"
!
...
!
ephone 3
Mac-address 0006.D74B.107C
button 1:16 6:30
!
!
!
ephone 4
Mac-address 0008.E31B.7A8A
button 1:17 6:31
!

Теперь, когда ephone 4 нажимает линию 6, вызов размещен для выравнивания 6 из ephone 3 (например, это вызывает A1234 автоматически). По умолчанию, если телефон получателя с положенной трубкой, то он используется, переходит к режиму динамика и отключает звук своего микрофона. Другими параметры команды intercom являются barge-in и no-auto-answer. Опция вторжения позволяет входящему внутреннему вызову вызывать существующий вызов в состояние ожидания. Телефон тогда сразу отвечает на внутренний вызов. Опция No-auto-answer заставляет внутренний вызов просто звонить вместо того, чтобы быть автоматически взятым.

Со всеми внутренними вызовами метка, настроенная с оператором внутреннего вызова, появляется на правой части показа, во многом как быстрый набор был бы. При отсутствии метки имя (если оно настроено на ephone-dn) отображается на экране слева, а номер интеркома - справа.

Примечание: Cisco не рекомендует использование Cisco 7910 для внутренней функциональной возможности, потому что телефон не имеет микрофона, и динамик не может быть включен звук, таким образом, телефон должен быть взят для ответа.

Конфигурация разбивки на страницы

Функция разбивки на страницы работает во многом как функция внутренней связи, ранее описанная, за исключением того, что это предоставляет только поток односторонней передачи речи без опции нажатия к ответу. Только простаивающие телефоны достигнуты разбивкой на страницы; телефоны в использовании не получат страницу. Разбивка на страницы поддерживает аудио индивидуальную рассылку использования распределения, групповая адресация (до устройств TEN), или оба (так, чтобы аудио могло достигнуть телефонов, которые не могут быть достигнуты через групповую адресацию). Разбивка на страницы групповой адресации рекомендуется. Каждое расширение разбивки на страницы требует уникального адреса групповой IP-адресации.

Например, скажите, что созданы три пейджинговых группы: "Охладите Людей", "Нехороших людей" и "Всех людей", который является просто суммой первых двух групп. Групповая адресация является методом передачи звука, таким образом, вы настроили бы придерживающееся:

!
ephone-dn 40
 number 4001
 name "Cool People"
 paging ip 239.0.1.20 port 2000
!
!
ephone-dn 41
 number 4002
 name "Uncool People"
 paging ip 239.0.1.21 port 2000
! 
!
ephone-dn 42
 number 4000
 name "All People"
 paging ip 239.0.1.22 port 2000
 paging group 40,41
!

Примечание: IP-телефоны не поддерживают групповую адресацию в 224. x . x . x адреса.

Теперь настройте и назначьте каждый ephone на DN разбивки на страницы как показано ниже (дополнительная настройка на каждом опущенном ephone). Помните, что каждый IP-телефон может принадлежать только одной пейджинговой группе. Кроме того, ephone-dn, настроенный для разбивки на страницы, не должен быть назначен на телефонную кнопку.

!
ephone 1
 paging-dn 40
!
ephone 2
 paging-dn 40
!
ephone 3
 paging-dn 41
!
ephone 4
 paging-dn 41
!
ephone 5
 paging-dn 42
!

С этой конфигурацией вы назначили разбивку на страницы номер 4001 ("Охлаждают Людей") к телефонам ephone 1 и 2, разбивка на страницы номер 4002 ("Нехорошие люди") к телефонам ephone 3 и 4 и разбивка на страницы номер 4000 ("Все люди") к телефонам ephone 1 - 5.

Любой вызов к 4001 подключению к телефонам ephone 1 и 2 (если они не заняты), например.

Примечание: Поисковая связь поддерживается на расстоянии не далее одного перехода между маршрутизаторами от маршрутизатора ITS.

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Упомянутые ниже команды show telephony-service (особенно все) дадут вам снимок конфигурации.

its-router# show telephony-service ?
  admin        Show telephony-service admin username and password
  all          Show telephony-service details
  dial-peer    Show telephony-service dialpeers 
  ephone       Show ephone configuration
  ephone-dn    Show ephone-dn configuration
  voice-port   Show telephony-service voice ports
  |            Output modifiers
<cr>

Упомянутые ниже команды show ephone дают вам текущее состояние IP-телефонов. В общем случае достаточно команды show ephone.

Its-router# show ephone ?
  7910              7910 phone status
  7940              7940 phone status
  7960              7960 phone status
  H.H.H             mac address
  dn                Dn with tag assigned
  offhook           Offhook phone status
  registered        Registered ephone status
  remote            non-local phones (with no arp entry)
  ringing           Ringing phone status
  summary           Summary of all ephone
  tapiclients       Ephone status of tapi client
  telephone-number  Telephone number assigned
  unregistered      Unregistered ephone status
  |                 Output modifiers
  <cr>

Выходные данные команды show ephone-dn будут выглядеть подобными выходным данным команды show voice port. Для самых обычных проблем эта команда не так полезна как некоторые из других программных средств.

Its-router# show ephone-dn ? 
  <1-960>   dn tag
  loopback  Show ephone-dn in loopback mode
  summary   Summary of all ephone-dn
  |         Output modifiers
  <cr>

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

Cisco ITS содержит дополнительные команды для устранения неполадок и процессы отладки, которые могут облегчить сбор информации.

Существует несколько отладок, которые могут быть полезными при устренении проблем. Команда debug ephone является единственной специфичной для Cisco ITS командой в том отношении.

Its-router# debug ephone ?
  alarm       Enable ephone alarm message debugging
  detail      Enable ephone detail debugging
  error       Enable ephone error debugging
  keepalive   Enable ephone keepalive debugging
  loopback    Enable ephone loopback debugging
  moh         Enable ephone music-on-hold debugging
  mwi         Enable ephone mwi debugging
  pak         Enable ephone packet debugging
  raw         Enable ephone raw protocol debugging
  register    Enable ephone registration debugging
  state       Enable ephone state debugging
  statistics  Enable ephone statistics debugging

Для большинства ситуаций, при устренении проблемы между одним или двумя телефонами, полезно выполнить команды debug ephone error и debug ephone state, пока проблема в частности не включает регистрацию, Индикатор ожидания сообщения (MWI) или MoH. Если количество телефонов велико, целесообразно ограничить вывод только соответствующими MAC-адресами. Пример:

its-router# debug ephone state Mac-address 0009.433C.E5EC
EPHONE state debugging is enabled for phone 0009.433C.E5EC

Проблемы, такие как вызов удаленных Адресов назначения VoIP могут потребовать дополнительных команд отладки, которые являются более общими к VoIP на маршрутизаторах Cisco, такими как команды debug voip ccapi inout и debug vtsp all. Специфические особенности для устранения проблем Сигнализации PSTN и других определяемых реализацией элементов не покрыты этим документом. Дополнительные сведения см. в следующих документах:

Вот выходные данные команды состояния ephone примера отладки для вызова от 1004 до 1002. Соответствующую часть выходных данных команды show ephone показывают ниже.

ephone-3 Mac:0006.D74B.107C TCP socket:[5] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.12 51718 Telecaster 7960 keepalive 92 max_line 6
button 1: dn 16 number 1002 IDLE 


ephone-4 Mac:0008.E31B.7A8A TCP socket:[2] activeLine:0 REGISTERED
mediaActive:0 offhook:0 ringing:0 reset:0 reset_sent:0 paging 0 debug:1
IP:10.1.150.13 50396 Telecaster 7960 keepalive 96 max_line 6
button 1: dn 17 number 1004 IDLE

Теперь можно исследовать отладку. Сообщение OFFHOOK замечено, вызов размещен (вы не видите отдельные цифры, перехваченные в этой трассировке), и этому отвечают. Сообщения об открытом приеме канала передаются каждому телефону и позже подтверждены; сообщение StartMedia говорит каждому телефону что IP-адрес и порт передавать аудио к. В конце появится сообщение ONHOOK.

Its-router# debug ephone state
EPHONE state debugging is enabled
its-router#
Sep 26 18:39:40.837: ephone-4[2]:OFFHOOK
Sep 26 18:39:40.837: ephone-4[2]:SIEZE on activeline 0
Sep 26 18:39:40.837: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOffHook
Sep 26 18:39:40.837: DN 17 Voice_Mode
Sep 26 18:39:40.837: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:40.841: dn_tone_control DN=17 tonetype=33:DtInsideDialTone onoff=1 pid=113
Sep 26 18:39:42.349: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:42.853: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.105: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-4[2]:Skinny-to-Skinny call DN 17 to DN 16 instance 1
Sep 26 18:39:43.609: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsRingOut
Sep 26 18:39:43.609: ephone-4[2]:Call Info DN 17 line 1 ref 52 called 1002 calling 1004 
origcalled calltype 2
Sep 26 18:39:43.609: ephone-4[2]: John Doe calling 
Sep 26 18:39:43.609: ephone-4[2]: Jane Doe
Sep 26 18:39:43.609: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:43.609: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsRingIn
Sep 26 18:39:43.613: ephone-3[5]:Call Info DN 16 line 1 ref 53 called 1002 calling 1004 
origcalled calltype 1
Sep 26 18:39:43.613: ephone-3[5]: John Doe calling 
Sep 26 18:39:43.613: ephone-3[5]: Jane Doe
Sep 26 18:39:43.613: ephone-3[5]:Ringer Inside Ring On
Sep 26 18:39:43.613: dn_tone_control DN=17 tonetype=36:DtAlertingTone onoff=1 pid=113
Sep 26 18:39:51.926: ephone-3[5]:OFFHOOK
Sep 26 18:39:51.926: ephone-3[5]:Ringer Off
Sep 26 18:39:51.926: ephone-3[5]:ANSWER call
Sep 26 18:39:51.926: ephone-3[5]:Answer Incoming call from ephone-(4) DN 17
Sep 26 18:39:51.926: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsConnected
Sep 26 18:39:51.926: ephone-4[2]:OpenReceive DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: ephone-3[5]:OpenReceive DN 16 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:51.926: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:51.930: DN 17 End Voice_Mode
Sep 26 18:39:51.930: DN 17 Voice_Mode
Sep 26 18:39:51.930: DN 16 Voice_Mode
Sep 26 18:39:51.930: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:39:52.182: ephone-4[2]:OpenReceiveChannelAck:IP 10.1.150.13, port=23094, 
dn_index=17, dn=17
Sep 26 18:39:52.182: ephone-3[5]:StartMedia 10.1.150.13 port=23094
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:39:52.182: ephone-3[5]:OpenReceiveChannelAck:IP 10.1.150.12, port=22778, 
dn_index=16, dn=16
Sep 26 18:39:52.182: ephone-4[2]:StartMedia 10.1.150.12 port=22778
Sep 26 18:39:52.182: DN 17 codec 4:G711Ulaw64k duration 20 ms bytes 160
Sep 26 18:40:01.254: ephone-3[5]:ONHOOK
Sep 26 18:40:01.254: ephone-4[2]:CloseReceive
Sep 26 18:40:01.254: ephone-4[2]:StopMedia
Sep 26 18:40:01.254: ephone-3[5]:call clean up this DN 16 was called by other DN 17
Sep 26 18:40:01.254: this ephone-3 other ephone-(4) other DN state CONNECTED
Sep 26 18:40:01.254: ephone-3[5]:CloseReceive
Sep 26 18:40:01.254: ephone-3[5]:StopMedia
Sep 26 18:40:01.254: DN 16 End Voice_Mode
Sep 26 18:40:01.254: ephone-3[5]:SetCallState line 1 DN 16 ref 53 TsOnHook
Sep 26 18:40:01.254: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.254: DN 17 End Voice_Mode
Sep 26 18:40:01.254: ephone-4[2]:SetCallState line 1 DN 17 ref 52 TsOnHook
Sep 26 18:40:01.254: ephone-4[2]:SpeakerPhoneOnHook
Sep 26 18:40:01.258: ephone-3[5]:SpeakerPhoneOnHook
Sep 26 18:40:01.354: DN 16 Voice_Mode
Sep 26 18:40:01.354: DN 16 End Voice_Mode
Sep 26 18:40:01.354: dn_tone_control DN=16 tonetype=0:DtSilence onoff=0 pid=113
Sep 26 18:40:01.366: SkinnyReportDnState DN 17 ONHOOK
Sep 26 18:40:01.366: dn_tone_control DN=17 tonetype=0:DtSilence onoff=0 pid=113

Дополнительные сведения


Document ID: 25100