Голосовая связь : Качество голосовой связи

Качество обслуживания голосовой связи: Пометка пакетов ToS-CoS для использования с LLQ

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает управление качеством обслуживания (QoS) для IP-телефонии (VoIP) в среде локальной сети путем назначения типов обслуживания (ToS), связываемых с параметрами классов обслуживания (CoS).

До недавнего времени общее согласие состояло в том, что QoS никогда не будет проблемой в стороне предприятия из-за пульсирующего характера сетевого трафика и возможности переполнения буфера. Причина для QoS на стороне локальной сети происходит из-за буферизации, не отсутствия пропускной способности. Поэтому программные средства QoS требуются, чтобы управлять этими буферами для уменьшения потери, задержки и разброса задержки. Буферы передачи имеют тенденцию наполнить до отказа в высокоскоростных сетях из-за пульсирующего характера сетей передачи данных, объединенных с большим объемом меньших пакетов Протокола TCP. Если буфер вывода заполняется, входные интерфейсы не в состоянии сразу разместить новый трафик потока в буфер вывода. Как только входной буфер заполняется (может произойти быстро), отбрасывание пакета происходит. Это - то, где качество голосовой связи может возможно ухудшиться из-за потери пакета.

Трафик VoIP чувствителен и к пакетам с задержкой и к отброшенным пакетам. Задержка никогда не должна быть фактором, независимо от размера буфера очереди, из-за высокой скорости на ссылках LAN. Однако отбрасывания всегда оказывают негативное влияние на качество голосовой связи во всех сетях. Использование множественных очередей на интерфейсах передачи является единственным способом устранить потенциал для отбрасываемого трафика, вызванного буферами, которые работают в 100%-й емкости. Разделение голоса и видео (и чувствительный к задержкам и отбрасываниям) в их собственные очереди может предотвратить, вытекает из того, чтобы быть отброшенным во входном интерфейсе, даже если потоки данных заполняют буфер передачи данных.

В сетях с высокими нагрузками по трафику важно управлять доставкой контрольного трафика для обеспечения положительного пользовательского опыта VoIP. Это легко проиллюстрировано. Например, когда IP-телефон используется, он спрашивает Сisco CallManager, что сделать. Сisco CallManager тогда дает IP-телефону команду играть тональный сигнал готовности к набору номера. Если Управление клиентским протоколом Skinny и контрольный трафик отброшены или задержаны, на пользовательский опыт оказывают негативное влияние. Для обеспечения QoS, отмечают заголовки пакета с более высоким приоритетом и для сопоставления их правильно с заголовками для Сcatalysts Уровня 2 для понимания. Это гарантирует правильное определение приоритетов на голосовых пакетах по LAN.

Предварительные условия

Требования

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения.

  • Голосовой шлюз Cisco 3725 с Cisco выпуск ПО IOS� 12.3 (4) T.

  • Catalyst 4000 Switch

  • Сisco CallManager и IP-телефоны

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

/image/gif/paws/23442/tos-cos-1.gif

Конфигурации

Эти конфигурации используются в данном документе.

Эта конфигурация показывает, как сопоставить ToS/значения точки кода дифференцированных услуг (DSCP) в значение CoS в 802.1p заголовочная часть. Существует много способов внедрить это, и небольшие различия варьируются в зависимости от дизайна. Эти два примера конфигурации здесь эквивалентны, и любой может использоваться для достижения того же результата. Обязательно только позвольте Пакеты VoIP, которые имеют IP precedence важных (5) в бите ToS. Никакой другой трафик не должен иметь этот установленный бит к важному. Это вызывает наложение нежелательного трафика в речевой очереди.

Примечание: Настройка LLQ сделана на других устройствах в сети, таких как Catalyst 4000, который не обсужден в этом документе.

В этом первом примере, только потоки RTP, что match IP precedence 5 помечен, и не RTCP или любая сигнализация H.225/245 и пакеты сообщения.

Cisco 3660 (пример 1)
!
ip cef
!

!--- The Cisco Express Forwarding (CEF) mechanism needs to be enabled 
!--- in order for the set cos command that is 
!--- configured later to take effect.
!--- If this is not on, the router reminds you with 
!--- the error "CEF switching needed for 'set' operations".

! 
class-map match-all RTP
match ip precedence 5 

!--- This command matches on all packets with the IP precedence of 5.
 
!
policy-map OutboundPolicy
class RTP
set CoS 5

!--- For all packets which previously matched on class-map RTP for 
!--- having precedence of 5, the CoS bit is now set to 5.

class class-default
set CoS 0

!--- All other traffic has a CoS of 0 and 
!--- carries a lower priority of delivery.

!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816

!--- There must be subinterfaces for FastEthernet to enable trunking, 
!--- as well as either dot1q or isl encapsulation.

ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy

!--- Apply the QoS to the interface that connects to the LAN
!--- via the Catalyst 4000.

!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media
no vad
!

Примечание: Команда ip qos dscp была представлена в программном обеспечении Cisco IOS версии 12.2(2)T. Это заменяет команду ip precedence (dial-peer). Все маршрутизаторы, которые работают на программном обеспечении Cisco IOS версии 12.2(2)T и ранее могут использовать ip precedence в конфигурации адресуемой точки вызова.

Второй пример имеет другие соответствующие параметры для классов policy-map. Конфигурация Cisco 3660 совпадает на пакетах настройки вызова H.225, а также потоках RTP. Критерии соответствия для потока RTP также немного отличаются. Не посмотрите на IP - заголовки, только посмотрите на диапазон порта UDP. Если это падает между 16384 и 32767, пометьте их и передайте им к policy-map.

Cisco 3660 (пример 2)
!
ip cef
!

!--- The CEF mechanism needs to be enabled 
!--- in order for the set cos command that is 
!--- configured later to take effect.
!--- If this is not on, the router reminds you with 
!--- the error "CEF switching needed for 'set' operations".
!
class-map match-all Call-Control
match access-group 101
!
class-map match-all RTP
match ip rtp 16384 16383

!--- Match on UDP port range 16384-32767 to single out 
!--- VoIP packets for policy-map.

!
access-list 101 permit tcp host 10.120.16.112 any eq 1720

!--- Match on all packets using TCP port 1720 which is 
!--- dedicated for H.225 call setup. 

!
policy-map OutboundPolicy
class RTP
set CoS 5

!--- For all VoIP packets that match the  UDP port range listed above,
!--- set the CoS bit to 5.

class Call-Control
set CoS 3
set ip precedence 3

!--- For all signaling and control packets that match access-list 
!--- 101, set the CoS bit to 3 and IP precedence to 3.

class class-default
set CoS 0

!--- All other traffic has a CoS of 0 and carries a 
!--- lower priority of delivery. 

!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/0.816
encapsulation dot1Q 816
ip address 10.120.16.112 255.255.255.0
service-policy output OutboundPolicy

!--- Apply your QoS to the interface that connects to the 
!--- LAN via the Catalyst 4000.

!
dial-peer voice 99131 voip
destination-pattern 9913109
session target ipv4:10.120.17.133
 ip qos dscp cs5 media 
no vad
!

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show policy-map interface Счетчики соответствий Показов для всех классов определенной карты политик обслуживания.

Маршрутизаторы теперь настроены для сопоставления бита ToS с битом CoS. Используйте команду show policy-map interface, чтобы удостовериться, что трафик фактически отмечен согласно конфигурации.

В этом первом примере выходных данных эти 539 Пакетов VoIP совпадают с class-map, и всем 539 пакетам отметили бит CoS к значению важных в результате. Этот тип организации очереди не должен ждать перегрузки, чтобы быть активным. Пока существует голосовой трафик, который пересекает Канал FastEthernet, он отмечает все пакеты соответственно. Во втором примере все Пакеты VoIP, отмеченные к значению CoS 5 и все пакеты сигнализации, отмечены к значению CoS 3 согласно конфигурации.

От первых 3660 примеров конфигурации:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816  
  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      539 packets, 42042 bytes
      5 minute offered rate 2000 bps, drop rate 0 BPS
      Match: ip precedence 5 
      QoS Set
        CoS 5
          Packets marked 539

    Class-map: class-default (match-any)
      13 packets, 1803 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any 
      QoS Set
        CoS 0
          Packets marked 13

От вторых 3660 примеров конфигурации:

vdtl-3660-16a#show policy-map interface fastethernet 0/0.816
 FastEthernet0/0.816 

  Service-policy output: OutboundPolicy

    Class-map: RTP (match-all)
      370 packets, 28860 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: ip rtp 16384 16383
      QoS Set
        CoS 5
          Packets marked 370

    Class-map: Call-Control (match-all)
      26 packets, 2697 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: access-group 101
      QoS Set
        ip precedence 3
          Packets marked 26
        CoS 3
          Packets marked 26

    Class-map: class-default (match-any)
      4363 packets, 515087 bytes
      5 minute offered rate 0 BPS, drop rate 0 BPS
      Match: any 
      QoS Set
        CoS 0
          Packets marked 4363
vdtl-3660-16a#

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 23442