Технологии коммутируемого доступа в сеть : Технология DDR

Общие сведения и устранение неисправностей, связанных с временем ожидания простоя

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Распространенной проблемой для каналов удаленного доступа является неожиданный сброс вызова. Причины могут быть разными - от отказов оборудования до неполадок на телефонной станции. Однако, одной из основных причин, по которым возникает неожиданный обрыв соединения, является истечение интервала простоя.

Другая общая проблема времени ожидания простоя - то, что ссылка не разъединяет, так как время простоя никогда не истекает. Это может привести к большим расходам на оплату подключений, которые оцениваются в зависимости от времени вызова.

В этом документе рассматривается конфигурирование и исправление проблем, связанных со временем простоя.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Распространенные проблемы и симптомы

Следующие признаки могут указать на проблемы, отнесенные ко времени простоя:

  • Вызовы разъединяются каждые две минуты (120 секунд) после установления связи.

    Это отключение обычно происходит из-за значения истечения срока действия по умолчанию, равного 120 секундам, а вот определение полезного трафика либо не задано, либо не применяется на интерфейсе. Несмотря на то, что команда dialer in-band включает время простоя по умолчанию 120 секунд на интерфейсе, это значение не появляется в выходных данных show running-configuration. Поскольку значение default idle-timeout нельзя увидеть, 120-секундное отключение зачастую неверно диагностируется.

  • Вызовы сбрасываются каждые X минут после установления соединения.

    Это разъединение обычно происходит из-за настраиваемого idle-timeout (использование команды таймаута простоя программы для набора номера), в то время как определение содержательного трафика или не определено или не применено к интерфейсу.

  • Вызовы отключаются преждевременно. Это возможно из-за низкого значения времени ожидания простоя номеронабирателя или ограниченного определения содержательного трафика.

  • Вызов не отключен. Вероятно, это вызвано высоким значением времени ожидания для программы набора номера и слишком общим определением содержательного трафика.

Время ожидания простоя

Команда key idle timeout - это время ожидания для простоя номеронабирателя, которая является командой настройки интерфейсов async, group-async, ISDN и dialer. (Другая часто используемая команда, - ppp timeout idle, - используемая в интерфейсах виртуального доступа, не рассматривается в данном документе. Для получения дополнительных сведений о команде ppp timeout idle см. документ "Времена ожидания протокола PPP для каждого пользователя".).)

Таймаут простоя программы для набора номера {x} команда может быть настроен на любом интерфейсе номеронабирателя. Простаивающие управления по счетчику, сколько времени соединение может быть простаивающим (в секундах), прежде чем оно будет завершено. Счетчик сбрасывается или считает в обратном порядке, в зависимости от того, что маршрутизатор определяет как "содержательный трафик". Если маршрутизатор видит представляющий интерес трафик (как определено в dialer-list), это перезагружает счетчик простоя, или иначе счетчик простоя продолжает считать в обратном порядке. Когда таймер достигает нуля, вызов разъединен.

Ниже перечислены пункты, на которые следует обратить внимание при вводе этой команды:

  • Эта команда применима только к интерфейсам с поддержкой номеронабирателя. По умолчанию все интерфейсы ISDN (Интерфейс базового уровня [BRI] и Интерфейс первого уровня [PRI]) с поддержкой программы набора номера, таким образом, эта команда может быть добавлена без проблем.

  • Асинхронные интерфейсы (например, интерфейс async x или интерфейс group-async x) не поддерживают набор номера по умолчанию. Необходимо включить на них поддержку набора номера, введя команду dialer in-band. Обратите внимание на то, что виртуальные шаблоны (и поэтому интерфейсы виртуального доступа) не с поддержкой программы набора номера, но являются точка-точка только. Поэтому они не могут использовать эту команду, пока рабочая Cisco Версия программного обеспечения 12.2 (4) T IOS�, когда были включены усовершенствования к структуре времени простоя.

  • Можно только настроить таймаут простоя программы для набора номера после ввода команды dialer in-band на асинхронном интерфейсе.

  • В интерфейсе номеронабирателя (то есть интерфейсе ISDN или асинхронном интерфейсе с внутриполосным номеронабирателем) стандартное время бездействия соответствует 120 секундам (двум минутам). Если команда dialer idle-timeout не настроена явно с другим значением времени ожидания при простое, то используется стандартное значение.

    Примечание: Время простоя по умолчанию не показывают в конфигурации, потому что это - по умолчанию. Используйте команду show dialer, чтобы определить, принуждено ли время простоя на интерфейсе.

  • Если вы хотите, чтобы пользователи были в состоянии оставаться на связи, пока они не принимают решение разъединить, используйте команду dialer idle-timeout 0. Нулевая опция для таймаута простоя программы для набора номера была представлена в программном обеспечении Cisco IOS версии 12.1(3)T и устанавливает время ожидания бесконечности.

Интересный трафик

С маршрутизацией вызовов по запросу (DDR) весь трафик классифицируется как содержательный или несодержательный. Если трафик является содержательным, то подключения маршрутизатора к узлу. Если трафик не является интересным, то соединение не происходит. Однако для соединений, которые уже связаны, представляющий интерес трафик имеет другую цель. Это используется для сброса времени простоя назад к максимальному значению (настроенный с командой таймаута простоя программы для набора номера). Когда устанавливается соединение, таймер простоя начинает убывать. Как только маршрутизатор получает пакет, соответствующий определению интересного трафика, таймер простоя сбрасывается в исходное максимальное значение.

Трафик, который, как полагают, является содержательным, определен dialer-list {n} команда (в режиме глобальной конфигурации), где {n} совпадает с номером в dialer-group {n} командный оператор под конфигурацией интерфейса.

Существует два метода для определения представляющего интерес трафика. Простой метод (с использованием только команды dialer-list) определяет весь протокол (например, IP или IPX) как содержательный или несодержательный. Однако, если вы должны дать гранулированное определение содержательного трафика (например, если трафик HTTP является содержательным, но трафиком Telnet, не), необходимо использовать команду dialer-list в сочетании с access-list.

См. Время простоя Настройки раздела и Представляющий интерес трафик для получения дополнительной информации о настройке представляющего интерес трафика.

Задание направления интересующего трафика

По умолчанию таймаут простоя программы для набора номера перезагружен назад к максимуму представляющим интерес трафиком в исходящем направлении. Если только входящий трафик может восстановить таймаут простоя, используйте дополнительное ключевое слово inbound. Используйте любое ключевое слово для входящего и исходящего трафика для сброса idle-timeout. Данная функция была представлена в Cisco IOS Software Release 12.1(1)T.

Преимущества: Путем указывания, что только входящий трафик перезагрузит таймер простоя номеронабирателя, можно препятствовать тому, чтобы неожиданный интернет-трафик мешал неиспользуемому соединению разъединяться.

Определение содержательного трафика и времени ожидания простоя

Представляющий интерес трафик должен быть определен на обоих концах соединения DDR. Даже если маршрутизатор, получающий вызов, обрабатывает только входящие вызовы и не выполняет исходящие, нужно выделять содержательный трафик.

Определение содержательного трафика имеет другую цель для входящих вызовов Async и вызовов ISDN.

Для пользователей ISND (в соответствии с интерфейсом Dialer X)

Команды dialer-group и dialer-list должны быть в интерфейсе программы для набора номера вне зависимости от того, хотите ли вы принудительно установить таймаут простоя. Группа дозвона и список команд дозвона необходимы для интерфейса номеронабирателя во избежание сбоев инкапсуляции. Это требование касается только пользователей ISDN и не имеет никакого отношения к пользователям асинхронных каналов и интерфейсу group-async.

Для осуществления времени простоя добавьте команды таймаута простоя программы для набора номера и внутриполосный номеронабиратель. Однако, если внутриполосный номеронабиратель будет настроен, но таймаут простоя программы для набора номера не, то время простоя примет значение по умолчанию к двум минутам для пользователей ISDN.

Если вы хотите, чтобы ваши пользователи ISDN оставались на связи, пока они не принимают решение разъединить, используйте команду dialer idle-timeout 0. Нулевой параметр для интервала простоя номеронабирателя был введен в Cisco IOS Software Release 12.1(3)T и устанавливает значение интервала на бесконечность.

Для пользователей ISDN (Соответствующий interface BRI x и interface Serial x:23)

Во всех физических интерфейсах ISDN по умолчанию включена поддержка DDR. Это означает, что внутриполосный номеронабиратель уже включен на том интерфейсе. Чтобы включить таймаут простоя, добавьте команду дозвона idle-timeout. Однако, если внутриполосный номеронабиратель настроен, но таймаут простоя программы для набора номера не, то настройки по умолчанию времени простоя к двум минутам для пользователей ISDN.

Команды dialer-group и dialer-list требуются на том интерфейсе, независимо от того, хотите ли вы принудить idle-timeout или нет. Группа дозвона и список команд дозвона необходимы для интерфейса во избежание сбоев инкапсуляции. Это требование только для пользователей ISDN, не для Пользователей асинхронной связи и async-interface группы.

Если вы хотите, чтобы ваши пользователи ISDN оставались на связи, пока они не принимают решение разъединить, используйте команду dialer idle-timeout 0. Нулевой параметр для интервала простоя номеронабирателя был введен в Cisco IOS Software Release 12.1(3)T и устанавливает значение интервала на бесконечность.

Для пользователей асинхронной связи (Соответствующий Interface Group-Async X)

Чтобы принудительно включить время ожидания при простое для пользователей асинхронной связи, настройте одну из следующих команды в интерфейсе group-async:

  • dialer in-band

  • время ожидания простоя программы для набора номера

  • dialer-group

Необходима также соответствующая команда dialer-list. Команды dialer-group и dialer-list позволяют указать интересующий трафик на интерфейсе group-async.

Для пользователей асинхронных каналов интересный трафик используется только для сброса тайм-аутов простоя. Если наличие содержательного трафика не определено, отключение пользователей выполняется по истечении таймаута простоя программы набора номера(по умолчанию 120 с), независимо от наличия в канале передачи трафика. Имея определение интересного трафика, сервер доступа к сети (NAS) распознает эти пакеты и сбросит счетчик времени ожидания, поэтому пользователь будет отключен только в случае, если канал действительно находится в режиме ожидания.

Можно изменить интересный трафик, ограничив его, например, только HTTP (веб)-трафиком. В такой ситуации, если пользователь не просматривает веб-сайты в течение 300 секунд (или для указанного времени ожидания простоя программы набора номера), они разъединены. Настройте представляющий интерес трафик в зависимости от структур трафика ваших пользователей.

Если вы хотите, чтобы ваши Пользователи асинхронной связи были в состоянии оставаться на связи, пока они не принимают решение разъединить, то удалите следующие команды из интерфейса group-async, как показано в конфигурации:

  • dialer in-band

  • время ожидания простоя программы для набора номера

  • dialer-group

Можно также установить время простоя в бесконечность с помощью команды dialer idle-timeout 0. Нулевой параметр для интервала простоя номеронабирателя был введен в Cisco IOS Software Release 12.1(3)T и устанавливает значение интервала на бесконечность.

Настройка времени ожидания простоя и содержательного трафика

В этом разделе рассматриваются, как можно настроить время простоя и представляющий интерес трафик на маршрутизаторе. Можно применить эту конфигурацию ко всем интерфейсам с включенным DDR, таким как:

interface BRI
interface async x
interface dialer x
interface group-async x
interface serial x:23

Сервер проверки подлинности, авторизации и учета (AAA) можно использовать для назначения таймаутов каждому пользователю. Дополнительные сведения см. в документе "Время ожидания для каждого пользователя РРР".

Пример конфигурации

Следующий пример конфигурации содержит простое определение содержательного трафика. В данном примере весь IP трафик считается содержательным:

interface BRI0/0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 900
!--- Idle-timeout is set at 900 seconds (15 minutes)
dialer-group 1
!--- Apply interesting traffic definition from dialer-list 1
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
dialer-list 1 protocol ip permit
!--- Designate all IP traffic as interesting.  
This definition was applied to BRI0/0 using dialer-group 1.   
Note that the dialer-list and dialer-group numbers match

В приведенной выше конфигурации подключение сохраняется активным как минимум 900 секунд (15 минут) и позволяет трафику IP в любом направлении (по умолчанию) вернуть таймер времени простоя опять на 900 секунд. Поэтому, если никакие проходы IP - трафика в любом направлении в течение 15 минут, маршрутизатор разъединяет линию, потому что истекло время простоя.

Примечание: При выполнении протокола маршрутизации по этому соединению DDR периодический трафик поддерживает соединение неопределенно. Следовательно, определение содержательного трафика, показанное выше, не рекомендуется для ссылок с протоколами маршрутизации (или другой периодический трафик) натыкание на него.

Использование списков доступа

В следующем примере показан маршрутизатор с интерфейсом базового уровня (BRI), который получает вызовы и включает команду dialer idle-timeout при помощи входящего ключевого слова. Эта команда разрешает только входящий трафик, который соответствует списку номеронабирателя для сброса таймера простоя номеронабирателя. На этом примере только трафик TCP на порте 80 (HTTP-трафик) может сбросить время ожидания простоя на 10 минут (600 секунд) назад. Поэтому, если конечный пользователь не просматривает веб-сайты в течение десяти минут, соединение разъединено.

Использование интерфейсов ISDN

interface BRI0/0   
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
encapsulation ppp
dialer idle-timeout 600 inbound

!--- Idle timeout is 600 seconds.  Only inbound interesting traffic will reset 
the idle timeout

dialer-group 1

!--- Apply the interesting traffic defintion from dialer-list 1

peer default ip address pool dialin
isdn switch-type basic-5ess
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http) from any host to any other host

access-list 101 deny ip any any

!--- All other IP traffic is uninteresting

dialer-list 1 protocol ip list 101

!--- Use list 101 for granular interesting traffic definition
ip local pool dialin 10.1.1.2 10.1.1.254

Использование асинхронных интерфейсов

Асинхронные интерфейсы не с включенным DDR по умолчанию, так использование внутриполосного номеронабирателя представляет их с включенным DDR.

Interface group-async 1
ip unnumbered ethernet 0
no ip directed-broadcast
encapsulation ppp
dialer in-band
dialer idle-timeout 600
dialer-group 1
peer default ip address pool dialin
no cdp enable
ppp authentication chap
!
access-list 101 permit tcp any any eq 80
access-list 101 deny ip any any

!--- Access-lists have an implicit deny.  However, we are explicitly denying IP 
here for clarity.


dialer-list 1 protocol ip list 101
ip local pool dialin 10.1.1.2 10.1.1.254

Усовершенствования таймаута простоя

Таймер простоя программы набора номера в программном обеспечении Cisco IOS выпуска ранее 12.2(4)T можно было сбросить только для интересного трафика на интерфейсах с поддержкой номеронабирателя (например, BRI, PRI и group-async с командой dialer in-band). Таймауты простоя нельзя применить к пользователям, подключенным к интерфейсам виртуальных шаблонов.

С программного обеспечения Cisco IOS версии 12.2(4)T функция Customer Profile Idle Timer Enhancements for Interesting Traffic предоставляет новые команды и функциональность, которые решают проблемы счетчика простоя для коммутируемой сети виртуального доступа (VPDN) сеансы, которые используют (спроектированные) интерфейсы виртуального доступа и полагайтесь на механизм таймера простоя PPP.

Проверка времени простоя

Выполните следующие шаги, чтобы проверить и устранить неполадки поведения при истечении времени ожидания простоя:

  1. Используя команду show user убедитесь, что вызов установлен.

  2. Используйте таймаут show caller, show dialer и пользователя show caller, чтобы определить, назначено ли время простоя правильно на связанный интерфейс. При выполнении команд show несколько раз время до разъединения уменьшается.

  3. Инициируйте содержательный трафик (определяемый в dialer-list x) на линии. Чтобы определить представляющий интерес трафик, следует просмотреть текущую конфигурацию.

  4. Выполните таймаут show caller, show dialer и пользователя show caller еще раз, чтобы определить, было ли перезагружено время простоя. Если это не происходит, то любой, представляющий интерес трафик не определен должным образом (использующий dialer-list) или это не было применено к интерфейсу (использование dialer-group).

Команды использовали проверять, что поведение при истечении времени ожидания простоя упомянуто ниже:

  • show caller timeout - эта команда показывает установленное абсолютное время ожидания и время ожидания простоя, а также время, прошедшее до отключения пользователя любыми интервалами ожидания.

  • show dialer [номер типа интерфейса] – отображается общая диагностическая информация для интерфейсов, настроенных для DDR. Если номеронабиратель подошел должным образом, состояние программы набора номера является канальным уровнем, обмениваются сообщениями, появляется. Если установлен физический уровень, это значит, что поднялся протокол линии передачи данных, но не протокол управления сетью (NСP). Исходный и конечный адреса пакета, инициировавшего вызов номера, показаны в строке причины вызова. Эта команда также отображает конфигурацию таймера и время перед временами соединения.

  • show caller user username detail - показываются параметры для конкретного пользователя, такие как назначенный IP-адрес, параметры протокола PPP и связки PPP и т. д. Если данная команда не поддерживается в вашей версии программного обеспечения Cisco IOS, используйте команду "show user command".

Для вызовов ISDN

Вот конфигурация для маршрутизатора получающей стороны с интерфейсом BRI, связанным с interface dialer 1 с командой dialer rotary-group 1. Помните, что в номеронабирателе интерфейса 1 с помощью команды dialer in-band включена DDR.

interface BRI0
   description 96665500
   no ip address
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer rotary-group 1
   dialer-group 1
   isdn switch-type basic-5ess
   no cdp enable
   ppp authentication pap
 !
 interface Dialer1
   ip address 10.1.1.1 255.255.255.0
   encapsulation ppp
   no ip route-cache
   no ip mroute-cache
   dialer in-band
   dialer idle-timeout 600
   dialer-group 1
   peer default ip address pool dialin
   no cdp enable
   ppp authentication chap callin
   ppp chap hostname cisco
   ppp chap password 7 <deleted>
 !
 ip local pool dialin 10.1.1.2 10.1.1.255
 dialer-list 1 protocol list 101
 access-list 101 permit icmp any any
 access-list 101 permit tcp any any eq 80
 access-list 101 deny ip any any

!--- Only http traffic and icmp traffic are interesting
 
 !

Выполните следующие шаги для проверки времени простоя:

  1. Убедитесь, что вызов соединен. Можно использовать команду show user, чтобы проверить, что связан пользователь. Пример:

    isdn2-4#show user
    
    Line   User  Host(s)       Idle     Location
    * 2 vty 0  idle         00:00:00 172.22.88.109
    
    Interface   User  Mode     Idle      Peer Address
    BR0:1       Preet Sync PPP 00:00:51  PPP: 10.1.1.2
    
  2. Проверьте, что время ожидания простоя применено к этому подключению. В примере ниже, пользователь Preet, набранный в и завершенный на interface dialer 1 и полученный IP-адрес 10.1.1.2 от входящего вызова пула. Следует убедиться, что для подключения используется время ожидания простоя длительностью 600 секунд (10 минут).

    isdn2-4#show dialer interface dialer1
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The idle timeout value configured on int dialer 1.   If the default 
    is in use, this value will be 120.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    !--- The user Preet obtained the idle timeout of 600 seconds.
    
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 557 secs
    

    Время до отключения уменьшается, так как по каналу не проходит никакой полезный трафик. В течение последних 43 секунд не наблюдалось никакого представляющего интерес трафика в обоих направлениях. Следовательно, пользователь разъединен в 600 - 43 = 557 секунд. Время, пока поле disconnect не начинает считать в обратном порядке однажды пользователь, связано и перезагружено к максимуму, когда получен представляющий интерес трафик.

    Connected to 4086666700 (Preet)
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle

    Другая команда, которая может использоваться для проверки времени простоя, является таймаутом show caller:

    isdn2-4#show caller timeout
    Line    User   Limit     Remaining   Timer  Type
    vty 2    -     00:10:00  00:09:59    Idle   Exec
    BR0:1   Preet  00:10:00  00:09:13    Dialer idle
    

    Поле "limit" показывает настроенное максимальное время простоя (в минутах) и поле "remaining" показывает время до отключения.

  3. Инициировать интересный трафик к одноранговому узлу. Сейчас мы инициируем интересный трафик к соседнему узлу. Удостоверьтесь, что вы посмотрели на текущую конфигурацию для определения точного определения содержательного трафика. Список доступа 101 задает протокол управляющих сообщений в Интернете (ICMP) и трафик TCP для порта 80. Поэтому мы теперь пропингуем 10.1.1.2 (IP-адрес, о котором пользователь Preet выполнил согласование) от маршрутизатора.

    isdn2-4#ping 10.1.1.2
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 36/37/40 ms
    isdn2-4#
  4. Убедитесь, что значение истечения времени из-за простоя переустановлено. Используйте таймаут show caller, show dialer и команды show caller user, чтобы проверить, что было перезагружено время простоя:

    isdn2-4#show caller timeout 
     Line     User      Limit    Remaining  Timer Type 
     vty 2    -         00:10:00 00:09:59   Idle Exec 
     BR0:1    Preet     00:10:00 00:09:59   Dialer idle
    !--- Idle-timout is reset back to maximum
    
    
    isdn2-4#show dialer interface dialer1
    
    Di1 - dialer type = IN-BAND SYNC NO-PARITY
    Load threshold for dialing additional calls is 255
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Number of active calls = 1
    
    Dial String   Successes   Failures   Last DNIS   Last status
    
    BRI0 - dialer type = ISDN
    Rotary group 1, priority = 0
    0 incoming call(s) have been screened.
    0 incoming call(s) rejected for callback.
    
    BRI0:1 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is data link layer up
    Time until disconnect 599 secs
    
    !--- Idle timeout is reset back to maximum.
    
    
    Connected to 4086666700 (Preet)
    
    BRI0:2 - dialer type = ISDN
    Idle timer (600 secs), Fast idle timer (20 secs)
    Wait for carrier (30 secs), Re-enable (15 secs)
    Dialer state is idle
    isdn2-4# 
    

Другая полезная команда, которая может использоваться для наблюдения сведений о времени ожидания на основе имени пользователя, является командой show caller user.

isdn2-4#show caller user Preet
 User: Preet, line BR0:1, service PPP 
 Connected for 00:05:36, Idle for 00:02:37
!--- Shows the inactivity for the last two minutes and 37 seconds. 
This counter increments to ten minutes and then the call is disconnected.


Timeouts: Limit    Remaining Timer  Type
          00:10:00 00:07:22  Dialer idle
!--- Time until idle disconnect.


PPP: LCP Open, PAP (<- none), IPCP
Dialer: Connected to 4086666700, inbound
        Type is ISDN, group Di1
IP: Local 10.1.1.1/24, remote 10.1.1.2
Counts: 215 packets input, 5392 bytes, 0 no buffer
        0 input errors, 0 CRC, 0 frame, 0 overrun
        230 packets output, 5603 bytes, 0 underruns
        0 output errors, 0 collisions, 7 interface resets

Если время простоя не перезагружено, продолжитесь к Проблемам времени ожидания простоя Устранения проблем раздела.

Для асинхронных вызовов

Вот типичная конфигурация асинхронных вызовов, которую можно наблюдать в среде ISP.

 interface Group-Async0
   ip unnumbered Loopback0
   encapsulation ppp
   dialer in-band

!--- Make this interface dialer capable
 
   dialer idle-timeout 600

!---  Idle timeout of 600 seconds (10 minutes)

   dialer-group 1

!--- Interesting traffic definition from dialer-list 1

   async mode interactive
   peer default ip address pool dialin
   ppp authentication pap chap callin
   group-range 1/3/00 1/3/71
   !
   ip local pool dialin 10.1.1.3 10.1.1.255
 dialer-list 1 protocol list 101

!--- Interesting traffic definition is defined by access-list 101

access-list 101 permit icmp any any

!--- Permit icmp from any host to any other host

 access-list 101 permit tcp any any eq 80

!--- Permit tcp port 80 (http traffic)

access-list 101 deny ip any any

!--- Deny all other IP traffic.  This interesting traffic definition 
will allow icmp and http traffic to reset the idle timeout. All other IP traffic will not 
affect the timeout.

Так же, как с ISDN, используйте show users, show dialer и таймаут show caller для проверки времени простоя.

Для поиска интерфейса и IP-адреса подключения однорангового узла, применяется команда show users.

c5800#show users
      Line      User  Host(s)         Idle     Location
   * 0 con 0          idle            00:00:00 
     tty 1/3/01 Preet Async interface 00:00:09 PPP: 10.1.1.3
!--- User Preet is connected to async interface 1/3/01 and has IP address 10.1.1.3

Interface    User Mode             Idle     Peer          Address

Используйте команду show dialer (указав определенный интерфейс) для изучения значений таймеров:

c5800#show dialer interface async 1/3/01
As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
Idle timer (600 secs), Fast idle timer (20 secs)
!--- Idle timeout of 600 seconds is applied to the interface if this value 
is 120 seconds.


!--- Verify that dialer in-band is configured under the group-async interface.

Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Time until disconnect 574 secs (Preet)
!--- Call will be disconnected in 574 seconds unless it receives interesting traffic.
Dial String     Successes    Failures    Last DNIS     Last status

Команда show caller timeout может также показать время разъединения:

c5800#show caller timeout
                        Session    Idle      Disconnect
   Line        User     Timeout    Timeout     User in
   con 0        -        -          -           - 
   tty 1/3/01  Preet     -          -           - 
   As1/3/01    Preet     -         00:10:00    00:09:19 

Мы будем теперь инициировать представляющий интерес трафик. Список доступа 101 определяет ICMP и трафик по протоколу TCP через порт 80 (трафик HTTP) как содержательный. Отправьте сигнал проверки связи на адрес 10.1.1.3 (IP-адрес, переданный пользователем Preet) с маршрутизатора, чтобы сбросить таймер режима ожидания.

c5800#ping 10.1.1.3
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 108/113/124 ms

Проверьте, что был перезагружен таймаут:

   c5800#show caller timeout
                      Session Idle    Disconnect
   Line       User    Timeout Timeout User in
   con 0      -        -       -      - 
   tty 1/3/01 Preet    -       -      - 
   As1/3/01   Preet    -     00:10:00 00:09:58
!--- Time to disconnect is close to 10 minutes

Это доказывает, что представляющий интерес трафик правильно определен и применен правильно. Поочередно, можно использовать команду show dialer для проверки значений таймаута:

c5800#show dialer interface async 1/3/01
   As1/3/01 - dialer type = IN-BAND ASYNC NO-PARITY
   Idle timer (600 secs), Fast idle timer (20 secs)
   Wait for carrier (30 secs), Re-enable (15 secs)
   Dialer state is data link layer up
   Time until disconnect 594 secs (Preet)
   Dial String   Successes    Failures   Last DNIS    Last status

Можно также использовать пользователя show caller подробная команда {имени пользователя} для проверки параметров, определенных для пользователя:

c5800#show caller user preet detailed 
User:   Preet, line tty 1/3/01, service Async
        Active time 00:01:14, Idle time 00:00:18
Timeouts:          Absolute   Idle      Idle
                              Session   Exec
Limits:            -          -         00:10:00
Disconnect in:     -          -         -    
TTY: Line 1/3/01, running PPP on As1/3/01   
Location: PPP: 10.1.1.3   
DS0: (slot/unit/channel)=1/4/0   
Status: Ready, Active, No Exit Banner, Async Interface Active
        HW PPP Support Active   
Capabilities: No Flush-at-Activation, Hardware Flowcontrol In
              Hardware Flowcontrol Out, Modem Callout, Modem RI is CD                 
              Line usable as async interface, Telnet Faststream   
Modem State: Ready

User: Preet, line As1/3/01, service PPP
      Active time 00:01:11, Idle time 00:00:18   
Timeouts:        Absolute Idle
Limits:          -        00:10:00    
Disconnect in:   -        00:09:41 
!--- Idle timeout of 10 minutes. The call will be disconnected in 9 minutes 41 secs 
unless it receives interesting traffic during that time. If the absolute column has a 
value, then the call will be disconnected at that time regardless of the idle timeout.

PPP: LCP Open, CHAP (<- local), IPCP
LCP: -> peer, ACCM, AuthProto, MagicNumber, PCompression, ACCompression          
     <- peer, ACCM, MagicNumber, PCompression, ACCompression   
NCP: Open IPCP   
IPCP: <- peer, Address
      -> peer, Address   
Dialer: Connected, inbound
        Idle timer 600 secs, idle 20 secs
        Type is IN-BAND ASYNC, group As1/3/01   
IP: Local 10.1.1.251, remote 10.1.1.3   
Counts: 12 packets input, 651 bytes, 0 no buffer 
        0 input errors, 0 CRC, 0 frame, 0 overrun           
        13 packets output, 666 bytes, 0 underruns           
        0 output errors, 0 collisions, 0 interface resets

Устранение проблем, связанных с временем простоя

Признак: Вызов отключается преждевременно или совсем не отключается

Если вызов неожиданно разъединяет, или вызов никогда не разъединяет, проверьте таймаут простоя программы для набора номера и определение содержательного трафика. Чтобы узнать, является ли пакет содержательным, можно использовать команду debug dialer packet. Пример:

Apr 26 01:57:24.483: Di1 DDR: ip (s=192.168.1.1, d=224.0.0.5), 
64 bytes, outgoing uninteresting (list 101)
Apr 26 01:57:26.225: Di1 DDR: ip (s=192.168.1.1, d=10.1.1.1), 
100 bytes, outgoing interesting (list 101)

В приведенном выше примере приветствия OSPF несодержательны согласно списку доступа 101, а второй пакет является содержательным согласно списку доступа 101. Устранение неполадок следующим образом:

  1. Скорректируйте время ожидания простоя номеронабирателя в конфигурации интерфейса номеронабирателя. По умолчанию используется значение 120 секунд, но его можно увеличить или уменьшить в зависимости от конкретных потребностей.

    router(config-if)#dialer idle-timeout 

    Примечание: Если вызов не разъединяет, проверяет, что нулевая опция для таймаута простоя программы для набора номера (представленный в Cisco IOS Software Release 12.1 (3) t) "not set".

  2. Изменение определения содержательного трафика (настроено с помощью команды "dialer-list"). Если вызов преждевременно обрывается, можно определить содержательный трафик менее строго (запретить меньшую часть и разрешить все остальное). Если вызов никогда не разъединяет, изменитесь, ваше определение содержательного трафика, чтобы быть более строгими (разрешите некоторым и запретите все остальное).

    Совет: Если ваше соединение не прерывается, обязательно определите трафик протокола маршрутизации (или любой другой периодический трафик) как несодержательный. Это не позволит периодическим приветствиям сбрасывать время ожидания простоя. Ниже представлено определение образца содержательного трафика:

    access-list 101 remark Interesting traffic for dialer-list 1   
    access-list 101 deny ospf any any
    !--- Mark OSPF as uninteresting.  This will prevent OSPF hellos from 
    keeping the link up.
    
    
    access-list 101 deny udp any any eq ntp
    
    !--- Define ntp traffic as NOT interesting.  This will prevent periodic ntp 
    traffic from keeping the link up indefinitely.
    
    
    access-list 101 permit ip any any
    !--- All other IP traffic is interesting. Change this depending on your 
    traffic needs.
    
    dialer-list 1 protocol ip list 101
    !--- This interesting traffic is applied to the dialer interface using 
    dialer-group 1.
    
    

    Для получения дополнительной информации обратитесь к документупо Технология удаленного доступа: Обзоры и объяснения.

Признак: Вызов разъединяется каждые несколько секунд

Еще одной проблемой является то, что происходит отключение вызова каждые х секунд (чаще всего каждые 120 секунд). В определенных ситуациях, даже если трафик передается по каналу, DDR не выполняет сброс тайм-аутов простоя. Вероятная причина:

  • представляющий интерес трафик, не определяемый

  • определение содержательного пакета неприменимо к интерфейсу

  • интерфейс, не сделанный с поддержкой программы набора номера

Чтобы устранить проблему:

  1. Проверьте, определен ли список дозвона и настроена ли группа дозвона (с указанием списка дозвона) в интерфейсе. Настройте простое определение содержательного трафика:

    router(config)#interface dialer 1
    router(config-if)#dialer-group 1
    router(config-if)#exit
    router(config)#dialer-list 1 protocol ip permit
    

    После разрешения проблемы частого разъединения можно настроить определение содержательного трафика под свои нужды.

  2. Гарантируйте, что внутриполосный номеронабиратель настроен на group-async и интерфейсах номеронабирателя. Эта команда не необходима на интерфейсах номеронабирателя как interface BRI x и interface Serial x:23 (для PRI).

  3. Отрегулируйте таймаут простоя программы для набора номера к желаемому значению.

    router(config-if)#dialer idle-timeout 900
    

Дополнительные сведения


Document ID: 23423