Коммутация LAN : EtherChannel

Настройка группирования магистралей FEC и ISL/802.1q между коммутатором CatOS и внешним маршрутизатором

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (7 ноября 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет примеры конфигурации для Fast EtherChannel (FEC), Протокола ISL и транкинга 802.1Q между Коммутатором Catalyst 6500, который выполняет CatalystOS (CatOS) и Маршрутизатор Cisco 7500. Результаты каждой команды появляются по мере выполнения. Несмотря на то, что Коммутатор Catalyst 6000 используется в этой конфигурации, вы могли заменить Catalyst 4000 или Коммутатором семейства Catalyst 5000, который выполняет CatOS.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Коммутаторы Catalyst серии 6000

    • CSX Выпуска 5.1 (1) CatOS или позже требуется, чтобы EtherChannel поддержки

  • Маршрутизаторы Cisco серии 7000 или 7500

    • Маршрутизаторы Cisco серии 7000 с Процессором переключателей маршрута серии 7000 (RSP7000) или Интерфейс шасси (RSP7000CI) или маршрутизаторы Cisco серии 7500 с Интерфейсным процессором Fast Ethernet (FEIP) или Многоцелевым интерфейсным процессором (VIP2) адаптеры портов

    • При использовании адаптера порта PA-2FEISL у вас должна быть проверка оборудования 1.2 или позже.

      Для получения дополнительной информации см. следующее уведомление: *Истекший* FN - 8791_11301999 - Рекомендации по замене 2-Port Fast Ethernet ISL PA-2FEISL для получения дополнительной информации.

    • Команда encapsulation dot1Q native была представлена в Cisco Выпуск ПО IOS� 12.1 (3) T. Эта команда изменяет конфигурацию.

      Посмотрите Конфигурацию 802.1Q Cisco 7500 для Cisco IOS Software Release Ранее, чем 12.1 (3) раздел T этого документа для получения дополнительной информации.

    • На маршрутизаторах Cisco серии 7500 функция Cisco Express Forwarding включена по умолчанию. Однако поддержка скоростной маршрутизации Cisco IP-маршрутизации между VLAN IEEE 802.1Q не была доступна до программного обеспечения Cisco IOS версии 12.2 и 12.2T. Все еще возможно настроить инкапсуляцию 802.1Q в предыдущих версиях, но необходимо сначала выполнить глобальную команду no ip cef для отключения скоростной маршрутизации Cisco.

    • Когда маршрутизатор серии "7500" настроен для Многопротокольной коммутации по меткам (MPLS) и FEC, поддержка в настоящее время недоступна маршрутизации (MPLS IP �) пакеты, которые вытекают из интерфейса MPLS к интерфейсу FEC. Поэтому не рекомендуется, чтобы MPLS и конфигурация FEC сосуществовали на одиночном маршрутизаторе.

    • Программное обеспечение Cisco IOS версии 11.1(14)CA или позже требуется, чтобы EtherChannel поддержки.

      Программное обеспечение Cisco IOS версии 11.3(1)T (любой плюс набор функций) или позже требуется, чтобы поддерживать Транкинг ISL.

      Программное обеспечение Cisco IOS версии 12.0(1)T (любой плюс набор функций) или позже требуется, чтобы поддерживать транкинг IEEE 802.1Q.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Версия CatOS 5.5.14 выполнения Catalyst 6500

  • Cisco 7500, выполняющий Cisco IOS Software Release 12.2.7b

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Важные примечания

  • Следует иметь в виду, что Коммутаторы серии Catalyst 4000 не поддерживают Транкинг ISL. Кроме того, некоторые модули коммутации Catalyst 5000 series switches не поддерживают EtherChannel. Выполните команду модуля show port capabilities , чтобы определить, является ли конкретный модуль способным EtherChannel и какой транкинг с инкапсуляцией это поддерживает.

  • Существуют определенные рекомендации для конфигурации EtherChannel и транкинга. Всегда обращайтесь к документации к программному обеспечению вашего коммутатора.

    Например, при выполнении выпуска ПО 5.5.x на Catalyst 5000 вы обратились бы к Руководству по конфигурации программного обеспечения (5.5) и тщательно исследовали бы любые рекомендации по конфигурации и ограничения в Fast EtherChannel Настройки и разделе Gigabit EtherChannel.

EtherChannel

Функция FEC или Gigabit EtherChannel (GEC) позволяет множественным каналам связи точка-точка быть связанными в одно логическое соединение. Catalyst 6000 поддерживает максимум восьми портов в полнодуплексном режиме, который обеспечивает 1600 Мбит/с или 1.6 пропускных способности (Гбит/с) для FEC и 16 Гбит/с для GEC. Cisco 7500 поддерживает максимум четыре порта для каждого FEC при 800 Мбит/с. Производительность и эксплутационные показатели EtherChannel отличаются в зависимости от коммутатора или маршрутизатора. Дополнительные сведения см. в разделе "Системные требования для реализации EtherChannel на коммутаторах Catalyst".

Если одна или более ссылок отказывают, EtherChannel распределяет трафик через все ссылки и обеспечивает избыточность. См. Понимание Балансировки Загрузки etherchannel и Резервирования на Коммутаторах Catalyst для получения дополнительной информации и примерах конфигурации отнесся к EtherChannel.

См. страницу EtherChannel технической поддержки Cisco и Документации для получения дополнительной информации.

Транкинг

Транкинг является способом нести трафик от несколько интерфейсов VLAN по каналу типа точка-точка или Связке EtherChannel между двумя устройствами. Это два пути, которыми может быть внедрена Группировка каналов Ethernet:

  • Межкоммутаторный канал (ISL) (инкапсуляция магистрали, запатентованная Cisco)

  • 802.1q (стандартная инкапсуляция транка IIEE)

См. страницу VLAN Trunking Protocols технической поддержки Cisco и Документации для получения дополнительной информации.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Эти примеры конфигурации показывают вам, как сделать эти вещи:

  • Настройте два порта доступа для Рабочей станции 1 в VLAN 1 и для Рабочей станции 2 в VLAN 2 на Catalyst 6500.

  • Настройте шлюз по умолчанию для Рабочей станции 1, чтобы быть 10.10.10.1 / 24 и для Рабочей станции 2, чтобы быть 10.10.11.1/24 на Cisco 7500.

  • Настройте ISL и магистрали "802.1q" по FEC с двумя портами между Коммутатором Catalyst 6500 и Маршрутизатором Cisco 7500.

  • Настройте подинтерфейсы портового канала с IP-адресами для Маршрутизации между виртуальными локальными сетями (IVR).

Схема сети

В настоящем документе используется следующая схема сети:

Магистральный VLAN 1 и VLAN 2 по FEC с 2 портами

141.gif

Конфигурации

Эти конфигурации используются в данном документе:

Коммутатор Catalyst 6500

!--- Set the IP address and default gateway for VLAN 1 for management purposes.

Catalyst6500> (enable) set interface sc0 10.10.10.2 255.255.255.0

Interface sc0 IP address and netmask set.

Catalyst6500> (enable) set ip route default 10.10.10.1

Route added.

!--- Set the VTP mode. In this example, the mode is set to be transparent. Depending on your
!--- network, set the VTP mode accordingly.
!--- For details on VTP, refer to Understanding and Configuring VLAN Trunk Protocol (VTP).

Catalyst6500> (enable) set vtp mode transparent

VTP domain modified

!--- Add VLAN 2. VLAN 1 already exists by default.

Catalyst6500> (enable) set vlan 2

VLAN 2 configuration successful

!--- Add port 3/4 to VLAN 2. Port 3/3 is already in VLAN 1 by default.

Catalyst6500> (enable) set vlan 2 3/4

VLAN 2 modified.
VLAN 1 modified.
VLAN  Mod/Ports
---- -----------------------
2     3/4

!--- Set the port speed to 100 and duplex to full. One of the requirements for EtherChannel
!--- to work is for speed and duplex to be the same on both sides. To guarantee this, hard
!--- code both speed and duplex on ports 3/1 and 3/2.

Catalyst6500> (enable) set port speed 3/1-2 100

Ports 3/1-2 transmission speed set to 100Mbps.

Catalyst6500> (enable) set port duplex 3/1-2 full

Ports 3/1-2 set to full-duplex.

!--- Enable FEC on ports 3/1 and 3/2. Because routers do not understand Port Aggregation
!--- Protocol (PAgP), set the channel mode to one which causes ports to channel but which
!--- does not generate PAgP frames.

Catalyst6500> (enable) set port channel 3/1-2 on

Port(s) 3/1-2 are assigned to admin group 105.
Port(s) 3/1-2 channel mode set to on.

!--- Enable trunking on ports 3/1 and 3/2. Because routers do not understand Dynamic
!--- Trunking Protocol (DTP), set the trunking mode to nonegotiate, which causes ports to
!--- trunk but which does not generate DTP frames.
!--- Note: Because EtherChannel is configured first, any trunk settings that are applied
!--- now to one port automatically apply to all other ports in the channel.
!--- Enter the trunking encapsulation as either ISL…

Catalyst6500> (enable) set trunk 3/1 nonegotiate isl

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to isl.

!--- …or as dot1q.
!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

Catalyst6500> (enable) set trunk 3/1 nonegotiate dot1q

Port(s) 3/1-2 trunk mode set to nonegotiate.
Port(s) 3/1-2 trunk type set to dot1q.

Catalyst6500> (enable) show config

This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
.........
..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Thu May 2 2002, 01:26:26
!
#version 5.5(14)
!
!
#system
set system name  Catalyst6500
!
#!
#vtp
set vtp mode transparent
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
set vlan 2 name VLAN0002 type ethernet mtu 1500 said 100002 state active
set vlan 1002 name fddi-default type fddi mtu 1500 said 101002 state active
set vlan 1004 name fddinet-default type fddinet mtu 1500 said 101004 state active stp ieee
set vlan 1005 name trnet-default type trbrf mtu 1500 said 101005 state active stp ibm
set vlan 1003 name token-ring-default type trcrf mtu 1500 said 101003 state active
mode srb aremaxhop 7 stemaxhop 7
backupcrf off
!
#ip
set interface sc0 1 10.10.10.2/255.255.255.0 10.10.10.255

set ip route 0.0.0.0/0.0.0.0 10.10.10.1
!
#set boot command
set boot config-register 0x2102
set boot system flash bootflash:cat6000-sup.5-5-14.bin
!
#port channel
set port channel 3/1-2 105
!
# default port status is enable
!
!
#module 1 empty
!
#module 2 : 2-port 1000BaseX Supervisor
!
#module 3 : 48-port 10/100BaseTX Ethernet
set vlan 2    3/4
set port disable    3/5

set port speed      3/1-2  100
set port duplex     3/1-2  full
set trunk 3/1  nonegotiate isl 1-1005
set trunk 3/2  nonegotiate isl 1-1005

!--- If IEEE 802.1Q is configured, you will see this output instead:
set trunk 3/1  nonegotiate dot1q 1-1005
set trunk 3/2  nonegotiate dot1q 1-1005


set port channel 3/1-2 mode on
!
#module 4 : 24-port 100BaseFX MM Ethernet
!
#module 5 empty
!
#module 6 empty
!
#module 15 empty
!
#module 16 empty
end

Маршрутизатор Cisco 7500

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- If you are using ISL trunking, configure two port-channel sub-interfaces and issue the
!--- encapsulation isl <VLAN> command to enable ISL trunking.
!--- Configure IP addresses for InterVLAN routing.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation isl 1

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation isl 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- If you are using 802.1Q trunking, issue the encapsulation dot1Q <vlan> native
!--- command to configure two port-channel sub-interfaces and enable 802.1Q trunking.
!--- Configure the IP addresses for InterVLAN routing.

!--- Note: The encapsulation dot1Q 1 native command was added in Cisco IOS Software
!--- Release 12.1(3)T. If you are using an earlier version of Cisco IOS, see the
!--- Cisco 7500 802.1Q Configuration for Cisco IOS Software Releases Earlier than 12.1(3)T
!--- section of this document, to configure 802.1Q trunking on the router.




!--- Ensure that the native VLAN (default is VLAN 1) matches across the link. For more
!--- information about the native VLAN and 802.1Q trunking, refer to Trunking Between
!--- Catalyst 4500/4000, 5500/5000, and 6500/6000 Series Switches Using 802.1Q
!--- Encapsulation with Cisco CatOS System Software.

7500(config)# interface port-channel 1.1

7500(config-subif)# encapsulation dot1Q 1 native

7500(config-subif)# ip address 10.10.10.1 255.255.255.0

7500(config-subif)# exit

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command, to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: To make this setup work and to successfully ping between Workstation 1 and
!--- Workstation 2, you must ensure that the default gateways on the workstations are setup
!--- properly. For Workstation 1, the default gateway should be 10.10.10.1; and for 
!--- Workstation 2, the default gateway should be 10.10.11.1.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service single-slot-reload-enable
!
hostname 7500
!
boot system disk1:rsp-jsv-mz.122-7b.bin
!
ip subnet-zero
!
ip cef
call rsvp-sync
!
!
!
interface Port-channel1
 no ip address
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0

!--- If 802.1Q trunking is configured, you will see this output instead:
interface Port-channel1.1
 encapsulation dot1Q 1 native
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0


!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
ip pim bidir-enable
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Конфигурация 802.1Q Cisco 7500 для Cisco IOS Software Release ранее, чем 12.1 (3) T
В версиях Cisco IOS, предшествующих 12.1(3)T, команда encapsulation dot1Q 1 native была недоступна. Однако все еще необходимо согласовать стандартную VLAN по всему каналу, как описано выше. Для настройки транкинга 802.1Q в версиях программного обеспечения ранее, чем 12.1 (3) T настройте IP-адрес для VLAN 1 на канале главного порта 1 интерфейс, не подинтерфейс port-channel.

!--- Configure a port-channel interface to enable FEC.

7500# configure terminal

 Enter configuration commands, one per line. End with CNTL/Z.

7500(config)# interface port-channel 1

01:34:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
          state to down

!--- Configure full-duplex to match the duplex setting on the Catalyst switch side.

7500(config-if)# full-duplex

7500(config-if)# exit

!--- Do not configure an interface port-channel 1.1
!--- Instead, create a port-channel 1 main interface and configure the IP address
!--- for VLAN 1 here.

7500(config)# interface port-channel 1

7500(config-if)# full-duplex

7500(config-if)# ip address 10.10.10.1 255.255.255.0

7500(config-if)# exit

7500(config)#

!--- It is still necessary to create a subinterface for VLAN 2.

7500(config)# interface port-channel 1.2

7500(config-subif)# encapsulation dot1Q 2

7500(config-subif)# ip address 10.10.11.1 255.255.255.0

7500(config-subif)# exit

!--- Configure the FastEthernet interfaces for speed 100, depending on the port adapter.
!--- Some FastEthernet port adapters can autonegotiate speed (10 or 100) and duplex (half
!--- or full). Others are only capable of 100 (half or full).

7500(config)# interface fastethernet 5/1/0

7500(config-if)# speed 100

!--- Issue the channel-group command to configure the FastEthernet interfaces to be
!--- members of port-channel 1.

7500(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

7500(config-if)# no shut

7500(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/0 added as member-1 to port-channel1

01:46:09: %LINK-3-UPDOWN: Interface FastEthernet5/1/0, changed state to up
01:46:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/0,
          changed state to up
01:46:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1,
          changed state to up

Router(config-if)# exit

Router(config)# interface fastethernet 5/1/1

Router(config-if)# speed 100

Router(config-if)# channel-group 1

%Interface MTU set to channel-group MTU 1500.

Router(config-if)# no shut

Router(config-if)#
%Interface MTU set to channel-group MTU 1500.

FastEthernet5/1/1 added as member-2 to port-channel1

01:54:52: %LINK-3-UPDOWN: Interface FastEthernet5/1/1, changed state to up
01:54:53: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet5/1/1,
          changed state to up

Router(config-if)# exit

!--- Remember to save the configuration.

7500# write memory

Building configuration...
[OK]
7500#

!--- Note: Remember also that—in any version of software previous to 12.2 or 12.2T for the
!--- 7000/7500 series—you will have to issue the no ip cef command globally before you
!--- configure 802.1Q trunking on a subinterface. Otherwise, you will see this error
!--- message: 802.1q encapsulation not supported with CEF configured on the interface.
!--- See the Components Used section of this document for more information.

7500# show running-config

Building configuration...

Current configuration : 1593 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 7500
!
!
ip subnet-zero
!
no ip cef
!
!
!
interface Port-channel1
ip address 10.10.10.1 255.255.255.0
 full-duplex
 hold-queue 300 in
!
interface Port-channel1.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet5/1/0
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
interface FastEthernet5/1/1
 no ip address
 no ip mroute-cache
 speed 100
 full-duplex
 channel-group 1
!
!
ip classless
no ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

7500#

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Команды show для Catalyst 6500

  • show interface IP-адрес интерфейса управления sc0 и VLAN. В данном примере виртуальная локальная сеть (VLAN) по умолчанию используется (VLAN 1).

    Catalyst6500> (enable) show interface
    
    sl0: flags=51<UP,POINTOPOINT,RUNNING>
            slip 0.0.0.0 dest 0.0.0.0
    sc0: flags=63<UP,BROADCAST,RUNNING>
            VLAN 1 inet 10.10.10.2 netmask 255.255.255.0 broadcast 10.10.10.255
    Catalyst6500> (enable)
  • show ip route – отображает стандартный шлюз. В данном примере, 10.10.10.1 IP-адрес port-channel 1 (для транкинга 802.1Q) или port-channel 1.1 (для Транкинга ISL).

    Catalyst6500> (enable) show ip route
    
    Fragmentation   Redirect   Unreachable
    -------------   --------   -----------
    enabled         enabled    enabled
    
    The primary gateway: 10.10.10.1
    Destination      Gateway          RouteMask    Flags   Use       Interface
    ---------------  ---------------  ----------   -----   --------  ---------
    default          10.10.10.1       0x0          UG      0           sc0
    10.10.10.0       10.10.10.2       0xffffff00   U       8           sc0
    default          default          0xff000000   UH      0           sl0
    Catalyst6500> (enable)
  • show port capabilities mod/port — Дает ознакомление в быстродействии оборудования модулей коммутации. В данном примере вы видите, что порт 3/1 (и 3/2) является способным EtherChannel, какие транкинги с инкапсуляцией это поддерживает, и другая информация.

    Catalyst6500> (enable) show port capabilities 3/1
    
    Model                    WS-X6248-RJ-45
    Port                     3/1
    Type                     10/100BaseTX
    Speed                    auto,10,100
    Duplex                   half,full
    Trunk encap type         802.1q,ISL
    Trunk mode               on,off,desirable,auto,nonegotiate
    Channel                  yes
    Broadcast suppression    percentage(0-100)
    Flow control             receive-(off,on),send-(off)
    Security                 yes
    Membership               static,dynamic
    Fast start               yes
    QOS scheduling           rx-(1q4t),tx-(2q2t)
    CoS rewrite              yes
    ToS rewrite              DSCP
    UDLD                     yes
    Inline power             no
    AuxiliaryVlan            1..1000,untagged,dot1p,none
    SPAN                     source,destination
    COPS port group          not supported
    Catalyst6500> (enable)
  • mod/port show port counters — Дает ознакомление в возможных ошибках порта. В этом примере данный порт работает без ошибок. При столкновении с ошибками на порту обратитесь к Устранению проблем Порта коммутатора и Интерфейсных проблем для получения дополнительной информации.

    Catalyst6500> (enable) show port counters 3/1
    
    Port  Align-Err  FCS-Err    Xmit-Err   Rcv-Err    UnderSize
    ----- ---------- ---------- ---------- ---------- ---------
     3/1           0          0          0          0         0
    
    Port  Single-Col Multi-Coll Late-Coll  Excess-Col Carri-Sen Runts     Giants
    ----- ---------- ---------- ---------- ---------- --------- --------- ---------
     3/1           0          0          0          0         0         0         -
    
    Last-Time-Cleared
    --------------------------
    Thu May 2 2002, 02:11:55
    Catalyst6500> (enable)
  • mod show port — Показывает состояние порта, VLAN, транк и информацию о скорости и дуплексном режиме. В данном примере порт доступа для Рабочей станции 1 является 3/3, который находится в VLAN 1. Порт доступа для рабочей станции 2 – 3/4, он принадлежит VLAN 2. Порты 3/1 и 3/2 являются портами FEC и транкингом.

    Catalyst6500> (enable) show port 3
    
    Port  Name                 Status     VLAN       Duplex Speed Type
    ----- -------------------- ---------- ---------- ------ ----- ------------
     3/1                       connected  trunk        full   100 10/100BaseTX
     3/2                       connected  trunk        full   100 10/100BaseTX
     3/3                       connected  1          a-half  a-10 10/100BaseTX
     3/4                       connected  2          a-full a-100 10/100BaseTX
    
    !--- Output suppressed.
    
    
  • show vlan – показывает, какие порты присвоены определенной VLANS. Заметьте, что магистральные порты в данном примере (3/1 и 3/2) не обнаруживаются в этих выходных данных, которые обычны.

    Catalyst6500> (enable) show vlan
    
    VLAN Name                             Status    IfIndex Mod/Ports, Vlans
    ---- -------------------------------- --------- ------- ------------------------
    1    default                          active    119     2/1-2
                                                            3/3,3/5-48
                                                            4/1-24
    2    VLAN0002                         active    124     3/4
    
    !--- Output suppressed.
    
    
  • show trunk магистральный режим, тип инкапсуляции, позволенные vlan и активные LAN. В этом примере VLAN 1 (которая всегда разрешена и активна по умолчанию) и VLAN 2 - активные VLAN для магистрали. Заметьте, что оба магистральных порта находятся в VLAN 1.

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  isl            trunking      1
     3/2      nonegotiate  isl            trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2

    Для транкинга 802.1Q выходные данные предыдущей команды изменяются на это:

    Catalyst6500> (enable) show trunk
    
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native VLAN
    --------  -----------  -------------  ------------  -----------
     3/1      nonegotiate  dot1q          trunking      1
     3/2      nonegotiate  dot1q          trunking      1
    
    Port      VLANs allowed on trunk
    --------  ---------------------------------------------------------------------
     3/1      1-1005
     3/2      1-1005
    
    Port      VLANs allowed and active in management domain
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    
    Port      VLANs in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     3/1      1-2
     3/2      1-2
    Catalyst6500> (enable)
  • show port channel – показывает состояние Etherchannel. В данном примере существует FEC с 2 портами (порты 3/1 и 3/2), который идет, чтобы препятствовать тому, чтобы были переданы Кадры PAgP. Можно также видеть удаленный интерфейс порт-канала 7500 маршрутизаторов.

    Catalyst6500> (enable)  show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1  connected  on                     105   833
     3/2  connected  on                     105   833
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
    3/1  7500                            Port-channel1.1           cisco RSP4
    3/2  
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

    Для FEC с транкингом 802.1Q выходные данные предыдущей команды изменяются на это:

    Catalyst6500> (enable) show port channel
    
    Port  Status     Channel              Admin Ch
                     Mode                 Group Id
    ----- ---------- -------------------- ----- -----
     3/1   connected  on                    257   769
     3/2   connected  on                    257   769
    ----- ---------- -------------------- ----- -----
    
    Port  Device-ID                       Port-ID                   Platform
    ----- ------------------------------- ------------------------- ----------------
     3/1       7500                            FastEthernet5/1/0         cisco RSP4
     3/2       7500                            FastEthernet5/1/1         cisco RSP4
    ----- ------------------------------- ------------------------- ----------------
    Catalyst6500> (enable)

Если у вас есть выходные данные команды show-tech support от вашего устройства Сisco, вы можете использовать Средство интерпретации выходных данных (только зарегистрированные клиенты) для отображения потенциальных проблем и исправляете.

Команды show маршрутизатора Cisco 7500

  • номер канала show interface port-channel — Дает статус члена для физических интерфейсов. В данном примере FEC с 2 портами настроен между портами 3/1 и 3/2 на Catalyst 6000 и между interface FastEthernet 5/1/0 и 5/1/1 на 7500. Port-channel 1 показывает как up/up.

    Этому настроили IP-адрес, который в этом случае означает, что это - IP-адрес собственного VLAN для транкинга 802.1Q. Посмотрите Конфигурацию 802.1Q Cisco 7500 для Cisco IOS Software Release Ранее, чем 12.1 (3) раздел T этого документа для получения дополнительной информации. Выходные данные также показывают для подинтерфейса 802.1Q VLAN 2 от команды show interface port channel 1.2.

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:14, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         6720 packets input, 923310 bytes, 0 no buffer
         Received 5010 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         1902 packets output, 573088 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation 802.1q Virtual LAN, Vlan ID  2.
      ARP type: ARPA, ARP Timeout 04:00:00

    Это - выходные данные для Транкинга ISL и FEC:

    7500# show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec, 
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, Unknown Speed
      ARP type: ARPA, ARP Timeout 04:00:00
        No. of active members in this channel: 2 
            Member 0 : FastEthernet5/1/0
            Member 1 : FastEthernet5/1/1
      Last input 00:00:01, output never, output hang never
      Last clearing of "show interface" counters never
      Input queue: 0/300/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         113 packets input, 7278 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
      13 packets output, 2264 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    
    7500# show interface port-channel 1.1
    
    Port-channel1.1 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.10.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    
    7500# show interface port-channel 1.2
    
    Port-channel1.2 is up, line protocol is up
      Hardware is FEChannel, address is 0001.6490.f8a8 (bia 0000.0000.0000)
      Internet address is 10.10.11.1/24
      MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
  • слот/port-adapter/порт show interfaces fastethernet — Показывает статус физических интерфейсов маршрутизатора и существуют ли какие-либо ошибки на интерфейсах. В этом примере маршрутизатор не содержит ошибок.

    7500# show interface fastethernet 5/1/0
    
    FastEthernet5/1/0 is up, line protocol is up
      Hardware is cyBus FastEthernet Interface, address is 0001.6490.f8a8
      (bia 0001.6490.f8a8)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
         reliability 255/255, txload 1/255, rxload 1/255
      Encapsulation ARPA, loopback not set
      Keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 1d00h, output 00:00:07, output hang never
      Last clearing of "show interface" counters 1d00h
      Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
      Queueing strategy: fifo
      Output queue :0/40 (size/max)
      5 minute input rate 0 bits/sec, 0 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         2929 packets input, 425318 bytes, 0 no buffer
         Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
         0 watchdog
         0 input packets with dribble condition detected
         12006 packets output, 1539768 bytes, 0 underruns
         0 output errors, 0 collisions, 6 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    7500#

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 23307