Асинхронный режим передачи (ATM) : "Класс обслуживания (IP, ATM и т. п.)"

Применение политик обслуживания QoS и CBWFQ/LLQ на ATM PVC с мостовыми соединениями

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Данный документ предоставляет пример конфигурации для параметров сложных очередей, таких как очередь с весами, основанными на классах (CBWFQ), и очередь с малыми задержками (LLQ), на ATM-интерфейсах, настроенных на прием элементов данных мостового протокола RFC 1483 (PDU).

Cisco Поддержки программного обеспечения IOS� три протокола маршрутизации ответвляемой сети (к другому Номеру сети IP) в мостовых приложениях RFC 1483 года. Этими протоколами являются протоколы интегрированной маршрутизации и мостовой передачи (IRB), маршрутно-мостовой инкапсуляции (RBE) и постоянных виртуальных каналов с мостовой схемой (PVC). Все эти протоколы дают возможность ATM PVC получать PDU в формате моста. Этот документ обращается к PVCs, настроенному с протоколом привязки такой, как соединено PVCs.

Политика службы, настроенная с помощью интерфейса командной строки (CLI) модульного качества обслуживания (QoS) (MQC), применяет механизмы QoS к интерфейсу, подчиненному интерфейсу или VC. В мостовых PVC политики обслуживания, которые применяют механизмы сложных очередей, поддерживаются только с RBE. Политики служб не поддерживаются на виртуальных соединениях ATM, настроенных для запуска IRB. На таких VC при определении class-map, который совпадает на списке доступа IP (ACL), не происходят никакие пакетные соответствия к этому классу, и все пакеты классифицированы к классу по умолчанию.

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем::

Примечание: Конфигурация IRB не поддерживает CBWFQ на-VC или LLQ. Конфигурация должна быть перемещена или на RBE или на PPPoE по конфигурации ATM, прежде чем вы попытаетесь внедрить CBWFQ или LLQ.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизатор Cisco 2620 с ATM-интерфейсом NM-1A-OC3

  • Программное обеспечение Cisco IOS версии 12.2 (27)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

Политика службы QoS управляет глубиной очереди, маркирует трафик и определяет некритический трафик на поканальной основе. В частности эта политика достигает этих целей:

  • NBAR использования для классификации неважного с коммерческой точки зрения трафика, такого как Napster.

  • Использует основанную на классе Характеристику назначения и контроля выполнения политик (правил) для маркировки значения приоритета приспосабливания, превышения и нарушения трафика.

  • Применяет основанный на классе WRED для управления глубиной очереди.

    Примечание:  Команды выходный данный service-policy и random-detect-group являются взаимоисключающими на уровне PVC. Вы не можете применить группу WRED к VC, для которого вы включили CBWFQ через приложение политики обслуживания. Однако можно применить обе функции при настройке команды random-detect на классе в policy-map.

  • Применяет маркировку на основе классов с командой набора для маркировки этих значений приоритета IP-трафика типом трафика.

Значение приоритета Тип трафика
1 Не критически важный трафик, например Napster
4 По умолчанию, используемый для обычного трафика
5 Зарезервировано для будущего трафика в реальном времени, например для передачи голосовых данных посредством IP (VoIP).
6 и 7 Зарезервирована для трафика управления сетью

Потенциальные точки перегрузки – это виртуальные каналы ATM, по которым передаются данные пользователям, подключенным к DSL. IP-потоки поступают на интерфейс Fast Ethernet со скоростью до 100 Мбит/с и задействуют большое количество виртуальных каналов ATM. Они настраиваются для категории обслуживания ATM с не заданной заранее скоростью (UBR) и пиковой скоростью передачи ячеек (PCR) интерфейса T1 (1.544 Мбит/с). Таким образом стратегия обслуживания QoS отмечает трафик, который поступает в Интерфейс Fast Ethernet. Повторно помеченные значения тогда используются WRED, чтобы создать классы сервиса на основе IP precedence и предоставить дифференцированный сервис через уникальные уровни отбрасывания на класс.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/22820/bridging_cbwfq1.gif

Примечание: VC ATM категории сервиса UBR не предоставляют минимальной пропускной способности по определению. Таким образом вы не можете применить CBWFQ или LLQ и гарантировать пропускную способность VC UBR. В заказе для этого необходимо изменить категорию обслуживания ATM на что-то другое, чем UBR, такой как VBR-nrt или ABR. Для получения дополнительной информации на этом, обратитесь к Пониманию Категории сервиса UBR для Виртуальных каналов ATM.

Конфигурации

В данном документе используется следующая конфигурация:

Маршрутизатор Cisco 2600
class-map match-any HTTP-HACKS 

!--- Use the class-map command in global configuration mode
!--- in order to match packets to a specified class.


   match protocol http url "*.ida*"  
   
!--- In order to configure NBAR to match HTTP traffic 
!--- by URL, HOST, or Multi-purpose Internet Mail Extension (MIME)-type, use the
!--- match protocol http command in class-map configuration mode.

   match protocol http url "*cmd.exe*"  
   match protocol http url "*root.exe*"  
   match protocol http url "*Admin.dll*"  
   match protocol http url "*readme.eml*"  
class-map match-any JUNK  
   match protocol napster 
   match protocol fasttrack
class-map match-all IP-PREC-4  match ip precedence 4class-map match-all DEFAULT  
match any
! 
policy-map DSL-OUT-C

!--- Use this command
!--- in order to create or modify a policy map that can be attached to one or more 
!--- interfaces to specify a service policy.

  class IP-PREC-4
   police 32000 250000 5000000 conform-action set-prec-transmit 4 exceed-action
 set-prec-transmit 3 violate-action set-prec-transmit 2
  
!--- Use this command to mark a packet with different quality of service (QoS) 
!--- values based on conformance to the service-level agreement.

! 
policy-map LAN-IN  
  class HTTP-HACKS  
     police 8000 1000 1000 conform-action drop exceed-action
       drop  
  class JUNK  
   set ip precedence 1  
  class DEFAULT  
   set ip precedence 4  
! 
policy-map DSL-OUT  
   class class-default
    
!-- Used to make class-default a single FIFO queue 
!-- inside the WFQ system. 
 
    bandwidth percent 1 
    
    random-detect  
    random-detect exponential-weighting-constant 7  
    random-detect precedence 0   20    40    10  
    random-detect precedence 1   22    40    10 
    random-detect precedence 2   24    40    10 
    random-detect precedence 3   26    40    10 
    random-detect precedence 4   28    40    10  
    random-detect precedence 5   31    40    10  
    random-detect precedence 6   33    40    10  
    random-detect precedence 7   35    40    10  
    random-detect precedence rsvp   37    40    10 
    service-policy DSL-OUT-C
    
!--- In order to use a service policy as a QoS policy within a policy map
!--- (called a hierarchical service policy), use the service-policy command
!--- in policy-map class configuration mode.

! 
interface Loopback1  
  ip address 172.16.1.1 255.255.255.0  
!  
interface FastEthernet0/0  
  ip address 10.1.1.1 255.255.255.192  
  service-policy input LAN-IN  
  
!--- Use this command in order to attach a policy map to an input interface
!--- or virtual circuit (VC), or an output interface or VC, to be used as 
!--- the service policy for that interface or VC.

!  
interface ATM1/0  
  no ip address  
  no atm ilmi-keepalive 
!  
interface ATM1/0.4 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
  no ip mroute-cache  
  atm route-bridged ip  
  pvc 1/35  
   service-policy output DSL-OUT  
  ! 
!  
interface ATM1/0.5 point-to-point  
  ip unnumbered Loopback1  
  no ip redirects  
  no ip unreachables  
 no ip mroute-cache  
  atm route-bridged ip 
 
!--- Use in order to configure an interface to use ATM RBE.

  pvc 1/36
   service-policy output DSL-OUT 
!
ip route 172.16.1.2 255.255.255.255 ATM1/0.4
ip route 172.16.1.3 255.255.255.255 ATM1/0.5
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show queueing interface atm статистику организации очереди определенного VC на интерфейсе. Когда Ip flow помещен в очередь очередям Уровня 3, ненулевое значение для активных "диалогов" отображено во время периодов перегрузки.

    2600# show queueing interface atm1/0.4
            Interface ATM1/0.4 VC 1/35
            Queueing strategy: weighted fair
            Total output drops per VC: 0
            Output queue: 0/512/64/0 (size/max total/threshold/drops)
               Conversations  0/1/64 (active/max active/max total)
               Reserved Conversations 1/1 (allocated/max allocated)
               Available Bandwidth 0 kilobits/sec
  • show policy-map interface atm — Используйте эту команду для проверки этих статистических данных при мониторинге политики обслуживания:

    • Приращение значений для пакетов, которые совпадают с классом. Если это не работает, гарантирует, что CEF включен и что пакеты придерживаются пересылающего в режиме CEF пути. Выполните команду show interface stats , чтобы просмотреть, CEF-коммутируемы ли пакеты.

    • Сравните значения "packets" и "pkts matched". Значение "pkts matched" возрастает только во время перегрузки. Для получения дополнительной информации обратитесь к Пониманию Счетчиков пакетов в Выходных данных show policy-map interface.

    • Правильное число случайных отбрасываний. Контролирует значение поля "mean queue depth" (средний размер очереди) и определяет, достигает ли это поле значения выше минимального порога. Когда средняя глубина очереди повышается выше минимального порога для определенного уровня Ip precedence, WRED начинает случайным образом отбрасывать пакеты.

2600# show policy-map interface atm1/0.4
ATM1/0.4: VC 1/35 -
 Service-policy output: DSL-OUT
 Class-map: class-default (match-any)
     29121 packets, 41550530 bytes
     5 minute offered rate 0 bps, drop rate 0 bps
     Match: any
     Queueing
       Output Queue: Conversation 73
       Bandwidth 1 (%)
       (pkts matched/bytes matched) 59/8894
       (depth/total drops/no-buffer drops) 0/0/0
        exponential weight: 7
        mean queue depth: 0

 class    Transmitted      Random drop   Tail drop    Minimum   Maximum   Mark
          pkts/bytes       pkts/bytes    pkts/bytes   thresh    thresh    prob
 0        15791/22456790       0/0           0/0          20        40    1/10
 1           0/0               0/0           0/0          22        40    1/10
 2         8555/13041140       0/0           0/0          24        40    1/10
 3         3417/5207580        0/0           0/0          26        40    1/10
 4         1358/845020         0/0           0/0          28        40    1/10
 5           0/0               0/0           0/0          31        40    1/10
 6           0/0               0/0           0/0          33        40    1/10
 7           0/0               0/0           0/0          35        40    1/10
 rsvp        0/0               0/0           0/0          37        40    1/10
     Service-policy : DSL-OUT-C
 Class-map: IP-PREC-4 (match-all)
   13330 packets, 19093740 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: ip precedence 4
   police:
     32000 bps, 250000 limit, 5000000 extended limit
     conformed 1358 packets, 845020 bytes; action: set-prec-transmit 4
     exceeded 3417 packets, 5207580 bytes; action: set-prec-transmit 3
     violated 8555 packets, 13041140 bytes; action: set-prec-transmit 2
     conformed 0 bps, exceed 0 bps, violate 0 bps
 Class-map: class-default (match-any)
   15791 packets, 22456790 bytes
   5 minute offered rate 0 bps, drop rate 0 bps
   Match: any 

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 22820