Протокол IP : Протокол EIGRP

"Сообщение об ошибке "%TUN-5-RECURDOWN" и нестабильность протоколов EIGRP/OSPF/BGP на соседних по туннелю GRE узлах"

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Сообщение об ошибках %TUN-5-RECURDOWN: Tunnel0 temporarily disabled due to recursive routing означает, что маршрутизатор туннеля универсальной инкапсуляции маршрутизации (GRE) обнаружил проблему рекурсивной маршрутизации. Это условие обычно происходит из-за одной из этих причин:

  • Ошибка конфигурации, при которой маршрутизатор пытается установить маршрут до адреса назначения туннеля через сам туннельный интерфейс (рекурсивная маршрутизация)

  • Временная нестабильность работы из-за пульсации маршрута в другом сегменте сети

Состояние интерфейса туннеля зависит от IP-достижимости назначения туннеля. Когда маршрутизатор обнаруживает ошибку рекурсивной маршрутизации для назначения туннеля, он завершает работу туннельного интерфейса в течение нескольких минут так, чтобы ситуация, причиняющая проблему, могла решить себя, поскольку сходятся протоколы маршрутизации. Если проблема вызвана неверной конфигурацией, ссылка может колебаться неопределенно.

Другим признаком данной проблемы является продолжающаяся периодическая потеря соединения с соседями по расширенному внутреннему протоколу маршрутизации (EIGRP), протоколу предпочтения кратчайшего пути (OSPF) или протоколу пограничного шлюза (BGP) при соединении соседей по туннелю GRE.

Этот документ показывает пример устранения проблем колеблющегося туннельного интерфейса, который выполняет EIGRP.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Данный документ не ограничен отдельными версиями программного или аппаратного обеспечения.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Схема сети

Маршрутизатор 1 (R1) и маршрутизатор 3 (R3) связаны с маршрутизатором 2 (R2). Возможность соединения сети такое, что R1 может достичь интерфейса обратной связи R3’s через R2 или наоборот. EIGRP запущен на туннельном интерфейсе между R1 и R3. R2 не является частью домена EIGRP.

/image/gif/paws/22327/gre_flap_01.gif

Конфигурации

_________________________ М1
hostname R1
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Tunnel0
 ip address 192.168.1.1 255.255.255.0
 tunnel source Loopback0
 tunnel destination 10.3.3.3
!
interface Serial0
 ip address 172.16.15.1 255.255.255.0
 encapsulation ppp
!
router eigrp 1
 network 10.1.1.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.15.2

R3
hostname R3
!
interface Loopback0
 ip address 10.3.3.3 255.255.255.0
!
interface Tunnel0
 ip address 192.168.1.3 255.255.255.0
 tunnel source Loopback0
 tunnel destination 10.1.1.1
!
interface Serial1
 ip address 172.16.25.3 255.255.255.0
!
router eigrp 1
 network 10.3.3.0 0.0.0.255
 network 192.168.1.0
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 172.16.25.2

Наблюдение

Наблюдайте эти сообщения об ошибках относительно R1 и R3. Состояние туннельного интерфейса постоянно колеблется между вверх и вниз.

01:11:39: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to up
01:11:48: %TUN-5-RECURDOWN:
          Tunnel0 temporarily disabled due to recursive routing
01:11:49: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to down
01:12:49: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to up
01:12:58: %TUN-5-RECURDOWN:
          Tunnel0 temporarily disabled due to recursive routing
01:12:59: %LINEPROTO-5-UPDOWN:
          Line protocol on Interface Tunnel0, changed state to down

Примечание: Каждая линия с меткой времени примера предыдущие выходные данные появляется на одной линии в эффективной выходной мощности.

Устранение неисправностей

Это - маршрут к назначению туннеля 10.3.3.3 на R1, прежде чем туннельный интерфейс восстановит работоспособность:

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.15.2 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       172.16.15.2/32 is directly connected, Serial0
C       172.16.15.0/24 is directly connected, Serial0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, Loopback0
S*   0.0.0.0/0 [1/0] via 172.16.15.2

Назначение туннеля 10.3.3.3 выбирает маршрут по умолчанию до 172.16.15.2 (последовательный 0).

Теперь, наблюдайте таблицу маршрутизации после того, как туннельный интерфейс восстановит работоспособность, показанный здесь:

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.15.2 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.25.0/24 [90/297756416] via 192.168.1.3, 00:00:00, Tunnel0
C       172.16.15.2/32 is directly connected, Serial0
C       172.16.15.0/24 is directly connected, Serial0
     10.0.0.0/24 is subnetted, 2 subnets
D       10.3.3.0 [90/297372416] via 192.168.1.3, 00:00:00, Tunnel0
C       10.1.1.0 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Tunnel0
S*   0.0.0.0/0 [1/0] via 172.16.15.2

Маршрут к назначению туннеля 10.3.3.3 изучен через EIGRP, и его следующий переход является interface Tunnel 0.

В этой ситуации оптимальный путь к назначению туннеля через туннельный интерфейс; однако, это происходит:

  1. Пакет заносится в выходную очередь интерфейса туннеля.

  2. Туннельный интерфейс добавляет к пакету заголовок GRE и включает его в очередь транспортного протокола, предназначенного адресу назначения туннельного интерфейса.

  3. IP ищет маршрут к адресу назначения (DA) и узнает, что именно через туннельный интерфейс, возвращает пакет к Шагу 1 выше; поэтому образуется петля рекурсивной маршрутизации.

Решение

Настройте статические маршруты для назначения туннеля и на R1 и на R3.

R1(config)# ip route 10.3.3.3 255.255.255.255  serial 0
R3(config)# ip route 10.1.1.1 255.255.255.255 serial 1

Теперь, наблюдайте IP-маршрут относительно R1, показанного ниже.

R1# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.16.15.2 to network 0.0.0.0

     172.16.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.16.25.0/24 [90/297756416] via 192.168.1.3, 00:01:08, Tunnel0
C       172.16.15.2/32 is directly connected, Serial0
C       172.16.15.0/24 is directly connected, Serial0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
S       10.3.3.3/32 is directly connected, Serial0
D       10.3.3.0/24 [90/297372416] via 192.168.1.3, 00:01:08, Tunnel0
C       10.1.1.0/24 is directly connected, Loopback0
C    192.168.1.0/24 is directly connected, Tunnel0
S*   0.0.0.0/0 [1/0] via 172.16.15.2

Более точный статический маршрут (10.3.3.3/32) предпочтительнее, чем менее точный полученный EIGRP маршрут (10.3.3.0/24) для туннеля-получателя. Данный более точный статический маршрут избегает рекурсивной петли маршрутизации, перебрасываемого интерфейса туннеля и, соответственно, перебрасывания EIGRP-соседей.

R1# show interfaces tunnel 0
Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  Internet address is 192.168.1.1/24
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set
  Keepalive set (10 sec)
  Tunnel source 10.1.1.1 (Loopback0), destination 10.3.3.3

% Warning: Функция, не поддерживавшая в аппаратных средствах. Туннельные пакеты будут коммутированным программным обеспечением

Когда тот же адрес обратной связи или физический адрес используются в качестве источника для двух других туннелей, сообщение замечено. Из-за этого, каждый пакет переходит к процессору, вместо того, чтобы быть коммутированными аппаратными средствами.

При использовании множественные интерфейсы обратной связи для адресов точки начала туннеля, эта проблема может быть решена при использовании вторичных адресов на интерфейсе обратной связи или.

Пакет приветствия OSPF передается маршрутизатором по Туннелю GRE, но это не делает поступает в другой конец туннеля.

Во включенной сети OSPF маршрутизатор R1 передает пакет приветствия OSPF по Туннелю GRE, но это не получено маршрутизатором R3. Используйте команду debug ip ospf hello для отладки привет события.

R1#debug ip ospf hello
May 31 13:58:29.675 EDT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.1
May 31 13:58:39.675 EDT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.1
May 31 13:58:49.675 EDT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.1


R3#debug ip ospf hello
May 31 15:02:07 ADT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.3
May 31 15:02:09 ADT: OSPF: Rcv hello from 172.16.15.1 area 0.0.0.12 from Tunnel0 192.168.1.1
May 31 15:02:09 ADT: OSPF: Send immediate hello to nbr 172.16.15.3, src address 192.168.1.3, on Tunnel0
May 31 15:02:09 ADT: OSPF: Send hello to 224.0.0.5 area 0.0.0.12 on Tunnel0 from 192.168.1.3

!--- The previous output shows that the hello packets
!--- re sent by R1 but not received by R3.

Решение

Настройте команду tunnel key на interface tunnel 10 на обоих маршрутизаторы. Эта команда включает групповую адресацию на GRE.


Дополнительные сведения


Document ID: 22327