Качество обслуживания (QoS) : QoS Link Efficiency Mechanisms

Общие сведения о сжатии (включая cRTP) и качестве обслуживания

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ рассматривает известные неполадки с включением Cisco программные характеристики IOS� сжатия и Качества обслуживания (QoS) на том же маршрутизатор.

Программное обеспечение Cisco IOS предлагает много функций, которые оптимизируют ссылки глобальной сети (WAN) для упрощения узкого места полосы пропускания глобальной сети (WAN). Сжатие является эффективным методом оптимизации и включает два типа:

  • Сжатие данных - Предоставляет каждый конец схемой шифрования, которая позволяет символам быть удаленными из кадров в отправляющей стороне ссылки, и затем правильно заменяет их в получающей стороне. Так как сжатые кадры занимают меньше пропускной способности, большее количество может быть передано на единицу времени. Примеры схем сжатия данных включают stac, Microsoft Point-to-Point Compression (MPPC) и Форум Frame Relay 9 (FRF.9).

  • Сжатие заголовка - Сжимает заголовок на различных уровнях эталонной модели Открытого взаимодействия системы (OSI). Примеры включают сжатие заголовка Протокола TCP, сжатый RTP (cRTP) и сжатый Протокол Интернета / Протокол датаграммы пользователя (IP/UDP).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Обзор сжатия данных

Базовая функция сжатия данных должна уменьшить размер фрейма данных, переданного по соединению сети. Сокращение размера кадра уменьшает время, требуемое передавать кадр по сети.

Двумя обычно используемыми алгоритмами сжатия данных на устройствах сетевых технологий является Накопитель и Средство прогнозирования.

Следующие примеры конфигурации показывают два способа включить сжатие при передаче информации на Интерфейсе Frame Relay или подинтерфейсе.

interface Serial0/5
  ip address 10.0.0.1 255.255.255.0
  no ip directed-broadcast
  encapsulation frame-relay IETF
  clockrate 1300000
  frame-relay map ip 10.0.0.2 16 broadcast IETF payload-compression FRF9 stac

interface Serial0/0.105 point-to-point
  ip address 192.168.162.1 255.255.255.0
  no ip directed-broadcast
  frame-relay interface-dlci 105 IETF
  class 128k
  frame-relay payload-compression FRF9 stac

Оборудование Cisco для сжатия данных

Сжатие данных с аппаратной поддержкой достигает тех же общих функциональных возможностей как сжатие данных на основе программного обеспечения, но ускоряет темпы сжатия путем разгрузки этого в вычислительном отношении от основного CPU. Другими словами:

  • Программное сжатие - Сжатие внедрено в программном обеспечении Cisco IOS, установленном в главном процессоре маршрутизатора.

  • Аппаратное сжатие - Сжатие внедрено в аппаратном сжатии, установленном в системном слоте. Аппаратное сжатие удаляет сжатие и ответственность распаковки от главного процессора, установленного в маршрутизаторе.

    В следующей таблице перечислены аппаратное сжатие Cisco и поддерживаемые платформы:

Аппаратное сжатие Поддерживаемые платформы Примечания
SA-Comp/1 и SA-Comp/4 сервисные адаптеры (CSA) Маршрутизаторы Cisco серии 7200 и многоцелевой интерфейсный процессор второго поколения (VIP2) у Cisco 7000 и маршрутизаторов серии "7500" Алгоритм Stacker поддержек по последовательным интерфейсам, настроенным с Протоколом PPP или Инкапсуляцией Frame Relay.
NM-COMPR Маршрутизаторы Cisco серии 3600 Алгоритм Stacker поддержек по Каналам "PPP" и Соединениям Frame Relay с алгоритмом сжатия FRF.9.
AIM-COMPR4 Cisco 3660 Series Router только Supports Lempel-Ziv Standard (LZS) и алгоритмы MPPC.

Сжатие Настройки на последовательном интерфейсе с командой, такой как stac компресса автоматически включает аппаратное сжатие, если это доступно. В противном случае программное сжатие включено. Можно использовать команду compress stac software для принуждения использования программного сжатия.

Организация сложных очередей и аппаратное сжатие

В этом разделе рассматриваются решенную проблему с функцией постановки в очередь с установлением приоритетa (PQ) традиционного синтаксиса Cisco и аппаратным сжатием. Аппаратное сжатие первоначально исключило пакеты из очереди настойчиво от PQs, эффективно удаляя преимущества PQ. Другими словами, PQ работал должным образом, но организация очереди функционально переместилась к собственным очередям аппаратного сжатия (holdq, вызов hw и compQ), которые являются строго первым прибыл, первым обслужен (FIFO). Признаки этой проблемы задокументированы в идентификатор ошибки Cisco CSCdp33759 (отмеченный как копия CSCdm91180).

Разрешение модифицирует драйвер аппаратного сжатия. В частности это душит скорость, на которой аппаратное сжатие исключает пакеты из очереди путем сокращения размера очередей аппаратных ресурсов на основе пропускной способности интерфейса. Этот механизм обратного давления гарантирует, что пакеты остаются в необычных очередях вместо того, чтобы быть проведенными в очередях аппаратного сжатия. Обратитесь к придерживающимся идентификаторам ошибок для получения дополнительной информации:

Примечание: Дополнительные сведения об этих идентификаторах ошибок могут быть найдены при помощи Bug Toolkit (только зарегистрированные клиенты).

  • CSCdm91180 - Применяется к Инкапсуляции Frame Relay и Модулю сервиса компрессии (CSA).

  • CSCdp33759 (и CSCdr18251) - Применяется к инкапсуляции PPP и CSA.

  • CSCdr18251 - Применяется к инкапсуляции PPP и сжатию модуля асинхронного интерфейса (AIM-COMPR).

Очереди аппаратного уровня сжатия Cisco 3660 могут быть замечены в придерживающемся примере выходных данных команды show pas caim stats. Если очереди аппаратного сжатия хранят много пакетов, пакет, исключенный из очереди от PQ, ждет в конечном участке этой очереди, и таким образом испытывает задержку.

Router> show pas caim stats 0

CompressionAim0
   ds:0x80F56A44 idb:0x80F50DB8
       422074 uncomp paks in  -->      422076 comp paks out
       422071 comp paks in    -->      422075 uncomp paks out
    633912308 uncomp bytes in -->    22791798 comp bytes out
     27433911 comp bytes in   -->   633911762 uncomp bytes out
          974 uncomp paks/sec in -->      974 comp paks/sec out
          974 comp paks/sec in -->        974 uncomp paks/sec out
     11739116 uncomp bits/sec in -->   422070 comp bits/sec out
       508035 comp bits/sec in -->   11739106 uncomp bits/sec out
   433 seconds since last clear
   holdq: 0  hw_enable: 1  src_limited: 0  num cnxts: 4
   no data: 0  drops: 0  nobuffers: 0 enc adj errs: 0 fallbacks: 0
   no Replace: 0 num seq errs: 0 num desc errs: 0 cmds complete: 844151
   Bad reqs: 0  Dead cnxts: 0 No Paks: 0 enq errs: 0
   rx pkt drops: 0  tx pkt drops: 0 >dequeues: 0 requeues: 0
   drops disabled: 0 clears: 0 ints: 844314 purges: 0
   no cnxts: 0  bad algos: 0 no crams: 0 bad paks: 0
   # opens: 0 # closes: 0 # hangs: 0

Примечание: CSCdr86700 удаляет изменения, внедренные в CSCdm91180 от платформ, не поддерживающих CSA.

Кроме того, при устренении этой проблемы, проблемы увеличения пакетов (приблизительно с 4-байтовыми) небольшими пакетами и определенные повторяющиеся структуры, такие как эхо-запросы Cisco с образцом 0xABCDABCD, были решены с идентификатором ошибки CSCdm11401. Небольшие пакеты, менее вероятно, будут отнесены к другим пакетам в потоке, и пытающийся сжать их может привести к расширенным пакетам или вызвать восстановление словаря в исходное состояние. Основная причина является проблемой с микросхемой, используемой на CSA. Идентификатор ошибки Cisco CSCdp64837 решает эту проблему путем изменения кода сжатия FRF.9, чтобы избежать сжимать пакеты, имеющие меньше чем 60 байтов полезных данных.

Прихотливая организация очереди и сжатие программ

В отличие от аппаратного сжатия, программное сжатие и необычная организация очереди, включая пользовательский, приоритетное, и взвешенная организация очередей, не поддерживаются на интерфейсах, настроенных с инкапсуляцией PPP. Это ограничение задокументировано в идентификаторы ошибок CSCdj45401 и CSCdk86833.

Причина для ограничения состоит в том, что сжатие PPP не является не сохраняющим состояние и поддерживает запись предыдущих сжатий по потоку данных для оптимизации коэффициентов сжатия. Сжатые пакеты должны поддерживаться в порядке для поддержания записи предыдущих сжатий. Если пакеты сжаты перед организацией очереди они должны быть помещены в одну очередь. Помещение их в других очередях, как пользовательское и постановка в очередь с установлением приоритетa делает, может привести к пакетам, поступающим из последовательности, которая ломает сжатие. Альтернативные решения являются субоптимальными и не были внедрены. Такие альтернативы включают пакеты сжатия, поскольку они исключены из очереди (недопустимый для целей повышения производительности), поддерживая отдельную запись предыдущих сжатий для каждой очереди (неподдерживаемый и включающий значительный объем служебных данных), и перезагружая запись предыдущих сжатий для каждого пакета (существенно коэффициенты сжатия влияний). Как обходной путь, можно настроить инкапсуляцию управления каналом передачи данных высокого уровня (HDLC), но эта конфигурация может влиять на производительность системы и не рекомендуется. Вместо этого используйте аппаратное сжатие.

Сжатие заголовков RTP и качество обслуживания (QoS)

RFC 1889 leavingcisco.com задает RTP, который управляет транспортом аудиопути для Передачи голоса по IP (VoIP). RTP предоставляет такие сервисы как упорядочение для определения потерянных пакетов и 32-разрядных значений, чтобы определить и различить несколька отправителей в многоадресной рассылке. Значительно, это не предоставляет или гарантирует QoS.

Пакеты VoIP составлены из одной или более выборок речевого кодека или кадров, инкапсулировавших в 40 байтах заголовков IP/UDP/RTP. 40 байтов относительно большое количество издержек для типичных 20 размеров полезной нагрузки VoIP в байтах, особенно по низкоскоростным соединениям. RFC 2508 leavingcisco.com задает сжатый RTP (cRTP), который разработан для сокращения заголовков IP/UDP/RTP до двух байтов для большинства пакетов в случае, куда никакие контрольные суммы UDP не передаются, или четыре байта с контрольными суммами. Алгоритм сжатия, определенный в этом документе, тянет в большой степени на дизайн сжатия Заголовка TCP/IP, как описано в RFC 1144 leavingcisco.com.

RFC 2508 фактически задает два формата cRTP:

  • Сжатый RTP (CR) - Используемый, когда IP, UDP и заголовки RTP остаются непротиворечивыми. Сжаты все три заголовка.

  • Сжатый UDP (CU) - Используемый, когда существует большое изменение в метке времени RTP или когда изменяется тип полезных данных RTP. IP и заголовки UDP сжаты, но заголовок RTP не.

Программное обеспечение Cisco IOS версии 12.1(5)T представило несколько усовершенствований для сжатия по Постоянным виртуальным каналам Frame Relay (PVCs) на Cisco 2600, 3600, и маршрутизаторы серии 7200. Эти улучшения включают придерживающееся:

Перед Cisco IOS Release 12.1 (5) T Cisco IOS Release 12.1 (5) T и 12.2
Низкоскоростные граничные способы фрагментации глобальной сети (WAN) должны были гарантировать, что качество голосовой связи не работало на интерфейсы с аппаратным сжатием. Эти способы фрагментации, которые включают MLPPP/LFI, C Приложения FRF.11 и FRF.12, действительно работают со сжатием на основе программного обеспечения. Фрагментация (FRF.12 или Фрагментация и чередование данных в канале (LFI)) поддерживается вместе с аппаратным сжатием. Кроме того, FRF.12 и Фрагментация буфера C FRF.11 поддерживаются с аппаратным сжатием FRF.9 на том же PVC. Голосовые пакеты от очереди с приоритетами с организацией очереди низкой задержки (LLQ) обходят механизм сжатия FRF.9. Пакеты данных сжаты.
Сжатия FRF.9 поддерживаются только на encap IETF PVCs cRTP и сжатие FRF.9 поддерживаются на том же PVC. Сжатие FRF.9 поддерживается на PVCs, настроенном с инкапсуляцией инженерной группы по развитию Интернета (IETF) и Cisco.
cRTP поддерживается на Frame Relay PVCs, настроенный с инкапсуляцией Cisco только. cRTP продолжает поддерживаться только на инкапсулировавшем Cisco PVCs.

Типичные ошибки

В следующей таблице перечислены известные неполадки с Характеристиками QoS Cisco IOS и cRTP. Этот список точен во время публикации. Также обратитесь к Комментарии к выпуску для версии программного обеспечения Cisco IOS для получения дополнительной информации.

Код неполадки Описание
CSCdv73543 Когда иерархическая политика QoS, с помощью команд Modular QoS CLI, будет применена к исходящему интерфейсу и задает двухуровневый ограничитель, скорость трафика, которой приспосабливают, может меньше, чем ожидаться. Проблема происходит, когда действие, взятое пакет в одном уровне, отличается от этого во втором уровне. Например, соответствуйте на первом уровне и превысьте на втором уровне. Пример политики проиллюстрирован ниже:
policy-map test-policer
  class class-default
    police 10000 1500 1500 conform-action
transmit exceed-action transmit
    service-policy inner-police
!
policy-map inner-police
  class prec5
    police 20000 1500 1500 conform-action
transmit exceed-action transmit
CSCdt52094 Отбрасывания недопустимого пакета могут быть замечены при использовании организации очереди низкой задержки (LLQ) по Frame Relay. Проблема была вызвана системой массового обслуживания, не принимая наращивания пропускной способности во внимание cRTP.
CSCds43465 Первоначально, cRTP произошел после организации очереди. Результат состоял в том, что организация очереди (потенциально) видела намного больший пакет, чем, что фактически было передано на проводе. Это поведение изменено с этим дефектом. Организация очереди теперь рассматривает сжатые пакеты. С этим изменением можно настроить инструкции для пропускной способности с CBWFQ на основе скоростей сжатых данных.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 22308