Качество обслуживания (QoS) : QoS Packet Marking

Порядок операций по реализации качества обслуживания

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 апреля 2015) | Отзыв


Содержание


Введение

Этот документ иллюстрирует заказ, в котором функции Качества обслуживания (QoS) выполняются, когда применено входящие или исходящие к интерфейсу на маршрутизаторе, выполняющем программное обеспечение Cisco IOS₩½. Конфигурация политик QoS осуществляется с помощью модульного интерфейса командной строки QoS (MQC). В этом документе также обсуждается маркировка заголовка IP (в т.ч. DSCP), приоритет IP и порядок, в котором элементы политики QoS оцениваются маршрутизатором.

Предварительные условия

Требования

Читатели данной документации должны знать:

  • Основные методы QoS

Используемые компоненты

Пример выходных данных в разделе Конфигураций этого документа был перехвачен на Платформе серии Cisco 7513, которая выполняет программное обеспечение Cisco IOS версии 12.2.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общая классификация

Классификация - это процесс определения классов трафика, которые сортируют трафик в группы категорий потоков. Классификация определяет "условия соответствия" для каждого класса трафика, который должен рассматриваться политикой QoS. Более в частности это определяет "фильтр трафика", что пакеты проверены против того, когда применена стратегия обслуживания.

И распределено и нераспределенные платформы приводят пакеты к одному классу в policy-map. Соответствие завершается в первом классе соответствия. Если два класса в policy-map совпадают с тем же приоритетом IP-трафика или Диапазоном IP-адресов, пакет всегда принадлежит первому классу соответствия. Поэтому заказ класса в policy-map очень важен.

Этот классификационный подход называется «общей классификацией» и имеет следующие преимущества:

  • Точный учет и предотвращение проблем двойного учета, которые были замечены перед "общей классификацией".

  • Сокращает воздействие списков управления доступом (ACL) на CPU, поскольку ACL проверяется скорее по классам, чем по функциям.

  • Быстрый поиск заголовков пакета за счет кэширования.

Общая классификация включена автоматически при присоединении карты политик ввода или вывода с командой service-policy.

Эта таблица иллюстрирует заказ операции с общей классификацией. Когда классификация происходит в контексте Характеристик QoS, важно понять от таблицы. Во входящем пути пакет сортируется перед коммутацией. На исходящем пути пакет сортируется после коммутации.

Входящий Исходящий
  1. Распространение политики QoS через протокол пограничных шлюзов (BGP) (QPPB)
  2. Общая классификация ввода
  3. Вводы для ACL
  4. Маркирование входа (маркировка на основе классов или CAR)
  5. Формирование политики ввода (при помощи средства формирования политик на основе классов или CAR)
  6. IP-безопасность (IPSec)
  7. Cisco Express Forwarding (CEF) или быстрая коммутация
  1. CEF или быстрая коммутация
  2. Общая классификация исходящих данных
  3. Списки ACL для выходных данных
  4. Выходная маркировка
  5. Ограничение выходных данных (с помощью ограничителя на основе классов или CAR)
  6. Очередность (очередь с весами, основанными на классах (CBWFQ) и очередь с малым временем ожидания (LLQ)) и механизм взвешенного случайного раннего обнаружения (WRED)

Примечание: Входящее Сетевое распознавание приложений (NBAR) происходит после ACL и перед маршрутизацией на основе политик.

Важные изменения были внедрены относительно использования повторно помеченного значения и упорядочения функций. Эти изменения включают выполнение функций учета входного CAR, входного MAC-адреса и IP-приоритетности перед классификацией выходных данных MQC:

  • Ограничение входящей скорости, или CAR, применяется к пакетам, следующим по пути коммутации процесса и предназначенных для маршрутизатора. Ранее можно было ограничить скорость передачи только скоммутированных пакетов, проходящих через маршрутизатор с использованием CEF.

  • Новые значения IP-приоритетности, заданные при помощи ввода CAR или QPPB, могут использоваться для выбора виртуального канала (VC) в VC-пучке ATM.

  • Для классификации исходящих пакетов MQC могут использоваться IP-приоритет, кодовая точка дифференцированной службы (DSCP) и значения группы QoS, установленные с помощью ввода CAR или QPPB.

Маркировка и другие QoS-действия на одном маршрутизаторе

QoS часто используется, чтобы пометить пакет и выполнить действие, которое обрабатывает помеченное значение на том же интерфейсе и маршрутизаторе. Можно настроить и маркировку и другие действия QoS с общей классификацией.

Можно отметить пакеты, используя следующие функции QoS:

  • команда набора с маркировкой на основе классов

  • команда политики с основанным на классе применением политик

  • CAR

Эта таблица указывает, учитывается ли повторно помеченное значение действием QoS в политике обслуживания.

Местонахождение политики Значение, используемое в действиях политики ограничения исходящего трафика
Маркируйте и примените действие QoS в той же политике. В функциях QoS используется исходное значение пакета со стандартной классификацией. При передаче пакету присваивается новое значение, которое используется следующим маршрутизатором.
Пометьте политику входящих и примените QoS к политике исходящих. Действия QoS используют новое или повторно помеченное значение при классификации трафика против политики ограничения исходящего трафика.

На исходящем пути происходит общая классификация до того как будет применена любая из возможностей QoS. Результатом этого подхода, является то, что любые функции QoS, примененные к политике ограничения исходящего трафика, действуют по оригинальному значению приоритета. Если нужно выполнить действия, основываясь на маркированном значении на том же маршрутизаторе, то следует маркировать пакеты на входящем интерфейсе и применить другие функции QoS в соответствии с новым приоритетом на исходящем интерфейсе.

Схема сети

Настройки данного раздела используются этой сетевой диаграммой:

/image/gif/paws/22141/qos_orderofop_3b.gif

Примечание: Функциональная Карта Многоуровневого Коммутатора (MSFC) действует как хост.

Конфигурации

Этот пример показывает, каким образом порядок операций может влиять на маркировку пакетов.

Отдельная настройка политики маркировки и управления трафиком
class-map match-all In_Mark
   match any 
policy-map In_Bound
  class In_Mark
    set ip precedence 5 

!--- Use Private address below:

interface FastEthernet4/0/0 
 ip address  10.20.3.2 255.255.255.0
ip route-cache distributed  
 service-policy input In_Bound

!--- Apply the input policy for class-based marking.

  
class-map match-all Out_Shaper
match ip precedence 5 
! 
policy Map Outbound_Shaper
class  Out_Shaper 
    shape average 64000 256 256 

!--- Use Private address below:

interface Serial2/0/0 
 ip address 172.16.20.1 255.255.255.252
ip route-cache distributed 
 service-policy output Outbound_Shaper

!--- Apply the output policy for class-based shaping.

Выполните эти шаги для подтверждения маркировки и политики формирования:

  1. Используйте команду ping по адресу 172.16.20.2. Эхо-запрос совпадает с критериями class-map по имени "In_Mark".

    msfc#ping 172.16.20.2
      
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 40.1.44.2, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms
  2. Используйте команду show policy-map interface fast 4/0/0 для просмотра счетчиков соответствий входящей политики маркировки на основе классов. Механизм классификации успешно сопоставляется на IP-пакетах и перемаркирует значение IP-приоритета на 5.

    7513#show policy-map interface fast 4/0/0 
     FastEthernet4/0/0 
      Service-policy input: In_Bound
     
        Class-map: In_Mark (match-all) 
          5 packets, 570 bytes 
          5 minute offered rate 0 bps, drop rate 0 bps 
          Match: any 
          QoS Set 
            ip precedence 5 
              Packets marked 5
     
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any
  3. С помощью команды show policy-map interface serial 2/0/0 вы можете просмотреть счетчики совпадения для политики формирования исходящего трафика на основании от класса. Механизм классификации был успешно сопоставлен со значением IP-приоритета, равным 5, в заголовке пакета; также с его помощью была выполнена постановка пакетов в правильную очередь для класса.

    7513#show policy-map interface serial 2/0/0 
     Serial2/0/0 
    
      Service-policy output: Outbound_Shaper
    
        Class-map: Out_Shaper(match-all) 
          5 packets, 520 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPSMatch: ip precedence 5 
          queue size 0, queue limit 16 
          packets output 5, packet drops 0 
          tail/random drops 0, no buffer drops 0, other drops 0 
          Shape: cir 64000,  Bc 256,  Be 256 
            output bytes 520, shape rate 0 BPS 
    
        Class-map: class-default (match-any) 
          0 packets, 0 bytes 
          5 minute offered rate 0 BPS, drop rate 0 BPS 
          Match: any  (1327)

Вы видите то, что происходит, когда мы настраиваем одиночную стратегию обслуживания, которая применяет и формирование и маркировку к классу трафика, как в данном примере.

Единая маркировка и конфигурация политик формирования трафика
class-map match-all prec5 
  match any 
! 
policy-map shape_five
  class prec5 
    set ip precedence 5 
    shape average 64000 256 256
int serial1/0/0
  service-policy out shape_five

Вывод команды show policy-map interface serial 2/0/0 показывает, что маршрутизатор произвел перемаркировку пяти ping-пакетов, но эти пакеты были направлены по классу class-default. Механизмы классификации QoS на этом маршрутизаторе не рассматривали помеченное значение в поле IP precedence (приоритет IP).

7513#show policy-map interface serial 2/0/0 
 Serial2/0/0
  
  Service-policy output: shape_five
 
    Class-map: prec5 (match-all) 
      0 packets, 0 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match:  any
      queue size 0, queue limit 16 
      packets output 0, packet drops 0 
      tail/random drops 0, no buffer drops 0, other drops 0 
      QoS Set 
        ip precedence 5 
          Packets marked 5 
      Shape: cir 64000,  BC 256,  Be 256 
        output bytes 0, shape rate 0 BPS 

    Class-map: class-default (match-any) 
      5 packets, 520 bytes 
      5 minute offered rate 0 BPS, drop rate 0 BPS 
      Match: any

Дополнительные сведения


Document ID: 22141