Коммутация LAN : EtherChannel

Настройка EtherChannel Между Коммутаторами Catalyst, работающих под управлением программного обеспечения системы Cisco IOS и маршрутизатора Cisco

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (22 сентября 2010) | Английский (7 октября 2015) | Отзыв


Содержание


Введение

Этот пример конфигурации демонстрирует, как установить Уровень 3 (L3) EtherChannel, без транкинга VLAN, между маршрутизатором Cisco и Cisco Catalyst 6500 коммутаторов рабочий Cisco Системное программное обеспечение IOS�. EtherChannel может называться Fast EtherChannel (FEC) или Gigabit EtherChannel (GEC); термин зависит от скорости интерфейсов или портов, которые используются для формирования EtherChannel. В данном примере два порта Fast Ethernet маршрутизатора Cisco и коммутатора Catalyst 6500 были связаны в FEC. В данном документе термины "FEC", "GEC", "канал порта", "канал", а также "группа портов" относятся к каналу EthernetChannel.

В данном документе рассматриваются только примеры файлов конфигурации для коммутатора и маршрутизатора, а также выходные данных соответствующих команд show.

Предварительные условия

Требования

Прежде чем использовать эту конфигурацию, убедитесь, что выполняются следующие требования:

  • Коммутаторы Catalyst серии 6500/6000 и 4500/4000 работают под управлением ПО Cisco IOS:

    • Коммутаторы Catalyst серии 6500/6000 и 4500/4000, работающие под управлением ПО Cisco IOS, поддерживают EtherChannel 2-го и 3-го уровней (L2 и L3) и обладают возможностью подключения до 8 сконфигурированных совместимых интерфейсов Ethernet к каждому модулю. Все интерфейсы в каждом канале EtherChannel должны иметь одинаковую скорость. Все интерфейсы должны быть настроены как интерфейсы L2 или L3.

    • Для балансировки нагрузки EtherChannel могут использоваться MAC-адреса, IP-адреса или номера портов протокола TCP.

      Примечание: Выбранный режим применяется ко всем каналам EthernetChannel, настроенным на коммутаторе.

    • Коммутаторы Catalyst 6500/6000 под управлением ПО Cisco IOS версии 12.1E или более поздней версии и коммутаторы Catalyst 4500/4000 под управлением ПО Cisco IOS версии 12.1(8a)EW или более поздней версии.

  • Маршрутизаторы Cisco:

    • IP-трафик распределяется через интерфейс канала порта, а трафик от других протоколов маршрутизации отправляется по одному каналу. Трафик в мостовых соединениях распределяется на основе имеющейся в пакете информации L3. Если информация L3 отсутствует в пакете, трафик отправляется по первому каналу.

  • EtherChannel поддерживаются широким спектром маршрутизаторов Cisco. Чтобы выяснить платформу или версию программы, поддерживающую EtherChannel на маршрутизаторе Cisco, используйте Cisco Feature Navigator II (только для зарегистрированных пользователей). Список маршрутизаторов и версий ПО Cisco IOS, поддерживающих EtherChannel, находится в разделе FEC.

Требования к аппаратному и программному обеспечению для работы с EtherChannel на продуктах Cisco см. в документе Системные требования для реализации EtherChannel на коммутаторах Catalyst.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Коммутатор Catalyst 6500 под управлением ПО Cisco IOS версии 12.1(8b)E10

  • Маршрутизатор Cisco 7500 под управлением ПО Cisco IOS версии 12.1(21)

Конфигурация коммутатора в данном документе подходит для любых коммутаторов Catalyst серии 6500/6000 и 4500/4000 под управлением программного обеспечения Cisco IOS.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Примечание: Команда write erase очищает конфигурации на всех устройствах, чтобы гарантировать, что они имеют конфигурацию по умолчанию. Не забудьте перезапустить устройства после выполнения команды write erase, чтобы сбросились все не заданные по умолчанию конфигурации.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Важные примечания

Если команда channel-group в первый раз выполняете с применением физического интерфейса, то она автоматически создает интерфейс порта-канала. Если интерфейс порт-канал был настроен до организации физических интерфейсов каналов, вначале удалите этот интерфейс порта-канала. Это относится только к коммутаторам Catalyst. Порядок конфигурации в маршрутизаторе 7500 был изменен. Необходимо настроить интерфейс порт-канала перед настройкой the�channel группы под физическим интерфейсом.

Порядок настройки канала порта в Catalyst 6500/6000 и 4500/4000 ПО Cisco IOS имеет важное значение. Оптимально выполнять команду switchport до вызова команды channel-group в физическом интерфейсе.

Если команда channel-group вызывается до выполнения команды switchport в физическом интерфейсе (интерфейс Gigabit Ethernet 1/1), интерфейс порт-канал создается автоматически и становится интерфейсом L3. Если затем вызвать команду switchport в физическом интерфейсе, этот интерфейс станет интерфейсом L2. Кроме того, ранее созданные интерфейс порт-канал не будет иметь связанного с ним физического интерфейса. Обратите внимание, что команда channel-group не предусмотрена в физическом интерфейсе. В этом случае необходимо вначале выполнить команду switchport во вновь настроенном интерфейсе порт-канал. Затем физический порт вновь принимает команду channel-group. В этом случае уровень интерфейса для канала порта меняется с L3 на L2.

Обратите внимание, что происходит, если в начале в физическом интерфейсе выполняется команда switchport, а затем команда channel-group. В этом случае интерфейс порт-канал создается автоматически и наследует все сконфигурированные команды switchport.

На коммутаторах Catalyst серий 6500/6000 под управлением ПО Cisco IOS все порты по умолчанию являются портами L3. На коммутаторе Catalyst 4500/4000 рабочее программное обеспечение Cisco IOS все порты являются портами L2 по умолчанию.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/21066/135-a.gif

Конфигурации

Эти конфигурации используются в данном документе:

Примечание: Замечания и пояснения выделены синим курсивом.

Коммутатор Catalyst 6500 (без транкинга виртуальной локальной сети)
Building configuration...
�
Current configuration : 5869 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cat6500
!
boot buffersize 126968
boot system flash slot0:c6sup11-jsv-mz.121-8b.E15.bin
boot bootldr bootflash:c6msfc-boot-mz.121-8b.E15
enable password ww
!
redundancy
�main-cpu
� auto-sync standard
ip subnet-zero
!
!
no ip finger
!
!
!
!

!--- In this example, you configure L3 EtherChannel.
!--- For more details, refer to this document:
!--- Configuring EtherChannels.
!--- A logical port-channel interface is automatically created�
!--- when ports are grouped into a channel group.


interface Port-channel 1
�ip address 11.1.1.2 255.255.255.0
 duplex full
 speed 100

!--- If you specify the speed and duplex setting at the port channel 
!--- level, these settings pass down to the physical ports.
!--- In other words, the physical ports inherit the same speed 
!--- and duplex settings as the port-channel interface.

 hold-queue 300 in
!
interface GigabitEthernet1/1
�no ip address
�shutdown
!
interface GigabitEthernet1/2
�no ip address
�shutdown
!
interface FastEthernet3/1
 no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (Port Aggregation Protocol [PAgP]), so PAgP
!--- needs to be disabled. On a Catalyst 4500/4000 switch, all ports are
!--- L2 ports by default. Convert this port from a physical L2 port to
!--- a physical L3 port with the no switchport command.

channel-group 1 mode on

interface FastEthernet3/2
�no ip address
 duplex full
 speed 100

!--- Port is a member of channel group 1. Routers do not support 
!--- EtherChannel negotiation (PAgP), so PAgP needs to be disabled.
!--- On a Catalyst 4500/4000 switch, all ports are L2 ports by default. 
!--- Convert this port from a physical L2 port to a physical L3 port 
!--- with the no switchport command.


channel-group 1 mode on


interface FastEthernet3/3
�no ip address
�switchport
�switchport mode access
!

!--- Output suppressed.

!
ip classless
no ip http server
!
!
!
line con 0
�transport input none
line vty 0 4
!
end

Маршрутизатор Cisco 7500 (без группирования магистралей VLAN)

!--- Output suppressed.

!
interface Port-channel1
�ip address 11.1.1.1 255.255.255.0
 full-duplex
�hold-queue 300 in
!
interface FastEthernet0/0
�no ip address
�full-duplex
 speed 100
�channel-group 1
!
interface FastEthernet0/1
�no ip address���
�full-duplex
 speed 100���������������������������� �
�channel-group 1

!--- Output suppressed.

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

команды "show"

Некоторые команды show поддерживаются Интерпретатором выходных данных (только для зарегистрированных пользователей); это позволяет просматривать анализ выходных данных команды show.

  • show etherchannel channel-id port-channel — позволяет проверить канал порта на коммутаторе Cisco IOS.

  • show interfaces port-channel channel-id — позволяет проверить канал порта на маршрутизаторе Cisco IOS.

Пример выходных данных команды show

Коммутатор Catalyst 6500/6000

  • show etherchannel channel-id port-channel

Router#show etherchannel 1 port-channel
Port-channels in the group:
----------------------
Port-channel: Po1
------------
Age of the Port-channel = 01h:56m:20s

Logical slot/port = 10/1 Number of ports in agport = 2
GC = 0x00010001 HotStandBy port = null
Passive port list = Fa3/1 Fa3/2
Port state = Port-channel L3-Ag Ag-Inuse
Ports in the Port-channel:
Index Load Port
-------------------
0 55 Fa3/1
1 AA Fa3/2
Time since last port bundled: 01h:55m:44s Fa3/2
Router#

Маршрутизатор Cisco 7500

  • show interfaces port-channel channel-id

Router#show interfaces port-channel 1
Port-channel1 is up, line protocol is up
Hardware is FastEtherChannel, address is 00e0.1476.7600 (bia 0000.0000.0000)
Internet address is 11.1.1.1/24
MTU 1500 bytes, BW 400000 Kbit, DLY 100 usec, rely 255/255, load 62/255
Encapsulation ARPA, loopback not set, keepalive set (10 sec), hdx
ARP type: ARPA, ARP Timeout 04:00:00
No. of members in this fechannel: 2
Member 0 : FastEthernet0/0
Member 1 : FastEthernet0/1
Last input never, output never, output hang never
Last clearing of "show interface" counters 10:51:55
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/300, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 98281000 bits/sec, 8762 packets/sec
4545 packets input, 539950 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 watchdog, 0 multicast
0 input packets with dribble condition detected
342251216 packets output, 3093422680 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 21066