Протокол IP : Dynamic Address Allocation and Resolution

Использование одного DHCP-сервера для голосовых сетей и сетей передачи данных

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В оптимизированной сети для IP-телефонии IP-адреса телефонов и ПК должны относиться к разным сегментам сети. Если протокол динамической конфигурации хоста (DHCP) используется при назначении адресов, то для каждого сегмента сети, как правило, необходим DHCP сервер. При наличии маршрутизаторов, способных ретранслировать DHCP в составе IP-сети, для назначения обоих диапазонов адресов можно использовать один и тот же сервер DHCP. В этом документе объясняется, почему и как можно использовать единый сервер для назначения IP-адресов для голосовой связи и передачи данных.

Примечание: Сведения, содержащиеся в этом документе не относятся к полностью коммутируемой сети или к случаю, когда отсутствует устройство маршрутизации. В таких сценариях существует только две возможности для присвоения других IP-адресов к телефонам и PC. Вы должны или иметь DHCP server с двумя Network Interface Cards или иметь двух Dhcp server.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Проблема

Если вы устанавливаете Сеть для IP-телефонии, то необходимо назначить IP-адреса для телефонов и PC в других сегментах сети. Для этих присвоений адресов нужен сервер DHCP на каждом сетевом сегменте. Однако у вас есть только один DHCP server.

Решение

Для присваивания текущим DHCP сервером адресов для обеих виртуальных локальных сетей необходимо иметь в сети устройства уровня 3 (L3), которые могут выполнять маршрутизацию между виртуальными локальными сетями.

Эти два примера в этом документе описывают, как использовать сервер DHCP для назначения IP-адресам и голоса и данных.

Настройка сети

Существует текущая сеть с Cisco Catalyst 6000 или Catalyst 3524-XL-PWR. В котором, VLAN 10 настроен, чтобы быть VLAN для передачи данных, используемым PC и серверами. В той же VLAN существует также DHCP server, который выполняет Windows 2000 для обеспечения адресов в диапазоне 10.10.10.20 к 10.10.10.200. IP-адрес сервера DHCP – 10.10.10.2.

dhcp-multintwk-1.gif

Чтобы добавить в эту сеть IP-телефонию, подключите IP-телефон с PC к порту Catalyst, где был подсоединен PC.

Пример Catalyst 6000 с MSFC

В этом сценарии, Cisco Catalyst 6000 с Функциональной Картой Многоуровневого Коммутатора (MSFC) выступает как устройство с поддержкой маршрутизации.

/image/gif/paws/19580/dhcp-multintwk-2.gif

Чтобы ПК и телефон могли использовать один порт Catalyst, вам нужно настроить команду auxiliaryVLAN, добавив в нее новую голосовую VLAN 110, как показано ниже:

cat6k-access> (enable) set VLAN 110 name 11.1.1.0_voice
cat6k-access> (enable) set VLAN 10 5/1-48
cat6k-access> (enable) set port auxiliaryVLAN 5/1-48 110

Чтобы разрешить данному DHCP-серверу в сети данных VLAN 10 быть использованным для назначения IP-адресов телефонам, выполните следующие шаги:

  1. Создайте один интерфейс на MSFC для каждой VLAN, данных и голоса.

  2. Настройте каждый интерфейс с допустимым адресом в VLAN.

  3. На interface VLAN 110, добавьте команду ip helper-address.

    Данная команда позволяет посылать широковещательные пакеты DHCP на голосовой VLAN 110 как одноадресные пакеты на сервер DHCP в данных VLAN 10.

    Конфигурация на MSFC должна выглядеть следующим образом:

    cat6k-msfc(config)#interface vlan10
    cat6k-msfc(config-if)#ip address 10.10.10.19
    cat6k-msfc(config-if)#<description of data VLAN for PCs and where the DHCP
     server is located>
    
    cat6k-msfc(config)#interface vlan110
    cat6k-msfc(config-if)#ip address 11.1.1.19
    cat6k-msfc(config-if)#ip helper-address 10.10.10.2
    cat6k-msfc(config-if)#<description VLAN for voice>
    

    Конфигурация Cisco Catalyst 6000 осталась прежней.

  4. Настройте DHCP server с новой областью адресов для телефонов (11.1.1.1. X) в голосовом VLAN 110.

    Если DHCP server не имеет области, которая совпадает с IP-адресом Агента ретрансляции, то запрос DHCP отказывает. Нужно добавить параметр 150 в эту область, чтобы предоставить телефонам адрес сервера TFTP. Для пошаговых инструкций на конфигурации DHCP server для телефонов обратитесь к Настройке DHCP Server Windows 2000 для Сisco CallManager.

Пример Catalyst 3524-XL с внешним маршрутизатором

В этом сценарии существует Cisco Catalyst 3524-XL-PWR и внешний маршрутизатор как устройство с поддержкой маршрутизации с одним интерфейсом в каждой VLAN.

/image/gif/paws/19580/dhcp-multintwk-3.gif

Чтобы позволить ПК и телефону быть на том же Порту Catalyst, настройте транкинг с новым голосовым VLAN 110 как показано:

interface FastEthernet0/13
description phone and PC
switchport mode trunk
switchport trunk encapsulation dot1q
switchport voice vlan 110
switchport trunk native vlan 10

Повторите конфигурацию для всех портов Catalyst, к которым подключен телефон, соединенный с ПК.

Чтобы разрешить данному DHCP-серверу в сети данных VLAN 10 быть использованным для назначения IP-адресов телефонам, выполните следующие шаги:

  1. Подключите два интерфейса маршрутизатора с двумя портами на 3524-XL Cisco Catalyst, один в VLAN 10 и другом в VLAN 110.

  2. На стороне маршрутизатора назначьте корректный адрес каждой VLAN.

    Примечание: С транкингом настроенного, можно также достигнуть этого с одним портом, связанным от Catalyst 3524-XL до маршрутизатора.

  3. Выполните команду ip helper-address на интерфейсе маршрутизатора, который связан с голосовым VLAN 110.

    Это позволяет отправлять принятые на интерфейсе широковещательные пакеты DHCP в виде одноадресных пакетов на сервер DHCP в сети данных VLAN 10.

    Конфигурация маршрутизатора должна быть следующей:

    router(config)#interface FastEthernet0/0 
    router(config-if)#ip address 10.10.10.19 255.255.255.0 
    
    router(config-if)#<description connected to catalyst port 0/10 
     data VLAN for PCs and DHCP server>
     
    router(config)#interface FastEthernet0/1
    router(config-if)#IP address 11.1.1.19 255.255.255.0 
    router(config-if)#IP helper-address 10.10.10.2 
    router(config-if)#<description connected to catalyst port 0/11 voice VLAN>
    
    

    Конфигурация на 3524-XL Cisco Catalyst должна быть:

    router(config)interface FastEthernet0/10
    router(config-if)#switchport access vlan 10
    router(config-if)#<description port on data VLAN going to the router FE0/0>
    
    router(config)interface FastEthernet0/11
    router(config-if)#switchport access vlan 110
    router(config-if)#<description port on voice VLAN going to the router FE0/1>
    
  4. Настройте DHCP server с новой областью адресов для телефонов (11.1.1.1. X) в голосовом VLAN 110.

    Если DHCP server не имеет области, которая совпадает с IP-адресом Агента ретрансляции, сбоями запроса DHCP. Нужно добавить параметр 150 в эту область, чтобы предоставить телефонам адрес сервера TFTP. Для пошаговых инструкций на конфигурации DHCP server для телефонов обратитесь к Настройке DHCP Server Windows 2000 для Сisco CallManager.

Как работает решение

Сервер DHCP может предоставлять адреса из определенного диапазона для сетей VLAN, в которых используется поле агента ретрансляции в пакетах DHCP. Relay Agent - это агент, который отвечает за преобразование трансляции DHCP пакетов, направленных по телефону в однонаправленные пакеты, которые, в свою очередь, отправляются на DHCP сервер. Этот агент также преобразовывает пакеты DHCP индивидуальной рассылки, передаваемые от DHCP server в транслируемые пакеты, которые передаются на телефонной сети. В данном примере Агент ретрансляции является интерфейсом VLAN 110 на MSFC, настроенном с командой ip helper-address.

Когда DHCP-сервер получает сообщение DHCP discover с текущим IP-адресом в поле Relay Agent, он использует этот адрес для сопоставления с соответствующей областью и назначает IP-адрес из нее. Подробные сведения об этом протоколе можно увидеть в RFC 3046. leavingcisco.com

В этом примере заменены следующие DHCP-пакеты:

/image/gif/paws/19580/dhcp-multintwk-4.gif

Голубые линии показывают пакеты DHCP, которые передаются и от IP-телефона. Это единственные пакеты, которые появляются, если сервер DHCP находится в той же сети Ethernet, что и телефоны.

Черные линии изображают одноадресные пакеты DHCP, которые Relay Agent передает в обе стороны для сервера DHCP.

Данная таблица отображает подробные сведения о пакетах для этого примера. Для получения дополнительной информации о протоколе DHCP и полях, обратитесь к RFC 1541 leavingcisco.com.

1 DHCP обнаруживает 2 DHCP обнаруживают
IP Source Address = [0.0.0.0] 
IP Destination Address = [255.255.255.255] 

DHCP Client IP Address = [0.0.0.0] 
DHCP Relay Agent = [0.0.0.0] 
Client Hardware Address = 00070EEA5449 
Message Type = 1 (DHCP Discover) 
Parameter Request List:
...
    150= Unknown Option 
... 
IP Source Address = [11.1.1.19] 
IP Destination Address =[10.10.10.2]

DHCP Client IP Address = [0.0.0.0]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 1 (DHCP Discover)
Parameter Request List:
...
    150= Unknown Option 
...
4 предложения DHCP 3 предложения DHCP
IP Source Address = [10.10.10.2]
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449
Message Type = 2 (DHCP Offer)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
IP Source Address = [10.10.10.2]
IP Destination Address = [11.1.1.19]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 2 (DHCP Offer)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
5 запросов DHCP 6 запрос DHCP
IP Source Address = [0.0.0.0] 
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [0.0.0.0]
DHCP Relay Agent = [0.0.0.0]
Client Hardware Address = 00070EEA5449 
Message Type = 3 (DHCP Request)
Request Specific IP Address = [11.1.1.25]
Parameter Request List:
...
    150= Unknown Option 
...
IP Source Address = [11.1.1.19] 
IP Destination Address = [10.10.10.2]

DHCP Client IP Address =  [0.0.0.0]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 3 (DHCP Request)
Request Specific IP Address = [11.1.1.25]
Parameter Request List:
...
    150= Unknown Option 
...
8 DHCP Ack 7 Ack DHCP
IP Source Address = [10.10.10.2]
IP Destination Address = [255.255.255.255]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449
Message Type = 5 (DHCP Ack)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...
IP Source Address = [10.10.10.2] 
IP Destination Address = [11.1.1.19]

DHCP Client IP Address = [11.1.1.25]
DHCP Relay Agent = [11.1.1.19]
Client Hardware Address = 00070EEA5449 
Message Type = 5 (DHCP Ack)
....
Address Renewel Interval = 216000 (seconds)
TFTF Server = "11.1.1.10"
...

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 19580