Широкополосные кабельные сети : Кабельные модемы

Настройка маршрутизатора Cisco для использования с кабельным модемом другого производителя

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (21 апреля 2016) | Отзыв


Содержание


Введение

В некоторых средах, где используются кабельные модемы (КМ) сторонних производителей, поддерживающие только мостовое соединение, маршрутизатор Cisco, например Cisco 806, можно соединить с КМ через интерфейс Ethernet. Маршрутизация в этом случае выполняется маршрутизатором, стоящим за КМ. На следующем этапе к маршрутизатору подключается клиентский компьютер или абонентское оборудование (CPE). После выполнения этого подключения на маршрутизаторе настраивается преобразование сетевых адресов (NAT).

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Маршрутизатор серии 806 рабочая Cisco КСИ выпуска 12.2 (2) IOS�

  • Маршрутизатор CM, действующий как мост

  • ПК, выполняющий Windows 2000, действующие как CPE

  • Система терминирования кабельных модемов (CMTS) uBR7246VXR

Примечание: Только конфигурации маршрутизатора Cisco 806 показывают в этом документе. Для получения дополнительной информации о настройке CMTS обратитесь к Примерам конфигурации Кабельной технологии и Техническим Примечаниям.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Схема сети

В настоящем документе используется следующая схема сети:

http://www.cisco.com/c/dam/en/us/support/docs/broadband-cable/cable-modems/19268-router-behind-cm-19268.gif

Конфигурации

Этот документ использует 806 конфигураций маршрутизатора:

806 конфигураций маршрутизатора
Building configuration...
Current configuration : 1673 bytes
!
version 12.2
no parser cache
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Router
!
logging rate-limit console 10 except errors
enable secret 5 $1$1m1W$uRyUMZQpUAp31C9OM2HQR.
!
username Router password 7 08325C5C00170247425D5506382E2523
username Cisco privilege 15 password 7
134146563C5D020B6F2B793C060703061E2A16706F7E62470C3416
ip subnet-zero
ip name-server 24.29.99.81
ip name-server 24.29.99.82
ip dhcp excluded-address 10.10.10.1 


!--- Issue the ip dhcp excluded-address command to exclude IP 
!--- addresses from being assigned by the DHCP server. This excludes 
!--- E0 IP address.

ip dhcp excluded-address 10.10.10.2
ip dhcp excluded-address 10.10.10.10
ip dhcp excluded-address 10.10.10.3
ip dhcp excluded-address 10.10.10.4
ip dhcp excluded-address 10.10.10.5
ip dhcp excluded-address 10.10.10.6
ip dhcp excluded-address 10.10.10.7
ip dhcp excluded-address 10.10.10.8
ip dhcp excluded-address 10.10.10.9
!
ip dhcp pool CLIENT 

!--- Configures a DHCP address pool.

import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 24.29.99.82
!
no ip dhcp-client network-discovery
lcp max-session-starts 0
!
!
!
interface Ethernet0 

!--- This interface connects to the internal network, including CPE.

ip address 10.10.10.1 255.255.255.0
ip nat inside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
interface Ethernet1 

!--- This interface connects to the same Ethernet segment as the CM.
 
ip address dhcp 

!--- This command allows the router to obtain IP address dynamically.

ip nat outside 

!--- IP NAT configuration.

no ip route-cache
no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload 

!--- IP NAT configuration.

ip classless
ip route 0.0.0.0 0.0.0.0 66.108.112.1

!--- IP address 66.108.112.1 is the next hop IP address, also called 
!--- the default gateway. Your Internet service provider (ISP) can tell you what IP address to 
!--- configure as the next hop address.

ip http server
!
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
line con 0
exec-timeout 120 0
stopbits 1
line vty 0 4
exec-timeout 30 0
login local
length 0
!
scheduler max-task-time 5000
end
Router#

                     

                      
                     

                     

Проверка

Чтобы проверить, что маршрутизатор получил IP-адрес на своем E1 Ethernet динамично, используйте команду show ip interface brief.

Router#show ip interface brief

Interface                  IP-Address      OK? Method Status Protocol
Ethernet0                  10.10.10.1      YES NVRAM  up    up
Ethernet1                  66.108.115.5    YES DHCP   up    up

Гарантируйте, что ваша таблица маршрутизации имеет корректные записи. Например, в этом показе, маршрут по умолчанию к 66.108.112.1. Когда маршрутизатор получает IP-адрес на Интерфейсе Ethernet, это установлено через процесс DHCP.

Router#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is 66.108.112.1 to network 0.0.0.0
66.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       66.0.0.0/8 is directly connected, Ethernet1
C       66.108.112.0/21 is directly connected, Ethernet1
10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Ethernet0
S*   0.0.0.0/0 [1/0] via 66.108.112.1

Устранение неполадок

Когда маршрутизатор связан позади CM, первая проблема, которая могла бы произойти, не получает IP-адрес динамично на Интерфейсе Ethernet маршрутизатора. Большинство интернет-провайдеров позволяет только один хост или ПК позади CM, Некоторые интернет-провайдеры назначают IP-адрес на ПК на основе имени хоста. Поэтому, если у вас есть маршрутизатор позади CM, тогда имя хоста для маршрутизатора, настроенного с помощью команды hostname, должно быть тем же именем хоста, данным интернет-провайдером.

Если маршрутизатор не получает IP-адрес динамично, первая вещь проверить состоит в том, если существует ip address dhcp команды настройки интерфейса. Эта команда находится под Интерфейсом Ethernet, связанным с CM. Команда была представлена в выпуске ПО IOS 12.1 (2) T.

Если команда ip address dhcp существует, но маршрутизатор позади CM все еще не получает IP-адрес, подключите ПК позади CM, чтобы обнаружить, если это получает IP-адрес. Это проверяет, что сервисы DHCP работают должным образом. Интернет-провайдеры, как правило, позволяют только один хост позади CM, поэтому подключая ПК позади количества CM как первый хост. Эта запись остается в базе данных ISP в течение 24 часов. Следовательно при соединении маршрутизатора позади CM интернет-провайдер думает, что маршрутизатор является вторым хостом и отклоняет его. Если это происходит, освободите IP-адрес своего ПК путем выполнения этих шагов на ПК Windows 2000:

  1. От меню Пуск выбирают Run.

  2. Введите cmd, тогда нажимают возврат каретки.

  3. В приглашении введите ipconfig/release.

  4. После выпуска IP-адреса ПК перезагрузите свой CM и попробуйте еще раз.

Если это не работает, необходимо вызвать интернет-провайдера и попросить, чтобы они очистили первую запись хоста на своем CMTS.

Другой метод должен настроить Интерфейс Ethernet маршрутизатора. Это соединяется с CM с MAC-адресом ПК с помощью адресной IEEE команды mac-address.

При помощи того же MAC-адреса на Интерфейсе Ethernet, который соединяется с CM как ПК, интернет-провайдер только учится об одном хосте и одном IP-адресе. ПК не становится отклоненным когда-то связанный позади маршрутизатора. NAT должен быть настроен на маршрутизаторе для принятия трансляций IP-адреса.

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

  • debug dhcp detail — Используйте команду debug dhcp detail для отображения информации об отладке DHCP. Это используется для устранения проблем, почему маршрутизатор Cisco был не в состоянии получать IP-адрес для Интерфейса Ethernet.

  • debug ip dhcp server [события] [связь] [пакет] — Использование команда debug ip dhcp server для отображения отладки Сервера DHCP. Это помогает определять, почему ПК, который связан с маршрутизатором, был не в состоянии получать IP-адрес.


Дополнительные сведения


Document ID: 19268