Голосовая связь и система унифицированных коммуникаций : Адаптеры для аналоговых телефонов Cisco серии ATA 180

Выбор конфигурации и устранение неисправностей для ATA 186 c привратниками Cisco IOS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (11 ноября 2015) | Отзыв


Содержание


Введение

Аналоговый телефонный адаптер Cisco Analog Telephone Adaptor (ATA) 186 является устройством сопряжения типа "телефонный аппарат - сеть Ethernet", который связывает обычный аналоговый телефон с телефонными сетями на базе IP. ATA 186 имеет два голосовых порта, которые могут только поддержать устаревшие аналоговые телефоны с тональным кнопочным набором. В отличие от обычной станции внешнего обмена (FXS) портируют, они не могут взаимодействоваться с PrivateBranch Exchange (PBX) (внутренняя автоматическая телефонная станция), потому что ATA 186 не может отослать цифры на этих портах. С данной конфигурацией вы можете использовать оба голосовых порта с разными адресами E.164 на каждом.

Предварительные условия

Требования

В данном документе предполагается, что читатель знаком с содержание документа "Базовая конфигурация Cisco ATA 186".

Эта конфигурация требует, чтобы ATA 186 был в версии 2.0 или позже, с помощью набора функций H.323.

Гарантируйте, что существует возможность подключения с помощью IP-адреса между ATA 186, шлюзом и сторожевыми устройствами. Кроме того, гарантируйте, что ATA 186 доступен через метод Web-сервера для дальнейшей конфигурации.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • ATA 186 с версией 2.12

  • Cisco 3640 с Cisco Выпуск ПО IOS� 12.1 как шлюз

  • Cisco 2600 с программным обеспечением Cisco IOS версии 12.2 как сторожевое устройство

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/19084/ata_gatekeeper_1.gif

Регистрация ATA 186 и Привратника

Следуйте этим инструкциям для регистрации ATA 186 в сторожевом устройстве.

  1. В Адресе web-браузера или поле Location, введите URL http://ip_address_of_ata/dev для доступа к окну конфигурации ATA 186, где ip_address_of_ata является IP-адрес ATA 186, вы регистрируетесь.

    В этом примере URL - http://172.16.104.117/dev. Появится окно настройки Cisco ATA 186.

    Примечание: Подчеркнутые поля являются важными сконфигурированными параметрами для этого сценария.

    /image/gif/paws/19084/ata_gatekeeper_2.gif

    IP-адресация может производиться статически или динамически, как объясняется в документе "Базовая конфигурация Cisco ATA 186". На предыдущем экране используется статический IP - адрес.

  2. В Окне конфигурации Cisco ATA 186 настройте эти поля:

    • UID0 и UID1 укажите E.164-адреса голосовых портов 0 и 1.

      Оба голосовых порта не могут иметь того же адреса E.164, поскольку ATA 186 не может искать, если один из портов занят. Если обоим голосовым портам назначат тот же адрес E.164, то вызов будет всегда передаваться первому голосовому порту. Если он занят, звонящему будет отправлен сигнал "занято".

    • RxCodec и TxCodec укажите идентификатор кодека.

      • G.723.1 — идентификатор кодека 0.

      • G.711a — идентификатор кодека 1.

      • G.711u — идентификатор кодека 2.

      • G.729a — идентификатор кодека 3.

      В конфигурации, показанной ниже, кодек G.729r8 используется на ATA 186 и на шлюзе.

    • LBRCodec — Настройте как 0 или 3, на основе выбранного кодека.

      • LBRC 0 — кодек G.723.1 доступен обоим портам FXS в любое время. Каждая линия может обслуживать два вызова G.723.1 без статуса конференц-связи. Поэтому до четырех вызовов G.723.1 могут быть поддержаны в Cisco ATA 186. Примером является ожидание вызова.

      • LBRC равняется 3 — G.729a доступен одному из двух портов FXS на обслуживание в порядке поступления основание. Если шлюз Cisco IOS настроен с кодеком G.729 по умолчанию, только один порт ATA 186 может использоваться. Чтобы препятствовать тому, чтобы повторный звонок отказал, настройте класс голосового кодека на шлюзе для согласования о повторном звонке с помощью кодека G.711. Для получения дальнейшей информации обратитесь к разделу Согласования кодека Кодеков Понимания: Сложность, Аппаратная поддержка, MOS и документ Согласования.

    • GKOrProxy — Настройте IP-адрес сторожевого устройства.

      Как только это сделано, что-либо, что набрано от голосовых портов ATA 186, передается сторожевому устройству.

  3. Нажмите кнопку Apply и затем повторно загрузите страницу.

    ATA 186 занимает 10 секунд для реконфигурирования себя.

Этими примерами являются соответствующие конфигурации для Сторожевого устройства Cisco IOS и шлюза:

С 2610 сторожевыми устройствами
interface Ethernet0/0
 ip addreinterface Ethernet0/0
 ip address 172.16.13.12 255.255.255.224
 half-duplex
 h323 interface
 h323 h323-id pro
 h323 gatekeeper ipaddr 172.16.13.12
 h323 t120 bypass
!
dial-peer cor custom
!
!
!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
no shutdown
!

С 3640 шлюзами
interface Ethernet0/0
 ip address 172.16.13.40 255.255.255.224
 half-duplex
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.13.33
ip http server
!
!
!
voice-port 3/0/0
!
voice-port 3/0/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 34
 port 3/0/0
!
dial-peer voice 2 pots
 destination-pattern 45
 port 3/0/1
!
dial-peer voice 100 pots
 destination-pattern 1234
 port 3/0/0
!
dial-peer voice 3000 voip
 destination-pattern 300.
 session target ras

!--- Dial-peer to send the calls to ATA.

!

Добавление функций безопасности

С выпуска 2.12 программного обеспечения ATA опции в этом разделе доступны для добавления безопасности.

Аутентификация оконечной точки в привратнике по идентификатору H.323 ID

Выполните эти действия для настройки ATA 186 для регистрации в ID H.323:

  1. Установите поле AutMethod в 0 (по умолчанию равняется 1).

    Шестнадцатеричное значение, которое должно быть настроено для этого поля, является 0x0.

  2. Установите Поле идентификатора пользователя для входа в 1.

  3. Настройте LoginID0 и LoginID1 с ID H.323 для ATA 186.

    ATA 186 регистрируется как два других терминала H.323, один для каждого порта.

Это - пример рабочей конфигурации для сторожевого устройства при использовании ATA с методом Аутентификации Caller ID H.323:

/image/gif/paws/19084/ata_gatekeeper_3.gif

С 2610 сторожевыми устройствами
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1

!--- Same as the LoginID0 and LoginID1 fields.

username atagw2
username 3640

!--- Same as the H.323 ID configured on the gateway.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security any

!--- Register after the H.323 ID or E.164 address is authenticated.

no shutdown
!

Аутентифицируйте оконечную точку в сторожевом устройстве с адресом E.164

Выполните эти действия для настройки ATA 186 для регистрации в адресе E.164:

  1. Установите поле AutMethod в 0 (по умолчанию равняется 1).

    Шестнадцатеричное значение, которое должно быть настроено для этого поля, является 0x0.

  2. Установите Поле идентификатора пользователя для входа в 0.

    ATA использует поля UID0 и UID1, которые будут аутентифицироваться сторожевым устройством.

Это - пример рабочей конфигурации для сторожевого устройства и шлюз при использовании ATA с методом Аутентификации Caller ID E.164:

С 2610 сторожевыми устройствами
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username 3001

!--- Same as the UID0.

username 3000

!--- Same as the UID1.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security any

!--- Register after the H.323 ID or E.164 address is authenticated.

no shutdown
!

Аутентифицируйте оконечную точку в сторожевом устройстве с ID H.323 и паролем

Выполните эти действия для настройки ATA 186 для регистрации в ID H.323 и пароле:

  1. Установите поле AutMethod в 1 (по умолчанию равняется 1).

    Шестнадцатеричное значение, которое должно быть настроено для этого поля, является 0x1. Это поле собирается указать, что ATA теперь ищет пароль.

  2. Установите Поле идентификатора пользователя для входа в 1.

  3. Настройте LoginID0 и LoginID1 с ID H.323 для ATA 186.

    ATA 186 регистрируется как два других терминала H.323, один для каждого порта.

  4. Настройте PWD0 и PWD1 с паролем для каждого порта.

    Примечание: ATA использует пароль для генерации маркера. Этот маркер передается сторожевому устройству для проверки подлинности.

  5. Настройте NTPIP с IP-адресом сервера Протокола NTP.

    Сторожевому устройству и ATA нужно было синхронизировать часы с тем же сервером NTP.

Примечание: Метка времени используется для генерации маркеров. Для получения дополнительной информации обратитесь к шлюзу к Сторожевому устройству (H.235) и Сторожевое устройство к Сторожевому устройству (IZCT) Руководство по поиску и устранению проблем Безопасности.

Это - пример рабочей конфигурации для сторожевого устройства и шлюз при использовании ATA с ID H.323 и методом проверки подлинности с помощью пароля:

С 2610 сторожевыми устройствами
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1 password cisco

!--- Same as the LoginID0 and PWD0 fields.

username atagw2 password cisco

!--- Same as the LoginID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security token required-for registration

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

Примечание: Для получения дополнительной информации о безопасности сторожевого устройства обратитесь к шлюзу к Сторожевому устройству (H.235) и Сторожевое устройство к Сторожевому устройству (IZCT) Руководство по поиску и устранению проблем Безопасности.

Аутентифицируйте оконечную точку в сторожевом устройстве с адресом E.164 и паролем

Выполните эти действия для настройки ATA 186 для регистрации в ID E.164 и пароле:

  1. Установите поле AutMethod в 1 (по умолчанию равняется 1).

    Шестнадцатеричное значение, которое должно быть настроено для этого поля, является 0x0. Это поле собирается указать, что ATA будет теперь искать пароль.

  2. Установите Поле идентификатора пользователя для входа в 0.

  3. Настройте UID0 и UID1 с ID E.164 для ATA 186.

    ATA 186 регистрируется как два других терминала H.323, один для каждого порта.

  4. Настройте PWD0 и PWD1 с паролем для каждого порта.

    Примечание: ATA использует пароль для генерации маркера. Этот маркер передается сторожевому устройству для проверки подлинности.

  5. Настройте NTPIP с IP-адресом сервера NTP.

    Сторожевому устройству и ATA нужно было синхронизировать часы с тем же сервером NTP.

Примечание: Метка времени используется для генерации маркеров. Для получения дополнительной информации обратитесь к шлюзу к Сторожевому устройству (H.235) и Сторожевое устройство к Сторожевому устройству (IZCT) Руководство по поиску и устранению проблем Безопасности.

Это - пример рабочей конфигурации для сторожевого устройства и шлюз при использовании ATA с ID E.164 и методом проверки подлинности с помощью пароля:

С 2610 сторожевыми устройствами
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username 3001 password cisco

!--- Same as the UID0 and PWD0 fields.

username 3000 password cisco


!--- Same as the UID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security token required-for registration

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

Примечание: Для получения дополнительной информации о безопасности сторожевого устройства обратитесь к шлюзу к Сторожевому устройству (H.235) и Сторожевое устройство к Сторожевому устройству (IZCT) Руководство по поиску и устранению проблем Безопасности.

Аутентифицируйте оконечную точку в сторожевом устройстве с ID H.323 и паролем Использование разделителя

Выполните эти действия для настройки ATA 186 для регистрации в ID H.323 и пароле:

  1. Установите поле AutMethod в 1 (по умолчанию равняется 1).

    Шестнадцатеричное значение, настроенное для этого поля, является 0x1. Это поле собирается указать, что ATA теперь ищет пароль.

  2. Установите Поле идентификатора пользователя для входа в 1.

  3. Настройте LoginID0 и LoginID1 с ID H.323, придерживавшимися разделителем и паролем для ATA 186.

    Например, LoginID0 является atagw1=cisco.

    ATA 186 регистрируется как два других терминала H.323, один для каждого порта.

    Примечание: ATA использует пароль для генерации маркера. Этот маркер передается сторожевому устройству для проверки подлинности.

  4. Настройте NTPIP с IP-адресом сервера NTP.

    Сторожевому устройству и ATA нужно было синхронизировать часы с тем же сервером NTP.

Примечание: Метка времени используется для генерации маркеров. Для получения дополнительной информации обратитесь к шлюзу к Сторожевому устройству (H.235) и Сторожевое устройство к Сторожевому устройству (IZCT) Руководство по поиску и устранению проблем Безопасности.

Это - пример рабочей конфигурации для сторожевого устройства и шлюз при использовании ATA с ID H.323 и методом проверки подлинности с помощью пароля с помощью разделителя:

С 2610 сторожевыми устройствами
aaa authentication login default local
aaa authentication login cisco none
aaa authentication login h323 local
aaa session-id common
enable password ww
!
username atagw1 password cisco

!--- Same as the LoginID0 and PWD0 fields.

username atagw2 password cisco

!--- Same as the LoginID1 and PWD1 fields.

!
gatekeeper
 zone local gk2 cisco.com 172.16.13.12
security h323-id
security password separator =

!--- Register after the H.323 ID or E.164 address and token is authenticated.

no shutdown
!

Примечание: Для получения дополнительной информации о безопасности сторожевого устройства обратитесь к шлюзу к Сторожевому устройству (H.235) и Сторожевое устройство к Сторожевому устройству (IZCT) Руководство по поиску и устранению проблем Безопасности.

Проверка

Пример в этом разделе показывает регистрацию конечных точек гэйткипера.

Для проверки конфигурации выполните команду show gatekeeper endpoint.

                            GATEKEEPER ENDPOINT
REGISTRATION

CallSignalAddr  Port  RASSignalAddr  Port  Zone Name  Type     Flags
--------------  ----  -------------  ----  ---------  ----     -----
172.16.13.40    1720  172.16.13.40   50923    gk2     VOIP-GW  E164-ID: 1234
                                                               H323-ID: 3640
172.16.13.43    1720  172.16.13.43   58400    gk2     VOIP-GW  H323-ID: 3660-2
172.16.104.117  1720  172.69.85.90   1719     gk2     TERM     E164-ID: 3000
172.16.104.117  1721  172.69.85.90   1739     gk2     TERM     E164-ID: 3001
Total number of active registrations=3

Примечание: ATA 186 регистрируется как терминал H.323 (УСЛОВИЕ) и не как шлюз H.323. Это сделано сознательно так, чтобы только вызовы, предназначенные для ATA 186, были переданы ему.

Примечание: У вас не может быть адреса в поле шлюза ATA. Вы не можете настроить ATA 186 для работы со сторожевым устройством, а также шлюзом.

Устранение неполадок

В данном разделе представлена информация по устранению неполадок конфигурации.

ATA 186 не предоставляет тональный сигнал готовности к набору номера, если это успешно не зарегистрировано в сторожевом устройстве. Если ATA 186 не регистрируется в сторожевом устройстве, проверьте эти элементы:

  • Возможность подключения с помощью IP-адреса существует между ATA 186 и сторожевым устройством.

  • Поля UID0 и UID1 ATA 186 настроены правильно.

    • Если поля UID установлены в 0, ATA 186 не пытается зарегистрироваться в сторожевом устройстве.

    • По крайней мере, поле UID0 должно быть ненулевым значением для ATA 186 для начала процесса регистрации.

    • Если и порты ATA 186 (UID0 и UID1) имеют ненулевые адреса E.164, ATA 186 пытается зарегистрироваться в обоих портах. Даже если один из портов неспособен зарегистрироваться, ATA 186 не предоставляет тональный сигнал готовности к набору номера.

  • Сторожевое устройство настроено правильно.

    • Если сторожевое устройство настроено с префиксом локальной зоны, адрес E.164 ATA 186 должен быть включен.

    • Если безопасность настроена на сторожевом устройстве, ATA 186 должен быть настроен соответственно.

Кроме того, проверьте, что поле UseSIP установлено в 0. Это необходимо для настройки ATA 186 в режиме H.323. Если поле UseSIP установлено в 1, ATA 186 не передает запрос регистрации к сторожевому устройству.

Устраните неполадки сторожевого устройства

Когда безопасность будет настроена, выполните команду debug aaa authentication.

Если никакая безопасность не настроена, выполните команду debug ras .

Примечание: ATA 186 регистрируется для этих двух голосовых портов отдельно. ATA 186, поэтому, получает аутентифицируемые вдвое более другие терминалы H.323, чем в этой отладке:

4w4d: AAA/AUTHEN/CONT (3800768902): continue_login (user='atagw1')
4w4d: AAA/AUTHEN (3800768902): status = GETPASS
4w4d: AAA/AUTHEN/CONT (3800768902): Method=LOCAL
4w4d: AAA/AUTHEN (3800768902): status = PASS
4w4d: AAA: parse name=<no string> idb type=-1    tty=-1
4w4d: AAA/MEMORY: create_user (0x83149EFC) user='atagw2'ruser='NULL' port='NULL'
      rem_addr='NULL' authen_type=ASCII service=LOGIN priv=0 initial_task_id='0'
4w4d: AAA/AUTHEN/START (294225678): port='' list='h323' action=LOGIN service=LOGIN
4w4d: AAA/AUTHEN/START (294225678): found list h323
4w4d: AAA/AUTHEN/START (294225678): Method=LOCAL
4w4d: AAA/AUTHEN (294225678): status = GETPASS
4w4d: AAA/H323: Password:
4w4d: AAA/AUTHEN/CONT (294225678): continue_login (user='atagw2')
4w4d: AAA/AUTHEN (294225678): status = GETPASS
4w4d: AAA/AUTHEN/CONT (294225678): Method=LOCAL
4w4d: AAA/AUTHEN (294225678): status = PASS
4w4d: AAA: parse name=<no string> idb type=-1    tty=-1
4w4d: AAA/MEMORY: create_user (0x831910C0) user='3660'  ruser='NULL' port='NULL'
      rem_addr='NULL' authen_type=ASCII service=LOGIN priv=0 initial_task_id='0

Для большего количества примеров устранения проблем обратитесь к Устранению проблем Проблем сторожевого устройства.

Устраните неполадки ATA 186

Когда вы работаете со сторожевыми устройствами от стороннего производителя и шлюзами, средство устранения проблем на ATA 186 очень полезно. Для включения средства устранения проблем ATA 186 выполните эти действия:

  1. В поле ATA Nprintf настройте IP-адрес ПК, который находится в той же подсети как ATA 186.

  2. После адреса должен быть указан порт 9001.

  3. В командной строке DOS на ПК выполните программу preserv.exe.

Можно загрузить программу preserv.exe от Центра ПО Cisco (только зарегистрированные клиенты).

Программа preserv.exe включена в последний Файл архива zip выпуска ПО ATA 186.

Типичные данные отладки для вызовов с модуля ATA 186

D:\Documents and Settings\sshafiqu\My Documents\voice\ata>prserv.exe
GK<-1: KPA-RRQ:300 sec
GK->1: RCF:TTL 300

!--- ATA was reset after the gatekeeper configuration was added.

WStop:0
Wed Feb 06 19:06:54 2002 Hello from 171.69.85.90(0)
Build 1109a: v2.12 ata186
Successfully Registered with the Gatekeeper
GK zone<gk2>172.16.13.12: 3000
GK zone:gk2
0x13e138 delayed RRQ: 48 ticks: 300
GK zone<gk2>172.16.13.12: 3001
GK zone:gk2
0x141e58 delayed RRQ: 56 ticks: 300
BMK : gk2
GK<-1: KPA-RRQ:300 sec
BMK : gk2
GK<-0: KPA-RRQ:300 sec
GK->1: RCF:TTL 300
GK->0: RCF:TTL 300
SCC->(0 0) <cmd 0>
3000 active @0xab45555a (GK @0xac100d0c)

!--- Call made from voice port 0.

[0]DTMF 1
[0]DTMF 2
[0]DTMF 3
[0]DTMF 4
[0]DTMF #
Calling 1234
SCC->(0 0) <cmd 16>
CLIP\
\SCC->(0 0) <cmd 2>
\<0 0> dial<1234>
GK<-0: ARQ: 0
GK->0: ACF:0:direct call
IRR in 240 sec
CallRasCallBack: 1 33e15eb 33e206b 33e39b0
Connect to <0xac100d28 1720>>..
>>>>>>>> TX CALLER ID : 0x1          0x80 6
Q931<-0:Setup:CRV 25006
Q931->0:Proceeding
Connect H245...
H245 TCP conn ac100d28 11006
CESE/MSDSE start:<0 0 0 0>
capSize = 3
H245->0:Cese
RemoteInputCap <15 5>
RemoteInputCap <15 4>
RemoteInputCap <15 1>
RemoteInputCap <4 11>
MODE FRAME : 11 2
RemoteAudioCap <4 10>
Capability set accepted
H245->0:MSD: <rn tt> = <0x269c 60>
H245->0:CeseAck
H245->0:MsdAck
h323.c 1837: cstate : 3
->H245<0> OLC
H245<-0:LcseOpen
set TX audio to G729/G729A 2 fpp
SetG723Mode: 2 0
H245->0:LcseOpen
H245->0:OLC mode 10
remote OpenLogicalReq G711/G729(10) : 2 fpp
OpenRtpRxPort(0,0x0,4000):14
RTP Rx Init: 0, 0
RTP->0:<0xab45555a 4000>
H245->0:LcseOpenAck
RTP<-0:<0xac100d28 17304>
[0]Enable encoder 18
RTP TX[0]:SSRC_ID = 4af964c0
RTP Tx Init: 0, 0
[0]DPKT 1st: 861812319 861812079, pt 18
Enable LEC adapt [0]=1
H323Dispatcher : 3 3
[0]Received pi=8 in q931
Q931->0:Progress
Q931->0:Connect
SCC:ev=12[0:0] 3 0
Q931->0:ReleaseComplete: reason 16, tone = 13
H245<-0:EndSessionCmd 1
0: Close RTPRX
write TCP err : 13 -33
[0:0]Rel LBRC Res
Q931<-*:ReleaseComplete

!--- ATA side hangs up the call.

write TCP err : 12 -33
GK<-0: DRQ:0

!--- Disconnect request sent by ATA.

SCC:ev=13[0:0] 4 0
[0:0]SCC: Disconnected
GK->0: DCF

!--- Disconnect confirm received.

SCC->(0 0) <cmd 1>
[0]MPT mode 0

Нет тонового соединения пример отладки ATA

Обоим голосовым портам нужен уникальный адрес E.164, иначе ATA получает Отклонение от сторожевого устройства. В это время вы будете видеть, что ATA 186 зарегистрирован единогласно порт как терминал H.323, но будет нет тонового соединения.

K<-0: GRQ
BMK : gk2
GK->0: GCF:GK@0xac100d0c-1719
BMK : gk2
Secured RRQ
GK<-0: RRQ
GK->0:RRJ: reason 4

Дополнительные сведения


Document ID: 19084