Протокол IP : Протокол EIGRP

Предотвращение дублирования идентификаторов маршрутизаторов EIGRP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Двойные идентификаторы маршрутизаторов Протокола EIGRP могут вызвать проблемы с перераспределением Внешних маршрутов eigrp. Этот документ объясняет проблему и предоставляет правильную конфигурацию для предотвращения его.

Идентификатор маршрутизатора в протоколе EIGRP обычно выбирается аналогично протоколу OSPF (Open Shortest Path First). Наиболее высокое значение IP-адреса, приписанного интерфейсу обратной связи, выбирается как ID маршрутизатора. Если нет никаких настроенных адресов обратной связи, самый высокий IP-адрес, назначенный на любой другой интерфейс, выбран в качестве идентификатора маршрутизатора.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Эта конфигурация разрабатывалась и проверялась с помощью Cisco Выпуск ПО IOS� 12.2 (10b).

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Проблема

Проблема, с которой встречаются с перераспределенными маршрутами из-за присутствия маршрутизаторов с двойными ID маршрутизатора EIGRP, может быть понята с помощью этой сетевой установки.

Схема сети

eigrp-dup-id.jpg

Конфигурации

Маршрутизатор 4
interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 10.10.10.10 255.255.255.0

!

interface Ethernet0

 ip address 172.16.3.4 255.255.255.0

!

router rip

 version 2

 network 10.0.0.0

 network 172.16.0.0

Маршрутизатор 3
interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Ethernet0

 ip address 172.16.3.3 255.255.255.0

 ip pim sparse-dense-mode

!

interface Serial1

 ip address 172.16.13.3 255.255.255.0

 clockrate 4000000

!

router eigrp 7

 redistribute rip metric 1 1 1 1 1

 network 172.16.0.0

!

router rip

 version 2

 network 172.16.0.0

Маршрутизатор 1
interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface Serial1

 ip address 172.16.13.1 255.255.255.0

 no ip mroute-cache

!

router eigrp 7

 network 172.16.0.0

 auto-summary

 no eigrp log-neighbor-changes

Команды "show"

Как ранее показано, Маршрутизатор 3 перераспределяет маршруты Протокола RIP в EIGRP. Это - 3 таблицы маршрутизации и таблица топологии EIGRP.

Router-3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
R    10.0.0.0/8 [120/1] via 172.16.3.4, 00:00:25, Ethernet0 
!--- Router 3 sees network 10.0.0.0.

     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
C       172.16.3.0 is directly connected, Ethernet0
router-3#


router-3#show ip eigrp topology 10.0.0.0 255.0.0.0
IP-EIGRP (AS 7): topology entry for 10.0.0.0/8
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2560000256
  Routing Descriptor Blocks:
  0.0.0.0, from Redistributed, Send flag is 0x0
      Composite metric is (2560000256/0), Route is External
      Vector metric:
        Minimum bandwidth is 1 Kbit
        Total delay is 10 microseconds
        Reliability is 1/255
        Load is 1/255
        Minimum MTU is 1
        Hop count is 0
      External data:
        Originating router is 2.2.2.2 (this system)
!--- Shows that Router 3 is the originating router of the external route.

        AS number of route is 0
        External protocol is RIP, external metric is 1
        Administrator tag is 0 (0x00000000)
router-3#

От предыдущих выходных данных вы видите, что Маршрутизатор 3 учился о сети 10.0.0.0 через RIP. Через перераспределение маршрут был введен в таблицу топологии EIGRP как внешний маршрут. Также видно, что маршрутизатор 3 является исходящим маршрутизатором внешнего маршрута (его идентификатор EIGRP-маршрутизатора равен 2.2.2.2).

Так как Маршрутизатор 3, кажется, перераспределяет внешний маршрут, он, как ожидают, будет видеть его в таблице маршрутизации Маршрутизатора 1. Это - показ таблицы маршрутизации и таблицы топологии EIGRP для Маршрутизатора 1.

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 3 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:31:59, Serial1
router-1#


router-1# show ip eigrp topology
IP-EIGRP Topology Table for AS(7)/ID(2.2.2.2)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.16.13.0/24, 1 successors, FD is 2169856
         via Connected, Serial1
P 172.16.3.0/24, 1 successors, FD is 2195456
         via 172.16.13.3 (2195456/281600), Serial1
router-1#

От предыдущих выходных данных вы видите, что ожидаемый маршрут 10.0.0.0/8 не находится в таблице маршрутизации или таблице топологии EIGRP Маршрутизатора 1. Возможной причиной является одинаковый EIGRP идентификатор маршрутизатора у маршрутизаторов Routers 1 и 3. В Cisco IOS Software Release 12.0 (2) и позднее Cisco делает запись дублирований идентификатора маршрутизатора в журнале Событий EIGRP, который можно просмотреть с командой show ip eigrp events. Это - выходные данные этого для Маршрутизатора 1:

router-1 #show ip eigrp events 
Event information for AS 7:
1    18:06:15.863 Change queue emptied, entries: 1
2    18:06:15.863 Ignored route, metric: 10.0.0.0 2560512256
3    18:06:15.863 Ignored route, neighbor info: 172.16.13.3 Serial2
4    18:06:15.863 Ignored route, dup router: 2.2.2.2


!--- Output suppressed.

От предыдущих выходных данных вы видите, что дублирование идентификатора маршрутизатора является причиной, что Маршрутизатор 1 не принимает маршрут от Маршрутизатора 3.

Решение

Решение состоит в том, чтобы изменить идентификатор маршрутизатора на одном из маршрутизаторов путем изменения самого высокого IP-адреса на интерфейсе обратной связи. Если вы ause программное обеспечение Cisco IOS версии 12.1(6) или позже, можно также использовать eigrp router-id <router-id> подкоманда маршрутизатора для изменения идентификатора маршрутизатора. В данном примере изменен идентификатор маршрутизатора Router 1.

router-1(config)#router eigrp 7 
router-1(config-router)#eigrp router-id 3.3.3.3

Примечание: Команда clear ip eigrp <Autonomous System проблемы после изменения ID маршрутизатора EIGRP.

Внешний маршрут теперь появляется в таблице маршрутизации как показано здесь.

router-1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, IA - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     172.16.0.0/24 is subnetted, 2 subnets
C       172.16.13.0 is directly connected, Serial1
D       172.16.3.0 [90/2195456] via 172.16.13.3, 00:00:00, Serial1
D EX 10.0.0.0/8 [170/2560512256] via 172.16.13.3, 00:00:00, Serial1
router-1# 

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 18685