Качество обслуживания (QoS) : Политики QoS

Frame Relay Traffic Shaping с распределенным QoS в маршрутизаторах Cisco серии 7500

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (23 апреля 2015) | Отзыв


Содержание


Введение

Этот документ разъясняет различия между приложением формирования трафика к Интерфейсам Frame Relay на маршрутизаторах Cisco серии 7500 с Многоцелевыми интерфейсными процессорами (VIP) и на других платформах. Другие платформы включают series маршрутизаторы Cisco 7200, 3600 и 2600.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

С Cisco Выпуск ПО IOS� 12.1 (5) T, политика Качества обслуживания (QoS) должна работать в распределенном режиме на VIP; Процессор переключателей маршрута (RSP) - базирующееся QoS больше не поддерживается. Таким образом необходимо использовать команду формы и другие команды Интерфейса командной строки Модульного QoS (MQC) для осуществления Distributed Traffic Shaping (dTS) для Интерфейсов Frame Relay на VIP на Cisco серии 7500. DTS комбинирует Generic Traffic Shaping (GTS) и Frame Relay Traffic Shaping (Frame Relay TS). Обратитесь к Distributed Traffic Shaping Настройки для примера конфигурации.

Эта таблица разъясняет, как настроить Frame Relay TS, который зависит от платформы:

Серия 7500 Платформы 7200, 3600, 2600 и другие Non-VIP
Поддерживаемые механизмы управления DTS Frame Relay TS
Команда конфигурирования команда shape в карте политики команда frame-relay traffic-shaping на главном интерфейсе, команды конфигурирования map-class для указания параметров формирования
Требует dCEF1 Да (проверка с помощью команды show cef linecard).) Нет

1 dCEF = Distributed Cisco Express Forwarding

Примечание: На Cisco серии 7500 возможность настроить Frame Relay теперь заблокирован TS через команду frame-relay traffic-shaping, потому что Frame Relay TS выполняет только RSP в режиме нераспространения. С dCEF и Frame Relay TS, смежность "избыточного направления" CEF заставляет RSP быстро коммутировать все пакеты, который является субоптимальным для максимальной скорости переадресации.

Порядок действий для настройки

Используйте эти шаги для настройки DTS на на основе VIP Интерфейсах Frame Relay:

  1. Включите dCEF с этой командой:

    router(config)# ip cef distributed
    
  2. Гарантируйте, что Интерфейс Frame Relay включен для распределенной коммутации.

    router(config-if)# interface serial 8/0/0 
    router(config-if)# ip route-cache distributed
    
    router# show ip interface serial 8/0/0 
    Serial8/0/0 is up, line protocol is up 
      Internet address is 24.0.0.2/24 
      Broadcast address is 255.255.255.255 
     
    !--- Output suppressed.
     
      ICMP redirects are always sent 
      ICMP unreachables are always sent 
      ICMP mask replies are never sent 
      IP fast switching is enabled 
      IP fast switching on the same interface is disabled 
      IP Flow switching is disabled 
      IP CEF switching is enabled 
      IP Distributed switching is enabled 
      IP Fast switching turbo vector 
      IP CEF switching with tag imposition turbo vector 
      IP multicast fast switching is enabled 
      IP multicast distributed fast switching is disabled 
      IP route-cache flags are Fast, Distributed, CEF 
      Router Discovery is disabled 
      IP output packet accounting is disabled
  3. Создайте политику обслуживания и примените ее к классу сопоставления.

    Можно внедрить одну из этой политики:

    Примечание: В то время как программное обеспечение Cisco IOS версии 12.1(2)T представило поддержку организации очереди низкой задержки (LLQ) на платформах кроме Cisco серии 7500, распределенный LLQ (dLLQ) был представлен в программном обеспечении Cisco IOS версии 12.1(5)T на VIP. Версия для распространения улучшает производительность этой функции. Можно определить уникальную служебную политику для каждого идентификатора канала связи (DLCI). Вы не должны использовать класс сопоставления. Можно применить команду service-policy непосредственно к подинтерфейсу или DLCI. Однако настройте dLLQ в классе сопоставления.

  4. Проверьте нормальную работу политики обслуживания с этими командами:

    • show policy-map interface

    • команда show interface shape

    • show vip full-qos

    Пример конфигурации DTS с иерархической политикой
    ip cef distributed 
    ! 
    class-map 1 
      match <> 
      
    !--- Define match-on criteria.
     
    class-map 2 
      match <> 
      
    !--- Define match-on criteria.
     
    ! 
    policy-map CBWFQ 
      class 1 
        bandwidth <>  
        
    !--- Define the value in kbps or percent.
     
      class 2 
        priority <>  
        
    !--- Define the value in kbps or percent.
     
    ! 
    policy-map SHAPE 
       class class-default 
        shape average   
        service-policy CBWFQ 
    ! 
    int s0/0 
      encapsulation frame-relay 
      ip route-cache distributed 
    
    !--- Do not configure frame-relay traffic-shaping.
    
    ! 
    int s0/0.1 point-to-point 
      ip address a.b.c.d 
      frame-relay interface-dlci xxx 
       class cisco 
    ! 
    map-class frame-relay cisco 
      service-policy output SHAPE

FRF.12 и DTS

Cisco IOS Software Release 12.1(5)T впервые содержало распределенную версию фрагментации Frame Relay, FRF.12. При применении распределенного FRF.12 к Интерфейсу Frame Relay необходимо определить класс сопоставления и применить политику обслуживания под классом сопоставления. При попытке настроить класс сопоставления с политикой обслуживания, примененной непосредственно к интерфейсу, отчеты маршрутизатора это сообщение об ошибках с включенной консолью регистрации:

Frame Relay fragmentation works with dTS only. 
Please remove traffic-shaping from the interface serial 1/0/0

Конфигурация в этом разделе и командах проверки конфигурации была протестирована на маршрутизаторе Cisco серии 7500, который выполняет Cisco IOS Software Release 12.2 (5) T на RSP 8.

Примечание: Обратитесь к VoIP over Frame Relay с Качеством обслуживания (Фрагментация, Формирование трафика, LLQ / IP RTP Priority) для получения дополнительной информации о выборе значений фрагментации.

Пример конфигурации DTS и FRF.12
interface Ethernet4/1/3 
 ip address 10.122.3.206 255.255.255.0 
! 
interface Serial5/0/0:0 
 no ip address 
 encapsulation frame-relay 
 load-interval 30 
 no fair-queue 

!--- Do not configure frame-relay traffic-shaping.

! 
interface Serial5/0/0:0.1 point-to-point 
 ip address 10.1.1.2 255.255.255.0 
 frame-relay interface-dlci 16  
 class test 
 frame-relay ip rtp header-compression 
! 
map-class frame-relay test 
 no frame-relay adaptive-shaping 
 service-policy output llq-shape 
 frame-relay fragment 120 

!--- Apply the frame-relay fragment command to the  
!--- Frame Relay map class.

 access-list 101 permit udp any range 16384 32767 any  range 16384 32767

MS-7507-8A# show ip rtp head 
RTP/UDP/IP header compression statistics: 
DLCI 16 Link/Destination info: point-to-point dlci 
Interface Serial5/0/0:0: 
Distributed fast switched: 
4 seconds since line card sent last stats update 
Rcvd: 105475 total, 105472 compressed, 0 errors 
0 dropped, 0 buffer copies, 0 buffer failures 
Sent: 99451 total, 99447 compressed,  
3776208 bytes saved, 2187963 bytes sent 
2.72 efficiency improvement factor 
Connect: 256 rx slots, 256 tx slots,  
0 long searches, 3 misses 0 collisions, 0 negative cache hits 
99% hit ratio, five minute miss rate 0 misses/sec, 0 max 

MS-7507-8A# show policy-map  
Policy Map llq-shape 
 Class class-default 
  shape peak 256000 1024 1024 
  service-policy llq 
Policy Map llq 
 Class voip 
  priority percent 50 

MS-7507-8A# show policy-map interface s 5/0/0:0.1 
Serial5/0/0:0.1: DLCI 16 - 
Service-policy output: llq-shape 
  queue stats for all priority classes: 
  queue size 0, queue limit 32 
  packets output 147008, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 
 Class-map: class-default (match-any) 
  148237 packets, 10393582 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: any  
   queue size 0, queue limit 64 
   packets output 149563, packet drops 0 
   tail/random drops 0, no buffer drops 0, other drops 0 
  Shape: cir 256000, Bc 1024, Be 1024 
   lower bound cir 0, adapt to fecn 0 
   output bytes 6972057, shape rate 10000 bps 
Service-policy : llq 
  Class-map: voip (match-all) 
  146701 packets, 10325334 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: access-group 101 
  Priority: 50% (128 kbps), burst bytes 3200, b/w  
  exceed drops: 0 
  Class-map: class-default (match-any) 
  1536 packets, 68248 bytes 
  30 second offered rate 0 bps, drop rate 0 bps 
  Match: any  
  queue size 0, queue limit 32 
  packets output 2555, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 

MS-7507-8A# show frame pvc 16 
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) 
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 
input pkts 3036327   output pkts 199453 
in bytes 198958363  
out bytes 17271661   dropped pkts 0   in FECN pkts 0  
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0  
in DE pkts 0         out DE pkts 0  
out bcast pkts 1071  out bcast bytes 371448  
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 35000 bits/sec, 50 packets/sec 
pvc create time 17:51:42, last time pvc status changed 17:50:53 
fragment type end-to-end fragment size 120  

MS-7507-8A# show interface shape 
Serial5/0/0:0 nobuffer drop 0 
Serial5/0/0:0.1(class 0): 
cir 256000, Bc 1024, Be 1024 
lower bound cir 0, adapt to fecn 0 
packets output 152104, bytes output 6985505 
queue limit 64, queue size 0, drops 0 
last clear = 16:58:59 ago, shape rate = 10000 bps

MS-7507-8A# show ip rtp head 
RTP/UDP/IP header compression statistics: 
DLCI 16 Link/Destination info: point-to-point dlci 
Interface Serial5/0/0:0: 
Distributed fast switched: 
4 seconds since line card sent last stats update 
Rcvd: 105475 total, 105472 compressed, 0 errors 
0 dropped, 0 buffer copies, 0 buffer failures 
Sent: 99451 total, 99447 compressed,  
3776208 bytes saved, 2187963 bytes sent 
2.72 efficiency improvement factor 
Connect: 256 rx slots, 256 tx slots,  
0 long searches, 3 misses 0 collisions, 0 negative cache hits 
99% hit ratio, five minute miss rate 0 misses/sec, 0 max 

MS-7507-8A# show policy-map  
Policy Map llq-shape 
 Class class-default 
  shape peak 256000 1024 1024 
  service-policy llq 
Policy Map llq 
 Class voip 
  priority percent 50 

MS-7507-8A# show policy-map interface s 5/0/0:0.1 
Serial5/0/0:0.1: DLCI 16 - 
Service-policy output: llq-shape 
  queue stats for all priority classes: 
  queue size 0, queue limit 32 
  packets output 147008, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 
 Class-map: class-default (match-any) 
  148237 packets, 10393582 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: any  
   queue size 0, queue limit 64 
   packets output 149563, packet drops 0 
   tail/random drops 0, no buffer drops 0, other drops 0 
  Shape: cir 256000, Bc 1024, Be 1024 
   lower bound cir 0, adapt to fecn 0 
   output bytes 6972057, shape rate 10000 bps 
Service-policy : llq 
  Class-map: voip (match-all) 
  146701 packets, 10325334 bytes 
  30 second offered rate 24000 bps, drop rate 0 bps 
  Match: access-group 101 
  Priority: 50% (128 kbps), burst bytes 3200, b/w  
  exceed drops: 0 
  Class-map: class-default (match-any) 
  1536 packets, 68248 bytes 
  30 second offered rate 0 bps, drop rate 0 bps 
  Match: any  
  queue size 0, queue limit 32 
  packets output 2555, packet drops 0 
  tail/random drops 0, no buffer drops 0, other drops 0 

MS-7507-8A# show frame pvc 16 
PVC Statistics for interface Serial5/0/0:0 (Frame Relay DTE) 
DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial5/0/0:0.1 
input pkts 3036327   output pkts 199453 
in bytes 198958363  
out bytes 17271661   dropped pkts 0   in FECN pkts 0  
in BECN pkts 0       out FECN pkts 0  out BECN pkts 0  
in DE pkts 0         out DE pkts 0  
out bcast pkts 1071  out bcast bytes 371448  
5 minute input rate 0 bits/sec, 0 packets/sec 
5 minute output rate 35000 bits/sec, 50 packets/sec 
pvc create time 17:51:42, last time pvc status changed 17:50:53 
fragment type end-to-end fragment size 120 

MS-7507-8A# show interface shape 
Serial5/0/0:0 nobuffer drop 0 
Serial5/0/0:0.1(class 0): 
cir 256000, Bc 1024, Be 1024 
lower bound cir 0, adapt to fecn 0 
packets output 152104, bytes output 6985505 
queue limit 64, queue size 0, drops 0 
last clear = 16:58:59 ago, shape rate = 10000 bps

Известные проблемы

При тихом использовании Cisco IOS Software Release 12.1E интерфейс VIP, который настроен с Инкапсуляцией Frame Relay, может завершиться катастрофическим отказом с ошибкой шины. В то время как интерфейс передает трафик, этот катастрофический отказ происходит при применении политики обслуживания. Обходной путь должен остановить весь фоновый трафик перед обновлением политики обслуживания. Или можно обновить к программному обеспечению Cisco IOS версии 12.2 или позже.

Для получения дополнительной информации обратитесь к странице Cisco Tools & Resources.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 18660