Технологии LRE и xDSL : Поддержка асимметричных цифровых абонентских линий (ADSL)

Руководство по настройке, поиску и устранению неполадок маршрутизатора Cisco DSL Router – Пошаговая настройка режима маршрутизации RFC1483 с одним статическим IP-адресом

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Интернет-провайдер (ISP) назначил одиночный статический открытый IP - адрес на маршрутизатор Cisco DSL.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Процедуры конфигурации

Важно: Прежде чем вы начнете, закроете все программы на ПК, который мог бы контролировать COM - порт. Устройства, такие как PDA и цифровые камеры часто размещают программы в панели задач, которые представляют COM - порт, неприменимый для конфигурации маршрутизатора Cisco DSL.

Подключите маршрутизатор Cisco DSL и ПК

Консольное соединение сделано с витым кабелем и подключает консольный порт маршрутизатора Cisco DSL к COM - порту на ПК. Консольный кабель, который включен с маршрутизатором Cisco DSL, является плоским голубым кабелем. Для получения дополнительной информации по схемам расположения выводов витого кабеля, или схемам расположения выводов RJ-45 на конвертер DB9, обратитесь к Руководству по разводке кабелей для Портов AUX и Консоли.

  1. Подключите разъём RJ-45 на одном конце кабеля Консоли Cisco к консольному порту маршрутизатора Cisco DSL.

  2. Подключите разъём RJ-45 в другом конце консольного кабеля к RJ-45 к преобразователю DB9.

  3. Подключите разъём DB9 с открытым COM - портом на ПК.

Включите и настройте HyperTerminal

Выполните следующие действия:

  1. Запустите программу Гипертерминала на ПК.

  2. Запустите сессию вашего HyperTerminal.

    1. Назначьте название к сеансу и нажмите OK.

    2. В окне Connect To нажмите Cancel.

    3. Выберите File> Properties.

    4. Из окна Properties перейдите к списку Connect Using и выберите COM-порт, где вы подключаете конец DB9 консольного кабеля.

    5. В окне Properties нажмите Configure и заполните эти значения:

      • –Бит в секунду: 9600

      • –Биты данных: 8

      • –Четность: нет

      • –Стоповые разряды: 1

      • Flow control — None

    6. Нажмите кнопку ОК.

    7. В меню Call нажмите Disconnect.

    8. В меню Call нажмите Call.

    9. Нажмите Enter, пока вы не будете видеть командную строку маршрутизатора на окне гипертерминала.

Очистите существующие конфигурации на маршрутизаторе Cisco DSL

Выполните следующие действия:

  1. Наберите enable в командной строке маршрутизатора для перехода в привилегированный режим.

    Router>enable
    Router#
    
    !--- The # symbol indicates that you are in privileged mode.
    
    
  2. Очистите существующие конфигурации на маршрутизаторе.

    Router#write erase
    
  3. Повторно загрузите маршрутизатор так, чтобы он загрузился с пустой загрузочной конфигурацией.

    Router#reload
    System configuration has been modified. Save? [yes/no]:no
    Proceed with reload? [confirm]yes
    
    !--- The router reload can take a few minutes.
    
    
  4. После того, как маршрутизатор перезагрузился, войдите в привилегированный режим снова.

    Router>enable
    Router#

Настройте маршрутизатор Cisco DSL

Выполните следующие действия.

  1. Настройте штамп времени сервиса, чтобы должным образом регистрировать и отобразить выходные данные отладки в разделе устранения проблем.

    Router#configure terminal
    Router(config)#service timestamps debug datetime msec
    Router(config)#service timestamps log datetime msec
    Router(config)#end
    
  2. Отключите консоль регистрации на маршрутизаторе Cisco DSL для подавления консольных сообщений, которые могли бы быть вызваны, в то время как вы настраиваете маршрутизатор.

    Router#configure terminal
          Router(config)#no logging console
          Router(config)#end
    
  3. Настройте ip routing, ноль подсети IP и ip classless для обеспечения гибкости в опциях настройки маршрутизации.

    Router#configure terminal
    Router(config)#ip routing
    Router(config)#ip subnet-zero
    Router(config)#ip classless
    Router(config)#end
    
  4. Настройте IP-адрес и маску подсети на Интерфейсе Ethernet маршрутизатора Cisco DSL.

    Для Технологии NAT: (Необязательно) Включите NAT внутри на Интерфейсе Ethernet.

    Router#configure terminal
    Router(config)#interface ethernet 0
    Router(config-if)#ip address <ip address> <subnet mask>
    
    !--- For NAT:
    
    Router(config-if)#ip nat inside
    Router(config-if)#no shut
    Router(config-if)#end
    
  5. Настройте ATM-интерфейс маршрутизатора Cisco DSL с командой no shut для внедрения интерфейса.

    Router#configure terminal
    Router(config)#interface atm 0
    Router(config-if)#no shut
    Router(config-if)#end
    
  6. Настройте подчиненного интерфейс ATM маршрутизатора Cisco DSL с постоянной виртуальной цепью (PVC) ATM и типом инкапсуляции.

    Router#configure terminal
    Router(config)#interface atm 0.1 point-to-point
    Router(config-subif)#
    Router(config-if)#ip address <ip address> <subnet mask>
    
    !--- For NAT:
    
    Router(config-if)#ip nat outside
    Router(config-subif)#pvc <vpi/vci>
    Router(config-subif-atm-vc)#encapsulation aal5snap
    Router(config-subif-atm-vc)#end
    
  7. Настройте маршрут по умолчанию с помощью ATM0.1 в качестве исходящего интерфейса.

    Router#configure terminal
    Router(config)#ip route 0.0.0.0 0.0.0.0 atm0.1
    Router(config)#end
    
  8. Для NAT: Настройте глобальные команды NAT на маршрутизаторе Cisco DSL, чтобы позволить совместно использовать статического открытого IP - адреса Интерфейса номеронабирателя.

    Router#configure terminal
    Router(config)#ip nat inside source list 1 interface atm0.1 overload
    Router(config)#access-list 1 permit <ip network address of ethernet0> 
     <wildcard mask>
    Router(config)#end
    

    Произвольные конфигурации

    Пул NAT, если дополнительные IP-адреса были предоставлены интернет-провайдером.

    Router(config)#ip nat inside source list 1 interface atm0.1 overload 
    Router(config)#ip nat pool <nat pool name> <first ip address> 
     <last ip address> netmask <subnet mask>
    Router(config)#end
    

    Статический NAT, если интернет-пользователи требуют доступа к внутренним серверам.

    Router(config)#ip nat inside source static tcp <inside ip address of server> 
     {80 or 25} <outside well-known ip address of server> {80 or 25} extendable
    Router(config)#end
    
  9. Для Протокола DHCP (динамического конфигурирования узла): (Необязательно) Настройте маршрутизатор Cisco DSL как DHCP server с пулом IP-адресов для присвоения на хосты, связанные с Интерфейсом Ethernet маршрутизатора Cisco DSL. DHCP server динамично назначает IP-адрес, Сервер доменных имен (DNS) и IP - адрес шлюза по умолчанию к хостам.

    Router#configure terminal
    Router(config)#ip dhcp excluded-address <ip address of ethernet0>
    Router(config)#ip dhcp pool <dhcp pool name>
    Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>  
    Router(dhcp-config)#default-router <ip address of ethernet0> 
    Router(dhcp-config)#dns-server <ip address of primary dns server> 
     <ip address of secondary dns server>
    Router(dhcp-config)#end
    
  10. Консоль enable logging на маршрутизаторе Cisco DSL, и затем пишет все изменения в память.

    Router#configure terminal
    Router(config)#logging console
    Router(config)#end
    *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
    Router#write memory
    Building configuration... [OK]
    Router#

Конфигурация

Это - конфигурация, которая создана после завершения процедур в разделе Процедур настройки этого документа.

Маршрутизатор Cisco DSL с одиночным статическим IP - адресом

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface atm0.1 point-to-point
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat outside
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!

!--- For NAT:

ip nat inside source list 1 interface atm0.1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface atm0.1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Проверка.

Маршрутизатор Cisco DSL теперь в рабочем состоянии для сервиса Ассиметричной цифровой абонентской линии (ADSL). Можно выполнить команду show run для наблюдения конфигурации.

Router#show run
Building configuration...

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Устранение неполадок

Обратитесь к Устранению проблем Маршрутизации RFC1483, если сервис ADSL не работает должным образом.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 71136