Голосовая связь и система унифицированных коммуникаций : Cisco ONS 15454 SDH Multiservice Provisioning Platform (MSPP)

Настройка EtherChannel, с использованием карты MLS на ONS 15454 и коммутатор Catalyst через RPR

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Этот documentdescribes процедура для настройки EtherChannel и туннелирования 802.1Q с помощью Cisco Catalyst 3500XL переключается и карта Серии ML по Адаптивному кольцу для пакетов (Resilient Packet Ring) (RPR) в среде Cisco ONS 15454.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Cisco ONS 15454

  • Cisco ONS 15454 карты Ethernet серии ML

  • Catalyst 3500XL Switch

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Версия 6 Cisco ONS 15454. x

  • Коммутатор Catalyst 3500XL, который выполняет Cisco Выпуск ПО IOS� 12.0 (5) XC

  • ML (связанный как часть выпуска ONS 15454 6.0), который выполняет Cisco Выпуск ПО IOS� 12.2 (27) Зв и позже

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Схема сети

Этот документ использует лабораторную установку с двумя ONS 15454 узла и два Коммутатора Catalyst 3500 XL. EachONS 15454 оборудован одним ML 1000-2 карты, и Адаптивное кольцо для пакетов (Resilient Packet Ring) (RPR) создано между ними по ML 1000-2 карты. Два Порта Gigabit Ethernet на Catalyst 3500 XL связаны с двумя Портами Gigabit Ethernet на ML 1000-2 карты соответственно. Схема сети отображена на рисунке 1.

Рисунок 1 – Схема построения сети

/image/gif/paws/69342/f1.gif

Конфигурация

RPR Настройки

Выполните эти шаги для построения RPR:

  1. Создайте канал между POS 0 из ML1000-2 на 15454 А ONS и POS 1 ML1000-2 на ONS 15454 B.

  2. Создайте канал между POS 1 ML1000-2 на 15454 А ONS и POS 0 из ML1000-2 на ONS 15454 B.

  3. Настройте карту ML1000-2 на 15454 А ONS.

    1. Включите интегрированное мостовое соединение и маршрутизацию (IRB).

      bridge irb
      
    2. Создайте мост 1

      Bridge 1 protocol rstp  
    3. Настройте интерфейс SRP.

      interface SPR1
       no ip address
       no keepalive
       spr station-id 3
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
    4. Настройте интерфейсный POS0.

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. Настройте интерфейсный POS1.

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
  4. Настройте карту ML1000-2 на ONS 15454 B.

    1. Включите интегрированное мостовое соединение и маршрутизацию (IRB).

      bridge irb
      
    2. Создайте мост 1

      Bridge 1 protocol rstp
      
    3. Настройте интерфейс SRP.

      interface SPR1
       no ip address
       no keepalive
       spr station-id 4
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
    4. Настройте интерфейсный POS0.

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. Настройте интерфейсный POS1.

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      

Настройка EtherChannel

Выполните эти шаги для построения EtherChannel:

  1. Настройте интерфейсный GigabitEthernet0/1 и GigabitEthernet0/2 на CAT3500_A.

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  2. Настройте интерфейсный GigabitEthernet0/1 и GigabitEthernet0/2 на CAT3500_B.

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  3. Настройте ML1000-2 на 15454 А ONS.

    1. Настройте interface GigabitEthernet 0 и GigabitEthernet 1.

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Настройте Port-Channel.

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
  4. Настройте ML1000-2 на ONS 15454 B.

    1. Настройте интерфейсный GigabitEthernet0 и GigabitEthernet 1.

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Настройте Port-Channel.

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      

Проверка

Выполните эти шаги для подтверждения конфигурации:

  1. Выполните команду show interfaces port-channel от ML1000-2 на 15454 А ONS. Эта команда showsthat EtherChannel содержит два Порта Gigabit Ethernet (см. символы, выделенные полужирным шрифтом).

    15454A_ML1000-2>show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 000d.28bd.0b34 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 4000 bits/sec, 7 packets/sec
    
      5 minute output rate 2000 bits/sec, 4 packets/sec
    
         495875 packets input, 33757916 bytes
    
         Received 493640 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         55924 packets output, 4080533 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
  2. Выполните команду show interfaces port-channel от ML1000-2 на ONS 15454 B. Эта команда показывает, что EtherChannel содержит два Порта Gigabit Ethernet (см. символы, выделенные полужирным шрифтом).

    15454B_ML1000-2>show int port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 0013.60f8.65f4 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 3000 bits/sec, 5 packets/sec
    
      5 minute output rate 3000 bits/sec, 6 packets/sec
    
         1970114 packets input, 143644364 bytes
    
         Received 1969971 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         2256335 packets output, 164715496 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
    
  3. Выполните команду show cdp neighbor на CAT3500_A (см. рисунок 2). Эта команда отображает CAT3500_B как свой соседний узел через EtherChannel.

    Рис. 2: show cdp граничит на CAT3500_A

    f2.gif

  4. Выполните команду show cdp neighbor на CAT3500_B (см. рисунок 3). Эта команда отображает CAT3500_A как свой соседний узел через EtherChannel.

    Рис. 3: show cdp граничит на CAT3500_B

    f3.gif

  5. Выполните эхо - тест (ping test).

    1. Настройте VLAN2 на CAT3500_A с IP-адресом 192.168.0.2.

      !
      interface VLAN2
       ip address 192.168.0.2 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    2. Настройте VLAN2 на CAT3500_B с IP-адресом 192.168.0.4.

      !
      interface VLAN2
       ip address 192.168.0.4 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    3. Выполните команду ping на CAT3500_A (см. рисунок 4).

      ping 192.168.0.4
      
      Рис. 4: ЭХО - ТЕСТ (PING TEST) от CAT3500_A до CAT3500_B

      /image/gif/paws/69342/f4.gif

    4. Выполните команду ping на CAT3500_B (см. рисунок 5).

      ping 192.168.0.2
      
      Рис. 5: ЭХО - ТЕСТ (PING TEST) от CAT3500_B до CAT3500_A

      /image/gif/paws/69342/f5.gif

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения