Видео и доставка контента : Универсальные широкополосные маршрутизаторы Cisco серии uBR7200

Служба прозрачной организации локальной сети поверх имеющейся кабельной

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Традиционно, система прерываний кабельного модема Cisco (CMTS) использовалась для обеспечения Высокоскоростных Сервисов передачи данных для домашних пользователей и для на основе IP Виртуальных частных сетей Уровня 3 (VPN).

Существуют, однако, некоторые клиенты, которые требуют соединений Уровня 2 для выполнения их компаний.

Некоторые причины выровнять по ширине развертывания Виртуальной частной сети Уровня 2 (L2VPN) включают:

  • Поддержка протоколов не-IPv4

  • Сквозное шифрование

  • Больше управления сетью

  • Использование пространства закрытого IP - адреса

Как правило, сервисы Уровня 2 предоставлены Телефонной компанией (Telco (телефонная компания)) и используют другие технологии, такие как Выделенные линии, Frame Relay, ISDN, ATM и другие.

С введением функции Службы прозрачной локальной сети (TLS) 802.1Q оператор нескольких служб (MSO) может усилить ее развертывания DOCSIS, чтобы предоставить сервисы L2VPN и таким образом улучшить ее коммерческие предложения.

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем:

  • Cisco выпуск ПО IOS� 12.2 (15) BC2

  • Платформа uBR7200VXR

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco ubr7246 VXR universal broadband router

  • Cisco Catalyst, 2924-XL (окончание срока службы)

  • Маршрутизатор Cisco 7206VXR

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Что такое TLS 802.1Q по Кабелю?

Функция TLS 802.1Q предоставляет средства создать L2VPN между множественными сайтами, подобными Частным Выделенным линиям, Frame Relay, ISDN, ATM, SMDS, и т.п. которые предлагаются Telco (телефонная компания).

Во многих случаях TLS может быть просмотрен как “подобный Frame Relay” сервис. Это может принять много структур трафика, таких как точка-точка, точка - многоточка, или полностью сцепилось.

Рисунок 1 показывает, как развертывания TLS 802.1Q концептуально походят на VLAN.

Рис. 1

/image/gif/paws/60027/tls_over_cable_01.gif

Рыночные драйверы

Основной драйвер для принятия этой функции является потенциалом для увеличения потоков доходов.

Функция TLS 802.1Q позволяет MSO конкурировать с Telco (телефонная компания) путем предоставления сервиса L2VPN, который может быть более экономичным до конца клиент.

Зона обслуживания MSO уже касается многих областей торговли в течение их развертываний. Многие из тех компаний уже подписывают на сервисы Кабельного телевидения и существующий слой 2 сервиса от Telco (телефонная компания).

Эти сервисы L2 Telco имеют тенденцию иметь повторяющиеся расходы, такие как доступ абонентской линии, доступ порта коммутатора, и т.д.

В большинстве случаев развертывания сервиса TLS 802.1Q могут быть настолько простыми:

  1. Отбросьте кабельный модем в клиентском узле сети.

  2. Должным образом обеспечьте сетевое оборудование MSO.

Для создания предложения более привлекательным и востребованным рынком MSO может принять решение связать Кабельное телевидение и TLS вместе.

Как работает операция TLS 802.1Q?

В настройке TLS 802.1Q кабельный модем определенного клиента обеспечен со стандартными методами инициализации, которые выделены DOCSIS.

В дополнение к инициализации CMTS настроен с определениями, которые известны как карты dot1q. Карты dot1q содержат MAC-адрес кабельного модема, ИДЕНТИФИКАТОР VLAN и исходящий интерфейс. Эти определения (или связывания) распространяются в базу данных Идентификатора службы (SID).

Трафик, который прибывает из определенного кабельного модема, помечен с ИДЕНТИФИКАТОРОМ VLAN и тогда отослан в сети, где это может быть соединено с другими VLAN от того же клиента. Существует несколько способов выполнить Маршрутизацию VLAN.

Рисунок 2 изображает топологию с двухточечным соединением L2VPN, чтобы проиллюстрировать, как работает TLS.

Рис. 2

/image/gif/paws/60027/tls_over_cable_02.gif

На каждом CMTS существует определение карты dot1q, которое связывает MAC-адрес кабельного модема с ИДЕНТИФИКАТОРОМ VLAN и исходящим интерфейсом.

Предположим, что вы отслеживаете пакет от Сайта к Сайту B; придерживающиеся события объясняют как CMTS процессы трафик от Сайта A:

  1. Кабельный модем берет Фрейм Ethernet и добавляет заголовок DOCSIS, который включает SID кабельного модема (или SFID).

  2. Когда трафик получен, CMTS выполняет поиск SID.

  3. CMTS определяет, является ли трафик TLS, на основе SID.

  4. Если трафик является TLS, CMTS изучает пакет и проверки для источника с MAC-адресом.

    1. Если MAC-адрес совпадает с MAC-адресом кабельного модема, то трафик передается коду Коммутации уровня 3.

    2. Если MAC-адрес не совпадает с MAC-адресом кабельного модема, то трафик помечен с надлежащим тегом VLAN и отослан на надлежащем исходящем интерфейсе.

На CMTS B, пакет, который прибывает из Сайта A, обработан таким образом:

  1. Когда CMTS получает помеченный кадр VLAN, он выполняет поиск в базе данных, чтобы определить, сопоставлена ли VLAN с кабельным модемом.

  2. Если соответствие найдено, то CMTS удаляет тег VLAN и добавляет заголовок DOCSIS.

  3. Процесс CMTS новый пакет DOCSIS, для приспосабливания соответствующему CoS или параметрам QoS.

  4. Пакет тогда отослан на кабельном сопряжении.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

Рисунок 3 иллюстрирует топологию сети, используемую в Конфигурациях, и Проверьте разделы.

Рис. 3

tls_over_cable_03.gif

Конфигурации

Эти конфигурации используются в данном документе:

  1. CMTS A

  2. CMTS B

  3. Коммутатор

  4. Маршрутизатор с поддержкой агрегирования

CMTS A
UBR-1:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.3973.be53 FastEthernet0/1 12 
!

CMTS B
UBR-2:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.39a7.8a67FastEthernet0/0 21 
!

Коммутатор
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         

SW# show vlan id 12

00:44:03: %SYS-5-CONFIG_I: Configured from console by console
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
12   VLAN0012                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
12   enet  100012     1500  -      -      -        -    -        0      0   

SW# show vlan id 21

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
21   VLAN0021                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
21   enet  100021     1500  -      -      -        -    -        0      0

Маршрутизатор с поддержкой агрегирования
!         
bridge irb
!         
!         
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!         
interface FastEthernet0/1.12
 encapsulation dot1Q 12
 bridge-group 1
!         
interface FastEthernet0/1.21
 encapsulation dot1Q 21
 bridge-group 1
!         
bridge 1 protocol ieee
!

Проверка.

В этом разделе содержатся сведения, которые можно использовать для подтверждения правильности работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Инициализация кабельного модема

Когда модем, который был обеспечен для TLS 802.1Q, прибывает онлайн, карта создана, который связывает модем с ИДЕНТИФИКАТОРОМ VLAN и выходным интерфейсом.

Выполните эти команды отладки для подтверждения сопоставления:

Эти выходные данные показывают, как CMTS сопоставляет VLAN и исходящий интерфейс, когда кабельный модем прибывает онлайн. Это также показывает нисходящий поток и ID Исходящего управляющего потока, которые привязаны к VLAN.


!--- Logs from CMTS A (UBR-1):

UBR-1# show debug

CMTS:
  CMTS L2 VPN debugging is on
CMTS specific:
  Debugging is on for Address 0000.3973.be53, Mask ffff.ffff.ffff

UBR-1#

cmts_l2vpn_init_cm: cm 0000.3973.be53 on Cable3/0, sid 0xA
map to FastEthernet0/1 VLAN id 12
 Mapped DS srv flow 22 on Cable3/0 to FastEthernet0/1 VLAN 12
 Mapped US srv flow 21 sid 10 on Cable3/0 to FastEthernet0/1 VLAN 12

Проход трафика

Чтобы видеть, прибывает ли тот трафик или из кабельного модема или предназначенный к кабельному модему, можно отладить его или посмотреть на счетчики.

Для отладки его включите эти отладки:

Примечание: Эти отладки только доступны на uBR7200 платформе.

Выходные данные следующего примера показывают отладку пакета от Сайта к Сайту B при активации многословного mac-address mac-address debug cable и условное выражение l2vpn debug cable.

Первая линия отладки является пакетом от источника от Сайта A. Поскольку пакет является ping - пакетом, следующая линия отладки является откликом на запрос ping. Это показывает, как пакет передан к кабельному модему.

UBR-1#

Pkt (size 114) from CM 0000.3973.be53 sid 10 src 0008.a3b6.d371
dst 0008.a3b6.d74b fwd to FastEthernet0/1 vlan 12

Send pkt size 118 from 0008.a3b6.d74b on FastEthernet0/1:vlan 12
to 0008.a3b6.d371 on Cable3/0:0xA CM 0000.3973.be53

Для просмотра байтов или пакетных счетчиков выполните mac-address карты vc dot1q l2vpn кабеля показа многословная команда:

UBR-1# show cable l2-vpn dot1q-vc-map 0000.3973.be53 verbose

MAC Address                         : 0000.3973.be53
Customer Name                       :
Prim Sid                            : 5
Cable Interface                     : Cable3/0
Ethernet Interface                  : FastEthernet0/1
DOT1Q VLAN ID                       : 12
Total US pkts                       : 0
Total US bytes                      : 0
Total DS pkts                       : 12
Total DS bytes                      : 816

Устранение неполадок

В настоящее время нет никакой определенной доступной информации для устранения проблем этой конфигурации.

Принципы проектирования

Существует несколько факторов проектирования для рассмотрения при развертывании сервисов по сети DOCSIS. Некоторые являются определенными для кабельной стороны, и другие - более общие вопросы.

Кабельная сторона (DOCSIS)

Размер канала или пропускная способность

Как правило, основное ограничение находится на Пропускной способности восходящего канала. Таблица 1 показывает приблизительные рисунки для других значений пропускной способности.

Таблица 1

Версия DOCSIS Ширина канала (МГц) Модуляция Приблизительная пропускная способность (Мбит/с)
1. x 1.6 QPSK 2.2
1. x 1.6 С 16 QAM 4.4
1. x 3.2 С 16 QAM 8.9
2.0 3.2 С 64 QAM 13
2.0 6.4 С 64 QAM 26

Версия DOCSIS 1.1 включила много функций, которые предоставляют оптимизацию Канала передачи от клиента. Некоторые из тех функций включают:

  • Конкатенация

  • Фрагментация

  • Исключение заголовков из полезной нагрузки

QoS DOCSIS

Переданный по сравнению с Оптимальным уровнем — Версия DOCSIS 1.0 обеспечивает гарантированную скорость на восходящем потоке только. Версия 1.1 и 2.0 обеспечивает гарантированную скорость в обоих направлениях. Для гарантии Committedinformation rate (CIR) (гарантированная скорость передачи) планировщик CMTS выполняет контроль доступа на восходящем потоке, для предотвращения превышения подписки.

Управляемая Задержка и Дрожание — Версия DOCSIS 1.1's Незапрашиваемые Предоставления (UGS) предоставляют постоянную скорость передачи данных (CBR) - как сервис. Задержка и дрожание могут эффективно управляться, для обеспечения гарантируемой минимальной скорости передачи данных для трафика, который требует предоставлений в неподвижных интервалах.

Безопасность

Трафик, который пересекает кабельный участок, может быть защищен с базовым интерфейсом обеспечения конфиденциальности (BPI) DOCSIS, в Версии DOCSIS 1.0 или BPI +, в более новых версиях DOCSIS. Затем кто-то не может snooping или подслушать данные на кабельной стороне.

Для клиентов, которые требуют большего количества безопасности — например, финансовые учреждения и т.п. — рекомендуется стратегия сквозного IPSec. Обратитесь к Безопасности в Cisco.

Общие проблемы

QoS

В среде 802.1Q существует три главных области QoS:

  • Сторона CPE — Как CPE определяет политику и отмечает трафик. Это управляется клиентом, и это относится к их внутренней политике QoS.

  • Кабельная сторона — Это соответствует протоколу DOCSIS и инициализации кабельного модема.

  • Магистраль — MSO может применить политики QoS на основе Соглашений об уровне обслуживания.

Производительность и масштабируемость

На CMTS существует только незначительное увеличение памяти для удержания структур данных, и dot1q сопоставляет (база данных). Коммутация для пакетов TLS совпадает с для любого другого пакета.

Количество поддерживаемых VLAN варьируется на основе платформы.

Соединяющие группы варьируются на основе платформы.

Как расширить TLS 802.1Q вне границ Ethernet

Будут времена, когда клиенты будут требовать подключения к сайтам, которые являются вне Ethernet физическими пределами; например, сайты в других городах, городах или состояниях.

В тех случаях MSO могут использовать одно из нескольких Решений по услугам Реле Городской Ethernet - сети.

Два из тех решений, которые были протестированной лабораторной работой:

  • TLS по Базовой IP - сети через версию 3 протокола туннелирования на уровне 2 (L2TP)

  • TLS по Ядру Многопротокольной коммутации по меткам (MPLS) через Ethernet по MPLS (EoMPLS)

Приложение A - трассировка пакетов между коммутатором L2 и маршрутизатором с поддержкой агрегирования

Этот раздел показывает трассировку пакетов ping - пакета между Коммутатором и Маршрутизатором с поддержкой агрегирования. Заметьте, что существует два пакета запроса проверки доступности (ping request): один от Сайта к Маршрутизатору с поддержкой агрегирования, и один от Маршрутизатора с поддержкой агрегирования до Сайта B. То же применяется к ответу эхо-запроса.

Frame 1 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 2 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 3 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 4 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 60027