Широкополосные кабельные сети : Системы терминирования кабельных модемов (CMTS)

комплексная конфигурация uBR7100 в режиме моста

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для Системы терминирования кабельных модемов (CMTS) Cisco uBR7100, которая действует как Протокол DHCP (динамического конфигурирования узла), Время дня (ToD) и TFTP server. Это также объясняет как созданному файл конфигурации DOCSIS с помощью интерфейса командной строки (CLI) на CMTS. В то время как CMTS настроен в режиме моста, эта конфигурация известна как “конфигурация все в одном для CMTS Cisco”. В настоящее время uBR7100 платформа является единственной платформой CMTS, которая поддерживает мостовое соединение.

Предварительные условия

Требования

У читателя данной документации должно быть основное понимание мостового соединения, DOCSIS, DHCP, ToD и TFTP протокол.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Система терминирования кабельных модемов Cisco uBR7100

  • Кабельные модемы совместимые с DOCSIS

  • Cisco Выпуск ПО IOS� 12.1 (7) EC или позже

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Описание

Кабельный модем, совместимый с DOCSIS, требует доступа к трем типам серверов для успешного подключения к сети.

  • DHCP server, который предоставляет кабельный модем IP-адресом, маской подсети и другими связанными параметрами IP.

  • RFC-868 leavingcisco.com- совместимый сервер ToD, который говорит модем, знает текущее время. Кабельному модему нужно знать время для того, чтобы правильно и аккуратно добавлять метки времени в журнал событий.

  • TFTP server, от которого кабельный модем в состоянии загрузить файл конфигурации DOCSIS, содержащий определенные для кабельного модема рабочие параметры.

Большинство операторов кабельной связи использует Cisco Network Registrar (CNR) в качестве DHCP, Сервера доменных имен (DNS) и Tftp server. Сервер ToD не является частью CNR. Сервер ToD, который используется, зависит от платформы в системе оператора кабельной связи. ToD должен быть RFC-868 leavingcisco.com- совместимый. Для систем UNIX это включено в Solaris; только необходимо удостовериться, что inetd.conf файл в / и т.д. каталог содержит эти линии:

# Time service is used for clock synchronization.
#
time    stream  tcp     nowait  root    internal
time    dgram   udp     wait    root    internal

Для Windows обычно используемым программным обеспечением является Greyware leavingcisco.com.

Эта таблица показывает Cisco IOS Software Release, в которых другие возможности сервера были добавлены к CMTS:

Возможности сервера Cisco IOS Software Release
DHCP 12.0 (1) T
ToD 12.0 (4) КСИ
TFTP 11.0 (для всех платформ)

Этот документ объясняет каждую из этих функций. Конфигурацию на CMTS, который содержит все эти возможности, называют “конфигурацией все в одном для CMTS”. С этой конфигурацией вы не требуете никаких дополнительных серверов, чтобы протестировать кабельные участки и предоставить доступ высокоскоростного Интернета.

Также возможно настроить файл конфигурации DOCSIS таким образом, чтобы он постоянно находился на CMTS вместо сервера TFTP. Согласно комментариям к релизу, для использования этой возможности необходимо Cisco IOS Software Release 12.1(2)EC1.

Несмотря на то, что эта “конфигурация все в одном” очень удобна для лабораторных сред, начального тестирования, небольших развертываний и устранения проблем, это не является масштабируемым для поддержки очень большого числа кабельных модемов. Таким образом, не рекомендуется использовать эту конфигурацию на в рабочем состоянии кабельных участках с большими развертываниями кабельных модемов.

Инженеры Технической поддержки Cisco часто используют эту конфигурацию для устранения переменных при устранении проблем проблем с кабелем.

Маршрутизация и операции объединения с помощью моста

Маршрутизаторы Cisco uBR7100 Series поддерживают эти режимы работы:

  • Режим маршрутизации — Маршрутизация операции является типичным режимом по умолчанию для маршрутизаторов Cisco CMTS. Это предоставляет широкий спектр средств маршрутизации программного обеспечения Cisco IOS, таких как DHCP server и контроль, по которому пакеты переданы по каждому интерфейсу.

  • Режим Прозрачного режима моста — Операции объединения с помощью моста между кабельным сопряжением и интерфейсами адаптера порта, как правило, не используются в установках DOCSIS ДЛЯ CMTS из-за возможной производительности и проблем безопасности. Если CMTS заменяет существующую сеть мостового соединения, мостовое соединение является очень эффективным, однако, в средах CMTS с ограниченным числом устройств оборудования в помещении заказчика (CPE) — как в обычном многоквартирном жилом доме (MDU) или устройство с несколькими владельцами (MTU) среда — особенно.

Concurrent Routing and Bridging (IRB)

Операция Integrated routing and bridging (IRB) позволяет соединять в определенном сегменте сетей или узлов, все же также позволяет тем хостам соединяться с устройствами на другом, протрассированных сетях, не имея необходимость использовать отдельный маршрутизатор для соединения этих двух сетей.

Примечание: Прозрачный режим моста и работа IRB поддерживаются только при использовании Cisco IOS Software Release 12.1 (7) EC и позднее. Для завершенных подробных данных о прозрачном режиме моста и работе IRB, см. главы Мостового соединения в Руководстве по конфигурации Мостового соединения и Сетевых решений IBM Cisco IOS, релизе 12.1, доступном на Cisco.com и Компакт-диске с документацией.

Виртуальный интерфейс мостовой группы

ubr7100_config_bridge_1.gif

Поскольку мостовое соединение работает в уровне канала передачи данных, и маршрутизация работает на сетевом уровне, они придерживаются других моделей конфигурации протокола. В то время как каждый маршрутизируемый интерфейс представляет отдельную сеть, беря основную модель IP в качестве примера, все мостовые интерфейсы принадлежали бы той же сети.

Когда определенный протокол и соединяется и маршрутизируется в группе мостов, в IRB виртуальный интерфейс мостовой группы представлен, чтобы избежать путать модель конфигурации протокола.

Виртуальный интерфейс мостовой группы является обычным маршрутизируемым интерфейсом, который не поддерживает мостовое соединение, но действительно представляет его соответствующую группу мостов маршрутизируемому интерфейсу. Это имеет все атрибуты сетевого уровня (такие как адрес сетевого уровня и фильтры), которые применяются к соответствующей группе мостов. Номер интерфейса, назначенный на этот виртуальный интерфейс, соответствует группе мостов, которую представляет этот виртуальный интерфейс. Это количество является ссылкой между виртуальным интерфейсом и группой мостов.

Когда вы позволяете направить для данного протокола на виртуальном интерфейсе мостовой группы, пакеты, прибывающие из маршрутизируемого интерфейса, но предназначенный для хоста в соединенном мостом домене, маршрутизируются к виртуальному интерфейсу мостовой группы и переданы к соответствующему мостовому интерфейсу. Весь трафик, маршрутизировавший к виртуальному интерфейсу мостовой группы, передан к соответствующей группе мостов как проходящий через мост трафик. Весь маршрутизуемый трафик, полученный на мостовом интерфейсе, маршрутизируется к другим маршрутизируемым интерфейсам, как будто он прибывает непосредственно из виртуального интерфейса мостовой группы.

Чтобы получить пакеты с возможностью трассировки, поступающие в мостовой интерфейс, но предназначенный для маршрутизируемого интерфейса или получить пакеты для маршрутизации, виртуальный интерфейс мостовой группы должен также иметь верные адреса. MAC-адреса и сетевые адреса назначены на виртуальный интерфейс мостовой группы этим способом:

  • Виртуальный интерфейс мостовой группы “одалживает” MAC-адрес одного из мостовых интерфейсов в группе мостов, привязанной к виртуальному интерфейсу мостовой группы.

  • Чтобы направить и соединить данный протокол в той же группе мостов, необходимо настроить атрибуты сетевого уровня протокола на виртуальном интерфейсе мостовой группы.

  • Никакие атрибуты протокола не должны быть настроены на мостовых интерфейсах, и никакие атрибуты мостового соединения не могут быть настроены на виртуальном интерфейсе мостовой группы.

Поскольку может быть только один виртуальный интерфейс мостовой группы, представляющий группу мостов — и группа мостов может быть составлена из других типов носителя, настроенных для нескольких других методов инкапсуляции — вы, возможно, должны настроить виртуальный интерфейс мостовой группы с определенными методами инкапсуляции, требуемыми коммутировать пакеты правильно.

Сервис DHCP Cisco IOS на CMTS

Маршрутизаторы Cisco рабочее программное обеспечение Cisco IOS версии 12.0(1)T или позже имеют способность выступать как Dhcp server. Этот сервис DHCP может быть настроен для обеспечения аренды DHCP кабельным модемам и CPE, таким как PC и рабочие станции.

Существует минимальный набор параметров DHCP, которые обычно необходимы кабельному модему для перехода в активный режим:

  • IP-адрес (поле "yiaddr" в заголовке пакета DHCP)

  • Маска подсети (параметр DHCP 1)

  • Смещение местного времени со Времени по Гринвичу (GMT) в секундах (Параметр DHCP 2)

  • Маршрутизатор по умолчанию (Параметр DHCP 3)

  • IP-адрес сервера ToD (DHCP, вариант 4)

  • Сервер журналов (DHCP, вариант 7)

  • IP-адрес сервера TFTP (поле siaddr в заголовке пакета DHCP)

  • Имя файла конфигурации DOCSIS (поле файла в заголовке пакета DHCP)

  • Время аренды DHCP в секундах (DHCP-параметр 51)

В маршрутизаторе те опции могут быть настроены с этими командами:

!
ip dhcp pool cm-platinum
 network 10.1.4.0 255.255.255.0
 bootfile platinum.cm
 next-server 10.1.4.1
 default-router 10.1.4.1
 option 7 ip 10.1.4.1
 option 4 ip 10.1.4.1
 option 2 hex ffff.8f80
 lease 7 0 10
!

Это пояснения каждой из тех команд:

  • пул DHCP — Определяет название области кабельного модема (cm-platinum).

  • сеть — Предоставляет IP-адрес и маску подсети (Параметр DHCP 1).

  • bootfile — Предоставляет название загрузочного файла, которое, в этом случае, является platinum.cm.

  • next-server — Задает IP-адрес сервера TFTP, который, в этом случае, является основным IP - адресом в интерфейсе c4/0.

  • default-router — Определяет шлюз по умолчанию, который, в этом случае, является первичным IP - адресом интерфейса c4/0 (Параметр DHCP 3).

  • опция 7 — Определяет Регистрационный Параметр DHCP сервера.

  • опция 4 — Предоставляет IP-адрес сервера ToD (первичный IP - адрес интерфейса c4/0).

  • опция 2 — Предоставляет параметр смещения времени для GMT – 8 часов (–8 часов равняется –28800 секундам, который равняется ffff.8f80 в шестнадцатеричных числах).

    Примечание: Чтобы узнать больше, как преобразовать десятичное значение времени смещения в шестнадцатеричный, обратитесь к тому, Как Вычислить Шестнадцатеричное значение для Параметра DHCP 2 (сдвиг времени).

  • арендный договор — Устанавливает время аренды (7 дней, 0 часов, 10 минут).

Для устройств CPE эти опции являются минимумом, требуемым работать успешно:

  • IP-адрес (поле "yiaddr" в заголовке пакета DHCP)

  • Маска подсети (параметр DHCP 1)

  • Маршрутизатор по умолчанию (Параметр DHCP 3)

  • IP-адрес одного или более DNSs (Параметр DHCP 6)

  • Имя домена (DHCP, параметр 15)

  • Время аренды DHCP в секундах (DHCP-параметр 51)

В маршрутизаторе те опции могут быть настроены с этими командами:

! 
ip dhcp pool pcs-irb

!--- The scope for the hosts.

   network 172.16.29.0 255.255.255.224

!--- The IP address and mask for the hosts.

   next-server 172.16.29.1

!--- TFTP server; in this case, the secondary address is used.

   default-router 172.16.29.1
   dns-server 172.16.30.2

!--- DNS server (which is not configured on the CMTS).

   domain-name cisco.com
   lease 7 0 10
!

Дополнительные возможности сервера DHCP

Это некоторые другие функции, которые могут быть использованы от DHCP server программного обеспечения Cisco IOS:

  • IP эхо-запрос dhcp — Эхо-запрос перед функцией арендного договора, которая гарантирует, что DHCP server не выполняет арендные договоры для IP-адресов, которые уже находятся в использовании.

  • ip dhcp database Функция, которая хранит связывания DHCP во внешней базе данных для поддерживания MAC-address-to-IP-address отношений во время цикла включения и выключения питания CMTS.

  • dhcp show ip — комплект команд, которые могут использоваться для мониторинга операции DHCP server.

  • команда debug ip dhcp server Набор команд, которые можно использовать для устранения неполадок DHCP-сервера.

Все эти дополнительные функции и функции описаны в Комментариях к выпуску характеристики сервера DHCP программного обеспечения Cisco IOS в документе сервера DHCP Cisco IOS.

Сервис TFTP Cisco IOS

После того как кабельный модем попытался установить связь с сервером ToD, он продолжает связываться с сервером TFTP для загрузки файла конфигурации DOCSIS. Если двоичный конфигурационный файл DOCSIS можно скопировать на флэш-устройство в Cisco CMTS, то маршрутизатор можно использовать как сервер TFTP для этого файла.

Это - процедура для загрузки файла конфигурации DOCSIS во флэш-память:

  1. Выполните эту команду ping, чтобы гарантировать, что CMTS может достигнуть сервера, где расположен файл конфигурации DOCSIS.

    Ubr7111# ping 172.16.30.2
    
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 172.16.30.2, timeout is 2 seconds:
    
    !--- Output suppressed.
    
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
  2. Скопируйте файл (в этом случае, это называют silver.cm) во флэш-память CMTS.

    Ubr7111# copy tftp flash
    
    Address or name of remote host []? 172.16.30.2
    Source filename []? silver.cm
    Destination filename [silver.cm]?
    
    Accessing tftp://172.16.30.2/silver.cm...
    Loading silver.cm from 172.16.30.2 (via Ethernet2/0): !
    [OK - 76/4096 bytes]
    
    76 bytes copied in 0.152 secs
  3. Проверьте флэш-память и проверьте, что размер файла корректен, с помощью команды dir.

    Ubr7111# dir
    
    Directory of disk0:/
    
       1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
       2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
    
    47890432 bytes total (17936384 bytes free)
  4. Для включения Сервиса TFTP на CMTS выполните эту команду в режиме глобальной конфигурации:

    tftp-server slot0:silver.cm alias silver.cm
    
  5. Подтвердите Шаг 4 путем проверки для этих линий в конфигурации:

    !
    tftp-server slot0:silver.cm alias silver.cm
    tftp-server server
    !

Для получения дополнительной информации о конфигурации TFTP server в маршрутизаторе, сошлитесь на Дополнительный документ Команд Функции Передачи файла.

Сервис ToD Cisco IOS

После того, как кабельный модем успешно получает аренду DHCP, он тогда пытается связаться с сервером ToD. Программы Cisco CMTS, использующие Cisco IOS Software Release 12.0(4)XI или выше, могут обеспечить услуги RFC 868 ToD. leavingcisco.com

Общее несовпадение - то, что сервис ToD, который кабельные модемы должны использовать для прибытия онлайн, совпадает с сервисом Протокола NTP, который обычно настраивается на маршрутизаторах Cisco. Сервис NTP и сервис ToD несовместимы. Кабельные модемы не могут общаться с NTP-сервером. В то время как кабельные модемы должны попытаться связаться с сервером ToD как с частью процесса прибытия онлайн, совместимые модемы с последними пересмотрами спецификации интерференции радиочастоты (RFI) DOCSIS 1.0 все еще продолжают прибывать онлайн, даже если не может быть достигнут сервер ToD.

В соответствии с последней версией данной спецификации, если кабельный модем не может подключиться к серверу ToD, он может продолжать процесс выхода в сеть. Это должно, однако, периодически пытаться связаться с сервером ToD, пока это не успешно. Более ранние версии спецификаций RFI DOCSIS 1.0 передали под мандат это, если кабельный модем не мог бы связаться с сервером ToD, то модем не мог прибыть онлайн. Важно сознавать, что кабельные модемы с более старой микропрограммой, могут соответствовать этой более старой версии спецификации.

Примечание: Кабельные модемы некоторых поставщиков не взаимодействуют с сервисом ToD программного обеспечения Cisco IOS. Если эти модемы совместимы с последними версиями спецификации радиопомех DOCSIS 1.0, они не должны прерывать соединение. Эта проблема совместимости обращается идентификатором ошибки Cisco CSCdt24107 (только зарегистрированные клиенты).

Для настройки ToD на CMTS Cisco выполните эти команды global:

service udp-small-servers max-servers no-limit
!
cable time-server
!

Встроенная программа создания файла конфигурации DOCSIS

Продукты Cisco CMTS с ПО Cisco IOS выпуск 12.1(2)EC или выше (в серии выпуска EC), могут быть конфигурированы для создания или хранения во внутренней памяти конфигурационные файлы DOCSIS. Выполнение так полезно, потому что оно убирает требование наличия доступа к внешнему программному средству создания файла конфигурации DOCSIS. Когда файл конфигурации DOCSIS создан с помощью программного средства внутренней конфигурации, файл становится автоматически доступным через TFTP. Кроме того, только кабельные модемы на непосредственно интерфейсах подключенного кабеля в состоянии загрузить эти файлы конфигурации.

Эти примеры конфигурации показывают создание двух файлов конфигурации DOCSIS.

Первое называют disable.cm, который позволяет кабельному модему прибывать онлайн, но препятствует тому, чтобы связанные устройства CPE обратились к сети поставщика услуг. В этом случае существует команда access-denied. Заметьте, что нисходящие и восходящие скорости в этом случае составляют 1 кбит/с, и максимальный размер пакета составляет 1600 байтов.

cable config-file disable.cm
   access-denied
   service-class 1 max-upstream 1
   service-class 1 max-downstream 1600
   timestamp
!

Оператор кабельной связи использует этот disable.cm файл конфигурации DOCSIS для запрета доступа к CPE позади кабельного модема, все еще позволяя кабельному модему прибыть онлайн. Это - более эффективный способ запретить сервис CPE, чем использование опции exclude в CNR, который не позволяет кабельному модему прибывать онлайн: кабельный модем неоднократно пытается прибыть онлайн и пропускная способность отходов.

Когда команда show cable modem выполнена, кабельные модемы с этим файлом конфигурации DOCSIS показывают эти выходные данные:

Cable1/0/U0 10  online(d)  2287  0.50  6  0  10.1.4.65  0010.7bed.9b45

Рекомендации по проверке для раздела Усовершенствованной конфигурации этого документа дают больше подробных данных об этих выходных данных. Статус, онлайновый (d), означает, что кабельные модемы являются онлайновыми, но запрещен доступ.

Во втором примере звонил файл конфигурации DOCSIS, platinum.cm создан. В этом случае максимальное восходящее значение составляет 1 Мбит/с, гарантируемое восходящее значение составляет 100 кбит/с, максимальная скорость нисходящего канала составляет 10 Мбит/с, и это позволяет до 30 устройств CPE быть связанными.

cable config-file platinum.cm
   service-class 1 max-upstream 1000
   service-class 1 guaranteed-upstream 100
   service-class 1 max-downstream 10000
   service-class 1 max-burst 1600
   cpe max 30
   timestamp
!

Заметьте, что при настройке файла конфигурации DOCSIS в CMTS вы не требуете platinum.cm псевдонима оператора tftp server slot0:platinum.cm, потому что нет никакого .cm файла, хранившего в памяти; это находится в конфигурации.

Дальнейшие подробности на внутреннем программном средстве файла конфигурации DOCSIS могут быть найдены в документе Командами Конфигурации CMTS Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

Типичную топологию лабораторной установки показывают в этом образе:

/image/gif/paws/29243/ubr7100_config_bridge_2.gif

Конфигурации

Эти конфигурации используются в данном документе:

Эта конфигурация поддерживается только на uBR7100 платформах CMTS.

Cisco IOS Software Release, который поддерживает конфигурацию все в одном, включая конфигурацию файла конфигурации DOCSIS, является программным обеспечением Cisco IOS версии 12.1(2)EC и последующими версиями Серии EC. Версия программного обеспечения Cisco IOS, которая использовалась в этой конфигурации, является ubr7100-ik1s-mz.121-11b. EC.bin.

Базовая конфигурация "все в одном"

Эта конфигурация суммирует все части, объясненные до сих пор. Это имеет две области DHCP: один для кабельных модемов и другого для хостов позади кабельных модемов.

Один файл конфигурации DOCSIS создают, называют platinum.cm. Этот файл применяется к пулу DHCP, называемому cm-platinum. Другой файл конфигурации DOCSIS с именем disabled.cm в данный момент не применяется.

Комментарии находятся в синем после связанных команд. Функционально законченные команды настройки выделены жирным шрифтом.

Базовая конфигурация "все в одном"
ubr7100# show run
Building configuration...
 
Current configuration : 3511 bytes
!
! Last configuration change at 01:12:37 PST Mon Sep 3 2001
!
version 12.1
no service pad
service timestamps debug datetime msec localtime

!--- Provides useful timestamps on all log messages.

service timestamps log datetime localtime
no service password-encryption
service linenumber
service udp-small-servers max-servers no-limit

!--- Supports a large number of modems or hosts attaching quickly.

 
!
hostname ubr7111
!
boot system flash disk0:ubr7100-ik1s-mz.121-11b.EC.bin
!
cable spectrum-group 3 frequency 40800000
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable timeserver

!---  Allows cable modems to obtain ToD from the uBR7100.

!
cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 8
 timestamp
!
clock timezone PST -9
clock calendar-valid
ip subnet-zero
no ip routing

!--- Disables routing on the CMTS.

no ip domain-lookup

!--- Prevents the CMTS from looking up domain names or attempting 
!--- to connect to machines (for example, when mistyping commands).

ip host ubr7111 172.16.26.103
ip domain-name cisco.com
ip name-server 171.68.10.70
ip name-server 171.69.2.132
ip name-server 171.68.200.250
no ip dhcp relay information check
 
ip dhcp excluded-address 10.45.50.1 10.45.50.5
!
ip dhcp pool cm-platinum

!--- Name of the DHCP pool. This scope is for the cable modems attached 
!--- to interface cable 4/0.

   network 10.1.4.0 255.255.255.0

!--- Pool of addresses for scope modems-c1/0.

   bootfile platinum.cm

!--- DOCSIS configuration file name associated with this pool.

   next-server 10.1.4.1

!--- IP address of the TFTP server which sends the boot file.

   default-router 10.1.4.1

!--- Default gateway for cable modems; necessary to get DOCSIS files.

   option 7 ip 10.1.4.1

!--- Log Server DHCP option.

   option 4 ip 10.1.4.1

!--- ToD server IP address.

   option 2 hex ffff.8f80

!--- Time offset for ToD, in seconds (HEX), from GMT.
!--- Pacific Standard Time offset from GMT = –28,000 seconds = ffff.8f80

   lease 7 0 10

!--- Lease 7 days 0 hours 10 minutes.

! 
ip dhcp pool pcs-irb

!--- Name of the DHCP pool. This scope is for the CPE attached to
!--- the cable modems that are connected to interface cable 1/0.

   network 172.16.29.0 255.255.255.0

!--- Pool of addresses for scope pcs-c4 (associated with the secondary address).

   next-server 172.16.29.1
   default-router 172.16.29.1
   dns-server 172.16.29.1
   domain-name cisco.com
   lease 7 0 10
!
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 no keepalive
 duplex half
 speed auto
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0/1
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 shutdown
 duplex auto
 speed 10
 no cdp enable
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Cable1/0
 ip address 14.66.1.2 255.255.255.0
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 no keepalive
 cable packet-cache
 cable downstream annex B
 cable downstream modulation 256qam
 cable downstream interleave-depth 32
 cable downstream frequency 525000000
 no cable downstream rf-shutdown
 cable downstream rf-power 55
 cable upstream 0 frequency 17808000
 cable upstream 0 power-level 0
 cable upstream 0 channel-width 3200000
 no cable upstream 0 shutdown
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 10.1.4.1 255.255.255.0
!
ip default-gateway 14.66.1.1
ip classless
no ip http server
!
no cdp run
bridge 1 protocol ieee
 bridge 1 route ip
alias exec scm show cable modem
!
line con 0
 exec-timeout 0 0
 privilege level 15
 length 0
line aux 0
line vty 0 4
 privilege level 15
 no login
line vty 5 15
 login
!
end

Советы по проверке для базовой конфигурации

В этом разделе приведена информация, которую можно использовать для проверки правильности работы конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  1. Удостоверьтесь, что команды поддерживаются в Cisco IOS Software Release путем запуска команды Show version.

  2. Проверьте, что файл конфигурации DOCSIS находится во флэш-памяти.

    Ubr7111# dir
    
    Directory of disk0:/
     
        1  -rw-          74   Feb 13 2001 16:14:26  silver.cm
        2  -rw-    10035464   Feb 14 2001 15:44:20  ubr7100-ik1s-mz.121-11b.EC.bin
     
    47890432 bytes total (17936384 bytes free)

    Примечание: Файл silver.cm был создан с помощью программного средства Конфигуратора DOCSIS CPE. Для файла platinum.cm, который был создан в конфигурации CMTS, вы не требуете platinum.cm псевдонима оператора tftp server slot0:platinum.cm, потому что нет никакого .cm файла; это находится в конфигурации.

  3. Проверьте, что кабельные модемы являются онлайновыми путем запуска команды show cable modem.

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    Заметьте, что все кабельные модемы являются онлайновыми. Те связанные с интерфейсным кабелем 1/0/U0 находятся в сети 10.1.4.0. Вы видите от конфигурации, что их IP-адреса взяты от пула DHCP, названного cm-platinum.

    Также заметьте, что кабельные модемы с MAC-адресами 0010.7bed.9b23 и 0010.7bed.9b45 имеют CPE позади них. Эти кабельные модемы подключаются к сети со стандартной конфигурацией мостовой передачи. Те PC настроены с DHCP так, чтобы они могли получить свои IP-адреса от сети.

    Ubr7111# show interface cable 1/0 modem 0
    
    SID   Priv bits  Type      State     IP address    method    MAC address
    75    00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
    75    00         modem     up        10.1.4.2      dhcp      0010.7bed.9b23
    76    00         modem     up        10.1.4.3      dhcp      0002.fdfa.0a63
    77    00         host      unknown   172.16.29.3   dhcp      00a0.243c.eff5
    77    00         modem     up        10.1.4.5      dhcp      0010.7bed.9b45
    78    00         modem     up        10.1.4.4      dhcp      0004.2752.ddd5
    79    00         modem     up        10.1.4.6      dhcp      0002.1685.b5db
    80    00         modem     up        10.1.4.7      dhcp      0001.64ff.e47d

    Этот снимок экрана показывает, что те PC получают IP-адрес от пулов, названных pcs-c4.

    ubr7100_config_bridge_3.gif

    Можно также видеть от этого ПК, что параметры настройки TCP/IP собираются получить IP-адрес автоматически.

    ubr7100_config_bridge_4.gif

Расширенная конфигурация "все в одном"

Этот раздел предоставляет более сложный пример конфигурации, который включает иерархическую функциональность пулов DHCP. Путем работы иерархии пула DHCP состоят в том, что любой пул DHCP с номером сети, который является подмножеством номера сети другого пула, наследовал все характеристики того другого пула. Это спасает повторения в конфигурации сервера DHCP. Если, однако, та же спецификация сделана с другим параметром, то параметр перезаписан. Данный пример показывает общий пул с загрузочным файлом, названным platinum.cm и подмножеством этого пула с загрузочным файлом, названным disable.cm.

В дополнение к пулам DHCP, созданным в базовом примере, существуют специальные требования для двух кабельных модемов.

Во-первых, кабельный модем 0010.7bed.9b45 запрещен доступа; этому предоставляют IP-адрес, но это не прибывает онлайн. Создайте этот пул:

ip dhcp pool cm-0010.7bed.9b45
   host 10.1.4.65 255.255.255.0
   client-identifier 0100.107b.ed9b.45
   bootfile disable.cm

Наиболее основная функция этого примера конфигурации является разделом, где вы задаете специальные пулы DHCP, которые соответствуют MAC-адресам отдельного кабельного модема. Такая спецификация позволяет DHCP server передавать уникальные параметры DHCP к этим модемам. Для определения определенного кабельного модема параметр идентификатора клиента используется. Идентификатор клиента должен устанавливаться в 01, придерживаться MAC-адресом устройства, которому соответствует запись. Этот 01 соответствует Ethernet для типа оборудования DHCP.

Примечание: При изменении файлов конфигурации для модема необходимо выполнить эти шаги, чтобы гарантировать, что кабельный модем добирается вручную настроенные параметры:

  1. Очистите таблицу привязки DHCP IP путем запуска команды ip address clear ip dhcp binding .

  2. Перезагрузите рассматриваемый кабельный модем путем запуска команды clear cable modem mac address res.

Во-вторых, кабельный модем 0010.7bed.9b23 также имеет специальное требование: это получает другое качество обслуживания (QoS). Поэтому другой загрузочный файл привязан к области, как показано в этой частичной конфигурации:

ip dhcp pool cm-0010.7bed.9b23
   host 10.1.4.66 255.255.255.0
   client-identifier 0100.107b.ed9b.23
   bootfile silver.cm
!

В процессе настройки пулов DHCP для определенных кабельных модемов рекомендуется всегда назначать соответствующее имя. Кроме того, потому что определенный IP-адрес назначен на пул с помощью команды host, необходимо выполнить IP dhcp исключает 10.1.4.60 10.1.4.70 команды global. Эта команда говорит DHCP не использовать адреса в этом диапазоне.

Советы по проверке для расширенной конфигурации

Проверка этой конфигурации фокусируется на сервисах, которые кабельные модемы получают, особенно 0010.7bed.9b45 и 0010.7bed.9b23. Необходимо быть уверены, что они получают и адреса, с которыми они были вручную настроены и сервис.

Первая вещь протестировать состоит в том, что 0010.7bed.9b45 прибывает онлайн, но что запрещен сервис. Выполните команду show cable modem.

7246VXR# show cable modem

Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable4/0/U0 7    online     2813    0.00  7   0   10.1.4.7        0002.1685.b5db
Cable4/0/U0 8    online     2809    0.25  7   0   10.1.4.10       0002.fdfa.0a63
Cable4/0/U0 9    online     2288   -0.25  5   1   10.1.4.66       0010.7bed.9b23
Cable4/0/U0 10   online(d)  2287    0.50  6   0   10.1.4.65       0010.7bed.9b45
Cable4/0/U0 11   online     2809   -0.50  7   0   10.1.4.6        0001.64ff.e47d
Cable4/0/U0 12   online     2812   -0.50  7   0   10.1.4.9        0004.2752.ddd5

Заметьте эти факты:

  • Кабельный модем 0010.7bed.9b23 получил IP-адрес 10.4.1.66, как задано в см-0010.7bed.9b23 области. Имеется присоединенный к нему компьютер, и он получает IP-адреса из пула pcs-c4.

  • Кабельный модем 0010.7bed.9b23 имеет другой QoS.

  • Кабельный модем 0010.7bed.9b45 получил IP-адрес 10.1.4.65, как указано в области cm-0010.7bed.9b45. Существует компьютер, подключенный к нему; значение CPE, однако, 0, потому что это сервис запрещено.

  • Онлайновое Состояние 0010.7bed.9b45 является онлайновым (d), что означает, что кабельный модем прибывает онлайн, но запрещен доступ к кабельной сети.

    Считайте эти выходные данные от команды debug cable mac log verbose выполненными на кабельном модеме:

    21:52:16:  78736.550 CMAC_LOG_RESET_RANGING_ABORTED              
    21:52:16:  78736.554 CMAC_LOG_STATE_CHANGE                       reset_interface_state
    21:52:16:  78736.558 CMAC_LOG_STATE_CHANGE                       reset_hardware_state
    21:52:17:  78737.024 CMAC_LOG_STATE_CHANGE                       wait_for_link_up_state
    21:52:17:  78737.028 CMAC_LOG_DRIVER_INIT_IDB_RESET              0x082B9CA8
    21:52:17:  78737.032 CMAC_LOG_LINK_DOWN                          
    21:52:17:  78737.034 CMAC_LOG_LINK_UP                            
    21:52:17:  78737.040 CMAC_LOG_STATE_CHANGE                       ds_channel_scanning_state
    21:52:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to down
    21:52:18:  78738.386 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:19:  78739.698 CMAC_LOG_DS_64QAM_LOCK_ACQUIRED             747000000
    21:52:19:  78739.702 CMAC_LOG_DS_CHANNEL_SCAN_COMPLETED          
    21:52:19:  78739.704 CMAC_LOG_STATE_CHANGE                       wait_ucd_state
    21:52:20:  78740.368 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.396 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:22:  78742.398 CMAC_LOG_ALL_UCDS_FOUND                     
    21:52:22:  78742.402 CMAC_LOG_STATE_CHANGE                       wait_map_state
    21:52:22:  78742.406 CMAC_LOG_FOUND_US_CHANNEL                   1
    21:52:24:  78744.412 CMAC_LOG_UCD_MSG_RCVD                       1
    21:52:24:  78744.416 CMAC_LOG_UCD_NEW_US_FREQUENCY               39984000
    21:52:24:  78744.420 CMAC_LOG_SLOT_SIZE_CHANGED                  8
    21:52:24:  78744.500 CMAC_LOG_UCD_UPDATED                        
    21:52:24:  78744.560 CMAC_LOG_MAP_MSG_RCVD                       
    21:52:24:  78744.564 CMAC_LOG_INITIAL_RANGING_MINISLOTS          41
    21:52:24:  78744.566 CMAC_LOG_STATE_CHANGE                       ranging_1_state
    21:52:24:  78744.570 CMAC_LOG_RANGING_OFFSET_SET_TO              9610
    21:52:24:  78744.574 CMAC_LOG_POWER_LEVEL_IS                     55.0  dBmV (commanded)
    21:52:24:  78744.578 CMAC_LOG_STARTING_RANGING                   
    21:52:24:  78744.580 CMAC_LOG_RANGING_BACKOFF_SET                0
    21:52:24:  78744.586 CMAC_LOG_RNG_REQ_QUEUED                     0
    21:52:24:  78744.622 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:24:  78744.626 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:24:  78744.628 CMAC_LOG_RNG_RSP_SID_ASSIGNED               10
    21:52:24:  78744.632 CMAC_LOG_ADJUST_RANGING_OFFSET              2286
    21:52:24:  78744.636 CMAC_LOG_RANGING_OFFSET_SET_TO              11896
    21:52:24:  78744.638 CMAC_LOG_STATE_CHANGE                       ranging_2_state
    21:52:24:  78744.644 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:25:  78745.654 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:25:  78745.658 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:25:  78745.660 CMAC_LOG_RANGING_SUCCESS                    
    21:52:25:  78745.680 CMAC_LOG_STATE_CHANGE                       dhcp_state
    21:52:25:  78745.820 CMAC_LOG_DHCP_ASSIGNED_IP_ADDRESS           10.1.4.65
    21:52:25:  78745.824 CMAC_LOG_DHCP_TFTP_SERVER_ADDRESS           10.1.4.1
    21:52:25:  78745.826 CMAC_LOG_DHCP_TOD_SERVER_ADDRESS            10.1.4.1
    21:52:25:  78745.830 CMAC_LOG_DHCP_SET_GATEWAY_ADDRESS           
    21:52:25:  78745.834 CMAC_LOG_DHCP_TZ_OFFSET                     -28800
    21:52:25:  78745.836 CMAC_LOG_DHCP_CONFIG_FILE_NAME              disable.cm
    21:52:25:  78745.840 CMAC_LOG_DHCP_ERROR_ACQUIRING_SEC_SVR_ADDR  
    21:52:25:  78745.846 CMAC_LOG_DHCP_COMPLETE                      
    21:52:25:  78745.968 CMAC_LOG_STATE_CHANGE                       establish_tod_state
    21:52:25:  78745.978 CMAC_LOG_TOD_REQUEST_SENT                   
    21:52:26:  78746.010 CMAC_LOG_TOD_REPLY_RECEIVED                 3192525217
    21:52:26:  78746.018 CMAC_LOG_TOD_COMPLETE                       
    21:52:26:  78746.020 CMAC_LOG_STATE_CHANGE                       security_association_state
    21:52:26:  78746.024 CMAC_LOG_SECURITY_BYPASSED                  
    21:52:26:  78746.028 CMAC_LOG_STATE_CHANGE                       configuration_file_state
    21:52:26:  78746.030 CMAC_LOG_LOADING_CONFIG_FILE                disable.cm
    21:52:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface cable-modem0, changed state to up
    21:52:27:  78747.064 CMAC_LOG_CONFIG_FILE_PROCESS_COMPLETE       
    21:52:27:  78747.066 CMAC_LOG_STATE_CHANGE                       registration_state
    21:52:27:  78747.070 CMAC_LOG_REG_REQ_MSG_QUEUED                 
    21:52:27:  78747.076 CMAC_LOG_REG_REQ_TRANSMITTED                
    21:52:27:  78747.080 CMAC_LOG_REG_RSP_MSG_RCVD                   
    21:52:27:  78747.082 CMAC_LOG_COS_ASSIGNED_SID                   1/10
    21:52:27:  78747.088 CMAC_LOG_RNG_REQ_QUEUED                     10
    21:52:27:  78747.090 CMAC_LOG_NETWORK_ACCESS_DENIED
    21:52:27:  78747.094 CMAC_LOG_REGISTRATION_OK                    
    21:52:27:  78747.096 CMAC_LOG_STATE_CHANGE                       establish_privacy_state
    21:52:27:  78747.100 CMAC_LOG_PRIVACY_NOT_CONFIGURED             
    21:52:27:  78747.102 CMAC_LOG_STATE_CHANGE                       maintenance_state
    21:52:31:  78751.122 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:31:  78751.124 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:37:  78757.164 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:37:  78757.168 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:43:  78763.206 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:43:  78763.210 CMAC_LOG_RNG_RSP_MSG_RCVD                   
    21:52:49:  78769.250 CMAC_LOG_RNG_REQ_TRANSMITTED                
    21:52:49:  78769.252 CMAC_LOG_RNG_RSP_MSG_RCVD

    Выходные данные этой команды отладки свидетельствуют об ОТКАЗЕ в доступе к сети.

Ubr7100# show cable modem detail

Interface   SID  MAC address    Max CPE  Concatenation  Rx SNR
Cable1/0/U0 7    0002.1685.b5db 10       yes            33.52
Cable1/0/U0 8    0002.fdfa.0a63 10       yes            33.24
Cable1/0/U0 9    0010.7bed.9b23 1        no             33.29
Cable1/0/U0 10   0010.7bed.9b45 1        no             33.23
Cable1/0/U0 11   0001.64ff.e47d 10       yes            33.20
Cable1/0/U0 12   0004.2752.ddd5 10       yes            33.44

Заметьте, что CPE Max для кабельных модемов с особыми областями действия равняется 1, и остальным 10 лет. Если вы видите platinum.cm конфигурации области, он имеет 10 заданных CPE; с другой стороны, область disable.cm имеет только 1 заданный CPE. Предварительно сконфигурированный файл конфигурации DOCSIS silver.cm имеет также только 1 заданный CPE.

Ubr7111# show interface cable 1/0 modem 0

SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.1.4.7      dhcp      0002.1685.b5db
8     00         modem     up        10.1.4.10     dhcp      0002.fdfa.0a63
9     00         host      unknown   172.16.29.2   static    00c0.4f97.61c5
9     00         modem     up        10.1.4.66     dhcp      0010.7bed.9b23
10    00         modem     up        10.1.4.65     dhcp      0010.7bed.9b45
11    00         modem     up        10.1.4.6      dhcp      0001.64ff.e47d
12    00         modem     up        10.1.4.9      dhcp      0004.2752.ddd5

Чтобы проверить, что кабельные модемы получают корректный уровень обслуживания, выполните команду show cable qos profile.

Ubr7111# show cable qos profile

ID  Prio Max       Guarantee Max        Max   TOS  TOS   Create  B     IP prec.
         upstream  upstream  downstream tx    mask value by      priv  rate
         bandwidth bandwidth bandwidth  burst                    enab  enab
1   0    0         0         0          0     0x0  0x0   cmts(r) no    no
2   0    64000     0         1000000    0     0x0  0x0   cmts(r) no    no
3   7    31200     31200     0          0     0x0  0x0   cmts    yes   no
4   7    87200     87200     0          0     0x0  0x0   cmts    yes   no
5   4    64000     0         512000     0     0x0  0x0   cm      no    no
6   0    1000      0         1600000    0     0x0  0x0   cm      no    no
7   0    128000    10000     10000000   1600  0x0  0x0   cm      no    no
8   0    0         0         0          0     0x0  0x0   mgmt    no    no
10  0    0         0         0          0     0x0  0x0   mgmt    no    no
12  0    0         100000000 0          0     0x0  0x0   mgmt    no    no

Заметьте что ИДЕНТИФИКАТОР QOS 7 соответствий конфигурация на platinum.cm:

cable config-file platinum.cm
 service-class 1 max-upstream 128
 service-class 1 guaranteed-upstream 10
 service-class 1 max-downstream 10000
 service-class 1 max-burst 1600
 cpe max 10
 timestamp

То же самое происходит с настройкой DOCSIS disable.cm:

Ubr7111# show ip dhcp binding

IP address       Hardware address        Lease expiration        Type
10.1.4.6         0100.0164.ffe4.7d       Mar 08 2001 07:58 AM    Automatic
10.1.4.7         0100.0216.85b5.db       Mar 08 2001 07:58 AM    Automatic
10.1.4.9         0100.0427.52dd.d5       Mar 08 2001 07:58 AM    Automatic
10.1.4.10        0100.02fd.fa0a.63       Mar 08 2001 08:36 AM    Automatic
10.1.4.65        0100.107b.ed9b.45       Infinite                Manual
10.1.4.66        0100.107b.ed9b.23       Infinite                Manual

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 29243