Видео и доставка контента : Универсальные широкополосные маршрутизаторы Cisco серии uBR7100

Настройка UBR 7100 в режиме моста

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ детализирует конфигурацию uBR7100 и Cisco Network Registrar для сети с мостовыми подключениями. В отличие от uBR7200, uBR7100 может использоваться в качестве моста. Конфигурация мостов состоит из отключения IP routing, помещения всех интерфейсов в одной группе мостов и настройки кабельного сопряжения. В этой конфигурации функции маршрутизации сделаны на шлюзе/маршрутизаторе uBR7100. Так как функции маршрутизации не сделаны на uBR7100, конфигурация оптимизирована. Конфигурация мостов помещает сервер Cisco Network Registrar (CNR) на ту же сеть как CMTS и кабельные модемы. CNR может находиться позади шлюза/маршрутизатора, когда шлюз настроен со вспомогательным IP - адресом для маршрутизации широковещательных сообщений между кабельными модемами и CNR.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

У читателя должно быть основное понимание протокола DOCSIS и Cisco командная строка IOS� на маршрутизаторах семейства uBR.

Используемые компоненты

Эта конфигурация разрабатывалась и проверялась с помощью придерживающегося:

  • Универсальные широкополосные маршрутизаторы Cisco серии uBR7100 рабочая версия Cisco IOS 12.10EC1

  • Cisco Network Registrar (CNR) рабочий V 5.5

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

Основы DOCSIS

От клиента предполагаемый DOCSIS является "plug and play (включай и работай)", означая, что кабельный модем автоматически настроен от сети. Когда кабель будет включен впервые, он просмотрит нисходящего для несущей DOCSIS. Модем соединится к первой несущей DOCSIS, которую он обнаруживает. Дескриптор восходящего канала (от абонента к оператору) (UCD), который чтения кабельного модема от несущей несущей, говорит модем, как передать. UCD имеет параметры прямого исправления ошибок (FEC), частоту канала от абонента к оператору, тип модуляции и скорость передачи в цифровых системах. Как только кабельный модем и CMTS договариваются о соответствующем уровне передачи, модем будет инициировать процесс Протокола DHCP (динамического конфигурирования узла). Сервер CNR должен услышать, что модемы обнаруживают. Модем и сервер CNR будут обмениваться последовательностью сообщений, которые приводят к модему, имеющему возможность подключения с помощью IP-адреса к остатку сети. Как только модем имеет возможность подключения с помощью IP-адреса, это может запросить Время дня (ToD) и загрузить его файл настройки кабельного модема. Как только модем настроен, он передаст запрос регистрации к CMTS. Если Базовая приватность (BPI) в CMTS, которую � не включен, модем зарегистрируется, если BPI будет включен, то модем будет обмениваться ключами шифрования с CMTS прежде чем быть полностью зарегистрированным.

Понятие режима моста

В мостовом режиме все интерфейсы на CMTS настроены в одной группе мостов. Все интерфейсы, привязанные к группе мостов, считают частью широковещательного домена. Это означает, что каждое устройство, привязанное к одному из этих интерфейсов, услышит широковещательные сообщения от всех устройств в группе мостов. Это удобно, так как мы можем поместить сервер CNR, CMTS и кабельные модемы в той же сети. Когда широковещательные сообщения кабельного модема, DHCP обнаруживает кабельное сопряжение на CMTS, передадут его другим интерфейсам в группе мостов. Так как сервер CNR находится в той же группе мостов, которую он услышит, что DHCP обнаруживает и ответит предложением DHCP. Впоследствии, модем получит ToD (или от внешнего сервера в группе мостов или от CMTS, настроенного, чтобы быть сервером ToD) и его файл конфигурации через Протокол TFTP и регистр с CMTS.

Настройка

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

http://www.cisco.com/c/dam/en/us/support/docs/video/ubr7100-series-universal-broadband-routers/24544-ubr7100-bridging-24544-1.gif

Рис. 1

Конфигурации

В данном документе используются следующие конфигурации.

Конфигурация разделена на две части: конфигурация Сервера CNR и конфигурация CMTS. CNR используется, чтобы назначить IP-адрес через DHCP и дать модемам информацию о сетевом подключении, которой они требуют к элементам ключа доступа сети. В разделе конфигурации CMTS uBR7100 настроен, чтобы зарегистрировать кабельные модемы и передать трафик кабельного модема к остатку LAN.

Конфигурация CNR

CNR Настройки состоит из настройки политики и областей для кабельных модемов и хостов. Политика является списком параметров DHCP, которые привязаны к области. Областями являются Диапазоны IP-адресов, которые должны быть назначены на сеть.

Создайте политику для кабельных модемов

  1. Запустите программу CNR и войдите. �Click на DHCP server.

    ubr7100_bridging_24544_2.gif

    Рис. 2

  2. Нажмите SHOW PROPERTIES button на панели Диспетчера серверов. �

  3. Щелкните по вкладке POLICIES. Политику в данном примере называют bb-ubr7114-1a. �

  4. Выберите NEW для создания новой политики.

  5. Под опциями edit добавляют придерживающиеся параметры DHCP:

    1. Dhcp-lease-time – Это - время аренды в секундах. В данном примере время аренды 604800 (который является кол-вом секунд в 7 дневных периодах). Обратите внимание на то, что в данном примере мы приняли решение сделать те арендные договоры постоянными путем проверки, что арендный договор является постоянной коробкой. �

    2. Маршрутизаторы – Это - адрес IP-шлюза. Для данного примера IP-адрес 14.66.1.1.

    3. tftp-server – Это - адрес TFTP server. Для данного примера адрес 14.66.1.1, который совпадает с IP-адресом сервера CNR. Обратите внимание на то, что каталог по умолчанию для подаваемые файлы на Платформе Windows является Программой Files\Network Registrar\Data\TFTP.

    4. log-server – Адрес для регистрации сообщений DHCP server. В данном примере это 14.66.1.1 (сервер CNR).

    5. time-server – сервер внешнего времени может быть использованием. В нашем примере CMTS действует как временной сервер 14.66.1.1.

    6. временной сдвиг – Это - время смещения от GMT в секундах. В данном примере сдвиг времени 18000.

    7. packet-file-name – Эта опция детализирует название файла см, который будет использоваться. В нашем примере используется gold.cm.

    ubr7100_bridging_24544_3.gif

    Рис. 3

Создайте область для кабельных модемов

  1. Щелкните по DHCP server. �

  2. Щелкните по кнопке Add Панель Диспетчера серверов.

    http://www.cisco.com/c/dam/en/us/support/docs/video/ubr7100-series-universal-broadband-routers/24544-ubr7100-bridging-24544-4.gif

    Рис. 4

  3. В Добавить коробке Области, которая раскрывается, назначают название к области.

  4. От политики выпадающий выбор политика, которая была создана для этой области.

  5. Введите сеть в Сетевой пробел. Для данного примера номер сети 14.66.1.0.

  6. Введите маску подсети для сети в пробеле Маски подсети. Для данного примера маска подсети 255.255.255.0.

  7. Введите первые и последние IP-адреса в коробки Стартового адреса и Конечного адреса. В данном примере первый адрес был бы 14.66.1.245, и последнее будет 14.66.1.254.

ubr7100_bridging_24544_5.gif

Рис. 5

Конфигурация CMTS

К uBR7100 Series маршрутизаторам прилагается созданный в преобразователе с повышением частоты. Внешний преобразователь частоты может использоваться рабочими выходными данными IF от порта DS0 до внешнего преобразователя частоты. В данном примере используется внутренний преобразователь сигнала с повышением частоты.

Примечание: Для получения дополнительной информации о настройке интегрированного преобразователя частоты обратитесь к Установке Интегрированного преобразователя частоты в Настройке Интерфейс кабеля Cisco для uBR7100 документации.

Так как эта конфигурация была выполнена в лабораторной среде, настройка RF была довольно проста. RF и измерения настройки выходят за рамки этого документа, и читатель отнесен в Соединение и Настройку документация Головной станции кабельной сети для надлежащей настройки RF и измерения и в соответствии со спецификацией DOCSIS (SP-RFI-IO5-991105 или более поздний пересмотр).

Настройка Cisco IOS

  1. Настройте имя хоста на CMTS.

  2. Настройте enable password на CMTS.

  3. Настройте пароль на линиях VTY.

  4. Отключите IP routing путем выполнения команды no ip routing.

  5. Настройте IP-адрес на Ethernet интерфейса быстрого 0/0.

  6. Настройте мостовое соединение на Интерфейсе Fast Ethernet с командой bridge-group.

  7. Отключите связующее дерево на Fast Ethernet 0/0 с командой bridge-group spanning-disabled.

  8. На интерфейсном кабеле 1/0 настраивают преобразователь с повышением частоты:

    1. Включите преобразователь, не выполняя cable downstream rf-shutdown.

    2. Установите нисходящую частоту с командой cable downstream frequency. Следует иметь в виду, что частота находится в Герц. Необходимо использовать стандартную частоту канала NTSC CATV.

    3. Установите питание нисходящего канала с командой cable downstream rf-power.

    4. Активируйте линейную карту, не выполняя завершение.

    5. Активируйте восходящий, не выполняя кабель в восходящем направлении 0 завершений.

    6. Установите частоту канала от абонента к оператору с командой cable upstream frequency.

    7. Установите ширину восходящего канала (от абонента к оператору) с помощью команды cable upstream channel-width.

  9. Настройте мостовое соединение на Интерфейсном кабеле 1/0.

  10. Отключите связующее дерево на Кабеле 1/0.

Имя устройства (маршрутизатор Cisco 1600)
version 12.1
       no service pad
       service timestamps debug datetime msec localtime
       service timestamps log datetime
       no service password-encryption
       enable password cisco
       service udp-small-servers max-servers no-limit
       service tcp-small-servers max-servers no-limit
       !
       hostname ubr7100
       !
       cable time-server
       !
       clock timezone PST -9
       clock calendar-valid
       ip subnet-zero
       no ip routing 
!--Disable IP routing, enabled by default 

       no ip domain-lookup
       !
       interface FastEthernet0/0
       ip address 14.66.1.2 255.255.255.0
       no ip route-cache
       no ip mroute-cache
       no keepalive
       duplex half
       speed auto
       no cdp enable
       bridge-group 1
       bridge-group 1 spanning-disabled
       !
       interface FastEthernet0/1
       ip address 14.66.1.2 255.255.255.0
       no ip route-cache
       no ip mroute-cache
       shutdown 
!-- Not connected
 
       duplex auto
       speed 10
       no cdp enable
       bridge-group 1
       bridge-group 1 spanning-disabled
       !
       interface Cable1/0
       ip address 14.66.1.2 255.255.255.0
       no ip route-cache
       no ip mroute-cache
       load-interval 30
       no keepalive
       cable downstream annex B
       cable downstream modulation 256qam 
!-- for a non-lab environment 64 QAM is suggested

       cable downstream interleave-depth 32
       cable downstream frequency 525000000 
!-- This is a required line for the uBR7100

       no cable downstream rf-shutdown 
!-- This line turns on the internal upconverter.

       cable downstream rf-power 55 
!-- This line specifies the CMTS's transmit level.

       cable upstream 0 frequency 17808000 
!-- This line configures the frequency specified in the UCD

       cable upstream 0 power-level 0
       cable upstream 0 channel-width 3200000
       no cable upstream 0 shutdown 
!-- This line turns the upstream receiver on.

       bridge-group 1 
!-- This line configure bridging on the cable interface.

       bridge-group 1 subscriber-loop-control
       bridge-group 1 spanning-disabled
       !
       ip default-gateway 14.66.1.1
       ip classless
       no ip http server
       !
       no cdp run
       alias exec scm show cable modem
       !
       line con 0
       exec-timeout 0 0
       privilege level 15
       length 0
       line aux 0
       line vty 0 4
       password cisco
       no login
       !
       end

Проверка.

Примечание: Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

show cable modem отобразит все модемы, которые связались с CMTS и информацией, касающейся состояния модема в процессе регистрации. Выходные данные этой команды являются снимком. В теории, если эта команда выполняется последовательно, вы видите, что модем развивается от Init (r1) к онлайн-статусу. В примере ниже BPI включен.

ubr7100#show cable modem
 Interface Prim Online Timing Rec QoS CPE IP address MACaddress
 Sid State Offset Power 
 Cable1/0/U0 1 online(pt) 1551 0.00 5 0  14.66.1.245 0050.7366.1e69
 Cable1/0/U0 2 online(pt) 1920 -0.75 5 0 14.66.1.252 0006.2854.72db
 Cable1/0/U0 3 online(pt) 1549 0.25 5 0  14.66.1.250 0050.7366.1e6d
 Cable1/0/U0 4 online(pt) 1548 -0.25 5 0 14.66.1.251 0050.7366.1e41

Проверка арендного договора в CNR

Чтобы подтвердить, что IP-адреса вручаются кабельному модему, перейдите к вкладке Lease для области. Подтвердите, что раздаются IP-адреса. Этот раздел отображает IP - блок и его сведения аренды. Выходные данные являются снимком. Для обновления информации поразите Кнопку раскрытия списка Обновления.

ubr7100_bridging_24544_6.gif

Рис. 6

Если модемы, подключенные к CMTS, не регистрируются, см. Устраняя неполадки Кабельных модемов uBR, Не Прибывающих Онлайн.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 24544