Коммутаторы : Мультисервисные коммутируемые маршрутизаторы Cisco Catalyst серии 8500

Конфигурирование многоадресной маршрутизации IP через модуль маршрутизации ATM (ARM) на коммутаторе Cisco Catalyst 8540 MSR

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Когда сети увеличиваются в размере, маршрутизация групповой IP-адресации становится критически важной как средство определить, какие сегменты требуют многоадресного трафика и которые не делают. Групповая IP-адресация является способом маршрутизации, который позволяет IP - трафику распространиться от одного источника до многих назначений, или от многих источников до многих назначений. Вместо того, чтобы передавать один пакет каждому назначению, один пакет передан к группе многоадресной рассылки, определенной одиночным групповым адресом IP - адреса назначения.

В данном документе описывается порядок конфигурации многоадресной IP-маршрутизации с использованием модуля ATM Router Module (ARM) на коммутаторах Catalyst 8540 MSR. Данная конфигурация поддерживается на ARM и на расширенном ARM (ARM I и ARM II соответственно).

Предварительные условия

Требования

Читатели данного документа должны хорошо разбираться в основных многоадресных конфигурациях IP в маршрутизаторах Cisco. Для общих сведений обратитесь к этим документам:

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Cisco 3600, 7200, и маршрутизаторы серии "7500" рабочая Cisco Выпуск ПО IOS� 12.1. (7)

  • MSR Catalyst 8540 и MSR Catalyst 8510 рабочий EY программного обеспечения Cisco IOS версии 12.1(7)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме:

/image/gif/paws/19244/arm-mul.gif

Маршрутизатор Cisco 3640, известный как C3640, связан с Cisco Catalyst 8540 MSR (известный как 8540MSR) через Порт Fast Ethernet 3/0/1. 8540MSR имеет ARM на SLOT 11. C8540MSR физически связан с 8510MSR использование interface atm 9/1/0. Коммутатор 8510MSR ATM подключается к 8540MSR на интерфейсе ATM 1/0/2.

Существует два постоянных виртуальных канала (PVCs), созданный через 8510MSR. Один постоянный виртуальный канал - от подчиненного многоточечного интерфейса 8540MSR ARM к маршрутизатору C7513, а другой – от того же подчиненного многоточечного интерфейса 8540MSR ARM к маршрутизатору C7204. Использованный протокол маршрутизации - OSPF (Open Shortest Path First). Независимая от IP-протокола групповая адресация (протокол PIM) (PIM) режим уплотнения настроена на маршрутизаторах. Это включает модуль ARM на 8540MSR. C3640, C7513 и C7204 настроили один интерфейс для присоединения к группе многоадресной рассылки 239.0.10.1. Эхо-запрос от C3640 до адреса групповой адресации 239.0.10.1 получает ответы от C3640, C7513 и C7204.

Конфигурации

Этот раздел содержит блоки конфигурации маршрутизаторов и коммутаторов, описанных на схеме сети. Несколько специфичных сведений о конфигурации:

  • Конфигурация, которая появляется в этом документе, использует aal5mux инкапсуляции.

  • В то время как постоянные виртуальные каналы ATM настроены к удаленным узлам, многоточечный подчиненный интерфейс создан на ARM.

  • PIM используется в режиме уплотнения. Насколько PIM затронут, ARM не дифференцируется между отдельными VC на многоточечном интерфейсе.

  • Многоадресный трафик передан всем VC, которые "передали" настроенный.

  • Выход show ip mroute показывает, что PIM идентифицирует только исходящий интерфейс, а не отдельные VCs.

Конфигурацию для маршрутизации групповой IP-адресации с помощью PIM показывают здесь. Все подходящие команды для маршрутизации групповой IP-адресации показывают полужирным.

C3640
ip multicast-routing
!
interface Ethernet1/0
 ip address 10.10.200.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 239.0.10.1
 half-duplex
!
!
router ospf 1
 log-adjacency-changes
 network 10.10.200.0 0.0.0.255 area 0
!

C8540MSR
ip multicast-routing
!
interface FastEthernet3/0/1
 ip address 10.10.200.2 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 no ip mroute-cache
!
!
interface ATM11/0/0.1 multipoint
 ip address 75.75.75.2 255.255.255.0
 ip pim dense-mode
 ip ospf network point-to-multipoint
 map-group multicast
 atm pvc 2 1000 pd on  encap aal5mux ip interface  ATM9/1/0 0 1000 
 atm pvc 2 1001 pd on  encap aal5mux ip interface  ATM9/1/0 0 1001 
!
!
router ospf 1
 log-adjacency-changes
 network 10.10.200.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.1 atm-vc 1000 aal5mux broadcast
 ip 75.75.75.3 atm-vc 1001 aal5mux broadcast

8510MSR
interface ATM1/0/2
 no ip address
 atm pvc 0 1000  interface  ATM1/0/1 0 1000 
!         
interface ATM1/0/3
 no ip address
 atm pvc 0 1001  interface  ATM1/0/2 0 1001 
! 

C7513
ip multicast-routing
!
!         
interface Ethernet9/0/2
 ip address 30.30.30.1 255.255.255.0
 ip pim dense-mode
 ip igmp join-group 239.0.10.1
!
interface ATM1/0/0.1 multipoint
 ip address 75.75.75.1 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 ip ospf network point-to-multipoint
 no ip mroute-cache
 map-group multicast
 atm pvc 1000 0 1000 aal5mux ip
!
!
router ospf 1
 log-adjacency-changes
 network 30.30.30.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.2 atm-vc 1000 broadcast
!

C7204
ip multicast-routing
!
interface Loopback0
 ip address 40.40.40.1 255.255.255.0
 ip igmp join-group 239.0.10.1
!
!
interface ATM4/0.5 multipoint
 ip address 75.75.75.3 255.255.255.0
 ip pim dense-mode
 no ip route-cache
 ip ospf network point-to-multipoint
 no ip mroute-cache
 map-group multicast
 atm pvc 1 0 1001 aal5mux ip
!
router ospf 1
 log-adjacency-changes
 network 40.40.40.0 0.0.0.255 area 0
 network 75.75.75.0 0.0.0.255 area 0
!
map-list multicast
 ip 75.75.75.2 atm-vc 1 broadcast

Проверка

Чтобы проверить правильность работы сети, воспользуйтесь такой командой:

Некоторые команды show поддерживаются интерпретатором выходных данных (только для зарегистрированных пользователей). Это позволяет просмотреть анализ выходных данных команды show.

  • show ip route — отображаются элементы таблицы IP-маршрутизации.

  • show ip pim neighbor соседей PIM, обнаруженных программным обеспечением Cisco IOS₩½.

  • show ip mroute содержание таблицы маршрутизации групповой IP-адресации.

  • show ip igmp groups группы многоадресной рассылки, которые напрямую подключаются к маршрутизатору и которые изучены через IGMP.

Эти выходные данные являются результатом команд show на устройствах, показанных в схеме сети. Эти выходные данные показывают, что сеть работает правильно.

C3640

Команду show ip route используют на C3640, чтобы убедиться, что этот маршрутизатор достигает всех сетевых IP-адресов. Это имеет маршрут к 75.75.75.1, 75.75.75.2, 75.75.75.3. Интерфейсы обратной связи определены. Все маршруты найдены через OSPF.

C3640#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/12] via 10.10.200.2, 00:01:48, Ethernet1/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.200.0 is directly connected, Ethernet1/0
     75.0.0.0/32 is subnetted, 3 subnets
O       75.75.75.3 [110/11] via 10.10.200.2, 00:01:48, Ethernet1/0
O       75.75.75.2 [110/10] via 10.10.200.2, 00:01:48, Ethernet1/0
O       75.75.75.1 [110/11] via 10.10.200.2, 00:01:48, Ethernet1/0
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/21] via 10.10.200.2, 00:01:49, Ethernet1/0

Данная команда используется для определения соседей IP PIM. Соседний узел в этом случае является C8540MSR.

C3640#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface          Uptime/Expires    Ver   DR
Address                                                      Priority/Mode
10.10.200.2       Ethernet1/0        3d03h/00:01:16    v2    N / DR

Если группа многоадресной рассылки пропингована от C3640, это успешно. Это свидетельствует о том, что C3640 выполняет многоадресную групповую рассылку по IP-адресу 239.0.10.1.

C3640#ping 239.0.10.1  

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.0.10.1, timeout is 2 seconds:
Reply to request 0 from 10.10.200.1, 4 ms
Reply to request 0 from 75.75.75.3, 4 ms
Reply to request 0 from 75.75.75.1, 4 ms

Команда show ip mroute отображает информацию о таблице многоадресной маршрутизации. В данном примере существует пустой маршрут для 239.0.10.1 и 224.0.1.40. Последний адрес многоадресной рассылки – назначенный Агентством по выделению имен и уникальных параметров протоколов Internet (IANA) для cisco-rp-discovery.

C3640#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Advertised via MSDP, U - URD,
       I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 2d23h/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet1/0, Forward/Dense, 2d23h/00:00:00

(*, 239.0.10.1), 1w1d/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet1/0, Forward/Dense, 2d23h/00:00:00
(10.10.200.1, 239.0.10.1), 00:02:37/00:00:22, flags: PCLTA
  Incoming interface: Ethernet1/0, RPF nbr 0.0.0.0
  Outgoing interface list: Null

Проверьте Группы IGMP IP с помощью команды show ip igmp groups. И IP-адрес групповой адресации cisco-rp-discovery и группа многоадресной рассылки igmp, что обнаружены соединения C3640.

C3640#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface            Uptime    Expires   Last Reporter
224.0.1.40       Ethernet1/0          3d00h     00:02:38  10.10.200.2
239.0.10.1       Ethernet1/0          1w1d      00:02:44  10.10.200.1

C8540MSR

Те же show-команды используются в коммутаторе C8540MSR Catalyst, как аналогичные в C3460. Команда show ip route показывает, что C8540MSR достигает всех подсетей сети.

C8540MSR#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/2] via 75.75.75.3, 01:25:34, ATM11/0/0.1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, Ethernet0
C       10.10.200.0 is directly connected, FastEthernet3/0/1
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.3/32 [110/1] via 75.75.75.3, 01:25:34, ATM11/0/0.1
O       75.75.75.1/32 [110/1] via 75.75.75.1, 01:25:34, ATM11/0/0.1
C       75.75.75.0/24 is directly connected, ATM11/0/0.1
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/11] via 75.75.75.1, 01:25:35, ATM11/0/0.1
S*   0.0.0.0/0 [1/0] via 10.118.1.21

Команда how ip pim neighbor отображает многоадресное окружение. В случае C8540MSR соседние узлы IP PIM являются C3640 (10.10.200.1), C7513 (75.75.75.1) и C7204 (75.75.75.3).

C8540MSR#show ip pim neighbor 
PIM Neighbor Table
Neighbor Address  Interface                Uptime    Expires   Ver  Mode
10.10.200.1       FastEthernet3/0/1        3d02h     00:01:25  v2   
75.75.75.3        ATM11/0/0.1              00:12:11  00:01:33  v2    (DR)
75.75.75.1        ATM11/0/0.1              00:18:43  00:01:32  v2

Команда show ip mroute выводит информацию о таблице многоадресной маршрутизации. В этом примере показано, что имеется пустой маршрут для 239.0.10.1 и 224.0.1.40. Последний адрес широковещания выделяется IANA для обнаружения cisco-rp.

C8540MSR#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, s - SSM Group, C - Connected, L - Local,
       P - Pruned, R - RP-bit set, F - Register flag, T - SPT-bit set,
       J - Join SPT, M - MSDP created entry, X - Proxy Join Timer Running
       A - Advertised via MSDP, U - URD, I - Received Source Specific Host
           Report 
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 3d03h/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 01:33:56/00:00:00
    FastEthernet3/0/1, Forward/Dense, 3d03h/00:00:00

(*, 239.0.10.1), 3d03h/00:02:59, RP 0.0.0.0, flags: DJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 01:33:56/00:00:00
    FastEthernet3/0/1, Forward/Dense, 3d03h/00:00:00

(10.10.200.1, 239.0.10.1), 00:00:17/00:02:49, flags: CT
  Incoming interface: FastEthernet3/0/1, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM11/0/0.1, Forward/Dense, 00:00:19/00:00:00

C7513

Описания и пояснения для команд, приведенные здесь, те же самые, что для C3640 и C8540MSR.

C7513#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/32 is subnetted, 1 subnets
O       40.40.40.1 [110/3] via 75.75.75.2, 02:05:04, ATM1/0/0.1
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, Ethernet9/0/1
O       10.10.200.0 [110/2] via 75.75.75.2, 02:05:04, ATM1/0/0.1
     11.0.0.0/24 is subnetted, 2 subnets
C       11.12.12.0 is directly connected, Serial0/0/0/2:2
C       11.11.11.0 is directly connected, Serial0/0/0/1:1
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.3/32 [110/2] via 75.75.75.2, 02:05:05, ATM1/0/0.1
O       75.75.75.2/32 [110/1] via 75.75.75.2, 02:05:05, ATM1/0/0.1
C       75.75.75.0/24 is directly connected, ATM1/0/0.1
     30.0.0.0/24 is subnetted, 1 subnets
C       30.30.30.0 is directly connected, Ethernet9/0/2
S*   0.0.0.0/0 [1/0] via 10.118.1.21
C7513#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
75.75.75.2        ATM1/0/0.1               04:28:34/00:01:18 v2    N / DR
C7513#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 22:03:58/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 22:03:58/00:00:00
    ATM1/0/0.1, Forward/Dense, 04:28:37/00:00:00

(*, 239.0.10.1), 22:03:58/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 22:03:58/00:00:00
    ATM1/0/0.1, Forward/Dense, 04:28:37/00:00:00

(10.10.200.1, 239.0.10.1), 00:00:51/00:02:08, flags: CLT
  Incoming interface: ATM1/0/0.1, RPF nbr 75.75.75.2
  Outgoing interface list:
    Ethernet9/0/2, Forward/Dense, 00:00:52/00:00:00
C7513#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter
224.0.1.40       Ethernet9/0/2        22:04:09  00:02:50  30.30.30.1
239.0.10.1       Ethernet9/0/2        22:04:15  00:02:50  30.30.30.1

C7204

Описания и пояснения для команд, приведенные здесь, те же самые, что для C3640 и C8540MSR.

C7204#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 10.118.1.21 to network 0.0.0.0
     40.0.0.0/24 is subnetted, 1 subnets
C       40.40.40.0 is directly connected, Loopback0
     10.0.0.0/24 is subnetted, 2 subnets
C       10.118.1.0 is directly connected, FastEthernet0/0
O       10.10.200.0 [110/2] via 75.75.75.2, 03:31:48, ATM4/0.5
     75.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O       75.75.75.2/32 [110/1] via 75.75.75.2, 03:31:48, ATM4/0.5
O       75.75.75.1/32 [110/2] via 75.75.75.2, 03:31:48, ATM4/0.5
C       75.75.75.0/24 is directly connected, ATM4/0.5
     30.0.0.0/24 is subnetted, 1 subnets
O       30.30.30.0 [110/12] via 75.75.75.2, 03:31:49, ATM4/0.5
S*   0.0.0.0/0 [1/0] via 10.118.1.21
C7204#show ip pim neighbor 
PIM Neighbor Table
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
75.75.75.2        ATM4/0.5                 03:32:29/00:01:23 v2    N /
C7204#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 05:20:47/00:00:00, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM4/0.5, Forward/Dense, 03:57:26/00:00:00

(*, 239.0.10.1), 03:31:41/00:00:00, RP 0.0.0.0, flags: DL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    ATM4/0.5, Forward/Dense, 03:31:41/00:00:00
7204#show ip igmp groups 
IGMP Connected Group Membership
Group Address    Interface                Uptime    Expires   Last Reporter
224.0.1.40       ATM4/0.5               05:20:53  00:02:24  75.75.75.3
239.0.10.1       Loopback0              23:33:52  stopped   40.40.40.1

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 19244