Широкополосные кабельные сети : Кабельные модемы

Невозможность подключения CPE

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ обсуждает некоторые наиболее распространенные причины, почему Customer Premises Equipment (CPE) — такой как ПК, выполняющий Windows 2000 или подобную операционную систему позади кабельного модема — неспособен получить IP-адрес или неспособен соединиться с Интернетом. Документ использует подход блок-схемы, чтобы вести вас через серию шагов устранять неполадки сети от стороны CPE или от Стороны головного узла.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Каким образом оборудование пользователя (CPE) получает IP-адрес?

После того, как кабельный модем подключается к сети, CPE позади кабельного модема пытается получить IP-адрес с помощью процесса Протокола DHCP (динамического конфигурирования узла). Клиент, как правило, передает Протокол начального загрузки (BOOTP) Запрос с набором параметра DHCP к DHCP DISCOVER, IP - адресу источника 0.0.0.0 и IP - адресу назначения 255.255.255.255. Этот пакет тогда передан к серверу DHCP системой терминирования кабельных модемов (CMTS). Переданный пакет имеет IP - адрес источника вторичного IP - адреса, настроенного на кабельном сопряжении, и имеет IP - адрес назначения сервера DHCP, как задано IP-адресом helper-address управляющего кабеля (см. пример конфигурации ниже).

Сервер DHCP отвечает ПРЕДЛОЖЕНИЕМ DHCP со многими опциями, включая “клиент-серверный назначенный IP - адрес”. Это передано назад к CPE CMTS. CPE мог бы тогда передать ЗАПРОС DHCP за назначенным IP - адресом. Ответ является ACK DHCP от сервера и от CPE с помощью назначаемого IP-адреса. Для наблюдения этого обмена выполните команду debug ip dhcp server packets для получения выходных данных, подобных этому, которое показывают ниже.

CPE mac address: 0010.a4e6.d04d 
CPE assigned IP address: 192.168.50.3 
DHCP Server IP address: 172.17.110.137 
5d20h: DHCPD: setting giaddr to 192.168.50.1. 
5d20h: DHCPD: BOOTREQUEST from 0100.10a4.e6d0.4d forwarded to 172.17.110.137.

!--- DHCP DISCOVER.

5d20h: DHCPD: forwarding BOOTREPLY to client 0010.a4e6.d04d.

!--- DHCP OFFER.
 
5d20h: DHCPD: creating ARP entry (192.168.50.3, 0010.a4e6.d04d). 
5d20h: DHCPD: unicasting BOOTREPLY to client 0010.a4e6.d04d (192.168.50.3). 
5d20h: DHCPD: setting giaddr to 192.168.50.1. 

5d20h: DHCPD: BOOTREQUEST from 0100.10a4.e6d0.4d forwarded to 172.17.110.137.

!--- DHCP REQUEST.

5d20h: DHCPD: forwarding BOOTREPLY to client 0010.a4e6.d04d.

!--- DHCP ACK.
 
5d20h: DHCPD: creating ARP entry (192.168.50.3, 0010.a4e6.d04d). 
5d20h: DHCPD: unicasting BOOTREPLY to client 0010.a4e6.d04d (192.168.50.3). 

caution Внимание: Команда debug ip dhcp server packets может вызвать значительное снижение производительности, если выполнено на занятом CMTS. Поэтому его использование только рекомендуется в лабораторной среде.

Вышеупомянутый процесс не мог бы работать как желаемый из-за многих факторов, некоторые из которых упомянуты ниже.

  • неправильно настроенный ПК

  • неправильно настроенный сервер DHCP

  • проблемы кабельного модема

  • Параметры файла конфигурации DOCSIS

Блок-схема в следующем разделе выделяет некоторые из большинства важных факторов, влияющих на способность CPE получить IP-адреса. Это также предоставляет шаги для устранения проблем неудачных попыток CPE для получения IP-адресов.

Блок-схема устранения неполадок

Можно щелкнуть по любой из зеленых коробок для движения соответствующего раздела.

cpe_no_connect_sm_1.gif

Проверка состояния на CMTS

Необходимо сначала определить, получил ли CPE IP-адрес (см. раздел Конфигурации CPE Проверки этого документа). Если IP-адрес не был назначен на CPE, подтвердите, что кабельный модем является онлайновым. Если кабельный модем не прибыл onlinecome онлайн, CPE не может получить IP-адрес.

Для проверки статуса на CMTS выполните команду show cable modem от CMTS. Пример выходных данных от этой команды показывают ниже.

Sniper# show cable modem 
Interface   Prim Online     Timing Rec    QoS CPE IP address      MAC address
            Sid  State      Offset Power
Cable2/0/U0 1    offline    2291    0.00  2   0   10.50.50.4      0050.7366.2223
Cable2/0/U0 2    online     2814    0.25  5   0   10.50.50.5      0001.9659.4449
Cable2/0/U0 3    online     2813    0.50  5   0   10.50.50.2      0001.9659.4477

Столбец Online State выше показов статус кабельного модема. Для CPE, чтобы успешно получить IP-адрес и установить подключение, кабельный модем должен быть в одном из следующих состояний:

  • Онлайн

  • Online (pt)

Любое состояние кроме двух выше указывает, что кабельный модем не зарегистрировался в CMTS и, поэтому, CPE не может получить IP-адрес.

Для исчерпывающей информации об устранении проблем возможных состояний кабельного модема обратитесь к Устранению проблем Кабельных модемов uBR, Не Подключающихся к сети.

Проверьте конфигурацию CPE

ПК, выполняющий Windows 95/98, 98, NT или 2000 потребностей иметь Стек TCP/IP, который должным образом установлен и настроен для получения IP-адреса.

Типовые снимки экрана в этом документе показывают клиенту, выполняющему Windows 2000. Другие операционные системы Windows имеют подобные конфигурации, хотя может отличаться появление диалоговых окон и команды, выполненной для доступа к окну IP Configuration.

Примечание: Этот раздел предполагает, что клиентский компьютер имеет Адаптер ethernet, который должным образом установлен и настроен. В противном случае обратитесь к своей документации по продукту или спросите поставщика своего адаптера для поддержки.

Для проверки IP-адреса, назначенного на ПК, используйте следующую процедуру:

  1. Нажмите кнопку Старт> Выполнение.

  2. В окне Run введите winipcfg.

    /image/gif/paws/15036/cpe_no_connect2.gif

  3. Нажмите кнопку OK

    Окно IP Configuration появляется.

    /image/gif/paws/15036/cpe_no_connect3.gif

    Примечание: Если существует несколько Адаптеров ethernet, установленных в клиентском компьютере, выберите адаптер, связанный с кабельным модемом с помощью стрелки выпадающего списка Имени адаптера.

    Со стороны CMTS можно проверить, какой CPE находится, позади которого кабельного модема и проверяют IP-адрес, назначенный на CPE путем запуска кабеля show interfaces x/y модем z команда. Аргументы этой команды определены следующим образом:

    • x является номером линейной карты.

    • y является номером нисходящего порта.

    • z является Идентификатор сервиса (SID) кабельного модема.

      Можно заставить z в 0 смотреть детали обо всех кабельных модемах и CPE на интерфейсе определенного канала от оператора к абоненту. Посмотрите выходные данные команды show interface cable в конце раздела Примера конфигурации этого документа.

    Если IP-адрес 0.0.0.0, то CPE был не в состоянии получать IP-адрес. Прежде чем вы продолжитесь к следующему шагу, нажмете кнопку Renew, чтобы попытаться получить IP-адрес. Если CPE не может получить IP-адрес, вы получите сообщение IpReneweAddress failed with error 2 в Windows 2000.

    Примечание: В Windows 98 CPE иногда назначают начало IP-адреса 169.254.n.n. Этим типом адреса является “фиктивный” IP-адрес, который назначает Windows, и это указывает, что не был получен рабочий IP-адрес.

  4. Проверьте, что CPE имеет Стек TCP/IP, который должным образом установлен и настроен, как показано ниже.

    1. Выберите Start> Settings> Network and Dial-up Connections> Local Area Connection.

    2. На экране Local Area Connection нажмите Properties.

      Окно Local Area Connection Properties появляется.

      /image/gif/paws/15036/cpe_no_connect4.gif

    3. Гарантируйте, что Протокол Интернета (TCP/IP) перечислен и выбран.

      В противном случае необходимо установить его.

  5. После обеспечения, что Стек TCP/IP установлен, проверьте, что он должным образом настроен, как показано ниже.

    1. В окне Local Area Connection Properties выберите Internet Protocol (TCP/IP).

    2. Нажмите Properties.

      Протокол Интернета (TCP/IP) Окно свойств появляется.

      /image/gif/paws/15036/cpe_no_connect5.gif

    3. Гарантируйте, что Получение IP-адреса автоматически и Получает адрес сервера DNS автоматически, переключатели установлены.

      Примечание: Для проверки конфигурации TCP/IP на других типах клиентов — например, Операционные системы UNIX выполнения CPE — консультируются документацией по продукту.

MAX-CPE

В режиме моста записью MAX-CPE по умолчанию в файле конфигурации DOCSIS является 1. Таким образом только один CPE может быть связан позади кабельного модема. Новая команда настройки позволяет CMTS задавать максимальное число разрешенных хостов на модем (заменяющий значение MAX-CPE в файле конфигурации DOCSIS). Эта команда является max-cpe кабельного модема [n | неограниченный] . Допустимый диапазон для n 1 - 254.

Для получения дополнительной информации об этой команде и ее отношении к MAX-CPE в файле конфигурации DOCSIS, обратитесь к Использованию Команды max-cpe в DOCSIS и CMTS.

Если параметром MAX-CPE в файле конфигурации DOCSIS является 0, и команда no cable modem max-cpe настроена на CMTS (по умолчанию) тогда, никакой CPE не может получить IP-адреса.

Cisco Network Registrar

Проверьте придерживающееся в Cisco Network Registrar (CNR):

  • Должным образом настроенная Политика для каждого CPE.

  • Области для соединения с той Политикой CPE.

  • Достаточное пространство IP-адресов для размещения всех клиентов, в случае, если все клиенты подключаются к сети в то же время.

  • Сервер DHCP не перегружен.

  • Существует маршрут назад от сервера DHCP до сетевого адреса CPE.

Для получения дополнительной информации о настройке CNR, обратитесь к Конфигурации Cisco Network Registrar.

CNR не используется

При использовании сервер DHCP не-CNR, гарантируете, что он установлен правильно согласно документации продукта. Это должно быть настроено в пути, который подобен разделу Cisco Network Registrar выше.

Консультация Интернет-провайдера

Если вы не управляете присвоением IP-адреса — кроме обеспечения, что кабельный модем является онлайновым — необходимо согласовать интернет-провайдером для устранения проблем проблем с подключением CPE. Ваш интернет-провайдер управляет присвоением IP-адреса, и вам, возможно, придется предоставить им MAC-адреса, используемые вашим CPE.

Примечание: Если у вас есть доступ к CMTS тогда, можно просмотреть и устранить неполадки, является ли модем онлайновым или нет. См. Устранение проблем Кабельных модемов uBR, Не Подключающихся к сети. В противном случае проверьте статус светодиодного индикатора на своих маршрутизаторах кабельного доступа Cisco серии uBR900.

ISP не присвоил IP-адрес

IP-адреса должны быть назначены интернет-провайдером через сервер DHCP. Если ваш IP-адрес назначен с помощью другого метода — например, статичная конфигурация — необходимо проверить законность назначенного IP - адреса с интернет-провайдером. Сбой, чтобы сделать так мог бы заставить разрывы сети другим пользователям и сбои устанавливать подключение.

Проверка IP-подключения

Если вашему CPE назначает действительный IP - адрес ваш интернет-провайдер, но вы все еще неспособны установить подключение, существует способ проверить возможность подключения с помощью IP-адреса. Во-первых, пропингуйте IP-адрес ПК. Затем пропингуйте каждый переход в сети по одному, чтобы видеть, как далеко через сеть можно достигнуть. Если эхо-запросы к остатку систем в сети испытывают таймаут, необходимо связаться персоналом службы технической поддержки интернет-провайдера для помощи.

Пример конфигурации

Эта конфигурация основывается на Cisco Выпуск ПО IOS� 12.1 (5) T.

write terminal

Sniper# write terminal

Building configuration...


Current configuration : 2472 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname Sniper
!
boot system flash slot0:ubr7200-ik1st-mz.121-5.T.bin
logging rate-limit console 10 except errors
enable password cisco
!
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
ip subnet-zero
no ip finger
no ip domain-lookup
!         
!
interface FastEthernet0/0
 no ip address
 shutdown
 half-duplex
!
interface Ethernet1/0
 ip address 172.17.110.148 255.255.255.224
 half-duplex
!
interface Ethernet1/1
 no ip address
 shutdown
 half-duplex
!
interface Cable2/0
 ip address 192.168.50.1 255.255.255.0 secondary
 ip address 10.50.50.1 255.255.255.0
 no keepalive
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable downstream frequency 555000000
 cable upstream 0 frequency 30000000
 cable upstream 0 power-level 0
 no cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
 cable dhcp-giaddr policy
 cable helper-address 172.17.110.137
!
interface Cable3/0
 no ip address
 no keepalive
 shutdown
 cable downstream annex B
 cable downstream modulation 64qam
 cable downstream interleave-depth 32
 cable upstream 0 shutdown
 cable upstream 1 shutdown
 cable upstream 2 shutdown
 cable upstream 3 shutdown
 cable upstream 4 shutdown
 cable upstream 5 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.17.110.129
no ip http server
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0
 exec-timeout 0 0
 password cisco
 no login
line vty 1 4
 exec-timeout 0 0
 no login
!
end

Sniper# 

кабель show interfaces

Sniper# show interfaces cable 2/0 modem 0
SID   Priv bits  Type      State     IP address    method    MAC address
7     00         modem     up        10.50.50.5    dhcp      0001.9659.4449
8     00         host      unknown   192.168.50.3  dhcp      0010.a4e6.d04d
8     00         modem     up        10.50.50.2    dhcp      0001.9659.4477
9     00         modem     up        10.50.50.4    dhcp      0050.7366.2223

Sniper#

Дополнительные сведения

Check status on CMTS IP Address not assigned by ISP Check IP Connectivity Max CPE Check CPE Configuration Check with your ISP Cisco Network Registrar Not Using CNR


Document ID: 15036