Коммутаторы : Cisco 6130 IP DSL Switch

"Настройка маршрутизатора Cisco 827 с одиночным IP-адресом, DHCP и PPPoA"

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (11 ноября 2015) | Отзыв


Содержание


Введение

Этот пример конфигурации показывает маршрутизатор Цифровой абонентской линии (DSL) Cisco 827, соединяющийся с Мультиплексором доступа к цифровой абонентской линии (DSLAM) (DSLAM) Cisco 6130 и завершающийся на Универсальном концентраторе доступа (UAC) Cisco 6400. Маршрутизатор Cisco 827 был настроен как сервер протокола динамической конфигурации узла (DHCP) с протоколом PPPoA через АТМ (PPPoA).

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Сведения в этом документе основаны на версиях оборудования и программного обеспечения, указанных ниже.

  • Customer Premises Equipment (CPE) Cisco 827-4V выпуск ПО IOS� 12.1 (1) XB

  • Выпуск ПО IOS Процессора Маршрутизации Узлов UAC Cisco 6400 12.0 (7) DC

  • Процессор коммутатора узлов UAC Cisco 6400 (NSP) выпуск ПО IOS 12.0 (4) дБ

  • Выпуск ПО Cisco 6130 DSLAM-NI2 IOS 12.1(1)DA

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Общие сведения

В этом случае интернет-провайдер (ISP) дал абоненту один IP-адрес (172.18.0.1) для интернет-соединения, но абонент имеет небольшую сеть PC и хочет иметь доступ в Интернет для всех устройств.

Решение, показанное здесь, внедряет Технологию NAT на Маршрутизаторе Cisco 827. NAT создан для упрощения и сохранения IP-адресов; эта технология позволяет объединенным сетям с частными (незарегистрированными) IP-адресами подключаться к Интернету. NAT воздействует на маршрутизатор, обычно подключая две сети, и преобразовывает частное (в этом случае 10.0.0.0 сети) адреса во внутренней сети к юридическому (в этом случае, 172.18.0.1) адреса, прежде чем пакеты будут переданы к другой сети. Как часть этой функциональности, NAT может быть настроен для объявления только одного адреса (172.18.0.1) для всей сети. Это предоставляет дополнительные меры безопасности, эффективно скрывая всю внутреннюю сеть позади одного IP-адреса.

NAT служит двойным целям безопасности и сохранения адреса, и, как правило, внедряется в средах удаленного доступа. В данном примере IP-адрес 10.0.0.1 вручную настроен на Интерфейсе Ethernet Маршрутизатора Cisco 827. Маршрутизатор Cisco 827 настроен для действия как сервер DHCP и арендует IP-адреса к локальным устройствам локальной сети, подключенным к его Сети Ethernet.

Следующая конфигурация показывает NAT, настроенный для Ethernet и ATM-интерфейсов. Интерфейс Ethernet (определяемый Ethernet0 в схеме сети ниже) имеет IP-адрес 10.0.0.1 с маской подсети 255.0.0.0. NAT настроен для внутренней части, что означает, что интерфейс связан с внутренней сетью, которая подвергается преобразованию NAT. ATM-интерфейс (определял Dialer0 в схеме сети ниже) имеет IP-адрес 172.18.0.1 и маску подсети 255.255.0.0. NAT на Dialer0 настроен для внешней стороны, что означает, что интерфейс связан с внешней сетью, такой как Интернет. Для получения дополнительной информации о сквозной архитектуре PPPoA Asynchronous Digital Subscriber Line (ADSL), обратитесь к Базовой архитектуре PPPoA.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сетевая установка, показанная на следующей схеме.

/image/gif/paws/12880/827dhcp_1ip2.gif

!--- конфигурацию

В данном документе используется следующая конфигурация.

Маршрутизатор Cisco 827
! 
version 12.1
service timestamps debug datetime msec 
service timestamps datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
ip dhcp excluded-address 10.0.0.1

!--- The DHCP pool does not lease this address; 
!--- it is used by interface E0.

!
ip dhcp pool <pool name>
network 10.0.0.0 255.0.0.0
 default-router 10.0.0.1

!--- The default gateway is assigned to local devices.

! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 ip nat inside
 no ip mroute-cache
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 !
 hold-queue 224 in 
! 
interface Dialer0 
  ip address 172.18.0.1 255.255.0.0    
  ip nat outside     
  no ip directed-broadcast 
  encapsulation ppp 
  dialer pool 1 
  dialer-group 2 
  ppp pap sent-username <username> password <password>
! 
ip nat inside source list 1  interface Dialer0 overload 
ip classless 
ip route 0.0.0.0 0.0.0.0 Dialer0 
no ip http server 
! 
access-list 1 permit 10.0.0.0 0.255.255.255 
dialer-list 2 protocol ip permit
! 
voice-port 1 
 timing hookflash-in 0
!
voice-port 2
 timing hookflash-in 0 
! 
voice-port 3
 timing hookflash-in 0 
!
voice-port 4 
 timing hookflash-in 0 
! 
end

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 12880