Технологии IBM : Коммутация соединения передачи данных (DLSw) и Data-Link Switching Plus (DLSw +)

Плюс коммутация каналов передачи данных

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Коммутация соединения передачи данных (DLSw) является стандартом, внедренным IBM, который поддерживает транспорт Протокола LLC по глобальным сетям (WAN). DLSw является более тщательно продуманной формой протокола RSRB и является более определенным относительно того, что это может или не может соединить. DLSw требует, чтобы маршрутизатор транспортировал допустимый сеанс LLC2 или Сеанс netbios.

Маршрутизаторы Cisco внедряют RFC 1795 (стандарт DSLw) и 2166 (версия 2 DLSw). Кроме того, DLSw реализует больше опций для управления широковещанием и транспортирует меньше информации через глобальную сеть (WAN), чем другие методы.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие команды

Этот раздел покрывает важные команды DLSw, команды для настройки DLSw и команд для устранения проблем DLSw.

source-bridge ring-group

Первый шаг в настройке DLSw должен добавить команду source-bridge ring-group. Это подключает Интерфейсы Token Ring, выполняющие мостовое соединение с маршрутизацией от источника (SRB).

Задача Команда
Определение группы одновременного вызова. source-bridge ring-group ring-group [виртуальный mac-адрес]

Примечание: При выполнении DLSw на маршрутизаторе, который только имеет Интерфейсы Ethernet, нет никакой потребности установить ring-group.

Определите идентификацию локального партнера

Следующая опция должна определить идентификацию локального партнера. Это - IP-адрес в той же коробке. Это в основном запускает DLSw в маршрутизаторе.

Задача Команда
Задайте локального партнера DLSw+. dlsw local-peer [IP-адрес peer-id] [группа группы] [граница] [стоимость стоимости] [lf размер] [секунды поддержки активности] [пассивный] [разнородный] [biu-сегмент]

Большая часть основного параметра в настройке DLSw должна установить local peer-id ip-address. Это описания параметров командной строки:

  • группа и граница — Эти команды выполнены вместе для создания пограничных одноранговых узлов в сети.

  • когда существуют разнообразные пути к тому же местоположению, стоимость — Эта команда выполнена. Эта команда говорит маршрутизатор, как достигнуть этих удаленных узлов с помощью пути наименьшей стоимости сначала.

  • lf — Эта команда определяет самый большой размер фрейма, который может обработать этот узел. Размеры фрейма могут быть:

    • Размер фрейма максимального размера в байтах 516-516

    • 1470-1470 размеров фрейма максимального размера в байтах

    • 1500 – максимальный размер кадра –1500 байт

    • максимальный размер кадра составляет 2052-2052 байт

    • 4472-4472 размера фрейма максимального размера в байтах

    • 8144-8144 размера фрейма максимального размера в байтах

    • 11407-11407 байт максимальный размер кадра

    • 11454-11454 байт максимальный размер кадра

    • 17800-17800 размеров фрейма максимального размера в байтах

  • keepalive — Эта команда определяет пакеты keepalive промежутка интервала. Интервал может колебаться от 0 до 1200 секунд. Это обычно устанавливается в 0 при настройке DLSw для Технологии DDR.

  • пассивный Эта команда настраивает маршрутизатор для не инициирования однорангового запуска от маршрутизатора.

  • разнородный — Эта команда означает, что маршрутизатор принимает соединения от любого удаленного узла, запрашивающего одноранговый запуск. Эта команда полезна в больших узлах, которые имеют много узлов, потому что вы не должны определять все удаленные узлы в центральном маршрутизаторе.

  • biu-сегмент — Эта команда является опцией для DLSw, который разрешает DLSw управлять размером сегмента выше в уровнях System Network Architecture (SNA). Эта команда включает конечные станции, полагают, что они могут передать большие объемы данных.

Определите удаленный узел

После определения локального партнера вы определяете удаленный узел. Можно определить три типа узлов: TCP, Fast-Sequenced Transport (FST) и прямое Высокоуровневое Управление каналом (HDLC) и Frame Relay. Это пояснения команд, выполненных для определения удаленного узла:

Задача Команда
Прямая инкапсуляция через Frame Relay номер dlci номера interface serial frame-relay list-number удаленного узла dlsw [IP-адрес backup-peer] [bytes-netbios-out bytes-list-name] [стоимость стоимости] [mac-address dest-mac] [access-list-number Dmac-output-list] [host-list-name Host-netbios-out] [секунды поддержки активности] [lf размер] [задерживается минуты] [список lsap-output-list] [pass-thru]
Прямая инкапсуляция через HDLC номер interface serial list-number удаленного узла dlsw [IP-адрес backup-peer] [bytes-netbios-out bytes-list-name] [стоимость стоимости] [mac-address dest-mac] [access-list-number Dmac-output-list] [host-list-name Host-netbios-out] [секунды поддержки активности] [lf размер] [задерживается минуты] [список lsap-output-list] [pass-thru]
FST IP-адрес fst list-number удаленного узла dlsw [IP-адрес backup-peer] [bytes-netbios-out bytes-list-name] [стоимость стоимости] [mac-address dest-mac] [access-list-number Dmac-output-list] [host-list-name Host-netbios-out] [секунды поддержки активности] [lf размер] [задерживается минуты] [список lsap-output-list] [pass-thru]
TCP  /* dlsw remote-peer list-number tcp ip-address [IP-адрес backup-peer] [bytes-netbios-out bytes-list-name] [стоимость стоимости] [mac-address dest-mac] [access-list-number Dmac-output-list] [динамичный] [host-list-name Host-netbios-out] [минуты бездействия] [секунды поддержки активности] [lf размер] [задерживается минуты] [список lsap-output-list] [никакие-llc минуты] [приоритет] [размер tcp-queue-max] [секунды таймаута] [v2-single-tcp]

Это описания параметров командной строки:

  • backup peer — Этот параметр командной строки определяет узел, который выполняет резервное копирование этот узел, если отказывает первый узел.

  • стоимость — Этот параметр командной строки определяет стоимость этого узла. Эта команда используется, когда существуют разнообразные пути к назначению и когда вам нужен предпочтительно-способный сценарий.

  • dest-mac, динамичный, нет и бездействие — Эти параметры командной строки, обсужден в разделе Резервного/затратного однорангового узла этого документа.

  • Dmac-output-list — Этот параметр командной строки выполнен для определения списка доступа, который говорит маршрутизатор, какие удаленные MAC - адреса назначения вы разрешаете или запрещаете, трафик проводника.

  • Host-netbios-out — Этот параметр командной строки выполнен для применения названий фильтра хостов NetBIOS.

  • keepalive — Этот параметр командной строки выполнен для определения интервала в секундах между пакетами Keepalive. Это используется главным образом для настроек DDR.

  • lf — Этот параметр командной строки указывает, что самый большой размер обеспечил узел.

  • задержитесь — Этот параметр командной строки задает период времени, что маршрутизатор оставляет резервный узел открытым, который становится активным (из-за первичного сбоя) после того, как основное соединение становится активным снова.

  • приоритет — Этот параметр командной строки создает множественные одноранговые телефонные соединения для приоритизации трафика DLSw.

  • tcp-queue-max — Этот параметр командной строки изменяет значение по умолчанию 200 для очередей TCP.

  • таймаут — Этот параметр командной строки является кол-вом секунд, что TCP ждет подтверждения перед разъединением соединения.

  • V2-single-tcpM — Этот параметр командной строки разработан для использования в средах Технологии NAT. Каждый узел думает, что имеет более высокий адрес IP, чтобы препятствовать тому, чтобы каждый узел разъединил один из TCP - подключений.

Таймеры, используемые в DLSw

Это пояснения таймеров, используемых в DLSw:

Параметр Описание
Icannotreach-block-time Долговечность кэша недостижимого ресурса, во время которого заблокированы поиски того ресурса. Допустимый диапазон составляет 1 - 86400 секунд. По умолчанию 0 (отключен)
Netbios-cache-timeout Долговечность кэша Расположения имени NetBIOS для обоих кэшей локальной и удаленной достижимости. Допустимый диапазон составляет 1 - 86400 секунд. По умолчанию составляет 16 минут.
Netbios-explorer-timeout Промежуток времени, что программное обеспечение IOS� ждет отклика обозревателя прежде, чем отметить недостижимый ресурс (LAN и глобальная сеть (WAN)). Допустимый диапазон составляет 1 - 86400 секунд. По умолчанию составляет 6 секунд.
Netbios-retry-interval Интервал между попытками анализатора NetBIOS (только LAN). Допустимый диапазон составляет 1 - 86400 секунд. По умолчанию составляет 1 секунду.
Netbios-verify-interval Интервал между созданием записи в кэше и когда запись отмечена как устаревшая. Если запрос на поиск наталкивается на старую запись кэша, направленный проверяют, что запрос передается, чтобы гарантировать, что это все еще существует. Допустимый диапазон составляет 1 - 86400 секунд. По умолчанию составляет 4 минуты.
Sna-cache-timeout Промежуток времени, что MAC/Точка доступа к сервису SNA (SAP) запись в кэше местоположения существует, прежде чем от этого сбросят (локальный и удаленный). Допустимый диапазон составляет 1 - 86400 секунд. По умолчанию составляет 16 минут.
Sna-explorer-timeout Промежуток времени, что программное обеспечение IOS ждет отклика обозревателя прежде, чем отметить недостижимый ресурс (LAN и глобальная сеть (WAN)). Допустимый диапазон составляет 1 - 86400 секунд. По умолчанию составляет 3 минуты.
Sna-retry-interval Интервал между проводником SNA повторяет (LAN). Допустимый диапазон составляет 1 - 86400 секунд. Значение по умолчанию — 30 секунд.
Sna-verify-interval Интервал между созданием записи в кэше и когда запись отмечена как устаревшая. Если запрос на поиск наталкивается на старую запись кэша, направленный проверяют, что запрос передается, чтобы гарантировать, что это все еще существует. Допустимый диапазон составляет 1 - 86400 секунд. По умолчанию составляет 4 минуты.
время ожидания браузера Время, в секундах, что маршрутизатор ждет всех анализаторов для возврата прежде, чем определить который узел использовать.

Эти параметры очень полезны. Например, можно изменить интервал в секундах, что маршрутизатор передает проводник. Это помогает уменьшать количество анализаторов в сети путем увеличения времени между ними. Кроме того, можно изменить значения, в которых маршрутизатор вызывает таймаут записей в кэше.

Дополнительные команды DLSw

Это дополнительные важные команды DLSw:

  • dlsw allroute-sna / netbios — Эта команда выполнена для изменения поведения DLSw так, чтобы все проводники маршрута использовались вместо анализаторов одного маршрута.

  • dlsw bridge-group — Эта команда выполнена для связи прозрачно соединенных мостом доменов DLSw. Это используется экстенсивно при настройке NetBIOS с Ethernet.

  • dlsw explorerq-depth — Это наборы команд значение очереди проводника DLSw. Эта команда выполнена после обычной команды source-bridge explorer-queue, но это обращается ко всему CANUREACH (CUR) кадры, которые должны быть обработаны. Эта команда важна, потому что она покрывает пакеты от Ethernet, даже при том, что она не покрыта командой source-bridge explorerq-depth. См. Понимание и Устранение проблем Мостового соединения исходного маршрута для получения дополнительной информации об этой команде.

команды "show"

Команды показа и выходные данные, описанные в этом разделе, полезны при устранении проблем DLSw.

show dlsw peer

Эта команда предоставляет сведения об узлах. Каждый настроенный удаленный узел отображен здесь, включая количество переданных и полученных пакетов.

Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 5.5.5.1         CONNECT          2         2  conf      0    0   0 00:00:06

Это возможные состояния:

  • CONNECT — Это состояние означает, что узел DLSw в порядке.

  • DISCONNECT - Это состояние означает, что узел не работает или не связанный.

  • CAP_EXG — Это состояние означает, что DLSw находится в обмене возможностей с удаленным узлом.

  • WAIT_RD — Это состояние является заключительным шагом в запуске узла. Этот узел ждет удаленного узла для открытия порта чтения. См. раздел отладки этого документа для получения дополнительной информации о том, когда узел запускает и запуск команды debug dlsw peer.

  • WAN_BUSY — Это состояние означает, что исходящая очередь TCP полна, и пакет не может быть передан.

Команда show dlsw peer также показывает количество отбрасываний, количество каналов через определенный узел, очередь TCP и время работы без сбоев. Счетчик сбросов увеличивается по этим причинам:

  • Интерфейс глобальной сети недоступен точке прямого вызова.

  • DLSw пытается передать пакет, прежде чем узел будет полностью связан (ждущий события TCP или функционального события). Полная Исходящая очередь TCP.

  • Несовпадение количества чисел последовательности FST.

  • Не удается получить буфер для медленной коммутации пакета FST.

  • Отказ контролера CiscoBus на высоком уровне (невозможно переместить пакет из принимающего буфера в передающий буфер, или наоборот).

  • IP-адрес назначения пакета FST не совпадает с локальным идентификатором однорангового узла.

  • Интерфейс WAN не работает для точки вызова FST.

  • Никакая команда кэша маршрутизации SRB не настроена.

  • Буфер кольца Madge переполняется на простых системах (слишком быстро передаются данные между WAN и LAN).

show dlsw capabilities

DLSw: Capabilities for peer 5.5.5.1(2065)
  vendor id (OUI)         : '00C' (cisco)
  version number          : 1
  release number          : 0
  init pacing window      : 20
  unsupported saps        : none
  num of tcp sessions     : 1
  loop prevent support    : no
  icanreach mac-exclusive : no
  icanreach netbios-excl. : no
  reachable mac addresses : none
  reachable netbios names : none
  cisco version number    : 1
  peer group number       : 0
  border peer capable     : no
  peer cost               : 3
  biu-segment configured  : no
  local-ack configured    : yes
  priority configured     : no
  version string          :
Cisco Internetwork Operating System Software
IOS (tm) 4500 Software (C4500-J-M), Version 10.3(13), RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1996 by cisco Systems, Inc.

show dlsw reachability

DLSw MAC address reachability cache list
Mac Addr        status     Loc.    peer/port            rif
0800.5a0a.c51d  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a49.1e38  FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
0800.5a95.3a13  FOUND      REMOTE  5.5.5.1(2065)
 
DLSw NetBIOS Name reachability cache list
NetBIOS Name    status     Loc.    peer/port            rif
PIN-PIN         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
QUENEPA         FOUND      LOCAL   TokenRing3/0     06B0.0021.00F0
WIN95           FOUND      REMOTE  5.5.5.1(2065)

Поле статуса является большей частью важной части команды show dlsw reach. Это возможные состояния:

  • FOUND – маршрутизатор обнаружил устройство.

  • SEARCHING — маршрутизатор ищет ресурс.

  • NOT_FOUND – отказное кэширование включено, и станция не отвечает на запросы.

  • UNCONFIRMED – станция конфигурирована, но DLSw не подтверждает ее.

  • VERIFY – Проверка данных кэша, так как кэш устарел или проверялась конфигурация пользователя.

команда show dlsw circuit

Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:32; Rx CW:20, Granted:32
        RIF = 06B0.0021.00F0

При запуске команды show dlsw circuit обратите внимание на управление потоками. Управление потоками существует в основании на канал. Это - связь, которая происходит, в то время как два узла DLSw назначают канал окно возможной передачи. Эти увеличения значения и уменьшения в зависимости от объема трафика, который канал пытается переместить через. Значение может измениться в зависимости от перегрузки облака.

Команда show dlsw circuit более обширна с IOS 11.1. Команда теперь разрешает вам посмотреть на канал DLSw на значении точки доступа к сервису (SAP) или значении MAC, которое упрощает располагающиеся каналы при устранении проблем. Ниже показан пример выходных данных:

ibu-7206#sh dlsw cir
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
ibu-7206#sh dls cir det ?
  <0-4294967295>  Circuit ID for a specific remote circuit
  mac-address     Display all remote circuits using a specific MAC
  sap-value       Display all remote circuits using a specific SAP
  <cr>
 
ibu-7206#show dlsw circuit detail mac 4000.0000.0001
Index           local addr(lsap)    remote addr(dsap)  state
1622193728      4001.68ff.0001(04)  4000.0000.0001(04) CONNECTED
        PCEP: 60A545B4   UCEP: 60B0B640
        Port:To3/0          peer 5.5.5.1(2065)
        Flow-Control-Tx CW:20, Permitted:29; Rx CW:20, Granted:29
        RIF = 06B0.0021.00F0
241-00  4000.0000.0001(04)  4001.68ff.0000(04) CONNECTED
        Port:To0          peer 5.5.7.1(2065)
        Flow-Control-Tx CW:20, Permitted:27; Rx CW:20, Granted:27
        RIF = 0630.00F1.0010
s5e#sh cls
DLU user: DLSWDLU
      SSap:0x63       type:  llc0   class:0
        DTE:0800.5a95.3a13 0800.5a0a.c51d F0 F0
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
 
        DTE:4000.0000.0001 4001.68ff.0000 04 04
        T1 timer:0      T2 timer:0      Inact timer:0
        max out:0       max in:0        retry count:0
        XID retry:0     XID timer:0     I-Frame:0
TokenRing0 DTE: 4000.0000.0001 4001.68ff.0000 04 04 state NORMAL
   V(S)=23, V(R)=23, Last N(R)=22, Local window=7, Remote Window=127
   akmax=3, n2=8, Next timer in 1240
   xid-retry timer      0/0       ack timer    1240/1000
   p timer              0/1000    idle timer  10224/10000
   rej timer            0/3200    busy timer      0/9600
   akdelay timer        0/100     txQ count       0/200

Устранение неисправностей

По умолчанию DLSw завершает сеансы LLC в маршрутизаторах (local-ack). Кроме того, потому что это завершает поле маршрутной информации (RIF), существуют другие проблемы проектирования для рассмотрения. Наиболее распространенные проблемы DLSw описаны в этом разделе.

Петли

Одна из большинства важных вещей для запоминания о DLSw является завершением RIF. Это - проблема, потому что могут легко быть созданы главные петли в сети. Эта схема демонстрирует петлю:

/image/gif/paws/12249/dlsw_1.gif

В этом случае, так как DLSw завершает RIF, пакет распространяется вокруг неопределенно. Это вызвано тем, что каждый раз, когда Фрейм CUR передается от узла до узла, принимающий пиринговый узел создает новый проводник (НИКАКОЙ RIF) и передает его. Шаги проводника описаны:

  1. 3174 в вызове 11 передают проводник для достижения хоста.

  2. И SF1, и мост копируют кадр.

  3. SF1 создает Фрейм CUR к LA1 (его узел), чтобы сказать LA1, что эти 3174 хотят достигнуть ХОСТА.

  4. SF2 получает пакет и выполняет тождественное действие.

  5. Теперь LA1 и LA2 создают анализатор и отправляют его кольцу.

  6. LA1 и LA2 получают проводник, который друг друга создал.

  7. Теперь существует дилемма, потому что каждая сторона полагает, что локально подключены эти 3174.

  8. Каждый маршрутизатор имеет эти 3174, и локальные и удаленные.

  9. Теперь они передают Кадр icanreach к SF1 и SF2, соответственно, который создает ответ от хоста к 3174.

  10. И SF1 и SF2 помещают отклик обозревателя на Token Ring, и каждый узнает, что MAC-адрес хоста достижим локально и удаленно.

  11. Достижимость DLSw эффективно межсетевые экраны против цикличного выполнения проводника неопределенно. Однако с кадрами ненумерованных сведений (UI), это может циклично выполнить, затем делать ЦП и использование линии до 100%.

Если это происходит, проверьте, что виртуальное кольцо в маршрутизаторах является точно тем же на каждой стороне облака, как отображено в этой схеме:

/image/gif/paws/12249/dlsw_2.gif

Маршрутизаторы на каждой стороне этого облака имеют тот же самый номер виртуального кольца. Это гарантирует, что один из маршрутизаторов передает проводник, который уже прошел через вызов, тогда маршрутизатор отбрасывает его. Когда LA1 генерирует проводник для Фрейма CUR, полученного SF1, LA2 отбрасывает его, потому что проводник уже прошел через вызов 1. В этом сценарии важно, чтобы маршрутизатору настроили другой мост, если пакет возглавляется для того же вызова, который имеет место стороны LA сети.

В Версии Ethernet того же сценария необходимо отключить узел. Пример отображен в этой схеме:

dlsw_3.gif

Поскольку пакет на Ethernet не имеет RIF, маршрутизатор не может определить, ли широковещание, созданное другим маршрутизатором на LAN, от другого маршрутизатора или от исходящей станции. С SNA пакет локально инициируется или удален. Поскольку анализаторы от Среды Token Ring в действительности имеют и источник и MAC - адреса назначения, они не широковещание на Ethernet, а directed frame к станции от другого.

То, что происходит в предыдущей схеме, объяснено в этих шагах:

  1. Explorer отправляется с 3174 на хост.

  2. Этот проводник принят и SF1 и SF2.

  3. SF1 и SF2 генерируют кадры CUR к другой стороне LA1 и LA2.

  4. Они генерируют проводник, на который отвечает хост; потому что это - анализатор одного маршрута, на это отвечают со все-проводником маршрута.

  5. И LA1 и LA2 создают Фрейм CUR к SF1 и SF2, которые создают пакет для 3174.

  6. SF1 слышит MAC-адрес ХОСТА, прибывающего из Ethernet, и теперь полагает, что ХОСТ расположен на локальной сети. Но в кэше SF1, ИДЕНТИФИКАТОР ХОСТА отвечает от удаленного узла.

  7. Это вынуждает маршрутизатор иметь ХОСТ, и локальный и удаленный, что означает, что сломан DLSw.

Резервные и затратные узлы

Резервные узлы добавляют отказоустойчивость к DLSw, если потерян узел. Это обычно устанавливается в базовых средах так, чтобы, когда центральный маршрутизатор отказывает, другой маршрутизатор мог принять отказывающий маршрутизатор. Конфигурации и схема в этом разделе иллюстрируют настройку резервного узла.

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   cost 2 promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   cost 4 promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

/image/gif/paws/12249/dlsw_8.gif

Первая вещь помнить об узлах стоимости DLSw состоит в том, что оба узла активны. Маршрутизатор поддерживает только один резервный узел. Это может иметь два в это время, если задерживаются, настроен. Это - то, что произошло в предыдущей схеме:

  1. D3a получает проводник и запускает процесс путем передачи Фрейма CUR к каждому удаленному узлу.

  2. D3B и D3C получают Фреймы CUR. Каждый генерирует проводник к хосту, который отвечает назад и на D3B и на D3C.

  3. И D3B и D3C отвечают назад на D3A с Icanreach.

  4. D3A передает отклику обозревателя до конца станцию.

  5. Удаленная станция запускает канал dlsw с eXchange IDentification (XID) для SNA и Asynchronous Balanced Mode Extended набора (SABME) для NetBIOS.

  6. D3A выбирает снижение затрат в достижимости.

Существует таймер в D3A, который может быть определен для сообщения маршрутизатора, сколько времени ждать всех анализаторов для возврата к D3A. Это избегает проблем с затратами, которые могут произойти, когда маршрутизатор использует первый проводник, который возвращается к нему. Выполните команду dlsw timer explorer-wait-time <seconds> для установки этого таймера.

Кроме того, при выполнении пограничных одноранговых узлов, DLSw передает только один Фрейм CUR к самому дешевому узлу. Это ведет себя по-другому, чем это делает когда стоимость выполнения без пограничных одноранговых узлов.

Резервные узлы работают немного по-другому. Вы задаете резервный узел в узле, который будет резервной копией для указанного узла. Это означает, что узел, который имеет инструкцию резервирования, является самим резервным узлом.

Задайте задерживаться опцию так, чтобы, когда основная адресуемая точка становится в рабочем состоянии снова, каналы не могли сразу разъединить. Это полезно, если основная адресуемая точка варьируется вверх и вниз, потому что вы не хотите использовать неисправный узел.

Это демонстрирует конфигурацию резервных узлов:

D3B
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3b
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.14.1
   promiscuous
!
interface Loopback0
 ip address 1.1.14.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.2 255.255.255.0
 bandwidth 125000
 clockrate 125000
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

D3C
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.12.1
   promiscuous
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 bandwidth 500000
 clockrate 500000
!
interface TokenRing0
 ip address 1.1.5.2 255.255.255.0
 ring-speed 16
 source-bridge 3 2 2
 source-bridge spanning
!

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1
dlsw remote-peer 0 tcp 1.1.14.1
dlsw remote-peer 0 tcp 1.1.12.1 backup-peer 1.1.14.1 linger 5
dlsw timer explorer-wait-time 2
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.6.1 255.255.255.0
 bandwidth 500000
!
interface Serial1
 ip address 1.1.4.2 255.255.255.0
 bandwidth 125000
!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!

Узел разъединен путем запуска команды show dlsw peer:

d3a#sh dls peer
Peers:                state     pkts_rx   pkts_tx  type  drops ckts TCP   uptime
 TCP 1.1.14.1        CONNECT        464      1286  conf      0    0   0 03:17:02
 TCP 1.1.12.1        DISCONN          0         0  conf      0    0   -        -

Пограничные узлы

Пограничные одноранговые узлы являются важной функцией DLSw, потому что они решают проблему управления широковещанием в сети. Данный пример иллюстрирует, как настроены пограничные одноранговые узлы и что происходит, когда подходит сеанс:

/image/gif/paws/12249/dlsw_6.gif

D3E
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3e
!
!
dlsw local-peer peer-id 1.1.11.1 group 1
   border promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
!
interface Loopback0
 ip address 1.1.11.1 255.255.255.0
!
interface Serial0
 ip address 1.1.3.1 255.255.255.0
!
interface Serial1
 ip address 1.1.2.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 ip address 10.17.1.189 255.255.255.0
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3C
Current configuration:
!
version 11.1

service udp-small-servers
service tcp-small-servers
!
hostname d3c
!
!
dlsw local-peer peer-id 1.1.12.1 group 2
   border promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
!
interface Loopback0
 ip address 1.1.12.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.1 255.255.255.0
 no fair-queue
 clockrate 500000
!
interface Serial1
 ip address 1.1.3.2 255.255.255.0
 clockrate 500000
!
interface TokenRing0
 no ip address
 shutdown
 ring-speed 16
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

D3F
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3f
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.10.1 group 1
   promiscuous
dlsw remote-peer 0 tcp 1.1.11.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.10.1 255.255.255.0
!
interface Serial0
 ip address 1.1.2.1 255.255.255.0
 no fair-queue
!!
interface TokenRing0
 ip address 1.1.1.1 255.255.255.0
 ring-speed 16
 source-bridge 1 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0

D3A
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname d3a
!
!
source-bridge ring-group 2
dlsw local-peer peer-id 1.1.13.1 group 2
   promiscuous
dlsw remote-peer 0 tcp 1.1.12.1
dlsw peer-on-demand-defaults inactivity 1
!
interface Loopback0
 ip address 1.1.13.1 255.255.255.0
!
interface Serial0
 ip address 1.1.4.2 255.255.255.0
!
interface TokenRing0
 ip address 1.1.5.1 255.255.255.0
 ring-speed 16
 source-bridge 3 1 2
 source-bridge spanning
!
router ospf 100
 network 1.0.0.0 0.255.255.255 area 0
!

Первая часть настройки пограничных одноранговых узлов должна создать случайные одноранговые узлы. Случайные одноранговые узлы принимают соединения от любого маршрутизатора DLSw, пытающегося открыть узел с этим маршрутизатором. Например, в предыдущей схеме, вы хотите, чтобы D3A открыл узел с D3F. Если нет никаких пограничных одноранговых узлов, необходимо установить статические одноранговые узлы в сети. Это хорошо работает, но когда у вас есть сотни узлов, и вы используете статические одноранговые узлы, когда маршрутизатор должен найти станцию удаленно, маршрутизатор должен передать Фрейм CUR к каждому узлу. Это может вызвать много издержек.

С другой стороны, при использовании пограничных одноранговых узлов тот удаленный маршрутизатор должен отправить только один запрос к пограничному одноранговому узлу. Этот запрос тогда распространяется через группы, и удаленный маршрутизатор открывает узел с другим удаленным маршрутизатором, чтобы запустить канал и установить соединение. Этот процесс объяснен в этой схеме:

/image/gif/paws/12249/dlsw_7.gif

  1. Когда D3A получает проводник, он передает широковещание к D3C. D3C является пограничным одноранговым узлом, к которому подключен D3A.

  2. Когда D3C получает Фрейм CUR, он передает Фрейм CUR ко всем узлам в группе. D3C также передает тестовый фрейм к любым локальным интерфейсам, которые настроены для этого, и передает Фрейм CUR к пограничным одноранговым узлам в другой группе.

  3. D3E получает CUR от D3C в другой группе. Затем D3E делает то же путем передачи CUR ко всем узлам в группе и любых локальных интерфейсах.

  4. D3F получает Фрейм CUR и передает тестовый опрос к локальному интерфейсу. Если D3F имеет узел, указывающий на другой маршрутизатор, он не может повторить тот Фрейм CUR к другому маршрутизатору.

  5. Когда D3F получает ответ для конечной станции, он возвращает Кадр icanreach к D3E.

  6. D3E передает его к D3C, который вперед это к D3A. D3A передает тестовый ответ к устройству.

  7. Когда конечная станция запускает канал dlsw с XID для SNA и SABME для NetBIOS, D3A инициирует одноранговое соединение с D3F и запускает сеанс.

Это - отладка и от D3C и от D3A во время этого процесса:

d3a#
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 40
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 40 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 0
DLSw: sending bcast to BP peer 1.1.12.1(2065)

Тестовый фрейм, который входит в маршрутизатор, замечен. Затем маршрутизатор генерирует Фрейм CUR к D3C. Действие D3C отображает эти выходные данные:

DLSw: Pak from peer 1.1.13.1(2065) with op DLX_MEMBER_TO_BP
DLSw: recv_member_to_border() from peer 1.1.13.1(2065)
DLSw: passing pak to core originally from 1.1.13.1 in group 2
%DLSWC-3-RECVSSP: SSP OP = 3( CUR  ) -explorer from peer 1.1.13.1(2065)
DLSw: Pak from peer 1.1.11.1(2065) with op DLX_RELAY_RSP
DLSW: relaying pak to member 1.1.13.1 in group 2

Когда D3C получает пакет от D3A, это передает пакет к ядру. Позже, вы видите ответ от удаленного узла, который передается назад к D3A. Затем D3A запускает соединение (узел по требованию) с удаленным узлом D3F в этой отладке:

DLSw: Pak from peer 1.1.12.1(2065) with op DLX_RELAY_RSP
DLSW: creating a peer-on-demand for 1.1.10.1
DLSw: passing pak to core originally from 1.1.10.1 in group 1
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 1.1.10.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44
DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing0
CSM:   smac c001.68ff.0000, dmac 4000.0000.0001, ssap 4 , dsap 4
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: action_a() attempting to connect peer 1.1.10.1(2065)
DLSw: action_a(): Write pipe opened for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state DISCONN, new state WAIT_RD
DLSw: passive open 1.1.10.1(11003) -> 2065
DLSw: action_c(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state WAIT_RD, new state CAP_EXG
DLSw: CapExId Msg sent to peer 1.1.10.1(2065)
DLSw: Recv CapExId Msg from peer 1.1.10.1(2065)
DLSw: Pos CapExResp sent to peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 1.1.10.1(2065)
DLSw: action_e(): for peer 1.1.10.1(2065)
DLSw: peer 1.1.10.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 1.1.10.1(2065)
DLSw: action_f(): for peer 1.1.10.1(2065)
DLSw: closing read pipe tcp connection for peer 1.1.10.1(2065)
DLSw: new_ckt_from_clsi(): TokenRing0 4001.68ff.0000:4->4000.0000.0001:4
DLSw: START-FSM (1474380): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 106
DLSw: END-FSM (1474380): state:DISCONNECTED->LOCAL_RESOLVE

После того, как маршрутизатор получает переданный пакет от пограничного однорангового узла, это открывает узел по требованию с удаленным узлом D3F (1.1.10.1) и запускает канал.

отладка

Первый шаг в любой сети DLSw поднимает узлы. Без узлов нет никакого обмена данными. Большинство подробных данных того, что происходит между узлами DLSw, объяснено в RFC 1795.

Примечание: Если вы говорите с оборудованием не марки CISCO через DLSw, используйте DLSw. Однако между маршрутизаторами Cisco, используйте DLSw+.

Эти выходные данные являются от запуска узлов debug dlsw и внедрения узлами между двумя маршрутизаторами Cisco:

DLSw: passive open 5.5.5.1(11010) -> 2065
DLSw: action_b(): opening write pipe for peer 5.5.5.1(2065)
DLSw: peer 5.5.5.1(2065), old state DISCONN, new state CAP_EXG
DLSw: CapExId Msg sent to peer 5.5.5.1(2065)
DLSw: Recv CapExId Msg from peer 5.5.5.1(2065)
DLSw: Pos CapExResp sent to peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
DLSw: Recv CapExPosRsp Msg from peer 5.5.5.1(2065)
DLSw: action_e(): for peer 5.5.5.1(2065)
shSw: peer 5.5.5.1(2065), old state CAP_EXG, new state CONNECT
DLSw: peer_act_on_capabilities() for peer 5.5.5.1(2065)
DLSw: action_f(): for peer 5.5.5.1(2065)
DLSw: closing read pipe tcp connection for peer 5.5.5.1(2065)

Эти выходные данные показывают маршрутизатор, запускающий узел и открывающий сеанс TCP с другим маршрутизатором. Затем это запускается к возможностям обмена. После успешного обмена возможностей связан узел. Когда нет никакого действия, такого как трафик, в отличие от RSRB, DLSw не перемещает узел в закрытое состояние. Они всегда остаются связанными. Если узлы разъединены, узел debug dlsw проблемы для определения, почему они не способны к открытию.

При устранении проблем переводимого в рабочее состояние сеанса выполните ядро debug dlsw, чтобы наблюдать ошибку сеанса и проверить, подходит ли канал.

Это - поток для 3174 коммуникационных процессоров к хосту через DLSw+:

/image/gif/paws/12249/dlsw_4.gif

Выходные данные debug dlsw отображают поток сеанса, переводимого в рабочее состояние правильно:

ibu-7206#debug dlsw
DLSw reachability debugging is on at event level for all protocol traffic
DLSw peer debugging is on
DLSw local circuit debugging is on
DLSw core message debugging is on
DLSw core state debugging is on
DLSw core flow control debugging is on
DLSw core xid debugging is on
ibu-7206#
DLSW Received-ctlQ : CLSI Msg : UDATA_STN.Ind   dlen: 208
CSM: Received CLSI Msg : UDATA_STN.Ind   dlen: 208 from TokenRing3/0
CSM:   smac 8800.5a49.1e38, dmac c000.0000.0080, ssap F0, dsap F0
CSM: Received frame type NETBIOS DATAGRAM from 0800.5a49.1e38, To3/0
DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
DLSw: Keepalive Request sent to peer 5.5.5.1(2065))
DLSw: Keepalive Response from peer 5.5.5.1(2065)
DLSW Received-ctlQ : CLSI Msg : TEST_STN.Ind   dlen: 41
CSM: Received CLSI Msg : TEST_STN.Ind   dlen: 41 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 0

Заметьте тестовый фрейм, прибывающий из LAN (локально) от станции c001.68ff.0001 к MAC-адресу 4000.0000.0001. Каждый.Ind указывает, что пакет входит от LAN. Когда маршрутизатор передает пакет к LAN, вы видите.RSP.

DLSw: peer_put_bcast() to non-grouped peer 5.5.5.1(2065)
%DLSWC-3-RECVSSP: SSP OP = 4( ICR  ) -explorer from peer 5.5.5.1(2065)
DISP Sent : CLSI Msg : TEST_STN.Rsp   dlen: 44

Теперь вы видите широковещание, передаваемое удаленному узлу и ответу первоначальной скорости передачи ячеек (ICR) назад. Это означает, что удаленный маршрутизатор идентифицировал станцию как доступную. TEST_STN.Rsp является маршрутизатором, передавая тестовый ответ к станции.

DLSW Received-ctlQ : CLSI Msg : ID_STN.Ind   dlen: 54
CSM: Received CLSI Msg : ID_STN.Ind   dlen: 54 from TokenRing3/0
CSM:   smac c001.68ff.0001, dmac 4000.0000.0001, ssap 4 , dsap 4

После того, как станция получает тестовый ответ, она передает первый XID. Можно заметить это с IS_STN.Ind. Теперь маршрутизатор должен держаться на этот кадр временно, пока это не очищает несколько подробных данных, промежуточных эти два маршрутизатора DLSw.

DLSw: new_ckt_from_clsi(): TokenRing3/0 4001.68ff.0001:4->4000.0000.0001:4
DLSw: START-FSM (1622182940): event:DLC-Id state:DISCONNECTED
DLSw: core: dlsw_action_a()
DISP Sent : CLSI Msg : REQ_OPNSTN.Req   dlen: 108
DLSw: END-FSM (1622182940): state:DISCONNECTED->LOCAL_RESOLVE
 
DLSW Received-ctlQ : CLSI Msg : REQ_OPNSTN.Cfm CLS_OK dlen: 108
DLSw: START-FSM (1622182940): event:DLC-ReqOpnStn.Cnf state:LOCAL_RESOLVE
DLSw: core: dlsw_action_b()
CORE: Setting lf size to 30
%DLSWC-3-SENDSSP: SSP OP = 3(CUR)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:LOCAL_RESOLVE->CKT_START
 
%DLSWC-3-RECVSSP: SSP OP = 4(ICR)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCI 0 - s:0 so:0 r:0 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-ICR state:CKT_START
DLSw: core: dlsw_action_e()
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  ACK   - s:20 so:1 r:20 ro:1
%DLSWC-3-SENDSSP: SSP OP = 5(ACK)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_START->CKT_ESTABLISHED

Здесь можно заметить внутренний поток DLSw между двумя узлами. Эти пакеты обычны для каждого запуска сеанса. Первый этап должен переместиться от отключенного состояния до состояния CKT_ESTABLISHED. Оба маршрутизатора передают Фрейм CUR для самого канала. Это вызывают, может вы достигать установления канала (CURCS). Когда узел, который инициирует кадр CURCS, принимает кадр ICRCS, это передает подтверждение и перемещается в установленное состояние канала. Теперь, оба маршрутизатора DLSw готовы к обработке XID.

DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
DLSw: 1622182940 sent FCA on  XID
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

Маршрутизатор получил XID после передачи тестового ответа к станции. Это сохраняет этот XID на мгновение, затем передает его к узлу через канал. Это означает, что вы передаете пакеты к/от узел с идентификатором канала, помеченным им. Таким образом, DLSw понимает действие между этими двумя станциями. Помните, что DLSw завершает Управление логическим Каналом (LLC), тип 2 (LLC2), сеанс в каждой стороне облака.

%DLSWC-3-RECVSSP: SSP OP = 7(XID)  from peer 5.5.5.1(2065)
DLSw: 1622182940 recv FCA on  XID   - s:20 so:0 r:20 ro:0
DLSw: START-FSM (1622182940): event:WAN-XID state:CKT_ESTABLISHED
DLSw: core: dlsw_action_g()
DISP Sent : CLSI Msg : ID.Rsp   dlen: 12
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED
 
DLSW Received-ctlQ : CLSI Msg : ID.Ind   dlen: 39
DLSw: START-FSM (1622182940): event:DLC-Id state:CKT_ESTABLISHED
DLSw: core: dlsw_action_f()
%DLSWC-3-SENDSSP: SSP OP = 7(XID)  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CKT_ESTABLISHED

Вы сначала замечаете ответ на первый XID, который передавался прежде. В ID.Rsp вы видите, что XID передавался станции, к которой станция ответила ID.Ind. Это - другой XID, который передавался через узлу DLSw.

%DLSWC-3-RECVSSP: SSP OP = 8(CONQ)  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-CONQ state:CKT_ESTABLISHED

Эта часть показывает нам, что станция с другой стороны ответила SABME (CONQ) к XID. Согласование XID завершилось, и маршрутизатор готов начать сеанс.

DLSw: core: dlsw_action_i()
DISP Sent : CLSI Msg : CONNECT.Req   dlen: 16

Затем маршрутизатор посылает SABME станции в CONNECT.Req.

DLSw: END-FSM (1622182940): state:CKT_ESTABLISHED->CONTACT_PENDING
 
DLSW Received-ctlQ : CLSI Msg : CONNECT.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Connect.Cnf state:CONTACT_PENDING
DLSw: core: dlsw_action_j()
%DLSWC-3-SENDSSP: SSP OP = 9( CONR )  to peer 5.5.5.1(2065) success
DISP Sent : CLSI Msg : FLOW.Req   dlen: 0
DLSw: END-FSM (1622182940): state:CONTACT_PENDING->CONNECTED

Затем вы получаете ненумерованное подтверждение (UA) от станции, которую показывают в сообщении CONNECT.Cfm. Это передается удаленному узлу через CONR. Затем процесс относительной скорости (RR) запущен с FLOW.Req.

%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:20 so:0 r:19 ro:0
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 34
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED
 
DLSw: 1622182940 decr s - s:19 so:0 r:19 ro:0
DLSW Received-disp : CLSI Msg : DATA.Ind   dlen: 35
DLSw: sent RWO
DLSw: 1622182940 sent FCI 80 on  INFO  - s:19 so:0 r:39 ro:1
%DLSWC-3-SENDSSP: SSP OP = 10(INFO)  to peer 5.5.5.1(2065) success
%DLSWC-3-RECVSSP: SSP OP = 10(INFO)  from peer 5.5.5.1(2065)
DLSw: 1622182940 decr r - s:19 so:0 r:38 ro:1
DLSw: 1622182940 recv FCA on  INFO  - s:19 so:0 r:38 ro:0
DLSw: 1622182940 recv FCI 0 - s:19 so:0 r:38 ro:0
DLSw: recv RWO
DLSw: START-FSM (1622182940): event:WAN-INFO state:CONNECTED
DLSw: core: dlsw_action_m()
DISP Sent : CLSI Msg : DATA.Req   dlen: 28
DLSw: END-FSM (1622182940): state:CONNECTED->CONNECTED

DATA.Req указывает, что маршрутизатор передал I-кадр. Данные. Ind указывает, что маршрутизатор получил I-кадр. Можно использовать эту информацию для определения потока пакетов через маршрутизаторы DLSw.

DLSW Received-ctlQ : CLSI Msg : DISCONNECT.Ind   dlen: 8
DLSw: START-FSM (1622182940): event:DLC-Disc.Ind state:CONNECTED

Эта часть содержит DISCONNECT.Ind..Ind указывает на пакет, входящий от LAN. В этом случае станция передает РАЗЪЕДИНЕНИЕ, которое заставляет маршрутизатор начинать разъединять канал.

DLSw: core: dlsw_action_n()
%DLSWC-3-SENDSSP: SSP OP = 14( HLTQ )  to peer 5.5.5.1(2065) success
DLSw: END-FSM (1622182940): state:CONNECTED->DISC_PENDING
 
%DLSWC-3-RECVSSP: SSP OP = 15( HLTR )  from peer 5.5.5.1(2065)
DLSw: START-FSM (1622182940): event:WAN-HLTR state:DISC_PENDING

После того, как маршрутизатор получает РАЗЪЕДИНЕНИЕ, он передает ОСТАНОВ к удаленному узлу и ждет ответа. Все, что оставляют, должно передать UA к станции и закрыть канал, который показывают в следующей отладке с DISCONNECT.Rsp:

DLSw: core: dlsw_action_q()
DISP Sent : CLSI Msg : DISCONNECT.Rsp   dlen: 4
DISP Sent : CLSI Msg : CLOSE_STN.Req   dlen: 4
DLSw: END-FSM (1622182940): state:DISC_PENDING->CLOSE_PEND
 
DLSW Received-ctlQ : CLSI Msg : CLOSE_STN.Cfm CLS_OK dlen: 8
DLSw: START-FSM (1622182940): event:DLC-CloseStn.Cnf state:CLOSE_PEND
DLSw: core: dlsw_action_y()
DLSw: 1622182940 to dead queue
DLSw: END-FSM (1622182940): state:CLOSE_PEND->DISCONNECTED

Последняя вещь, которую выполняет DLSw, состоит в том, чтобы поместить канал в бездействующую очередь. Оттуда, указатели очищены и готовы к новому каналу.

Сеансы NetBIOS

DLSw обрабатывает сеансы NetBIOS различным образом, но методы отладки во всех случаях почти не отличаются.

/image/gif/paws/12249/dlsw_5.gif

Примечание: Помните, что XID не текут для Станций NETBIOS и что маршрутизаторы DLSw обмениваются коммутатором системы запросов Имени NETBIOS (SSP) кадры и распознанное Имя NETBIOS. Это - основное различие.


Дополнительные сведения


Document ID: 12249