Голосовая связь : H.323

VoIP через Frame Relay с многоточечными PVC и приоритезацией

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ обсуждает формирование трафика и приоритизацию для Передачи голоса по IP (VoIP) по Сети Frame Relay с топологией звезды. Конфигурация концентратора так, что существует два постоянных виртуальных канала (PVCs), один для каждого удаленного луча, и и данные и голос передаются по тому же PVCs. Следует отметить, что приоритизация и фрагментация, обсужденная в этом документе, применяются не только к этому сценарию, но также и к сценарию, где у вас могут быть один PVC с речью и данными и другой с только данными. Данные PVCs должны быть формы трафика так же, как речь и данные PVCs. Это - то, вследствие того, что, когда одиночный физический канал разделен, в этом случае в концентраторе, задержка сериализации влияет на все данные.

В топологии ниже, Нью-Йорк представляет центральный маршрутизатор концентратора. Raleigh и Сан-Хосе представляют удаленные маршрутизаторы, связанные с концентратором через Сеть Frame Relay. Существует два PVCs, которые соединяются с нью-йоркским маршрутизатором. В этом случае Нью-Йорк никогда не должен передавать больше чем 64 кбит/с к Raleigh и аналогично, это никогда не должно передавать больше чем 192 кбит/с к Сан-Хосе, потому что это превышает настраиваемую согласованную скорость передачи информации (CIR) на Frame Relay mapclass.

В топологии, показанной в этом документе, маршрутизаторы с конфигурациями VoIP напрямую подключаются к Облаку Frame Relay. В некоторой топологии, однако, с поддержкой голоса маршрутизаторы могут существовать где угодно в сети, за исключением Cisco AS5300. Для получения дополнительной информации об этом обратитесь к предоставленному примечанию. Голосовые маршрутизаторы могут быть связаны через подключение по локальной сети с другими маршрутизаторами, которые связаны с глобальной сетью (WAN). Это важно для примечания, потому что, если голосовые маршрутизаторы непосредственно не связаны с Сервисом Frame Relay, все команды настройки возможности подключения к глобальной сети (WAN) настроены на тех маршрутизаторах, которые связаны с глобальной сетью (WAN), а не на голосовых маршрутизаторах.

Примечание: Маршрутизаторы Cisco AS5300 с high-speed serial interface не разработаны к соединению поддерживаемых данных с глобальной сетью (WAN). Необходимо использовать Cisco AS5300s в качестве промежуточных маршрутизаторов LAN с основными функциональными возможностями для обработки голосовых вызовов. Вы требуете специализированных маршрутизаторов для действия как прямые подключения к глобальной сети (WAN).

Предварительные условия

Требования

Перед применением этой конфигурации убедитесь в выполнении следующих предварительных условий:

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Три Маршрутизатора Cisco 3640 с Cisco Выпуск ПО IOS� 12.3 (5) Enterprise Plus

  • Четыре аналоговых телефона соединились с портами Станции внешнего обмена (FXS) на лучах

  • Одна УАТС соединилась с контроллером T1 на маршрутизаторе концентратора

Лучи могут также быть Cisco 2600 или платформой 1750 года. Концентратор может быть Cisco 2600 или 3600 платформами в случае оцифрованной речи, но это может также быть платформа Cisco 1750, если только аналоговый голосовой канал существует в концентраторе. Все формирование трафика и конфигурации применяются к другим платформам также.

Примечание: Хотя этот документ не ограничен определенным программным обеспечением, некоторые команды, используемые здесь, не доступны со всеми версиями программного обеспечения Cisco IOS. Например, команда frame-relay fragment поддерживается с IP Plus, но не образом IP.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Формирование трафика Настройки и приоритизация для VoIP over Frame Relay

При выполнении VoIP over Frame Relay важно, чтобы трафик, передаваемый по кадру, остался на уровне, который меньше чем или равен Frame Relay CIR. Маршрутизатор не передает трафик, который превышает CIR, когда настроено с Frame Relay Traffic Shaping (FRTS) как показано. При настройке маршрутизатора для выполнения на скорости, больше, чем CIR, можно испытать проблемы качества голосовой связи, и качество голосовой связи не гарантируется при выполнении PVCs выше гарантируемого CIR.

Примечание: Если Пакеты Frame Relay получены с установленным битом уведомления о явной обратной перегрузке (BECN), возможно настроить адаптивную регулировку, чтобы позволить маршрутизатору снизить скорость коэффициента передачи к указанному значению. Вам советуют, однако, что скорости трафика не должны превышать CIR Сервиса Frame Relay, когда переданы голосовые пакеты. Когда оперативные голосовые пакеты передаются по сети, это должно гарантировать правильное качество и доставку. Конфигурация, где CIR превышен, только рекомендуется для данных PVCs, которые не переносят голосовой трафик.

Примечание: Кроме того, прежде чем можно будет настроить маршрутизатор для использования VoIP, лучше, если вы понимаете функции Качества обслуживания (QoS) в программном обеспечении Cisco IOS. Для узнавания больше о Характеристиках QoS обратитесь к Организации очереди, Формированию трафика, и фильтрации и Фрагментации для Голоса.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе используется сетевая конфигурация, изображенная ниже на рисунке:

/image/gif/paws/12162/voip_fr_mp_1.gif

Конфигурации

Эти конфигурации используются в данном документе:

Нью-йоркский маршрутизатор концентратора
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname newyork
!
logging buffered 50000 debugging
enable secret < password > [Choose a strong password with 
at least one capital letter, one number, and one special character.]
!
controller T1 2/0
framing esf
linecode b8zs
ds0-group 1 timeslots 1-4 type e&m-wink-start
!
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay traffic-shaping

!--- This CLI command enables traffic shaping for both PVCs.

!
interface Serial2/0.1 point-to-point
description Connection to Raleigh PVC
ip address 172.16.120.2 255.255.255.0
  frame-relay interface-dlci 100
  class class-raleigh
!
interface Serial2/0.2 point-to-point
description Connection to San Jose PVC
ip address 172.16.130.2 255.255.255.0
frame-relay interface-dlci 200
  class class-sanjose
!
ip classless
!
map-class frame-relay class-raleigh
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80

!--- Recommended fragment size for 10ms delay when carrying voice
!--- traffic based on the configured CIR 64000.
!--- based on the configured CIR 64000

 frame-relay ip rtp priority 16384 16383 48

!--- Two calls with g729, no CRTP, at 24 kbps/each.

 !
map-class frame-relay class-sanjose
 frame-relay cir 192000
 frame-relay bc 1920
 frame-relay be 0
 frame-relay mincir 192000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 240

!--- This is the recommended fragment size for 10ms delay when carrying voice traffic
!--- based on the configured CIR 192000.

frame-relay ip rtp priority 16384 16383 48 

!--- Two calls with G729, no Compressed Real Time Protocol (cRTP), at 24kbpseach.

!
!
voice-port 2/0:1
!
dial-peer cor custom
!
dial-peer voice 100 pots

!--- Calls to the Public Switched Telephone Network (PSTN).

 destination-pattern 212.......
prefix 212
port 2/0:1
!
dial-peer voice 200 pots

!--- Calls to the corporate network-four digit extension forwarded.

destination-pattern 567....
 port 2/0:1
!
dial-peer voice 110 voip

!--- Calls to Raleigh.

destination-pattern 919392....
session target ipv4:172.16.120.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
dial-peer voice 210 voip    
!--- Calls to San Jose.

destination-pattern 408527....
session target ipv4:172.16.130.1
 ip qos dscp cs5 media
dtmf-relay h245-alphanumeric
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end  

Команда ip qos dscp была представлена в IOS version12.2 (2) T для замены команды ip precedence (dial-peer) .

Команда frame-relay ip rtp priority резервирует очередь строго по приоритету для ряда потоков пакетов Протокола RTP, который принадлежит диапазону протокола датаграмм пользователя (UDP) (UDP) порты назначения.

Примечание: Поскольку команда frame-relay ip rtp priority отдает абсолютный приоритет по другому трафику, используйте эту команду с осторожностью. В случае перегрузки, если трафик превышает настраиваемую пропускную способность, то весь дополнительный трафик отброшен.

Cisco 3640 Raleigh
Current configuration:
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname raleigh3640a
!

logging buffered 50000 debugging
enable secret < password > [Choose a strong password with at 
least one capital letter, one number, and one special character.]
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
dial-peer voice 1 pots
 destination-pattern 9193924100
port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 2126789001
  ip qos dscp cs5 media
 dtmf-relay h245-alphanumeric
 session target ipv4: 172.16.120.2 
!

interface Loopback0
 ip address 172.16.125.1 255.255.255.255
 no ip directed-broadcast
!

interface Serial2/0
 no ip address
 encapsulation frame-relay
 frame-relay traffic-shaping
!
interface Serial2/0.1 point-to-point
description Connection to New York
 ip address 172.16.120.1 255.255.255.0

 frame-relay interface-dlci 100
  class fr_class_voip  
!
!
ip classless
no ip http server
!
!
map-class frame-relay fr_class_voip
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment  80


!--- The recommended fragment size for 10ms delay when carrying voice traffic.


!--- based on the configured CIR 64000.


  frame-relay ip rtp priority 16384 16383 48
!
!
line con 0
 exec-timeout 0 0
 transport input none
line aux 0
line vty 0 4
 no login
!
end

Проверка.

Этот раздел предоставляет сведения, можно использовать, чтобы подтвердить, что работает конфигурация.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

newyork#show frame-relay fragment

interface   dlci   frag-type   frag-size   in-frag   out-frag   dropped-frag
 
Serial1/0.1 100    end-to-end    80          16        20           0 

Serial1/0.2 200    end-to-end    240         12        10           0 

newyork#show traffic-shape  serial 2/0.1
Interface Se2/0.1

     Access    Target   Byte   Sustain   Excess   Interval    Increment    Adapt
VC   List      Rate     Limit  bits/int  bits/int (ms)        (bytes)      Active

100            64000    80     640       0         10          80          -
  
newyork#show traffic-shape queue
Traffic queued in shaping queue on Serial2/0.1 dlci 100
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
     Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 16 kilobits/sec

Traffic queued in shaping queue on Serial2/0.2 dlci 200
  Queueing strategy: weighted fair
  Queueing Stats: 0/600/64/0 (size/max total/threshold/drops)
    Conversations  0/1/16 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
     Available Bandwidth 144 kilobits/sec

newyork#show frame-relay pvc 100

PVC Statistics for interface Serial2/0 (Frame Relay DCE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial2/0.1

input pkts 1078          output pkts 1078         in bytes 157792
out bytes 172284         dropped pkts 0           in pkts dropped 0
out pkts dropped 0                out bytes dropped 0
in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
out BECN pkts 0          in DE pkts 0             out DE pkts 0
out bcast pkts 28        out bcast bytes 8498
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
pvc create time 00:27:48, last time pvc status changed 00:27:48
Queueing strategy: weighted fair
Current fair queue configuration:
	Discard     Dynamic      Reserved
	threshold   queue count  queue count
		64          16           0
Output queue size 0/max total 600/drops 0
fragment type end-to-end        fragment size 80
cir 64000     bc   640       be 0         limit 80     interval 10
mincir 64000     byte increment 80    BECN response no  IF_CONG no
frags 2707      bytes 172284    frags delayed 2707      bytes delayed 172284
shaping inactive
traffic shaping drops 0
ip rtp priority parameters 16384 32767 48000

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Процедура устранения неполадок

Вот сведения об устранении проблем и инструкции, относящиеся к этой конфигурации:

  1. Устраните неполадки Frame Relay и QoS, внедренного для голоса, и гарантируйте его нормальную работу.

  2. Продолжитесь к устранению проблем при отказе голосового вызова по мере необходимости.

    Примечание: Для более подробных сведений об устранении проблем обратитесь к VoIP over Frame Relay с QoS (Фрагментация, Формирование трафика, LLQ / IP RTP Priority).

Команды для устранения неполадок

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

  • debug priority — События постановки в очередь с установлением приоритетa (PQ) Показов и показывают, происходит ли отбрасывание в этой очереди. Для получения дополнительной информации см. раздел "Поиск и устранение причин потери данных на выходе при использовании очереди с приоритетом".

  • debug frame-relay fragment — событие Displays или сообщения об ошибках отнеслись к Фрагментации Frame Relay. Эта команда только выполнена на уровне PVC на выбранном интерфейсе.

    newyork#debug priority 
    Priority output queueing debugging is on
    newyork#ping 172.16.120.1
    Type escape sequence to abort. 
    Sending 5, 100-byte ICMP Echos to 172.16.120.1, timeout is 2 seconds: 
    !!!!! 
    Success rate is 100 percent (5/5), round-trip min/avg/max = 56/57/60 ms 
    newyork# 
    *Mar  1 05:11:24.746: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.754: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.810: PQ: Serial2/0 output (Pk size/Q 104/2)
    *Mar  1 05:11:24.818: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.874: PQ: Serial2/0 output (Pk size/Q 104/2) 
    *Mar  1 05:11:24.882: PQ: Serial2/0 output (Pk size/Q 13/0) 
    
    newyork#debug frame-relay fragment interface serial 2/0 100
    This may severely impact network performance.
    You are advised to enable no logging console debug. Continue?[confirm]
    Frame Relay fragment/packet debugging is on
    Displaying fragments/packets on interface Serial2/0 dlci 100 only
    
    *Mar  1 20:58:32.838: Serial1/0.1(o): dlci 100, tx-seq-num 3645, 
    B bit set, frag_hdr 03 B1 9C 3D
    *Mar  1 20:58:32.846: Serial1/0.1(o): dlci 100, tx-seq-num 3646, 
    E bit set, frag_hdr 03 B1 5C 3E
    *Mar  1 20:58:32.890: Serial1/0.1(i): dlci 100, rx-seq-num 17, 
    exp_seq-num 17,B bit set,
    	 frag_hdr 03 B1 80 11
    *Mar  1 20:58:32.894: Serial1/0.1(i): dlci 100, rx-seq-num 18, 
    exp_seq-num 18,E bit set,
    	 frag_hdr 03 B1 40 12

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12162