Многопротокольная коммутация по меткам (MPLS) : Механизм MPLS over ATM

MPLS VPN через ATM: с OSPF на абонентской стороне (с областью 0)

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Когда Протокол OSPF присутствует на абонентской стороне с областью 0, этот документ предоставляет пример конфигурации Виртуальной частной сети (VPN) Многопротокольной коммутации по меткам (MPLS) по ATM.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Приведенные ниже буквы соответствуют различным типам используемых маршрутизаторов и коммутаторов:

  • P - Основной маршрутизатор провайдера

  • PE - маршрутизатор на стороне поставщика

  • CE – Граничный маршрутизатор клиента

  • C – маршрутизатор клиента

Эта схема показывает типичную конфигурацию с помощью этих условных обозначений:

/image/gif/paws/10473/mplsvpn.gif

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Сведения в этом документе основаны на версиях оборудования и программного обеспечения, указанных ниже.

  • Граничные маршрутизаторы провайдеров:

    • Программное обеспечение - Cisco Выпуск ПО IOS� 12.1 (3) T. Функции MPLS VPN появляются в релизе 12.0 (5) T. OSPF как протокол маршрутизации PE-CE появляется в релизе 12.0 (7) T.

    • Аппаратные средства - Cisco 3660 или 7206 маршрутизаторов. Для получения дополнительной информации других аппаратных средств можно использовать, обратиться к MPLS Разработки для руководства ATM.

  • Граничные маршрутизаторы клиентов: Любой маршрутизатор, который в состоянии обмениваться сведениями о маршрутизации с его Периферийным маршрутизатором, может использоваться.

  • P-маршрутизаторы и коммутаторы: Функция интеграции MPLS VPN находится только на краю сети MPLS, таким образом, может использоваться любой Коммутатор с поддержкой MPLS. В этом примере конфигурации облако MPLS составлено из 8540 маршрутизаторов Мультисервисного ATM - коммутатора (MSR) и LightStream 1010. При использовании Cisco Lightstream 1010, мы рекомендуем использовать версию программного обеспечения WA4.8d или позже. В базовой сети ATM также можно использовать другие коммутаторы ATM, например Cisco BPX 8650 или MGX 8850.

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Теоретические сведения

Функция VPN, когда используется с MPLS, позволяет нескольким узлам прозрачно соединять через сеть поставщика услуг. Одна сеть поставщика услуг может поддерживать несколько различных IP-сетей VPN. Любая из этих сетей для пользователей является частной сетью, отделенной от других сетей. В пределах сети VPN с каждого узла могут быть переданы IP-пакеты на другой узел этой же сети.

Каждая сеть VPN связана с одним или более коммутируемым или пересылаемым экземпляром (VRF). VRF состоит из таблицы IP-маршрутизации, полученная скоростная маршрутизация Cisco (EF) таблица и ряд интерфейсов, которые используют эту таблицу пересылки.

Маршрутизатор поддерживает отдельную маршрутизацию и таблицу EF Cisco для каждого VRF. Эта возможность предотвращает передачу данных за пределы сети VPN и разрешает использование одной подсети в нескольких VPN без дублирования IP-адресов.

Маршрутизатор, использующий протокол BGP, распространяет данные VPN-маршрутизации через расширенные сообщества BGP.

Дополнительные сведения относительно распространения обновлений через VPN можно получить на следующих URL:

Использование OSPF

Традиционно, тщательно разработанная сеть OSPF состоит из магистральной области (область 0) и много областей, связанных с этой магистралью через Пограничный маршрутизатор области (ABR).

При помощи магистрали MPLS для VPN с OSPF на узле клиента можно представить третий уровень в иерархии Модели OSPF. Этот третий уровень называют Супермагистралью MPLS VPN.

В простых случаях Супермагистраль MPLS VPN объединена со стандартной областью 0 магистралей. Это означает, что нет никакого area 0 backbone на сети заказчика, так как Супермагистраль MPLS VPN играет ту же роль как area 0 backbone. Это показывают в приведенном ниже рисунке:

/image/gif/paws/10473/mpls_ospf1.gif

В этой схеме:

  • Периферийные маршрутизаторы являются ABR и Граничными маршрутизаторами автономной системы (ASBR).

  • Маршрутизаторы CE являются простыми маршрутизаторами OSPF.

  • Информация VPN транспортируется с помощью расширенных сообществ (группа узлов) BGP от PE до других PE и повторно внедрена в области OSPF как Вся сеть (тип 3) Описания локального состояния соединениий (LSA).

Супермагистраль MPLS VPN также позволяет клиентам использовать множественную область 0 магистралей на их узлах. Каждый узел может иметь отдельную область 0, пока он связан с Супермагистралью MPLS VPN. Результат совпадает с разделенной областью 0 магистралей. Это показывают в приведенном ниже рисунке:

/image/gif/paws/10473/mpls_ospf2.gif

В данном случае:

  • Периферийные маршрутизаторы являются ABR и Граничными маршрутизаторами автономной системы.

  • Маршрутизаторы CE являются маршрутизаторами ABR.

  • LSAs с содержанием информации VPN транспортируется с помощью расширенных сообществ (группа узлов) BGP от PE до других PE. Во Всей сети (тип 3) LSA информация транспортируется между PE и CEs.

Этот пример конфигурации основывается на второй настройке, показанной выше. Можно найти пример конфигурации, который использует первую настройку в MPLS VPN по ATM: с OSPF на абонентской стороне (без области 0).

Информация от протокола OSPF транспортируется с Расширенными атрибутами сообщества BGP (включая тот, который определяет сеть OSPF). Каждая VPN должна иметь свой собственный процесс OSPF. Для определения этого выполните следующую команду:

ID <process маршрутизатора ospf> маршрутизация <VPN VRF или name> экземпляра VRF

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Поиск дополнительной информации о командах в данном документе можно выполнить с помощью средства "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сетевая установка, показанная на следующей схеме.

/image/gif/paws/10473/mpls_ospf4.gif

Процедура конфигурации

Эта процедура настройки конфигурации также описывается в документации Cisco IOS ("Виртуальные частные сети MPLS").

Часть I

Убедитесь, что режим ip cef включен. При использовании Маршрутизатор Cisco 7500, гарантируете, что включен распределенный ip cef. На PE, как только MPLS установлен:

  1. Создайте одну VRF для каждой VPN, подключенной с помощью команды ip vrf <VPN routing/forwarding instance name >. При этом выполните следующие действия:

    • Выполните команду ниже для определения правильного маршрута distinguisher используемый для той VPN. Это используется для расширения IP-адресов, чтобы можно было определить их принадлежность к VPN.

      признак маршрута <VPN резерфорда>

    • Задайте свойства импорта и экспорта для расширенных сообществ BGP. Данные свойства используются для фильтрации процессов экспорта-импорта.

      route-target [export|import|both] <предназначается для расширенного сообщества VPN>

  2. Настройте сведения о переадресации для соответствующих интерфейсов путем выдачи этой команды:

    ip vrf forwarding <имя таблицы>

    Не забудьте после этого настроить IP-адрес.

  3. В зависимости от используемого протокола маршрутизации PE-CE, необходимо выполнить одно или несколько следующих действий:

    • Определите статические маршруты следующим образом:

      ip route vrf vrf-name prefix mask [next-hop-address] [interface {interface-number}]

    • Настройте Протокол RIP путем выдачи команды:

      name> маршрутизации/экземпляра VRF <VPN VRF ipv4 address-family

      Как только это сделано, введите обычные команды Конфигурации RIP.

      Примечание:

      • Применимо только к интерфейсам продвижения для текущего VRF.

      • Необходимо перераспределить корректный BGP в RIP. Во время выполнения необходимо указать используемую метрику.

    • Задайте сведения о соседях BGP.

    • Настройте OSPF путем выдачи новой ПО Cisco IOS команды:

      ID <process маршрутизатора ospf> name> маршрутизации/экземпляра VRF <VPN VRF.

    Примечание:

    • Применимо только к интерфейсам продвижения для текущего VRF.

    • Необходимо перераспределить корректный BGP в OSPF. Во время выполнения необходимо указать используемую метрику.

    • Как только процесс OSPF приписан VRF, этот номер процесса всегда используется для этого определенного VRF. Этот параметр применяется, даже если он не указан в командной строке.

Часть II

Настройка BGP между PE маршрутизаторами. Существует несколько способов настроить протокол BGP, например с помощью отражателя маршрутов или методов конфедерации. Используемый здесь метод - настройка непосредственного соседа - является наиболее простым и наименее масштабируемым решением.

  1. Объявите различных соседей.

  2. Введите name> маршрутизации/экземпляра VRF <VPN VRF ipv4 address-family для каждого подарка VPN в этом Периферийном маршрутизаторе. При необходимости выполните одно или несколько следующих действий:

    • Перераспределите данные статической маршрутизации.

    • Перераспределение данных RIP-маршрутизации.

    • Перераспределение данных OSPF-маршрутизации.

    • Включите соседство BGP с CE-маршрутизаторами.

  3. Введите режим для семейство адресов vpnv4 и:

    • Активируйте соседей.

    • Укажите необходимость использования расширенного сообщества. Данное действие является обязательным.

Конфигурации

Примечание: Только соответствующие части следующего результата включены здесь.

Alcazaba
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!         
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.10 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 150.150.0.1 255.255.255.0
 no ip mroute-cache
!
interface ATM4/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 150.150.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 150.150.0.0 0.0.0.255 area 0
 network 222.0.0.0 0.0.0.255 area 0
!
router bgp 1
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Kozel
!
ip cef
!
ip vrf vpn1
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Loopback1
 ip vrf forwarding vpn1
 ip address 222.0.0.30 255.255.255.255
!         
interface Ethernet1/1
 ip vrf forwarding vpn1
 ip address 69.69.0.1 255.255.255.252
 no ip mroute-cache
 tag-switching ip
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 !
 pvc ilmi 0/16 ilmi
 !
!
interface ATM4/0.1 tag-switching
 ip address 11.0.0.6 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 11.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
!
router ospf 2 vrf vpn1
 log-adjacency-changes
 redistribute bgp 1 metric-type 1 subnets
 network 69.69.0.0 0.0.0.255 area 0
 network 222.0.0.0 0.0.0.255 area 0
!
router bgp 1
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.11 remote-as 1
 neighbor 223.0.0.11 update-source Loopback0
 !
 address-family ipv4 vrf vpn1
 redistribute ospf 2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.11 activate
 neighbor 223.0.0.11 send-community extended
 exit-address-family
!

Быстрый
!
interface Loopback0
 ip address 222.0.0.1 255.255.255.255
!
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet0/0
 ip address 7.7.8.1 255.255.255.0
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 network 7.7.7.7 0.0.0.0 area 1
 network 150.150.0.0 0.0.0.255 area 0
 network 222.0.0.1 0.0.0.0 area 1
!

Pivrnec
!
interface Loopback0
 ip address 222.0.0.3 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 6.6.7.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 69.69.0.2 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 3
 network 69.69.0.0 0.0.0.255 area 0
 network 222.0.0.3 0.0.0.0 area 3
!

Guilder
!         
interface Loopback0
 ip address 222.0.0.11 255.255.255.255
!
interface Ethernet0/1
 ip address 7.7.8.2 255.255.255.0
!
router ospf 2
 network 7.7.8.0 0.0.0.255 area 1
 network 222.0.0.0 0.0.0.255 area 1
!

Ischia
!
interface Loopback0
 ip address 222.0.0.22 255.255.255.255
!
interface Ethernet1/4
 ip address 6.6.7.2 255.255.255.0
!
router ospf 1
 log-adjacency-changes
 network 6.6.7.0 0.0.0.255 area 3
 network 222.0.0.0 0.0.0.255 area 3
!

Проверка

В этом разделе содержатся сведения, которые помогают убедиться в надлежащей работе конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • маршрутизация <VPN show ip route vrf или name> экземпляра VRF

  • маршрутизация <VPN VRF show ip bgp vpnv4 или name> экземпляра VRF <B.C.D>

  • Номер ID <process show ip ospf>

  • Номер ID <process show ip ospf> интерфейс

  • Номер ID <process show ip ospf> база данных

  • маршрутизация <VPN show tag-switching forwarding-table vrf или name> экземпляра VRF

Выполните первые две команды выше для показа VRF для определенной VPN в Периферийном маршрутизаторе.

Команды OSPF

Команды для периферийного маршрутизатора

Информация о show ospf следующих команд для соответствующего VRF. Большинство важных частей выходных данных ниже показывают полужирным текст.

Примечание: Вы не должны задавать VRF при выдаче этих команд.

Alcazaba#show ip ospf 2
 Routing Process "ospf 2" with ID 222.0.0.10
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 Connected to MPLS VPN Superbackbone
 It is an area border and autonomous system boundary router
 Redistributing External Routes from,
    bgp 1, includes subnets in redistribution
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 1. 1 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 2
        Area has no authentication
        SPF algorithm executed 4 times
        Area ranges are
        Number of LSA 13. Checksum Sum 0x715C5 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

Alcazaba#show ip ospf 2 database
 
            OSPF Router with ID (222.0.0.10) (Process ID 2)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       272         0x80000009 0xCA39   1
222.0.0.10      222.0.0.10      197         0x80000003 0xFCFF   2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      197         0x80000002 0xEA6E  
 
                Summary Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      197         0x80000002 0x4768  
6.6.7.0         222.0.0.10      750         0x80000001 0xD4D7  
7.7.7.7         222.0.0.1       272         0x80000002 0x72CC  
7.7.8.0         222.0.0.1       1003        0x80000003 0x635   
69.69.0.0       222.0.0.10      197         0x80000002 0x2228  
222.0.0.1       222.0.0.1       272         0x80000002 0x5A21  
222.0.0.3       222.0.0.10      197         0x80000004 0xE8FA  
222.0.0.11      222.0.0.1       1010        0x80000001 0x5C0C  
222.0.0.22      222.0.0.10      752         0x80000001 0x9435  
222.0.0.30      222.0.0.10      199         0x80000002 0x795B  

Alcazaba#show ip ospf 2 interface
Loopback1 is up, line protocol is up 
  Internet Address 222.0.0.10/32, Area 0 
  Process ID 2, Router ID 222.0.0.10, Network Type LOOPBACK, Cost: 1
  Loopback interface is treated as a stub Host
Ethernet1/1 is up, line protocol is up 
  Internet Address 150.150.0.1/24, Area 0 
  Process ID 2, Router ID 222.0.0.10, Network Type BROADCAST, Cost: 10
  Transmit Delay is 1 sec, State DR, Priority 1 
  Designated Router (ID) 222.0.0.10, Interface address 150.150.0.1
  Backup Designated router (ID) 222.0.0.1, Interface address 150.150.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:08
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 6, maximum is 6
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 222.0.0.1  (Backup Designated Router)
  Suppress hello for 0 neighbor(s)

Команды для маршрутизатора CE

В этом случае Маршрутизатор CE является ABR, потому что он также связан с другой областью. Если бы этот маршрутизатор был только для имения интерфейсов в области 0, то это был бы стандартный маршрутизатор, не ABR или ASBR.

rapid#show ip ospf
 Routing Process "ospf 1" with ID 222.0.0.1
 Supports only single TOS(TOS0) routes
 Supports opaque LSA
 It is an area border router
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
 Number of external LSA 0. Checksum Sum 0x0     
 Number of opaque AS LSA 0. Checksum Sum 0x0     
 Number of DCbitless external and opaque AS LSA 0
 Number of DoNotAge external and opaque AS LSA 0
 Number of areas in this router is 2. 2 normal 0 stub 0 nssa
 External flood list length 0
    Area BACKBONE(0)
        Number of interfaces in this area is 1
        Area has no authentication
        SPF algorithm executed 14 times
        Area ranges are
        Number of LSA 13. Checksum Sum 0x715C5 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0
    Area 1
        Number of interfaces in this area is 3
        Area has no authentication
        SPF algorithm executed 48 times
        Area ranges are
        Number of LSA 16. Checksum Sum 0x8CCBE 
        Number of opaque link LSA 0. Checksum Sum 0x0     
        Number of DCbitless LSA 0
        Number of indication LSA 0
        Number of DoNotAge LSA 0
        Flood list length 0

rapid#show ip ospf database
 
       OSPF Router with ID (222.0.0.1) (Process ID 1)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       331         0x80000009 0xCA39   1
222.0.0.10      222.0.0.10      259         0x80000003 0xFCFF   2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
150.150.0.1     222.0.0.10      259         0x80000002 0xEA6E  
 
                Summary Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.10      259         0x80000002 0x4768  
6.6.7.0         222.0.0.10      812         0x80000001 0xD4D7  
7.7.7.7         222.0.0.1       331         0x80000002 0x72CC  
7.7.8.0         222.0.0.1       1062        0x80000003 0x635   
69.69.0.0       222.0.0.10      259         0x80000002 0x2228  
222.0.0.1       222.0.0.1       331         0x80000002 0x5A21  
222.0.0.3       222.0.0.10      260         0x80000004 0xE8FA  
222.0.0.11      222.0.0.1       1069        0x80000001 0x5C0C  
222.0.0.22      222.0.0.10      813         0x80000001 0x9435  
222.0.0.30      222.0.0.10      260         0x80000002 0x795B  
 
                Router Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
222.0.0.1       222.0.0.1       1078        0x80000029 0x658E   3
222.0.0.10      222.0.0.10      2962        0x80000003 0xFCFF   2
222.0.0.11      222.0.0.11      1080        0x80000003 0xA97F   2
 
                Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
7.7.8.2         222.0.0.11      1081        0x80000001 0x93DA  
150.150.0.1     222.0.0.10      2962        0x80000002 0xEA6E  
 
                Summary Net Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
6.6.6.6         222.0.0.1       332         0x80000002 0x69C5  
6.6.6.6         222.0.0.10      2720        0x80000002 0x4768  
6.6.7.0         222.0.0.1       820         0x80000001 0xF635  
69.69.0.0       222.0.0.1       341         0x80000002 0x4485  
150.150.0.0     222.0.0.1       341         0x80000004 0x57CB  
222.0.0.3       222.0.0.1       341         0x80000002 0xF56   
222.0.0.3       222.0.0.10      2727        0x80000002 0xECF8  
222.0.0.10      222.0.0.1       341         0x80000002 0x6404  
222.0.0.22      222.0.0.1       820         0x80000001 0xB692  
222.0.0.30      222.0.0.1       341         0x80000002 0x9BB8  
 
                Summary ASB Link States (Area 1)
 
Link ID         ADV Router      Age         Seq#       Checksum
222.0.0.10      222.0.0.1       341         0x80000002 0x4C1C  

Команды для маршрутизатора C

Выполните следующую команду для показа таблицы IP-маршрутизации:

Guilder#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     69.0.0.0/30 is subnetted, 1 subnets
O IA    69.69.0.0 [110/21] via 7.7.8.1, 00:06:33, Ethernet0/1
     222.0.0.0/32 is subnetted, 6 subnets
O IA    222.0.0.30 [110/21] via 7.7.8.1, 00:06:33, Ethernet0/1
O IA    222.0.0.22 [110/41] via 7.7.8.1, 00:06:33, Ethernet0/1
O IA    222.0.0.10 [110/21] via 7.7.8.1, 00:06:33, Ethernet0/1
C       222.0.0.11 is directly connected, Loopback0
O IA    222.0.0.3 [110/31] via 7.7.8.1, 00:06:33, Ethernet0/1
O       222.0.0.1 [110/11] via 7.7.8.1, 00:06:33, Ethernet0/1
     6.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O IA    6.6.6.6/32 [110/31] via 7.7.8.1, 00:06:34, Ethernet0/1
O IA    6.6.7.0/24 [110/40] via 7.7.8.1, 00:06:34, Ethernet0/1
     7.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O       7.7.7.7/32 [110/11] via 7.7.8.1, 00:06:35, Ethernet0/1
C       7.7.8.0/24 is directly connected, Ethernet0/1
     10.0.0.0/22 is subnetted, 1 subnets
C       10.200.8.0 is directly connected, Ethernet0/0
     150.150.0.0/24 is subnetted, 1 subnets
O IA    150.150.0.0 [110/20] via 7.7.8.1, 00:06:35, Ethernet0/1

Метки MPLS

Подтвердите, что существует две метки на стеке меток на Коммутируемом маршрутизаторе имени точки входа (LSR) следующим образом:

Alcazaba#show tag-switching forwarding-table vrf vpn1 6.6.7.2 detail 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
None   2/41        6.6.7.0/24        0          AT4/0.1    point2point  
        MAC/Encaps=4/12, MTU=4466, Tag Stack{2/41(vcd=10) 29}
        000A8847 0000A0000001D000

Теперь, подтвердите, что они появляются на выходном LSR:

Kozel#show tag-switching forwarding-table vrf vpn1 6.6.7.2 detail
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
29     Untagged    6.6.7.0/24[V]     1466       Et1/1      69.69.0.2    
        MAC/Encaps=0/0, MTU=1500, Tag Stack{}
        VPN route: vpn1
    Per-packet load-sharing

Команды проверки

Можно теперь выполнить команду ping для тестирования этого, все прекрасно:

Ischia#ping 222.0.0.11
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 222.0.0.11, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
Ischia#trac
Ischia#traceroute 222.0.0.11
 
Type escape sequence to abort.
Tracing the route to 222.0.0.11
 
  1 6.6.7.1 0 msec 0 msec 0 msec
  2 69.69.0.1 0 msec 0 msec 0 msec
  3 150.150.0.1 4 msec 4 msec 0 msec
  4 150.150.0.2 4 msec 0 msec 0 msec
  5 7.7.8.2 4 msec *  0 msec

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 10473