Глобальная сеть (WAN) : Frame Relay

Настройка взвешенной, беспристрастной постановки в очередь на основе классов с помощью FRTS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для Взвешенной организации очереди на основе классов (CBWFQ) с Frame Relay Traffic Shaping (FRTS).

CBWFQ расширяет Организацию очереди стандартной взвешенной очереди (WFQ) функциональность для оказания поддержки для определяемых пользователем классов трафика. Механизм FRTS использует очередности в сети Frame Relay для ограничения резких скачков, которые могут привести к перегрузке. . Данные буферизованы и затем переданы в сеть в отрегулированных суммах, чтобы гарантировать, что трафик соответствует в обещанном конверте трафика для определенного соединения.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

CBWFQ поддерживается с придерживающегося Cisco Выпуски ПО IOS� в зависимости от платформы:

  • Cisco серии 7500 с Versatile Interface Processors (vip) (распределенный CBWFQ) - программное обеспечение Cisco IOS версии 12.1(5)T

  • Серия Cisco 7200, 2600/3600 Серия и другие Платформы серии не-7500 - программное обеспечение Cisco IOS версии 12.1(2)T

Однако, оба маршрутизаторы, используемые для этой документации по конфигурации, выполняли Cisco IOS Software Release 12.2 (2).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Почему CBWFQ использования с FRTS?

Если у вас есть определенные данные для защиты, CBWFQ предоставляет способ далее задать эти данные с помощью определенных классов. С помощью CBWFQ весовой коэффициент класса можно разделить на коэффициенты для каждого пакета в соответствии с условиями класса. Этот вес получен исходя из пропускной способности, назначенной классу. WFQ тогда применен к этим классам, вместо того, чтобы быть примененным к самим потокам, и классы могут включать несколько потоков.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Таблица ниже предоставляет краткое справочное руководство записям, которые вы могли бы видеть в конфигурациях:

Поле Описание
FR Interface Output interface.
subinterface Логический интерфейс.
dlci Идентификатор подключения соединения данных (DLCI). Значение, которое задает постоянную виртуальную цепь (PVC) или коммутируемый виртуальный канал (SVC) в Сети Frame Relay.
class XXX Применяет map-class frame-relay XXX.
map-class frame-relay XXX Параметры FRTS.
service-policy ZZZ CBWFQ.
policy-map ZZZ Именованная политика.
class YYY Называет класс.
bandwidth, policing, priority Специфические особенности для этого потока.
class class-default Синтаксис и записывающие вопросы при создании классов по умолчанию.
class-map match-all YYY Устанавливает условия соответствия, против которых проверен пакет.
match access-group 101 Связывает class-map со списком доступа.
access-list 101 permit ip any any Обычный список доступа.

Примечание:  Серия Cisco 7500: С программного обеспечения Cisco IOS версии 12.1(5)T политика Качества обслуживания (QoS) должна работать в распределенном режиме на Многоцелевом интерфейсном процессоре (VIP), потому что больше не поддерживается Маршрут/Коммутатор (RSP) - базирующееся QoS. Поэтому используйте команду формы и другие команды для Интерфейса командной строки (CLI) модульного QoS для осуществления Distributed Traffic Shaping (dTS) для Интерфейсов Frame Relay на VIP на Cisco серии 7500. DTS комбинирует Generic Traffic Shaping (GTS) и FRTS.

Обязательная процедура

CBWFQ Настройки с FRTS включает выполняющий трех обязательных действий:

  1. Определите карты классов (class-map).

    Установите условия соответствия, против которых пакет проверен, чтобы определить, принадлежит ли он классу.

  2. Настройте карту политик (policy-map) и классы определения (класс).

    Задает название карты политик. Спецификации партнеров для гарантированных пропускных способностей, применения политик и приоритета к каждому классу трафика. Этот процесс влечет за собой конфигурацию полосы пропускания, и т.д., чтобы быть примененным к пакетам, принадлежащим одним из ранее определенных карт классов. Для этого процесса настройте карту политик, которая задает политику для каждого класса трафика.

  3. Подключите Политику обслуживания к классу сопоставления FRTS (стратегия обслуживания).

    Подключите предписанную политику, определенную с определенной стратегией обслуживания к классу сопоставления (и таким образом DLCI или подинтерфейс, где map-class frame-relay применен).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/17920/traffic_shaping.gif

Схема сети выше использует придерживающиеся значения:

  • КОНЦЕНТРАТОР - физическая скорость = 192 кбит/с, гарантированная скорость = 32 кбит/с

  • УДАЛЕННЫЙ - физическая скорость = 64 кбит/с, гарантированная скорость = 32 кбит/с

Конфигурации

В данном документе используются следующие конфигурации.

Концентратор с настроенным CBWFQ
<snip> 
!
class-map match-all YYY
  match access-group 101
!
!
policy-map ZZZ
  class YYY
   bandwidth percent 50
<snip>
interface Serial0/0 
  no ip address 
  encapsulation frame-relay 
  no fair-queue 
  frame-relay traffic-shaping 

 interface Serial0/0.1 point-to-point 
  ip address 10.1.1.1 255.255.255.0 
  frame-relay interface-dlci 16  
  frame-relay class XXX 
 ! 
 map-class frame-relay XXX 
  frame-relay cir 64000  
  frame-relay mincir 32000 
  frame-relay adaptive-shaping becn 
  frame-relay bc 8000
  service-policy output ZZZ
<snip>
!
access-list 101 permit ip host 10.0.0.1 host 11.0.0.1

Удаленный
interface Serial0/0 
no ip address 
encapsulation frame-relay 
no fair-queue 
frame-relay traffic-shaping 
! 
interface Serial0/0.1 point-to-point 
ip address 10.1.1.2 255.255.255.0 
frame-relay interface-dlci 16  
frame-relay class XXX 
! 
map-class frame-relay XXX 
frame-relay cir 64000 
frame-relay mincir 32000 
frame-relay adaptive-shaping becn 
frame-relay bc 8000 
!

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show frame-relay pvc- Отображаются статистические данные о постоянных виртуальных каналах для интерфейсов Frame Relay.

  • show policy-map- Отображает конфигурацию всех классов, включающих определенную карту политик обслуживания или все классы для всех карт существующей политики.

  • show policy-map [interface] - Отображает конфигурацию всех классов, настроенных для всей политики обслуживания на заданном интерфейсе или отображать классы для политики обслуживания для определенного PVC на интерфейсе.

Ниже приводится пример выходных данных команды show frame-relay pvc:

Hubrouter#show frame-relay pvc [interface interface ][dlci]
PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            1            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0       out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  pvc create time 00:01:12, last time pvc status changed 00:01:12
Hubrouter#

Можно использовать придерживающийся синтаксис с этой командой:

  • интерфейс - (Необязательно) Указывает на определенный интерфейс, для которого отображена информация PVC.

  • интерфейс - (Необязательно) Номер интерфейса, содержащий DLCI, для которых вы хотите отобразить информацию PVC.

  • dlci - (Необязательно) определенный номер DLCI используется на интерфейсе. Статистика для указанного канала PVC отображается при указанном номере DLCI.

Ниже приводится пример выходных данных команды show policy-map:

Hubrouter#show policy-map 
   Policy Map ZZZ 
    Class YYY 
      Weighted Fair Queueing 
            Bandwidth 50 (%) Max Threshold 64 (packets) 
    Class WWW 
      Weighted Fair Queueing 
            Bandwidth 25 (%) Max Threshold 64 (packets)

Ниже приводится пример выходных данных show policy-map [interface].

 Hubrouter#show policy-map interface s0/0.1 
  Serial 0/0.1: DLCI 16 
  Service-policy output: ZZZ (1057) 
    Class-map: YYY (match-all) (1059/2) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 101 (1063) 
      Weighted Fair Queueing 
        Output Queue: Conversation 73 
        Bandwidth 50 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: WWW (match-all) (1067/3) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 102 (1071) 
      Weighted Fair Queueing 
        Output Queue: Conversation 74 
        Bandwidth 25 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: class-default (match-any) (1075/0) 
         2 packets, 706 bytes 
         30 second offered rate 0 bps, drop rate 0 bps    
         Match: any  (1079)

Другие сроки, которые можно также видеть в подобных конфигурациях, объяснены ниже:

  • CIR - заявленная скорость передачи информации. Скорость, с которой сеть Frame Relay передает информацию при нормальных условиях, берется среднее значение за минимальный отрезок времени.

  • FIFO организация очереди - Первым прибыл, организация очереди первым обслужен. Метод FIFO включает буферизацию и пересылку пакетов в порядке появления. . Метод FIFO не предполагает никаких приоритетов или классов трафика. . Существует только одна очередь, и все пакеты обрабатываются одинаково. . Пакеты отправляются интерфейсом в порядке поступления.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 17920