Коммутация LAN : Concurrent Routing and Bridging (IRB)

Общие сведения о настройке маршрутизации и мостовой передачи в VLAN на маршрутизаторе с функцией IRB

21 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Перевод, выполненный профессиональным переводчиком (22 сентября 2010) | Английский (31 декабря 2015) | Отзыв


Содержание


Введение

В этом документе описывается порядок развертывания сетей VLAN с помощью маршрутизатора, поддерживающего IP-маршрутизацию, мостовые соединения, а также мостовые соединения с поддержкой протокола интегрированной маршрутизации и мостовых соединений IRB. Также в данном документе представлен пример настройки функции IRB на маршрутизаторе.

Примечание: Функция IRB была намерено отключена в коммутаторах серии Catalyst 6500 и маршрутизаторах серии Cisco 7600. Дополнительную информацию см. в разделе Основные ограничения и рекомендации документа Комментарии к выпуску для Cisco IOS версии 12.1 E для коммутаторов Catalyst 6000 и маршрутизаторов Cisco 7600 с модулями Supervisor Engine и MSFC.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. Cisco Technical Tips Conventions.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, содержащиеся в данном документе, были получены с устройств в специальной лабораторной среде. Все устройства, описанные в данном документе, были запущены с конфигурацией по умолчанию. При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Общие сведения

Чтобы сеть VLAN могла задействовать маршрутизатор, он должен иметь возможность пересылать кадры из одного интерфейса в другой, одновременно поддерживая заголовок VLAN. Если маршрутизатор сконфигурирован для маршрутизации протокола уровня 3 (сетевой уровень), он будет завершать уровни VLAN и MAC интерфейсом, по которому поступают кадры. Заголовок уровня MAC может поддерживаться, если маршрутизатор устанавливает мостовое соединение для протокола сетевого уровня. Но при стандартном мостовом соединении действие заголовка VLAN будет завершаться. Используя функцию IRB в Cisco Выпуск 11.2 IOS� или больше, маршрутизатор может быть настроен для маршрутизации и мостового соединения того же протокола сетевого уровня на том же интерфейсе. Это позволяет поддерживать заголовок VLAN для кадра, пока маршрутизатор переключается с одного интерфейса на другой. Функция IRB обеспечивает возможность маршрутизации между доменами, связанными мостовым соединением, и маршрутизируемыми доменами с помощью виртуального интерфейса мостовой группы BVI (Bridge Group Virtual Interface). BVI — это виртуальный интерфейс внутри маршрутизатора, который функционирует как обычный маршрутизируемый интерфейс, но представляет соизмеримую мостовую группу для маршрутизируемых интерфейсов в маршрутизаторе. Номером интерфейса BVI является номер мостовой группы, представляемой этим виртуальным интерфейсом. Этот номер связывает интерфейс BVI с мостовой группой.

При настройке и активации маршрутизации через BVI, пакеты, которые поступают по маршрутизируемому интерфейсу и предназначены узлу в сегменте мостовой группы, маршрутизируются на BVI. Из BVI пакеты пересылаются модулю мостового соединения, который затем пересылает их через мостовой интерфейс. Эта пересылка осуществляется с учетом целевого MAC-адреса. Аналогичным образом пакеты, которые поступают по мостовому интерфейсу, но предназначены узлу в маршрутизируемой сети, в первую очередь передаются BVI. Затем BVI пересылает эти пакеты модулю маршрутизации, который затем отправляет их в маршрутизируемый интерфейс. На отдельном физическом интерфейсе IRB может быть создан с помощью двух субинтерфейсов VLAN (маркировка 802.1Q); один субинтерфейс VLAN обладает IP-адресом, используемым для маршрутизации, а другой субинтерфейс VLAN создает мост между субинтерфейсом, используемым для маршрутизации, и другими физическими интерфейсами маршрутизатора.

Поскольку BVI представляет целую мостовую группу как маршрутизируемый интерфейс, его необходимо настраивать только с параметрами уровня 3 (L3), например адресами сетевого уровня. Аналогичным образом, интерфейсы настроенные для мостовой передачи протокола не должны настраиваться с какими-либо параметрами L3.

Маршрутизация и мостовая передача в сетях VLAN с использованием IRB

На рис.1 компьютеры A и B подключены к сетям VLAN, которые, в свою очередь, отделены друг от друга маршрутизатором. Этот пример иллюстрирует неверное представление о том, что в пределах одной VLAN может существовать соединение с помощью центрального маршрутизатора.

/image/gif/paws/17054/router_vlan1.gif

На этом рисунке также показан поток трех уровней заголовков для кадра, который проходит по каналам от ПК А к ПК B.

Так как используется магистральное соединение, при прохождении кадра через коммутатор применяется заголовок VLAN. Может быть несколько VLAN, взаимодействующих по магистрали.

Маршрутизатор прерывает уровень VLAN и уровень MAC. Он проверяет целевой IP-адрес и пересылает кадр соответствующим образом. В рассматриваемом случае IP-кадр должен пересылаться через порт на ПК В. Данный канал является магистралью сети VLAN, поэтому заголовок VLAN также применяется.

Хотя VLAN, соединяющая коммутатор 2 с маршрутизатором, имеет тот же номер, что и VLAN между коммутатором 1 и маршрутизатором, они отличаются. Исходный заголовок VLAN удаляется, когда кадр приходит на маршрутизатор. Новый заголовок может быть применен, когда кадр покинет маршрутизатор. Этот новый заголовок может содержать тот же номер VLAN, который использовался в заголовке VLAN, снятом во время получения кадра. Помимо прочего здесь демонстрируется, что IP-кадр проходит маршрутизатор без прикрепленного заголовка VLAN и пересылается на основе содержимого в поле целевого IP-адреса, без учета содержимого поля VLAN ID.

Поскольку два магистральных соединения VLAN находятся на противоположных сторонах маршрутизатора, они должны быть разными IP-подсетями.

Для того, чтобы у двух ПК был одинаковый адрес подсети, в маршрутизаторе должно быть установлено мостовое IP-соединение на соответствующие интерфейсы. Однако даже общая подсеть для устройств в сетях VLAN не означает, что они находятся в одной и той же сети VLAN.

На рис. II изображена примерная топология VLAN.

/image/gif/paws/17054/router_vlan2.gif

Необходимости переадресации конечных станций IP во время перемещений можно избежать, если установить IP-мост на некоторые или на все интерфейсы в маршрутизаторе, подключенном к этим сетям VLAN. Хотя при этом устраняются все преимущества создания маршрутизируемых сетей, позволяющие управлять широковещательной рассылкой на сетевом уровне. На рисунке III показано, какие изменения происходят, если маршрутизатор настроен для IP-моста. На рисунке IV показано, какие изменения происходят, если маршрутизатор настроен для IP-моста с функцией IRB.

Рисунок III показывает, что маршрутизатор устанавливает IP-мост. Теперь оба ПК находятся в одной подсети.

Примечание: Маршрутизатор (мост) теперь пересылает заголовок MAC-уровня на исходящий связанный интерфейс. Маршрутизатор по-прежнему прерывает заголовок VLAN и применяет новый заголовок перед отправкой кадра на ПК B.

/image/gif/paws/17054/router_vlan3.gif

На рисунке IV показано, что происходит, если настроена функция IRB. Теперь VLAN включает в себя маршрутизатор и заголовок VLAN поддерживается во время прохождения кадра через маршрутизатор.

/image/gif/paws/17054/router_vlan4.gif

Пример конфигурации IRB

Это пример конфигурации IRB. Данная конфигурация позволяет организовать IP-мост между двумя интерфейсами Ethernet и маршрутизировать IP-трафик из связанных интерфейсов, используя BVI. На следующей схеме сети когда ПК_A пытается связаться с ПК_B, маршрутизатор R1 обнаруживает, что целевой IP-адрес (ПК_B) находится в той же подсети, поэтому пакеты передаются по мостовому соединению маршрутизатором R1 между интерфейсами E0 и E1. Когда ПК_A или ПК_B предпринимают попытку установить соединение с ПК_C, маршрутизатор R1 определяет, что целевой IP-адрес (ПК_C) находится в другой подсети и передает пакет посредством интерфейса BVI. Таким образом одним и тем же маршрутизатором устанавливается мост для IP-протокола, а также выполняется маршрутизация.

Схема сети

router_vlan5.gif

!--- конфигурацию

Пример конфигурации
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
ip subnet-zero
no ip domain-lookup
bridge irb

!-- This command enables the IRB feature on this router.

!
!
!
interface Ethernet0
no ip address
no ip directed-broadcast
bridge-group 1

!-- The interface E0 is in bridge-group 1.

!
Interface Ethernet1
no ip address
no ip directed-broadcast
bridge-group 1

!-- The interface E1 is in bridge-group 1.

!
Interface Serial0
ip address 10.10.20.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
interface BVI1
ip address 10.10.10.1 255.255.255.0

!-- An ip address is assigned to the logical BVI for routing


!-- IP between bridged interfaces and routed interfaces.

no ip directed-broadcast
!
ip classless
ip route 10.10.30.0 255.255.255.0 10.10.20.2
!
bridge 1 protocol ieee

!-- This command enables the bridging on this router.

bridge 1 route ip

!-- This command enable bridging as well routing for IP protocol.

!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

выходные данные команды "show"

show interfaces [интерфейс] irb

Эта команда отображает протоколы, для которых может осуществляться маршрутизация или установка мостовых соединений для определенного интерфейса, как это показано ниже:

R1#show interface e0 irb

Ethernet0

Routed protocols on Ethernet0:
ip
    
Bridged protocols on Ethernet0:
ip         ipx

!-- IP protocol is routed as well as bridged.


Software MAC address filter on Ethernet0
 Hash Len    Address      Matches  Act      Type
 0x00:  0 ffff.ffff.ffff     0     RCV  Physical broadcast
 0x2A:  0 0900.2b01.0001     0     RCV  DEC spanning tree
 0x9E:  0 0000.0c3a.5092     0     RCV  Interface MAC address
 0x9E:  1 0000.0c3a.5092     0     RCV  Bridge-group Virtual Interface
 0xC0:  0 0100.0ccc.cccc    157    RCV  CDP
 0xC2:  0 0180.c200.0000     0     RCV  IEEE spanning tree
 0xC2:  1 0180.c200.0000     0     RCV  IBM spanning tree
R1#

Дополнительные сведения


Document ID: 17054