Коммутация LAN : Протокол ISL

Настройка магистралей ISL на коммутаторах Cisco

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (11 ноября 2015) | Отзыв


Содержание


Введение

В этом документе обсуждается настройка групп (транков) протокола межкоммутаторных соединений (ISL) на внешних маршрутизаторах Cisco, включая серии 7500/7000, 3600, 4500 и 2500. Не затрагивается настройка магистральных каналов ISL на коммутаторах 2-го уровня (L2) / 3-го уровня (L3), таких как Cisco Catalyst 6500 или 4500.

Для получения информации о настройке ISL и магистралей "802.1q" между коммутаторами Катализатора L2 и L3, которые выполняют операционную систему Catalyst (CatOS) или Cisco программное обеспечение IOS�, обратитесь к любому из них:

Предварительные условия

Требования

Для использования данного документа требуется знание следующих тем:

  • Поддержка ISL на Коммутаторах Catalyst

    Поддержка ISL независима от оборудования для Коммутаторов Catalyst. При соединении внешнего маршрутизатора с Catalyst 6500/6000, 5500/5000 или коммутатор 4500/4000, используйте одну из этих команд для определения поддержки инкапсуляции по модулям:

    • CatOS — show port capabilities

    • Программное обеспечение Cisco IOS — show interfaces capabilities

  • Поддержка ISL на маршрутизаторах Cisco

    В программном обеспечении Cisco IOS версии 11.2 и позже, только Плюс набор функций необходимо. Плюс набор функций или IP Plus или Рабочий стол Плюс. Любой Fast Ethernet или Интерфейс Gigabit Ethernet на маршрутизаторах поддерживают транкинг ISL VLAN.

    В программном обеспечении Cisco IOS версии 11.3 и ранее, только IP и Межсетевой пакетный обмен (IPX) с (Novell-Ether) инкапсуляция IEEE 802.3 имеют поддержку по ISL. Программное обеспечение Cisco IOS версии 11.3 добавило дополнительные инкапсуляции и протоколы.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

VLAN является логическим широковещательным доменом. Чтобы позволить данным пересекать между двумя VLAN или широковещательными доменами, необходимо использовать устройство L3 для маршрутизации между VLAN. Модель Открытого взаимодействия системы (OSI) с семью уровнями определяет это правило. Любое из этих устройств может выполнить эту маршрутизацию:

  • Внешний маршрутизатор, такой как 2500, 4000, или 7000

  • Встроенный маршрутизатор, такой как функциональная карта многоуровневого коммутатора (MSFC)

  • Внешнее устройство с Пом маршрутизации, как хост UNIX, который выполняется маршрутизировавший или пропущенный

Первоначальный способ должен был подключить другой физический порт на маршрутизаторе к каждому отдельному VLAN. Этот метод становится очень дорогим как количество увеличений VLAN. Но существует лучший метод. Администраторы сети могут решить использовать транкинг VLAN для присвоения несколько интерфейсов VLAN на одиночный маршрутизируемый интерфейс вместо этого. Только маршрутизаторы с 100 МБ или более быстрыми Портами Ethernet могут сделать транкинг VLAN.

Транкинг VLAN позволяет Fast Ethernet на 100 МБ или Интерфейсам Gigabit Ethernet на 1000 МБ размещать метку в пакет, который определяет VLAN, которой принадлежит пакет. Когда другой конец магистрального канала ISL получает этот маркированный тегами пакет, магистральный канал ISL размещает пакет в корректную VLAN. Метка ISL является 30 байтовыми заголовками, которые добавлены вокруг кадра Fast Ethernet. Поэтому ISL является технологией точка-точка и только работает между двумя коммутаторами Cisco или маршрутизаторами, которые поддерживают ISL на Fast Ethernet на 100 МБ или Интерфейсах Gigabit Ethernet на 1000 МБ.

Этот рисунок предоставляет визуальное описание магистральных каналов ISL:

/image/gif/paws/17051/24a.gif

Конфигурации

Выполните следующие действия:

  1. Подключите маршрутизатор с коммутатором со способными к ISL портами с использованием соответствующих кабелей.

    Используйте или сквозную Категорию 5 или оптоволоконные кабели.

  2. Удостоверьтесь, что вы создали VLAN на стороне Коммутатора Catalyst и что вы настроили порт коммутатора, чтобы быть магистральным портом.

    Примечание: Помните, что маршрутизаторы Cisco не могут выполнить согласование о Протоколе Протокола DTP или Dynamic InterSwitch Link (DISL) кадры. Поэтому необходимо настроить режим магистрали, чтобы быть nonegotiate на стороне коммутатора. Обратитесь to�the ISL Настройки документа и 802.1q Соединяющий магистралью Между Коммутатором CatOS и Внешним маршрутизатором (Маршрутизация между виртуальными локальными сетями (IVR)) или Раздел связанных сведений этого документа.

  3. Начните определять VLAN на маршрутизаторе.

    Удостоверьтесь, что вы знаете что L2 и информация по настройке L3 для каждой VLAN. Это включает IP-адрес, номер сети IPX и другую информацию.

version 11.3
no service password-encryption
!
hostname lt-4500-static
!
enable secret 5 $1$XqiP$3ADCgrFMC21pwyVQIkith.
!
no ip domain-lookup
appletalk routing
ipx routing 0000.0c0b.f2f5
!
!
interface FastEthernet0              

!--- Only Layer 1 is configured here.

 no ip address
 full-duplex             
!
interface FastEthernet0.1            

!--- All L2 and L3 are on subinterfaces.

 encapsulation isl 1                 

!--- This defines ISL encapsulation and the VLAN number.

 ip address 10.6.1.220 255.255.255.0
 no ip redirects           
 appletalk cable-range 100-100 100.149
 appletalk zone cisco
 ipx network ABC encapsulation SAP
!
interface FastEthernet0.2
 encapsulation isl 2
 ip address 10.7.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 200-200 200.135
 appletalk zone cisco1
 ipx network DEADBEEF encapsulation ARPA
!
interface FastEthernet0.3
 encapsulation isl 3
 ip address 10.8.1.220 255.255.255.0
 no ip redirects
 appletalk cable-range 300-300 300.69
 appletalk zone cisco2
 ipx network 1234 encapsulation SNAP
!
ip classless
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Необходимо настроить encapsulation isl vlan# команда перед настройкой любого другого L2 или информации о L3. Подинтерфейс не должен совпадать с количеством ИДЕНТИФИКАТОРА VLAN. Однако соответствие делает администрирование и устранение неполадок проблем VLAN проще.

Необходимо использовать подинтерфейсы для предотвращения нарушения правила разделения горизонта. Правило разделения горизонтов запрещает рекламу маршрута маршрутизатором через интерфейс, который сам маршрутизатор использует для достижения назначения. Этот подход подобен использованию подчиненных интерфейс типа точка-точка с Frame Relay в среде глобальной сети (WAN).

Отладка и устранение неполадок

Как только вы проверили, что конфигурация, программное обеспечение Cisco IOS и аппаратная платформа корректны, необходимо проверить, что вещи работают правильно. Используйте команды в этом разделе, чтобы проверить операцию и устранять проблемы.

Примечание: Некоторые команды show поддерживаются Интерпретатором выходных данных (только для зарегистрированных пользователей); это позволяет просматривать анализ выходных данных команды show.

Примечание: Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки.

  • show vlan Эта команда показывает, какие сведения уровня L2 или L3 сконфигурированы для каждой VLAN.

    lt-4500-static# show vlan
    Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.1       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.6.1.220                   0                   0
           IPX (SAP)        ABC.0000.0c0b.f2f5              0                   8
             AppleTalk           100.149                    0                  22
    Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.2       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.7.1.220                   0                   0
        IPX (ARPA)     DEADBEEF.0000.0c0b.f2f5              0                   8
             AppleTalk           200.135                    0                  22
    Virtual LAN ID:  3 (Inter Switch Link Encapsulation)
    vLAN Trunk Interface:   FastEthernet0.3       
       Protocols Configured:   Address:              Received:        Transmitted:
               IP              10.8.1.220                   0                   0
           IPX (SNAP)      1234.0000.0c0b.f2f5              0                   9
             AppleTalk           300.69                     0                  23
    
  • show interface команда говорит вам состояние интерфейса и подинтерфейсов, а также Цвета VLAN подинтерфейсов. Цвет VLAN совпадает с номером виртуальной локальной сети (VLAN).

    lt-4500-static# show interface
    FastEthernet0 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ARPA, loopback not set, keepalive set (10 sec)
      Full-duplex, 100Mb/s, 100BaseTX/FX
      ARP type: ARPA, ARP Timeout 04:00:00
      Last input 00:00:00, output 00:00:03, output hang never
      Last clearing of "show interface" counters 00:04:25
      Queueing strategy: fifo
      Output queue 0/40, 0 drops; input queue 0/75, 0 drops
      5 minute input rate 0 bits/sec, 1 packets/sec
      5 minute output rate 0 bits/sec, 0 packets/sec
         415 packets input, 25392 bytes, 0 no buffer
         Received 415 broadcasts, 0 runts, 0 giants, 0 throttles
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
         0 watchdog, 0 multicast
         0 input packets with dribble condition detected
         137 packets output, 12378 bytes, 0 underruns
         0 output errors, 0 collisions, 0 interface resets
         0 babbles, 0 late collision, 0 deferred
         0 lost carrier, 0 no carrier
         0 output buffer failures, 0 output buffers swapped out
    FastEthernet0.1 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.6.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 1.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.2 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.7.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 2.
      ARP type: ARPA, ARP Timeout 04:00:00
    FastEthernet0.3 is up, line protocol is up 
      Hardware is DEC21140, address is 0000.0c0b.f2f5 (bia 0000.0c0b.f2f5)
      Internet address is 10.8.1.220/24
      MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec, rely 255/255, load 1/255
      Encapsulation ISL Virtual LAN, Color 3.
      ARP type: ARPA, ARP Timeout 04:00:00
    
  • покажите {ip | ipx | AppleTalk} маршрут — Эта команда говорит вам, что корректный подчиненный интерфейс ISL изучает или передает сведения о маршрутизации.

    lt-4500-static# show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
           U - per-user static route, o - ODR
    Gateway of last resort is not set
          10.0.0.0/24 is subnetted, 3 subnets
    C       10.8.1.0 is directly connected, FastEthernet0.3
    C       10.7.1.0 is directly connected, FastEthernet0.2
    C       10.6.1.0 is directly connected, FastEthernet0.1
    
    lt-4500-static# show appletalk route
    Codes: R - RTMP derived, E - EIGRP derived, C - connected, A - AURP
           S - static  P - proxy 
    3 routes in internet
    The first zone listed for each entry is its default (primary) zone.
    C Net 100-100 directly connected, Fa0.1, zone cisco
    C Net 200-200 directly connected, Fa0.2, zone cisco1
    C Net 300-300 directly connected, Fa0.3, zone cisco2
    
    lt-4500-static# show ipx route
    Codes: C - Connected primary network,    c - Connected secondary network
           S - Static, F - Floating static, L - Local (internal), W - IPXWAN
           R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
           s - seconds, u - uses, U - Per-user static
    3 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.
    No default route known.
    C        ABC (ISL vLAN),      Fa0.1
    C       1234 (ISL vLAN),      Fa0.3
    C   DEADBEEF (ISL vLAN),      Fa0.2
    
  • debug vlan packet — Эта команда говорит вам, если существует неверная конфигурация пакетов на магистральном канале ISL или если неправильный подчиненный интерфейс ISL передает или получает пакеты.

    caution Внимание.  : Всегда будьте осторожны при использовании любой команды отладки. Команды отладки могут вызвать сложные проблемы производительности на маршрутизаторе. Для отключения отладки выполните команду undebug all.

    lt-4500-static# debug vlan packet
    Virtual LAN packet information debugging is on
    lt-4500-static#
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 3
          on interface FastEthernet0.3 which is not configured to
          route or bridge this packet type.
    vLAN: ISL packet received bearing colour ID 4 on FastEthernet0
          which has no subinterface configured to route or bridge ID 4.
    vLAN: ISL packet received bearing colour ID 5 on FastEthernet0
          which has no subinterface configured to route or bridge ID 5.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 1
          on interface FastEthernet0.1 which is not configured to
          route or bridge this packet type.
    vLAN: Received ISL encapsulated UNKNOWN packet bearing colour ID 2
          on interface FastEthernet0.2 which is not configured to
          route or bridge this packet type.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 17051