Голосовая связь : H.323

Настройка ретрансляции сигнала отбоя на голосовых портах FXS/FXO

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

При интеграции технологий IP-телефонии (VoIP) с существующей учрежденческой АТС (УАТС) и телефонной сетью общего пользования (ТфОП) иногда возникает необходимость передачи вида сигнала известного как «сигнал отбоя». Сигнал отбоя представляет собой кратковременное прерывание токовой цепи на магистральных каналах с сигнализацией готовности по шлейфу, которое не интерпретируется подключенной системой как разъединение вызова.

Один раз УАТС или PSTN снимает показания сигнал отбоя, это обычно приостанавливает текущий вызов и предоставляет дополнительный тональный сигнал или доступ к другим функциям, таким как доступ ожидания вызова или передача.

Сигнал отбоя сделан путем мгновенного придавливания подставки по телефону. Некоторые телефонные трубки имеют кнопку, названную 'флэш-памятью' или 'отзывом', который передает 'разрыв петли по времени' или 'откалиброванный сигнал Flash', который является сигналом отбоя, который имеет точную синхронизацию.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизаторы Cisco 1750

  • Cisco выпуск ПО IOS� 12. 2,5 А

  • Поддержка программного обеспечения версии 2 H.323 является предпосылкой. Это было доступно начиная с Cisco IOS Software Release 12.05T и позже. Обнаружение хук-флэша / генерация поддерживается на аналоговой Станции внешнего обмена (FXS) и Отделении междугородной телефонной связи (FXO) голосовые порты. Они доступны на этих Аппаратных платформах Cisco:

    • 1750/51/60

    • 2600

    • 3600

    • 3700

    • MC 3810

    • Catalyst 4000 с модулем шлюза доступа (AGM)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Общие сведения

Много клиентов используют комбинацию FXS и Портов FXO для расширения телефонных трубок по IP - сетям. Они хотят сохранить функции существующей УАТС, такие как переадресация вызовов, никакой ответ на голосовую почту, и передавать/держаться удаленные расширения. Более раннее программное обеспечение Cisco VoIP не предоставляло полное управление для разрешения прозрачной интеграции. Однако с выпуском поддержки H.323 версии 2 в Cisco IOS Software Release 12.0.5T и позже, теперь возможно обнаружить и передать сигнализацию отбоя по IP - сетям.

Когда порт FXS настроен для длинного 'сигнала отбоя в' значении таймера (больше, чем 500 мс), пользователи могут жаловаться, что, когда они зависают и сразу берут телефонную трубку, не очистился вызов. Если значение установлено слишком низко, сигнал отбоя может быть интерпретирован как зависание, но более высокое значение означает, что телефонную трубку нужно оставить "зависнутой" в течение более длинного периода для очистки вызова. В некоторых случаях сильный удар подставки может вызвать проблемы также. Поскольку телефонная трубка "зависнута", напряжение пружины на кнопке обработчика прерываний вызывает множественные короткие перерывы на линии, известной как сильный удар подставки. Тщательная настройка сигнала отбоя в синхронизации значения может быть необходима для лучших результатов. Одна возможность в таких случаях состоит в том, чтобы использовать телефонные трубки с кнопкой флэш-памяти, которая передает сигнал отбоя определенного периода. Порт FXO может собираться совпасть с этим значением, и Порт FXO тогда генерирует исходящее сообщение hookflash. Много PBXes имеют опцию Класса обслуживания (CoS), названную 'откалиброванным сигналом Flash' или 'разрывом петли по времени', который позволяет им распознавать сигналы отбоя определенной продолжительности и игнорировать другие короче или более длинные циклические прерывания. Такие параметры настройки полезны в устранении ложных разъединений и генерации недопустимых сигналов хук-флэш к УАТС.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Настройте OPX PLAR и передачу сигнала отбоя

Используйте эту процедуру для настройки частного канала, автоматический вызов по звонку (PLAR) Дистанционное расширение (OPX) и передача сигнала отбоя.

  1. Настройте Порт FXO на Маршрутизаторе MainSite как подключение-PLAR-opx.

    Режим OPX позволяет удаленным пользователям на портах FXS появляться к центральной АТС как непосредственно связанное расширение. Когда Порт FXO обнаруживает вызывной сигнал от УАТС, маршрутизатор передает настройку вызова VoIP к удаленному порту FXS, но это не берет Порт FXO при снятой трубке. Когда порт FXS маршрутизатора RemoteSide взят, в результате УАТС только видит сигнал ответа вызова. После того, как УАТС достигает времени ожидания ответа (вызов раздается), тогда это может закончить вызов, передать вызов голосовой почте или звонить на другое расширение/группу одновременного вызова. Без режима OPX сразу используется Порт FXO после того, как это снимает показания звон, и УАТС тогда неспособна выполнить переадресацию вызовов, никакой ответ, или перевернуться к голосовой почте.

  2. Маршрутизатор на удаленной стороне должен быть настроен, чтобы снять показания и затем передать сигнал хук-флэш порту FXS.

    Так как сигнал отбоя является мгновенным перерывом в текущем зацикливании на порту FXS и не может быть передан как аудиосигнал, маршрутизатор передает сигнал хук-флэш через двухтональный многочастотный набор (DTMF) реле как'!' символ. Маршрутизатор с Портом FXO тогда передает разрыв короткого контура, который внешнее устройство рассматривает как сигнал отбоя. Для надлежащего прохождения сигнала хук-флэш VoIP одноранговые соединение должны быть настроены для h245-сигнала dtmf-relay.

  3. Таймеры физического порта должны быть отрегулированы для удовлетворения характеристикам телефонной трубки на порту FXS и продолжительности циклического прерывания сигнала отбоя из Порта FXO как показано здесь:

    • Голосовой порт FXS (Маршрутизатор на удаленной стороне) использует сигнал отбоя синхронизации - в msec дайте команду, откуда msec является максимальным значением циклического прерывания (в миллисекундах) телефонной трубки, которая интерпретируется как сигнал отбоя. Циклическое прерывание, больше, чем установленное значение, расценено как разъединение, и вызов отброшен. Любой интервал под этим значением заставляет маршрутизатор передавать'!' символ через H.245-сигнальную Передачу сигналов DTMF в сообщениях протоколов VoIP.

    • Голосовой порт FXO (Маршрутизатор MainSite) использует сигнал отбоя синхронизации msec команда, где msec является продолжительностью исходящего циклического прерывания в миллисекундах. Когда маршрутизатор получает H.245-сигнальный сигнал Передачи сигналов DTMF в сообщениях протоколов VoIP, Порт FXO генерирует циклическое прерывание для заданного интервала.

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

/image/gif/paws/15405/pbx_across_ip.gif

Конфигурации

В данном документе используются конфигурации, показанные ниже.

MainSite
MainSite#show run 
Building configuration...

Current configuration : 1121 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MainSite
!
memory-size iomem 20
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback1
 ip address 205.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.1 255.255.255.252
 no fair-queue
 clockrate 1300000
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 205.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
voice-port 1/0
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec. 

 connection plar opx 200
 
!--- Use PLAR OPX option on the FXO port. 

!
voice-port 1/1
 timing hookflash-out 500
 
!--- Outgoing hookflash is 500 msec.

 connection plar opx 201
 
!--- Use PLAR OPX option on the FXO port.

!
dial-peer voice 100 pots
 destination-pattern 100
 port 1/0
!
dial-peer voice 101 pots
 destination-pattern 101
 port 1/1
!
dial-peer voice 200 voip
 incoming called-number .
 destination-pattern 20.
 session target ipv4:200.1.1.1
 dtmf-relay h245-signal
 
!--- H.245-signal to pass hookflash.

 ip precedence 5
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Удаленный сайт
RemoteSite#show run 
Building configuration...

Current configuration : 1096 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RemoteSite
!
memory-size iomem 25
ip subnet-zero
!
call rsvp-sync
voice rtp send-recv
!
interface Loopback0
 ip address 200.1.1.1 255.255.255.0
!
interface Serial0
 bandwidth 1500
 ip address 192.168.1.2 255.255.255.252
 no fair-queue
 ip rtp priority 16384 16383 100
!
router eigrp 1
 network 192.168.1.0
 network 200.1.1.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip pim bidir-enable
!
!
voice-port 1/0 
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.   
  
 connection plar 100
 
!--- PLAR provides dial tone from remote PBX. 

!
voice-port 1/1
 timing hookflash-in 1000
 
!--- Interpret loop breaks of up to 1 second.    
 
 connection plar 101
 
!--- PLAR provides dial tone from the remote PBX.

!
dial-peer voice 100 voip
 incoming called-number .
 destination-pattern 10.
 session target ipv4:205.1.1.1
 dtmf-relay h245-signal
 
!--- Use H.245-signal to pass hookflash.

 ip precedence 5
!
dial-peer voice 200 pots
 destination-pattern 200
 port 1/0
!
dial-peer voice 201 pots
 destination-pattern 201
 port 1/1
!
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Проверка и устранение неполадок

Этот раздел предоставляет сведения, можно использовать, чтобы проверить и устранить неполадки конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug h225 {asn1 | события} - Отображает дополнительные сведения о фактическом содержании Регистрации H.225, Разрешения и Статуса (RAS) сообщения.

    asn1 Указывает, что только отображено содержание ASN.1 любого сообщения H.225, передаваемого или полученного.
    события Указывает, что отображены ключевые события Q.931, которые происходят при размещении вызова H.323 от одного шлюза до другого.

Сигнал отбоя передают, поскольку H.245 обменивается сообщениями через TCP, таким образом, возможно контролировать сигнализацию при помощи debug h245 asn1 для показа пакетов H.245.

Это два следа отладки. Первые показы получение цифры '5' (передача вызовов H.245 передает цифру и продолжительность). Второй след показывает сигнал отбоя (показанный как'!'). Нет никакой продолжительности для сигнала отбоя. Сигнал отослан Порт FXO на основе настроенного сигнала отбоя синхронизации msec значение.

MainSite#
MainSite#debug h245 asn1 
H.245 ASN1 Messages debugging is on
MainSite#
00:52:17: H245 MSC INCOMING ENCODE BUFFER::= 6D 810B66A0 0F9F58AD AF684A00 00
00:52:17: 
00:52:17: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "5"
      
!--- Digit relayed is 5. 

      duration 4000
      rtp 
      {
        timestamp 2913953866
        logicalChannelNumber 1
      }
    }

00:52:18: H245 MSC INCOMING ENCODE BUFFER::= 6D 82064001 26000000 
00:52:18: 
00:52:18: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signalUpdate :
 
    {
      duration 295
      
!--- Digit duration was 295 msec. 

      rtp 
      {
        logicalChannelNumber 1
      }
    }

MainSite#


!--- This trace from the destination router shows 
!--- the hookflash passed as the character '!'. 

MainSite#
00:52:36: H245 MSC INCOMING ENCODE BUFFER::= 6D 81020420 
00:52:36: 
00:52:36: H245 MSC INCOMING PDU ::=

value MultimediaSystemControlMessage ::= indication : userInput : signal : 
    {
      signalType "!"
     
 !--- Hookflash is passed as '!'. 

    }

MainSite#

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 15405