Технологии коммутируемого доступа в сеть : Технология DDR

Dial-on-Demand Routing (DDR) с простым IP и DHCP сервером

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ объясняет использование Cisco программное обеспечение IOS� Простая функция IP, которая полезна в случаях, где весь сайт соединяется с Интернетом через интернет-провайдера (ISP), который назначает только один IP-адрес для всего удаленного сайта. Маршрутизатор Easy IP вызывает сервер сетевого доступа (NAS) поставщика услуг и согласовывает собственный WAN IP-адрес. Затем маршрутизатор использует трансляцию сетевых адресов (NAT) через этот согласованный адрес с преобразованием адреса порта (PAT) для обеспечения внешнего доступа к внутренним пользователям. Еще одна дополнительная функция маршрутизатора Easy IP - играть роль сервера DHCP (протокол динамической конфигурации узла) для внутренних клиентов LAN. Маршрутизатор Cisco для малого и домашнего офиса (SOHO) обычно используется в конфигурации этого типа.

Предварительные условия

Требования

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизатор Easy IP - Cisco 3620 с четырьмя Ethernet и восемью интерфейсами BRI рабочее программное обеспечение Cisco IOS версии 12.0(7) XK2.

  • Сервер доступа – Cisco AS5300 с одним портом Ethernet, одним портом Fast Ethernet и четырьмя портами T1/PRI с разделением каналов под управлением Cisco IOS software release 12.1(7).

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Общие сведения

Компоненты Easy IP

  • Протокол управления/IP Протокола PPP (IPCP): Это определено в RFC 1332 leavingcisco.com. IPCP обеспечивает возможность динамически настраивать IP-адреса через PPP. Служба маршрутизации Easy IP на Cisco IOS использует протокол PPP/IPCP для динамического согласования IP-адреса собственного WAN-интерфейса с центральным сервером доступа или DHCP-сервером.

  • NAT: Функционирует на маршрутизаторе, обеспечивающем соединение двух и более сетей. В Easy IP для адресации по крайней мере одной из этих сетей (обозначаемой как "внутренняя" или "LAN") используются частные адреса, которые должны быть преобразованы в зарегистрированные адреса, прежде чем пакеты можно будет передавать в другую зарегистрированную сеть ("внешнюю" или "WAN"). В контексте Easy IP преобразование адресов портов (PAT) используется для перевода всех внутренних частных адресов в один внешний зарегистрированный IP-адрес.

  • Так как требуется всего три бита подсети, для описания хоста в адресе остается пять бит: Это - дополнительная функция маршрутизатора Easy IP Cisco, который может использоваться для присвоения IP-адресов на внутренних клиентов LAN. Можно использовать также другие способы присваивания IP-адресов клиентам, такие как статические назначения или использование сервера DHCP PC.

Как удобно работает IP в пошаговом режиме

  1. Если маршрутизатор Easy IP настроен как DHCP server, LAN, на которую внутренние клиенты получают закрытый IP - адрес от него, включается. Если он не настроен как таковой, клиенты должны иметь IP-адрес, присвоенный им каким-нибудь другим способом.

  2. Когда внутренний клиент LAN генерирует содержательный трафик (как это определено списками контроля доступа) для удаленного доступа, маршрутизатор Easy IP вызывает и запрашивает зарегистрированный IP-адрес с сервера доступа центрального узла с помощью PPP/IPCP. После того, как подключение установлено, другие внутренние клиенты LAN могут использовать этот канал, как показано в шаге 4.

  3. Центральный сервер доступа к узлу отвечает динамическим глобальным адресом из пула локальных IP-адресов, который назначается WAN-интерфейсу маршрутизатора Easy IP.

  4. Маршрутизатор Easy IP использует PAT для автоматического создания трансляции, которая привязывает зарегистрированный IP - адрес Интерфейса WAN с закрытым IP - адресом LAN, которой сделаны внутренний клиент и соединение с Сервером доступа на центральном узле.

Для более подробного понимания Простого IP сошлитесь на Описание технологических решений - Cisco IOS Easy IP.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

/image/gif/paws/15364/ddreasyip.gif

Конфигурации

В данном документе используется следующая конфигурация:

Простой маршрутизатор IP
EasyIP#show running-config
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname EasyIP
!
username ISP-AS password 0 ipnegotiate

! --- Username for remote router (ISP-AS) and shared secret.
! --- Shared secret(used for CHAP) must be the same on both sides.

ip subnet-zero
no ip domain-lookup
no ip dhcp conflict logging

! --- Disable the recording of DHCP address conflicts on the DHCP server.

ip dhcp excluded-address 10.0.0.1

! --- Specifies a IP address that the DHCP server should not assign to clients.

ip dhcp pool soho

! --- Configure the DHCP address pool name and enter DHCP pool configuration mode.

 network 10.0.0.0 255.0.0.0

 ! --- Specifies the subnet network number and mask of the DHCP address pool.

 default-router 10.0.0.1

 ! --- Specifies the IP address of the default router for a DHCP clients.
 
 lease infinite

 ! --- Specifies the duration of the lease.

!
isdn switch-type basic-5ess
isdn voice-call-failure 0
!
interface Ethernet0/0
 ip address 10.0.0.1 255.0.0.0

 ! --- IP address for the Ethernet interface. 

 no ip directed-broadcast
 ip nat inside

! --- Defines the interface as internal for network address translation.

!

! Unused ethernet interfaces omitted for brevity

!
interface BRI1/0
 ip address negotiated

! --- Enables PPP/IPCP negotiation for this interface.

 no ip directed-broadcast
 ip nat outside

! --- Defines the interface as external for network address translation.

 encapsulation ppp
 dialer idle-timeout 60

! --- Idle timeout(in seconds)for this BRI interface.

 dialer string 97771200

! --- Specifies the telephone number required to reach the central access server.

 dialer-group 1

! --- Apply interesting traffic defined in dialer-list 1.

 isdn switch-type basic-5ess
 ppp authentication chap
!

!-- Unused BRI interfaces omitted for brevity.

!
ip nat inside source list 100 interface BRI1/0 overload 

! --- Establishes dynamic source translation (with PAT) for addresses which are 
! --- identified by the access list 100.

ip classless
ip route 0.0.0.0 0.0.0.0 BRI1/0 permanent

! --- Default route is via BRI1/0.

no ip http server
!
access-list 100 permit ip 10.0.0.0 0.255.255.255 any

! --- Defines an access list permitting those addresses that are to be translated.

dialer-list 1 protocol ip permit

! --- Interesting traffic is defined by dialer-list1.
! --- This is applied to BRI1/0 using dialer-group 1.

line con 0
 transport input none
line aux 0
line vty 0 4
 login
!         
end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

команды "show"

Некоторые команды show поддерживаются Интерпретатором выходных данных; это позволяет выполнять анализ выходных данных команды show.

  • show ip interface brief- Отображает состояние интерфейса и IP-адрес, настроенный в интерфейсе.

  • show interfaces- Предоставляет сведения высокого уровня об интерфейсе staus для определенного интерфейса.

  • команда show ip nat statistics служит для отображения статистики трансляции сетевых адресов (NAT).

  • show ip nat translations – Показывает активные трансляции NAT.

  • show port - отображение статуса каждого уровня ISDN. Проверка функционирования первого и второго уровней модели OSI в сети ISDN. См. документ Использование Команды show isdn status для Устранения проблем BRI для дополнительных сведений об устранении проблем.

  • show dialer - Отображает сведения о программе для набора номера.

Образец команды show output

Следующие выходные данные команды show получены до того, как маршрутизатор Easy IP инициировал коммутируемое соединение с сервером доступа центрального узла: как видно, интерфейс BRI1/0 работает и не имеет IP-адреса, но IP-адрес будет согласован с помощью IPCP.

EasyIP#show ip interface brief
Interface                  IP-Address      OK? Method Status                Prol
Ethernet0/0                10.0.0.1        YES manual up                    up  
Ethernet0/1                unassigned      YES manual administratively down dow 
Ethernet0/2                unassigned      YES manual administratively down dow 
Ethernet0/3                unassigned      YES manual administratively down dow 
BRI1/0                     unassigned      YES IPCP   up                    up

! -- Interface is Up, but no IP Address is assigned since it is not connected

BRI1/0:1                   unassigned      YES unset  down                  dow 
BRI1/0:2                   unassigned      YES unset  down                  dow 

! -- Both B-channels are down

BRI1/1                     unassigned      YES manual administratively down dow 
BRI1/1:1                   unassigned      YES unset  administratively down dow 
BRI1/1:2                   unassigned      YES unset  administratively down dow

EasyIP#show interfaces bri1/0
BRI1/0 is up, line protocol is up (spoofing)
  Hardware is BRI with integrated NT1
Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
   .
   .
EasyIP#

Придерживающиеся выходные данные команды show, которые взяты после маршрутизатора Easy IP, инициировали подключение удаленного доступа с Сервером доступа на центральном узле, показывает, что интерфейс BRI1/0 получил свой IP-адрес 200.1.0.3 от Сервера доступа на центральном узле через PPP/IPCP.

EasyIP#show ip interface brief 
Interface                  IP-Address      OK? Method Status                Prorocol
Ethernet0/0                10.0.0.1        YES manual up                    up  
Ethernet0/1                unassigned      YES manual administratively down dow 
Ethernet0/2                unassigned      YES manual administratively down dow 
Ethernet0/3                unassigned      YES manual administratively down dow 
BRI1/0                     200.1.0.3       YES IPCP   up                    up  

! -- Int BRI1/0 has a registers IP address assigned after connection is up

BRI1/0:1                   unassigned      YES unset  up                    up  
BRI1/0:2                   unassigned      YES unset  down                  dow 

! -- 1st B-channel (BRI1/0:1) is UP

BRI1/1                     unassigned      YES manual administratively down dow 
BRI1/1:1                   unassigned      YES unset  administratively down dow 
BRI1/1:2                   unassigned      YES unset  administratively down dow
EasyIP#show interfaces bri1/0
BRI1/0 is up, line protocol is up (spoofing)
  Hardware is BRI with integrated NT1
Internet address is 200.1.0.3/32
  MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
  .
  . 
  EasyIP#

Необходимо проверить, могут ли главные узлы внутренней частной сети подключиться к серверу доступа центрального узла и правильно ли выполняется преобразование NAT. Это может быть выполнено при помощи утилиты расширенной проверки ping. На маршрутизаторе EasyIP отправьте эхо-запрос к интерфейсу Ethernet сервера доступа центрального узла, а в качестве источника эхо-запроса задайте адрес маршрутизатора EasyIP в частной LAN. Это гарантирует, что пакет обработан PAT и что клиенты на LAN могут связаться с сетью на центральном объекте.

EasyIP#ping
Protocol [ip]: 
Target IP address: 192.168.16.1

! -- Ethernet interface IP address of the Central Site Access Server.

Repeat count [5]: 10
Datagram size [100]: 
Timeout in seconds [2]: 
Extended commands [n]: y
Source address or interface: 10.0.0.1

! --Ethernet interface IP address (private) of the Easy IP router.

Type of service [0]: 
Set DF bit in IP header? [no]: 
Validate reply data? [no]: 
Data pattern [0xABCD]: 
Loose, Strict, Record, Timestamp, Verbose[none]: 
Sweep range of sizes [n]: 
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 192.168.16.1, timeout is 2 seconds:
!!!!!!!!!!
Success rate is 100 percent (10/10), round-trip min/avg/max = 32/34/36 ms

Приведенный выше вывод показывает, что процент успешных попыток равен 100, что означает, что средство NAT функционирует корректно и что узлы SOHO могут подключаться к серверу доступа на центральном узле. Более подробные сведения о преобразованиях NAT можно получить из приведенного вывода команд show.

EasyIP#show ip nat statistics 
Total active translations: 10 (0 static, 10 dynamic; 10 extended)
Outside interfaces:
  BRI1/0, BRI1/0:1, BRI1/0:2
Inside interfaces: 
  Ethernet0/0
Hits: 169  Misses: 185
Expired translations: 175
Dynamic mappings:
-- Inside Source
access-list 100 interface BRI1/0 refcount 10
EasyIP#show ip nat translations 
Pro Inside global      Inside local       Outside local      Outside global
icmp 200.1.0.3:32      10.0.0.1:32        192.168.16.1:32    192.168.16.1:32
icmp 200.1.0.3:33      10.0.0.1:33        192.168.16.1:33    192.168.16.1:33
icmp 200.1.0.3:34      10.0.0.1:34        192.168.16.1:34    192.168.16.1:34
icmp 200.1.0.3:35      10.0.0.1:35        192.168.16.1:35    192.168.16.1:35
icmp 200.1.0.3:36      10.0.0.1:36        192.168.16.1:36    192.168.16.1:36
icmp 200.1.0.3:37      10.0.0.1:37        192.168.16.1:37    192.168.16.1:37
icmp 200.1.0.3:38      10.0.0.1:38        192.168.16.1:38    192.168.16.1:38
icmp 200.1.0.3:39      10.0.0.1:39        192.168.16.1:39    192.168.16.1:39
icmp 200.1.0.3:40      10.0.0.1:40        192.168.16.1:40    192.168.16.1:40
icmp 200.1.0.3:41      10.0.0.1:41        192.168.16.1:41    192.168.16.1:41
EasyIP#

Вывод команды show isdn status отображает состояние каждого уровня ISDN. Удостоверьтесь, что уровни 1 и 2 соответствуют показанному в примере

EasyIP#show isdn status 
Global ISDN Switchtype = basic-5ess
ISDN BRI1/0 interface
        dsl 8, interface ISDN Switchtype = basic-5ess
    Layer 1 Status:
        ACTIVE
    Layer 2 Status:
        TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
    Layer 3 Status:
        1 Active Layer 3 Call(s)
    Activated dsl 8 CCBs = 1
        CCB:callid=8098, sapi=0, ces=1, B-chan=1, calltype=DATA
    The Free Channel Mask:  0x80000002

См. документ Использование Команды show isdn status для Устранения проблем BRI для дополнительных сведений об устранении проблем.

Придерживающиеся выходные данные show dialer показывают, что вызов номера инициируется внутренним IP-адресом частной сети (например, 10.0.0.1).

EasyIP#show dialer 

BRI1/0 - dialer type = ISDN

Dial String      Successes   Failures    Last DNIS   Last status
97771200                23          0    00:02:02       successful   Default
0 incoming call(s) have been screened.
0 incoming call(s) rejected for callback.

BRI1/0:1 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is data link layer up
Dial reason: ip (s=10.0.0.1, d=192.168.16.1)
Time until disconnect 36 secs
Current call connected 00:02:03
Connected to 97771200 (ISP-AS)

BRI1/0:2 - dialer type = ISDN
Idle timer (120 secs), Fast idle timer (20 secs)
Wait for carrier (30 secs), Re-enable (15 secs)
Dialer state is idle

Устранение неполадок

команды "debug"

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug ppp negotiation - Предоставляет сведения о процессе согласования Протокола PPP. debug ip nat - Предоставляет сведения

  • команда debug ip nat- выдает сведения о пакетах IP, преобразованных функцией NAT IP.

  • debug isdn q921 Предоставляет отладку уровня канала передачи данных сообщений q.921.

  • debug isdn q931- Предоставляет отладку сетевого уровня сообщений q.931.

  • "debug dialer" - выполняет маршрутизацию вызовов по запросу (DDR) для исходящих вызовов.

Пример отладочных выходных данных

Следующие выходные данные отладки согласования ppp показывают процесс согласования протокола PPP/IPCP.

EasyIP#debug ppp negotiation 
PPP protocol negotiation debugging is on
.
.

2d07h: BR1/0:1 IPCP: O CONFREQ [Closed] id 223 len 10
2d07h: BR1/0:1 IPCP:    Address 0.0.0.0 (0x030600000000)
2d07h: BR1/0:1 CDPCP: O CONFREQ [Closed] id 63 len 4
2d07h: BR1/0:1 IPCP: I CONFREQ [REQsent] id 47 len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.1 (0x0306C8010001)
2d07h: BR1/0:1 IPCP: O CONFACK [REQsent] id 47 len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.1 (0x0306C8010001)
2d07h: BR1/0:1 CDPCP: I CONFREQ [REQsent] id 41 Len 4
2d07h: BR1/0:1 CDPCP: O CONFACK [REQsent] id 41 Len 4
2d07h: BR1/0:1 IPCP: I CONFNAK [ACKsent] id 223 Len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.3 (0x0306C8010003)
2d07h: BR1/0:1 IPCP: O CONFREQ [ACKsent] id 224 Len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.3 (0x0306C8010003)
2d07h: BR1/0:1 CDPCP: I CONFACK [ACKsent] id 63 Len 4
2d07h: BR1/0:1 CDPCP: State is Open
2d07h: BR1/0:1 IPCP: I CONFACK [ACKsent] id 224 Len 10
2d07h: BR1/0:1 IPCP:    Address 200.1.0.3 (0x0306C8010003)
2d07h: BR1/0:1 IPCP: State is Open
2d07h: BR1/0 IPCP: Install negotiated IP interface address 200.1.0.3

! -- The EasyIP router will install the negotiated WAN IP address.

2d07h: BR1/0 IPCP: Install route to 200.1.0.1

! -- A route to the Central Site Access Server is installed.

2d07h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/0:1, changed state Up
2d07h: %ISDN-6-CONNECT: Interface BRI1/0:1 is now connected to 97771200 ISP-AS
EasyIP#

Выходные данные debug ip nat отображают информацию о пакетах IP, преобразованных трансляцией сетевого IP - адреса (NAT) функция.

EasyIP#debug ip nat detailed 
IP NAT detailed debugging is on
.
.
2d00h: NAT: o: icmp (10.0.0.1, 2015) -> (192.168.16.1, 2015) [909]
2d00h: NAT: i: icmp (10.0.0.1, 2015) -> (192.168.16.1, 2015) [909]
2d00h: NAT: ipnat_allocate_port: wanted 2015 got 2015
2d00h: NAT*: o: icmp (192.168.16.1, 2015) -> (200.1.0.3, 2015) [909]
2d00h: NAT: o: icmp (10.0.0.1, 2016) -> (192.168.16.1, 2016) [910]
2d00h: NAT: i: icmp (10.0.0.1, 2016) -> (192.168.16.1, 2016) [910]
2d00h: NAT: ipnat_allocate_port: wanted 2016 got 2016
2d00h: NAT*: o: icmp (192.168.16.1, 2016) -> (200.1.0.3, 2016) [910]
2d00h: NAT: o: icmp (10.0.0.1, 2017) -> (192.168.16.1, 2017) [911]
2d00h: NAT: i: icmp (10.0.0.1, 2017) -> (192.168.16.1, 2017) [911]
2d00h: NAT: ipnat_allocate_port: wanted 2017 got 2017
2d00h: NAT*: o: icmp (192.168.16.1, 2017) -> (200.1.0.3, 2017) [911]
2d00h: NAT: o: icmp (10.0.0.1, 2018) -> (192.168.16.1, 2018) [912]
2d00h: NAT: i: icmp (10.0.0.1, 2018) -> (192.168.16.1, 2018) [912]
.
.

EasyIP#undebug all 
All possible debugging has been turned off

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 15364