Интерфейсы и модули Cisco : Модуль коммутации контента Cisco

Настройка распределения нагрузки сервера IOS с помощью зондов HTTP в режиме диспетчера

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (19 сентября 2015) | Отзыв


Содержание


Введение

Функцией Распределения нагрузки сервера (SLB) IOS� Cisco является Cisco на основе IOS решение, которое предоставляет распределение нагрузки сервера. Эта функция позволяет вам определять виртуальный сервер, который представляет кластер реальных серверов, известных как ферма серверов. Когда клиент инициирует соединение к виртуальному серверу, IOS SLB балансировки нагрузки подключается к выбранному реальному серверу, в зависимости от настройки баланса алгоритма баланса загрузки или упредителя равновесия нагрузки.

SLB IOS может быть настроен для работы в следующих двух режимах.

  • режим координации — В этом режиме, адрес виртуального сервера известен реальным серверам. Необходимо настроить каждый из реальных серверов с адресами обратной связи для их уникального интерфейса обратной связи. Это необходимо для предоставления каждому компьютеру серверной фермы IP-адреса фактического виртуального сервера. Реальному серверу назначения тогда позволят непосредственно ответить клиентам, использующим адрес обратной связи, как это было бы для собственного IP-адреса. SLB IOS перенаправляет пакеты к реальному серверу на Уровне 2 в уровне управления доступом к среде (MAC). Так как IP-адрес виртуального сервера не модифицируется в режиме координации, реальные серверы должны быть смежны с уровнем 2 с SLB IOS, или промежуточные маршрутизаторы не могли бы быть в состоянии направить к выбранному реальному серверу.

  • адресный режим — В этом режиме, виртуальный сервер может быть назначен на IP-адрес, который неизвестен реальным серверам. SLB IOS преобразовывает пакеты, которыми обмениваются между клиентом и реальным сервером, преобразовывая IP-адрес виртуального сервера в адрес реального сервера через Технологию NAT. Для использования адресного режима добавьте туземную команду сервера к ферме серверов.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Релиз 12.1 Supervisor IOS семейства Catalyst 6000 (6) E для Supervisor Engine 1 с MSFC1 (c6sup11-jsv-mz.121-6. E1

  • Microsoft Windows 2000 / Web-серверы IIS

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

Зонды HTTP

SLB IOS поддерживает зонды Протокола HTTP, зонды эхо-запроса и зонды Протокола WSP. Можно использовать метод Проверки HTTP, чтобы проверить подключение и контролировать реальные серверы, являющиеся с балансировкой нагрузки. Зонды определяют статус каждого реального сервера в ферме серверов. В данном примере Проверки HTTP настроены с помощью порта TCP 80. Проверки HTTP настроены, чтобы соединяться каждые восемь секунд и запрашивать команду get метода, ища 200 кодов ответа от сервера. Эти конфигурации являются всеми значениями по умолчанию.

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/15055/ios_slb-01.gif

Конфигурации

Конфигурация IOS SLB Использование Catalyst 6509
Current configuration:

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname cat6

!

boot buffersize 126968

boot system flash slot0:c6sup11-jsv-mz.121-6.E1.bin

!

redundancy

 main-cpu

  auto-sync standard

ip subnet-zero

!

no ip finger

no ip domain-lookup

!

ip slb probe KEEPALIVE http

!

ip slb serverfarm SERVERS

 probe KEEPALIVE

 !

 real 10.1.1.3

  inservice

 !

 real 10.1.1.5

  inservice

!

ip slb vserver WEBSITE

 virtual 172.17.63.215 tcp www

 serverfarm SERVERS

 inservice

!

cns event-service server

!

interface GigabitEthernet1/1

 no ip address

 shutdown

!

interface GigabitEthernet1/2

 no ip address

 shutdown

!

interface FastEthernet2/1

 no ip address

 switchport

 switchport access vlan 100

 switchport mode access

!

interface FastEthernet2/2

 no ip address

 shutdown

!

interface FastEthernet2/3

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/4

 no ip address

 switchport

 switchport access vlan 200

 switchport mode access

!

interface FastEthernet2/5

 no ip address

 shutdown

!

interface FastEthernet2/48

 no ip address

 shutdown

!         

interface Vlan1

 no ip address

 shutdown

!

interface Vlan100

 ip address 172.17.63.211 255.255.255.192

!

interface Vlan200

 ip address 10.1.1.250 255.255.255.0

!

ip default-gateway 172.17.63.193

ip classless

ip route 0.0.0.0 0.0.0.0 172.17.63.193

no ip http server

!

line con 0

 transport input none

line vty 0 4

 password cisco

 login

!

end

команды show и их краткие описания

команда "show ip slb mode"

Команда show ip slb mode отображает статус Режима SLB.

cat6#show ip slb mode 
     SLB forwarding mode = rp (default) 
     SLB configured mode = rp (default) 

Для выполнения программного обеспечения SLB Cisco IOS необходимо настроить режим с помощью команды show ip slb mode [csm | rp] перед любой конфигурацией. В команде show ip slb mode аргумент армированного пластика является по умолчанию. Если у вас есть Модуль коммутации контента (CSM), можно только настроить аргумент CSM. CSM предоставляет высокопроизводительные подключения между фермами серверов сетевых устройств на основе Уровня 4 через 7 информационных пакетов. Можно представлять группу реальных серверов (ферма серверов) как экземпляр одиночного сервера (виртуальный сервер), сбалансировать трафик к ферме серверов путем выбора одного из реальных серверов (распределение нагрузки сервера) и ограничить трафик индивидуальными серверами (сложные подключения) и фермы серверов (политика). Для получения дополнительной информации посмотрите Настройку, Безопасную (маршрутизатор) Режим на Модуле коммутации контента.

команда "show ip slb vserver"

Команда show ip slb vserver отображает данные виртуального сервера. Ниже также виден статус виртуального сервера и количество соединений:

cat6#show ip slb vserver 

slb vserver      protocol      virtual              state      conns 
------------------------------------------------------------------------ 
WEBSITE         TCP       172.16.63.215/32:80      OPERATIONAL   0 

команда "show ip slb reals"

Команда show ip slb reals отображает сведения о каждом реальном сервере, например, на какой серверной ферме находится каждый сервер, состояния серверов, пороги и подключения.

cat6#show ip slb reals 

real             server farm      weight     state        conns 
------------------------------------------------------------------- 
10.1.1.5         SERVERS           8        OPERATIONAL     0 
10.1.1.3         SERVERS           8        OPERATIONAL     0 

команда "show ip slb serverfarms"

Команда show ip slb serverfarms показывает сведения о серверных фермах. Эта команда показывает предиктор, используемый для распределения нагрузки. В этом примере используется циклический алгоритм, заданный по умолчанию. Вы не будете видеть "ни один" под NAT, потому что устройство находится в режиме координации.

cat6#show ip slb serverfarm 

server farm      predictor    nat        reals    redirect    bind id 
-------------------------------------------------------------------------- 
SERVERS       roundrobin     none         2          0             0 

команда show ip slb conns

Show ip slb conns [virtual_server-название vserver | IP-адрес клиента | firewallfarm-название межсетевого экрана] [подробность] команда отображает активные соединения.

  • vserver - Отображает только те соединения, связанные с определенным виртуальным сервером.

  • virtualserver-название - Название виртуального сервера.

  • клиент - Отображает соединения с определенным IP - адресом клиента.

  • iP-адрес- IP-адрес клиента.

  • подробность - Отображает подробную информацию о соединении.

Если никакие опции не заданы, команда show ip slb conns отображает выходные данные для всех активных подключений IOS SLB.

cat6#show ip slb conns 

vserver         prot    client             real                state            nat 
----------------------------------------------------------------------- --------------- 
WEBSITE         TCP  10.21.188.123:2187    10.1.1.5            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2190    10.1.1.5            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2192    10.1.1.3            ESTAB            none 
WEBSITE         TCP  10.21.188.123:2197    10.1.1.3            CLOSING       	none 
WEBSITE         TCP  10.21.188.123:2200    10.1.1.5            SYNCLIENT        none 
WEBSITE         TCP  10.21.188.123:2201    10.1.1.5            SYNCLIENT        none 

cat6#show ip slb conns detail 

WEBSITE, client = 10.21.188.123:2187 state = ESTAB, real = 10.1.1.5, 
nat = none  v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 1, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2205 state = CLOSING, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 3, sticky = FALSE, flows attached = 0 
WEBSITE, client = 10.21.188.123:2206 state = ESTAB, real = 10.1.1.5, 
nat = none v_ip = 172.17.63.215:80, TCP, service = NONE 
  client_syns = 2, sticky = FALSE, flows attached = 0 

команда show ip slb probe

Команда show ip slb probe отображает информацию о SLB IOS.

Существует три операционных состояния зонда:

  • ПОДВЕДЕННЫЙ - зонд в настоящее время отказывал.

  • В РАБОЧЕМ СОСТОЯНИИ - зонд функционирует обычно.

  • При ТЕСТИРОВАНИИ - зонд никогда не успешно выполнялся, ни из-за какого ответа. SLB IOS не поддерживает счетчиков или таймеров для этого состояния.

Другой отображенной информацией является придерживающееся:

  • Простои - количество интервалов между успешными тестовыми сообщениями.

  • Текущий - время начиная с последнего тестового успеха. Т.е. продолжительность (до сих пор) простоя простого.

  • Кумулятивный - общее время реальный сервер находился под зондовыми испытаниями и отказал. Это значение является суммой Текущего времени плюс общее время всего предыдущего бездействия.

cat6#show ip slb probe 

Server:Port          	State        Outages  	Current    Cumulative 
----------------------------------------------------------------------- 
10.1.1.3:80             OPERATIONAL    1        never         00:05:22 
10.1.1.5:80             OPERATIONAL    0        never         00:00:00 

Обратная связь в режиме диспетчера

После настройки функции SLB на Catalyst 6500 необходимо настроить каждый реальный сервер с устройством возвратной петли / интерфейс. Настройте IP-адрес виртуального сервера как IP - адрес обратной связи с маской подсети 255.0.0.0.

Route Table 
======================================================================= ==== 
Interface List 
0x1 ........................... MS TCP Loopback interface 
0x2 ...00 60 b0 87 dc 1a ...... AMD PCNET Family Ethernet Adapter 
0x1000004 ...02 00 4c 4f 4f 50 ...... MS LoopBack Driver 
======================================================================= ==== 
Active Routes: 
Network	        Destination         Netmask         Gateway     Interface   Metric 
0.0.0.0         0.0.0.0             10.1.1.250      10.1.1.3        1 
10.1.1.0        255.255.255.0       10.1.1.3        10.1.1.3        1 
10.1.1.3        255.255.255.255     127.0.0.1       127.0.0.1       1 
10.255.255.255  255.255.255.255     10.1.1.3        10.1.1.3        1 
127.0.0.0       255.0.0.0           127.0.0.1       127.0.0.1       1 
172.17.63.215   255.255.255.255     127.0.0.1       127.0.0.1       1 
224.0.0.0       224.0.0.0           10.1.1.3        10.1.1.3        1 
224.0.0.0       224.0.0.0           172.17.63.215   172.17.63.215   1 
255.255.255.255 255.255.255.255     10.1.1.3        10.1.1.3        1 
======================================================================= ==== 

Исследуйте сетевой адрес в каждой строке таблицы, где вы видите, что появляется адрес обратной связи. Для серверов для передачи должным образом вам нужна ссылка на хорошо известный сетевой адрес многоадресной рассылки. Это находится в восьмой строке примера, таким образом, необходимо удалить дополнительный маршрут по умолчанию. Это - то, сетевой адрес которого начинается с той же первой цифры как адрес кластера и придерживается три, обнуляет. В приведенном выше примере дополнительный маршрут находится во второй строке.

Ниже приводятся хорошо известные сетевые адреса многоадресной рассылки:

224.0.0.0      224.0.0.0    172.17.63.215      172.17.63.215       1 

Ниже приводятся автоматически установленные маршруты по умолчанию, удаленные из вышеупомянутой таблицы:

0.0.0.0          0.0.0.0    172.17.63.193   172.17.63.215       1

Необходимо удалить дополнительный маршрут для разрешения соответствующего взаимодействия с виртуальным сервером SLB.

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 15055