Оптические сети : Automatic Protection Switching (APS )

Настройка избыточности для POS/APS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ обсуждает функцию Автоматического переключения на резерв (APS) и предоставляет пример того, как настроить APS для резервирования Передачи пакета по сети SONET (POS).

Этот документ позволяет вам понять, как APS работает и помогает вам настраивать и поддерживать APS на маршрутизаторах Cisco. Топология сети на рисунке 1 является основанием этого документа:

Рисунок 1 – топология сети

pos-aps_14680-a.gif

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • SynchronousOptical Network (SONET) (синхронная оптоволоконная сеть) и Технологии пакетной передачи POS (по сети Sonet).

  • Основы конфигурации маршрутизатора Cisco.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco выпуск ПО IOS� 12.0 (10) S.

  • Платформы оборудования серии Cisco 12000.

Поддержка функции APS доступна на платформах оборудования серии Cisco 7500 и 12000, и на программном обеспечении Cisco IOS версии 12.2(5) и позже.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Автоматическое переключение на резерв

Функция APS обеспечивает избыточность и позволяет переключать цепи POS в случае сбоя цепи. Реализация APS позволяет вам настраивать пару линий SONET для избыточности линий. Когда Работа (W) интерфейсные сбои, Защищение (P) интерфейс быстро принимает трафик. В случае сечения волоконного кабеля активная линия переключается автоматически на резервную линию в 60 миллисекундах (10 миллисекундных инициализаций и 50 миллисекундных переключений). APS SONET выполняет переключатели на Уровне 1 (L1). Поэтому переключатель значительно быстрее, чем на Уровне 2 (L2) или Уровень 3 (L3).

Механизм защиты, что эта функция использование имеет 1+1 архитектуру, как описано в Публикации Bellcore TR-TSY-000253, Системах Передачи по протоколу SONET, Общих Общих критериях, Разделе 5.3. APS SONET соответствует GR-253 и ITU-T G.783. Поэтому APS SONET позволяет маршрутизаторам Cisco интегрироваться эффективно с Мультиплексорами ввода-вывода SONET (ADM). Эта функция позволяет конфигурацию любой двунаправленной или однонаправленной коммутации, но двунаправленная нереверсивная коммутация является по умолчанию.

В APS 1+1 архитектура каждая резервная пара линий состоит из интерфейса W и интерфейса P. Интерфейсы W и P подключены к SONET ADM, который посылает ту же сигнальную полезную нагрузку на интерфейсы W и P. W и каналы P могут завершиться в двух портах того же адаптера, линейной карты, или в двух других маршрутизаторах. Когда условие Потери сигнала (SF) или условие Ухудшения качества сигнала (SD) происходят, аппаратные коммутаторы от линии W до линии P. Существует реверсивный параметр. После обнаружения SF условия аппаратные коммутаторы назад к W выравнивают автоматически после восстановления линии W и истечения настроенного периода. Внутриполосный Протокол Protect Group (PGP) достигает координации между линией W и линией P. В нереверсивной опции, если SF условие происходит, аппаратные коммутаторы к P выравнивают, и автоматически не возвращается к линии W.

В цепи P байты K1 и K2 из поля служебной информации Line OverHead (LOH) кадра SONET указывают текущий статус подключения APS и передают все запросы на выполнение действий. Два конца соединения используют этот канал сигнализации для поддержания синхронизации. W и сами каналы P, в маршрутизаторе или маршрутизаторах, в которых они завершают, синхронизируются по независимому каналу связи (использующий PGP APS), изолируются от W и каналов P. Этим независимым каналом может быть другое Подключение SONET, Ethernet или соединение с более низкой пропускной способностью. В маршрутизаторе, настроенном для APS, конфигурация для интерфейса P включает IP-адрес маршрутизатора (обычно и рекомендуемый быть адресом обратной связи), который имеет интерфейс W.

PGP APS, который выполняется поверх Протокола UDP, предоставляет связь между процессом, который управляет интерфейсом W и процессом, который управляет интерфейсом P. Процесс, который управляет каналом P, использует этот протокол для направления процесса, который содержит канал W, на том, активировать ли или деактивировать канал W, в случае ухудшения, потери сигнала канала или ручного вмешательства. Если два процесса теряют связь друг с другом, маршрутизатор W берет на себя полное управление каналом W, как будто не существовал никакой канал P.

APS и связанные команды

Вот спусковые механизмы APS, категоризированные иерархически (от самый низкого приоритета до наивысшего приоритета):

  • Запрос на переключение вручную.

  • Условие SD (Уровень ошибок в канале связи (BER), превышающий порог SD).

  • SF условие (Потеря фрейма (LOF), Потеря сигнала (LOS), Сигнальная линия Индикации тревоги (AIS-L) и BER Линии, который превышает 10-3/or пользователя-provisionable).

  • Запрос принудительного переключения.

Вот параметры IOS для настройки APS:

GSR(config-if)# aps ?
authentication  Authentication string 
force           Force channel 
group           Group association 
lockout         Lockout protection channel 
manual          Manually switch channel 
protect         Protect specified circuit 
reflector       Configure for reflector mode APS 
revert          Specify revert operation and interval 
signaling      Specify SONET/SDH K1K2 signaling 
timers          APS timers 
unidirectional  Configure for unidirectional mode 
working         Working channel number 

В дополнение к новым командам IOS для функции APS Порог "POS" команд настройки Интерфейса пакетной передачи POS (по сети Sonet) и POS report были добавлены для поддержки пользовательской конфигурации пороговых величин BER и создания отчетов Сигналов оповещения SONET. Ниже приведен пример выходных данных:

GSR(config-if)# POS threshold ? 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  sd-ber  set Signal Degrade BER threshold 
  sf-ber  set Signal Fail BER threshold 

GSR(config-if)# POS report ?
  all     all Alarms/Signals 
  b1-tca  B1 BER threshold crossing alarm 
  b2-tca  B2 BER threshold crossing alarm 
  b3-tca  B3 BER threshold crossing alarm 
  lais    Line Alarm Indication Signal 
  lrdi    Line Remote Defect Indication 
  pais    Path Alarm Indication Signal 
  plop    Path Loss of Pointer 
  prdi    Path Remote Defect Indication 
  rdool   Receive Data Out Of Lock 
  sd-ber  LBIP BER in excess of SD threshold 
  sf-ber  LBIP BER in excess of SF threshold 
  slof    Section Loss of Frame 
  slos    Section Loss of Signal 

Режимы коммутации

В двунаправленном режиме, Получающий (Rx) и Передающий (Tx) каналы соединены как пара. В однонаправленном режиме Tx и каналы Rx коммутированы независимо. Например, в двунаправленном режиме, если канал Rx на интерфейсе W имеет потерю сигнала канала, и Rx и каналы Tx коммутированы.

Двунаправленный режим (рекомендуется)

Маршрутизатор W распознает сбой и уведомляет маршрутизатор P (через локальную межкомпонентную систему PGP). Маршрутизатор P дает маршрутизатору W команду отменять выбор интерфейса W (через локальную межкомпонентную систему PGP). Запросы маршрутизатора P ADM для коммутации Tx и Rx к P (через байты K1/K2 на интерфейсе P, которые переходят к ADM). Маршрутизатор P выбирает интерфейс P, и ADM соответствует запросу коммутатора и сигнализирует соответствие (через байты K1/K2 на ADM к волокну интерфейса P).

Однонаправленный режим

Когда существует сигнал тревоги LOS/LOF (сбой) на Rx W, маршрутизатор W распознает сбой и уведомляет маршрутизатор P (через локальную межкомпонентную систему PGP). Маршрутизатор P дает маршрутизатору W команду отменять выбор интерфейса W (через локальную межкомпонентную систему PGP). Маршрутизатор W утверждает Line Alarm Indication Signal (LAIS) столько, сколько интерфейс W является невыбранным, чтобы вынудить ADM коммутировать Rx к интерфейсу P. Запросы маршрутизатора P ADM для коммутации к интерфейсу P (через байты K1/K2 на P взаимодействуют к оптоволокну ADM). Маршрутизатор P выбирает интерфейс P, и динамический мультиплексор (ADM) выполняет требование коммутатора.

В однонаправленном режиме маршрутизатор принуждает ADM для коммутации. В заказе для этого маршрутизатор утверждает LAIS (постоянно, если на W; мгновенно, если в P). Поэтому однонаправленное, которое вы видите, довольно реально, в котором однонаправленный режим соответствует GR-253. Однако то, что также делает однонаправленное, для принуждения второго однонаправленного коммутатора, который переключается, кажется, являются двунаправленными. Это результат ограничений, внедренных к механизмы маршрутизации (IP). На каждому уровне эти механизмы предполагают, что прием и передача трафика должны осуществляться на одном и том же интерфейса., Таким образом, маршрутизатор соответствует однонаправленным протоколам в GR-253, но вызывает коммутацию в модель, которая поддерживает IP. Следовательно, маршрутизатор не поддерживает Tx и Rx на других оптоволоконных парах.

Примечание: Главное отклонение Серии Cisco 12000 от GR-253 - то, что Серия Cisco 12000 не соединяет передачи к W и P, но поддерживает один интерфейс активным за один раз.

Основные сценарии

Неисправность оптоволоконного кабеля между рабочим интерфейсом и ADM

ADM видит ошибку оптоволоконного канала и передает SF ЗАПРОС КОММУТАТОРА к маршрутизатору P (через K1 / байты K2 на волокне интерфейса P) и запрашивает коммутатор к интерфейсу P. Маршрутизатор P сообщает, что маршрутизатор W для отмены выбора (деактивировал) интерфейс W (через локальное межкомпонентное соединение). Маршрутизатор P выбирает (активирует) интерфейс P. Маршрутизатор P сообщает ADM соответствия с запросом коммутатора (через K1 / байты K2 на оптоволокне ADM интерфейса P).

Сбой волоконного соединения между ADM и рабочим интерфейсом (двунаправленный режим)

Маршрутизатор W распознает сбой и уведомляет маршрутизатор P (через локальное межкомпонентное соединение). Маршрутизатор P дает маршрутизатору W команду отменять выбор интерфейса W (через локальное межкомпонентное соединение). ADM запросов маршрутизатора P для коммутации Tx и Rx к P (через байты K1/K2 на P взаимодействуют к оптоволокну ADM). Маршрутизатор P выбирает интерфейс P, и ADM соответствует соответствию запросов коммутатора и сигналов (через байты K1/K2 на ADM к волокну интерфейса P).

Сбой ADM к рабочему оптоволоконному интерфейсу (однонаправленный режим)

Маршрутизатор W распознает сбой и уведомляет маршрутизатор P (через локальное межкомпонентное соединение). Маршрутизатор P дает маршрутизатору W команду отменять выбор интерфейса W (через локальное межкомпонентное соединение). Маршрутизатор W утверждает LAIS для 100 мс, чтобы вынудить ADM коммутировать Rx к интерфейсу P. ADM запросов маршрутизатора P для коммутации к интерфейсу P (через байты K1/K2 на P взаимодействуют к оптоволокну ADM). Маршрутизатор P выбирает интерфейс P, и динамический мультиплексор (ADM) выполняет требование коммутатора.

Сбой передающего и принимающего оптоволоконных соединений между рабочим интерфейсом и каналами ADM

Обе последовательности начинаются. Инициирует ли маршрутизатор P сначала коммутатор к P, или ADM инициирует коммутатор, не имеет значения, потому что результатом является то же.

Оборудованное POS действие маршрутизаторов Cisco как Терминальное оборудование (TE) для раздела SONET/синхронной цифровой иерархии (SDH), линии и сегментов контура ссылки, и может обнаружить и сообщить об этих ошибках SONET/SDH и сигналах тревоги:

  • Раздел: Сигналы LOS, LOF и пересечения порога (TCA) (B1)

  • Линия: AIS (линия и путь), удаленное обнаружение дефектов (RDI) (линия и путь), удаленная индикация ошибок (REI), TCA (B2)

  • Путь: AIS, RDI, REI, (B3), новые события указателя (NEWPTR), Positive Stuffing Event (PSE), Negative Stuffing Event (NSE)

Другие зарегистрированные сведения включают:

  • SF-ber

  • SD-ber

  • C2 – метка сигнала (схема полезной нагрузки)

  • J1 - байт трассировки маршрута

B1, B2, и B3 классифицируются как параметры отслеживания производительности, в то время как другие, такие как LOS, LOF, и LAIS подпадают под определение аварийных сигналов. Мониторинг производительности относится к сложным сигналам предупреждения; обычные сигналы предупреждения сообщают о сбоях. Байт состояния K1/K2 также сообщается для SONET APS или SDH MSP (многофункциональный путь коммутации).

K1/K2 байт

Когда вы обсуждаете APS, сначала необходимо понять, как SONET использует байты K1/K2 в LOH.

Каждый синхронный транспортный сигнал (STS-1) состоит из 810 байтов, из которых 27 байтов – транспортные издержки и 783 байта – блок синхронного полезного трафика (SPE). Таблица 1 иллюстрирует формат кадра STS-1 и этих 9 строк на 90 столбцов.

Таблица 1 – формат кадра STS-1

Служебные данные маршрута
Служебные данные раздела Формирование кадров A1 Формирование кадров A2 Формирование кадров A3 Трассировка J1
B1 BIP-8 Служебный канал E1 Пользователь E1 B3 BIP-8
D1 Data Com D2 Data Com D3 Data Com Метка сигнала C2
Служебные данные строки Указатель H1 Указатель H2 Действие указателя H3 Статус маршрута G1
B2 BIP-8 K1 K2 Пользовательский канал F2
D4 Data Com D5 Data Com Data Com D6 Индикатор H4
D7 Data Com D8 Data Com D9 Data Com Наращивание Z3
D10 Data Com D12 Data Com D12 Data Com Наращивание Z4
Статус/наращивание Sync S1/Z1 Наращивание M0 или M1/Z2 REI-L Служебный канал E2 Последовательное соединение Z5

Байты K1/K2 образуют 16-разрядное поле. Таблица 2 перечисляет использование каждого бита.

Таблица 2 - K1 укусила описания

Биты (шестнадцатеричный формат) Описание
K1 биты 12345678
Биты 5 - 8
nnnn Номер канала, связанного с кодом команды.
Биты 1 - 4
1111 (0xF) Запрос блокировки защиты.
1110 (0xE) Запрос принудительного переключения.
1101 (0xD) SF - запрос с высоким приоритетом.
1100 (0xC) SF – запрос с низким приоритетом.
1011 (0xB) SD — запрос с высоким приоритетом.
1010 (0xA) SD - запрос с низким приоритетом.
1001 (0x9) Не используется.
1000 (0x8) Запрос на переключение вручную.
0111 (0x7) Не используется.
0110 (0x6) Ждите для восстановления запроса.
0101 (0x5) Не используется.
0100 (0x4) Запрос осуществления.
0011 (0x3) Не используется.
0010 (0x2) Обратный запрос.
0001 (0x1) Не возвращайте запрос.
0000 (0x0) Нет запроса.

Примечание: Бит 1 является битом младшего разряда.

Описания битов таблицы 3 - K2

Биты Описание
Биты K2 12345678  
Биты 1 - 4  
nnnn Номер канала, связанного с кодом команды.
Бит 5  
1 Архитектура "1 к n" (1:n).
0 Архитектура "один-плюс-один" (1+1).
Биты 6 - 8  
111 Линейная AIS.
110 Линейный RDI.
101 Двунаправленный режим работы.
100 Однонаправленный режим работы.
Другой Зарезервированный.

Примечание: В K2 (12345678):

  • K2 [1-4] – В настоящее время номер параллельного канала.

  • K2[5] – архитектура (всегда 0 для 1+1).

  • K2 [6-8] – Предоставленный рабочий режим (4 = unidir; 5 = bidir).

  • K2 [6-8] – Также переносит код аварийного сигнала 6=LRDI и 7=LAIS.

Примечание: В SDH, K2 [6-8] переносы только коды аварийного сигнала. Код рабочего режима не отправлен.

Примечание: , Например, если маршрутизатор получает SF, каковы значения для K1 и соответствующего K2 на W? На стороне P?

Примечание:  Ответ: Только K1/K2 передач и чтений P, никогда W. В двунаправленном режиме, если W получает SF, и никакой более высокий запрос не вытесняет его, код от P до ADM:

K1= 0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x05 (protect bridged [working bridge is incomplete];bidirectional)

Примечание: После ответа ADM:

K1 = 0x21 (Reverse request, channel 1) 
K2 = 0x15 (Working bridged; bidirectional)

Примечание: Защищать маршрутизатор txk1k2 будет:

K1=0xC1 (switch request, SF on 1=working, low priority) 
K2 = 0x15 (working bridged; bidirectional) 

Примечание: Коммутатор на данном этапе укомплектован.

Настройте APS

Рисунок 2 показывает основному APS 1+1 конфигурацию от GSR до ADM (ONS 15454) в двунаправленном режиме, нереверсивном (по умолчанию на Серии Cisco 12000). APS линеен коммутированный и сделан на линейном уровне (между Серией Cisco 12000 и ADM по сравнению с путем или от начала до конца).

Примечание: Данный пример не имеет независимого канала для PGP, потому что и интерфейсы W и P находятся на том же маршрутизатор.

Рисунок 2 – основной APS 1+1 конфигурация

pos-aps_14680-a.gif

gsrA# show running-config
! 
interface Loopback0 
ip address 100.1.1.1 255.255.255.0 
no ip directed-broadcast 
! 
interface POS1/0 
ip address 10.1.1.1 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS1/1 
ip address 10.1.1.3 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 100.1.1.1
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 100.1.1.0 0.0.0.255 area 0 

gsrB#show running-config 
! 
interface Loopback0 
ip address 200.1.1.1 255.255.255.0 
! 
interface POS3/0
ip address 10.1.1.2 255.255.255.0 
no ip directed-broadcast 
crc 16 
aps group 10 
aps working 1 
! 
interface POS3/1 
ip address 10.1.1.4 255.255.255.0 
no ip directed-broadcast 
no keepalive 
crc 16 
aps group 10 
aps revert 1 
aps protect 1 200.1.1.1 
! 
router ospf 100 
network 10.1.1.0 0.0.0.255 area 0 
network 200.1.1.0 0.0.0.255 area 0 
! 

Контролируйте и поддержите APS

Для предоставления сведения о системных процессах программное обеспечение IOS включает обширный набор команд EXEC, которые начинаются со слова, показывают. При выполнении этих команд показа детализированные таблицы сведений о системе появляются. Вот список некоторых общих команд показа для функции APS, вместе с примерами выходных данных:

  • show aps

  • show controllers POS

  • show interface POS

! 
gsrA# show aps
POS1/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x20 0x05 
Reverse Request (protect) 
Transmitted K1K2: 0xE0 0x05 
Forced Switch (protect) 
Working channel 1 at 100.1.1.1 (Enabled) 
Pending local request(s): 
0x0E (No Request, channel(s) 0 1) 
Remote APS configuration: working 
POS1/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 100.1.1.1 
Remote APS configuration: working 

gsrA# show controllers POS 1/0
POS1/0 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active) 

!--- Ensure that the working channel is active.

COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00    
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show controllers POS 1/1 
POS1/1 
SECTION 
LOF = 0          LOS    = 0                            BIP(B1) = 0 
LINE 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B2) = 0 
PATH 
AIS = 0          RDI    = 0          FEBE = 0          BIP(B3) = 0 
LOP = 0          NEWPTR = 0          PSE  = 0          NSE     = 0 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 0          PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 20/05 Tx(K1/K2): E0/05    
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 0 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : 12012 
Remote interface: POS3/0 
Remote IP addr  : 10.1.1.2 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrA# show interface p1/0 
POS1/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrA# show interface p1/1 
POS1/1 is up, line protocol is down  (APS protect - inactive) 

! 
gsrB# show aps
POS3/1 APS Group 10: protect channel 0 (inactive) 
bidirectional, revertive (1 min) 
SONET framing; SONET APS signaling by default 
Received K1K2: 0x00 0x05 
No Request (Null) 
Transmitted K1K2: 0x00 0x05 
No Request (Null) 
Working channel 1 at 200.1.1.1 (Enabled) 
Remote APS configuration: working 
POS3/0 APS Group 10: working channel 1 (active) 

!--- Verify whether the working channel is active.

SONET framing; SONET APS signaling by default 
Protect at 200.1.1.1 
Remote APS configuration: working 
! 
gsrB# show controllers p 3/0
POS3/0 
SECTION 
LOF = 11         LOS    = 11                           BIP(B1) = 
46701837 
LINE 
AIS = 10         RDI    = 11         FEBE = 1873       BIP(B2) = 8662 
PATH 
AIS = 14         RDI    = 27         FEBE = 460909     BIP(B3) = 
516875 
LOP = 0          NEWPTR = 11637      PSE  = 2          NSE     = 16818 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
working (active)

!--- Verify whether the working channel is active.

COAPS = 103        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/00  S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 11 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB# show controllers p 3/1 
POS3/1 
SECTION 
LOF = 10         LOS    = 10                           BIP(B1) = 
250005115 
LINE 
AIS = 11         RDI    = 8          FEBE = 517        BIP(B2) = 5016 
PATH 
AIS = 14         RDI    = 25         FEBE = 3663       BIP(B3) = 7164 
LOP = 0          NEWPTR = 184        PSE  = 1          NSE     = 247 
Active Defects: None 
Active Alarms:  None 
Alarm reporting enabled for: SF SLOS SLOF B1-TCA B2-TCA PLOP B3-TCA 
Framing: SONET 
APS 
protect (inactive) 
COAPS = 538        PSBF = 0 
State: PSBF_state = False 
ais_shut = FALSE 
Rx(K1/K2): 00/05 Tx(K1/K2): 00/05 
Signalling protocol: SONET APS by default 
S1S0 = 00, C2 = CF 
Remote aps status working; Reflected local aps status working 
CLOCK RECOVERY 
RDOOL = 10 
State: RDOOL_state = False 
PATH TRACE BUFFER : STABLE 
Remote hostname : hswan-gsr12008-2b 
Remote interface: POS1/0 
Remote IP addr  : 10.1.1.1 
Remote Rx(K1/K2): 00/00  Tx(K1/K2): 00/00 
BER thresholds:  SF = 10e-3  SD = 10e-6 
TCA thresholds:  B1 = 10e-6  B2 = 10e-6  B3 = 10e-6 
! 
gsrB#show interface p3/0 
POS3/0 is up, line protocol is up  (APS working - active) 

!--- Verify whether the working channel is active.

gsrB#show interface p3/1 
POS3/1 is up, line protocol is down  (APS protect - inactive) 
! 

APS устранения неполадок

Для устренения проблем с APS соберите, выходные данные от них показывают и команды отладки:

  • show ver

  • show run

  • show ip int b

  • show contr POS

  • debug aps

  • show aps

Выполните необходимые действия для воссоздания проблемы. Выполните эти команды, чтобы собрать окончательный результат и выключить отладку:

  • show aps

  • команда no debug aps

Примечание: Под обычными условиями команда debug aps не производит выходных данных. Когда ненормальное состояние происходит, это отчеты по командам условие.

Примечание: Если W и оптоволоконные кабели P находятся в других маршрутизаторах (как они обычно), необходимо собрать выходные данные command на обоих маршрутизаторах.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14680