Технологии коммутируемого доступа в сеть : Технология DDR

Настройка маршрутизатора на подключение нескольких узлов для проведения телеконференций с использованием ISDN BRI

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В определенных ситуациях необходимо было бы настроить маршрутизатор для вызова номера множественных сайтов. Например, вам, вероятно, придется набрать один маршрутизатор, чтобы соединиться с частью корпоративной сети и набрать маршрутизатор интернет-провайдера (ISP) для соединения с Интернетом.

Этот документ представляет пример конфигурации, в котором центральный маршрутизатор обращается к Интернету, и удаленный офис использует Цифровую сеть с интеграцией услуг (ISDN). Удаленный офис может также обратиться к центральному маршрутизатору и Интернету через центральный маршрутизатор.

Предварительные условия

Требования

Прежде чем вы продолжите эту конфигурацию, гарантируете что вы:

  • Проверьте работу первого и второго уровней сети ISDN. Для получения дополнительной информации посмотрите Использование Команды show isdn status для Устранения проблем BRI.

  • Получите необходимую информацию из интернет-провайдера, такого как метод аутентификации, который мог быть Протоколом аутентификации по квитированию вызова (CHAP) или Протоколом аутентификации пароля (PAP), именем пользователя и паролем, количество для вызова номера, и IP-адрес для интерфейса номеронабирателя (пока интерфейс не использует согласованный адрес). Кроме того, узнайте, необходим ли NAT для соединения множественных хостов интернет-провайдера.

  • От удаленного маршрутизатора получите информацию о методе аутентификации, имени пользователя и пароле, количество для вызова номера, и IP-адрес.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Маршрутизатор Cisco 803 с Cisco Выпуск ПО IOS� 12.1 (11) IP Plus.

    Примечание: Если необходимо настроить NAT, гарантировать, что у вас есть IP Plus (это имеет на название Файла IOS), набор функций.

  • Маршрутизатор Cisco 2501, который является удаленным офисом, который выполняет программное обеспечение Cisco IOS версии 12.2(5).

Примечание: Конфигурация для маршрутизатора ISP не включена. Обратитесь к Странице поддержки технологии технологий коммутируемого доступа в сеть для некоторых примеров конфигурации.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Родственные продукты

Эта конфигурация может быть использована для любого маршрутизатора с интерфейсом базового уровня (BRI). Это включает маршрутизаторы со встроенными интерфейсами BRI, такими как Cisco 800 (например, 801, 802, 803, 804) и Cisco 1600 (например, 1603-R и 1604-R) Series маршрутизаторы. Это также включает маршрутизаторы, которые принимают Интерфейсные карты WAN BRI (WIC) или Сетевые модули, как 1600, 1700, серии 2600 и 3600. Для получения дополнительных сведений о BRI WIC или о сетевых модулях обратитесь к матрице совместимости оборудования платформы / карты WAN-интерфейса (WIC) для маршрутизаторов серий 1600, 1700, 2600 и 3600.

Примечание: Используйте команду Show version, чтобы проверить, имеет ли маршрутизатор интерфейс BRI.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/14562/isdn800_14562.gif

Конфигурации

В этой конфигурации центральный маршрутизатор называют "центральным", и удаленный офис корпорации называют "удаленным".

В центре интерфейс номеронабирателя 1 настроен на доступ к Интернету. IP-адрес назначается ISP. NAT используется, чтобы позволить IP - сетям центральной LAN, удаленной LAN и центрально-удаленной глобальной сети (WAN) обращаться к Интернету с помощью одного динамично-назначенного-IP-адреса. Обратитесь к ISP, чтобы узнать, необходимо ли включить NAT.

Примечание: Мы настроили и PAP и CHAP, потому что это зависит от того, что настроил интернет-провайдер (однако, только один из них используется).

центральный
 version 12.1 
  no parser cache 
  service timestamps debug datetime msec 
  service timestamps log datetime msec 
  ! 
  hostname central 
  ! 
  username remote password 0 remote
 
 !--- Username and shared secret password for the router (remote)
  !--- (used for CHAP authentication).
  !--- Shared secret password must be the same on both sides.

  ! 
  isdn switch-type basic-net3
  !  
  ! 
  interface Ethernet0 
   ip address 10.1.0.1 255.255.255.0 
   ip nat inside 

   !--- Ethernet 0 is an inside NAT interface.
   !--- All traffic from this network will be translated.

   no cdp enable 
  ! 
  interface BRI0

   !--- If you have additional BRIs, copy this BRI 0 configuration to the other BRIs.

   no ip address 
   encapsulation ppp 
   dialer pool-member 1

   !--- Assign BRI0 as member of dialer pool 1.
   !--- Dialer pool 1 is specified in interface Dialer 1.

   dialer pool-member 2 

   !--- Assign BRI0 as member of dialer pool 2.
   !--- Dialer pool 2 is specified in interface Dialer 2.

   isdn switch-type basic-net3     

   !--- This depends on the country. 

   no cdp enable 
   ppp authentication chap pap callin

   !--- Permit one-way CHAP and PAP authentication.
   !--- Configure authentication on both the physical and dialer interface.

  ! 
  interface Dialer1 

  !--- Create a dialer interface for every device to which you need to connect.

   description CONNECTION TO INTERNET 
   ip address negotiated 
   
!--- This IP address is obtained from the ISP. If the ISP permits a static
   !--- address, configure that address instead.

   ip nat outside 

   !--- The Outside NAT interface. Because this interface only has one IP address,
   !--- all traffic from the inside network will be Port Address Translated (PAT).

   encapsulation ppp 
   dialer pool 1 

   !--- Dialer profile 1. Remember that interface BRI 0 is a member of this profile.

   dialer remote-name ISP  
   dialer idle-timeout 180 
   dialer string 6122 

   !--- The number used to dial the ISP.

   dialer-group 1 
   
!--- Apply interesting traffic definition from dialer-list 1.

   no cdp enable 
   ppp authentication chap pap callin 
   ppp chap hostname XXXXX   

   !--- XXXXX is the username the ISP expects in order to authenticate this router.
   !--- For more information, refer to the document on ppp chap hostname.

   ppp chap password YYYYY    
  
 !--- YYYYY is the password the ISP expects in order to authenticate this router.

   ppp pap sent-username XXXXX password YYYYY 

   !--- PAP username and password. 
   !--- This is required only if the ISP does not support CHAP.

  ! 
  interface Dialer2 
   description CONNECTION TO REMOTE OFFICE 
   ip address 192.168.17.2 255.255.255.252

   !--- IP address for the connection to the remote office.
   !--- The remote office BRI interface is in the same subnet.

   ip nat inside

   !--- Dialer 2 is an inside NAT interface.
   !--- With this configuration, traffic from remote office is translated
   !--- before it is sent to the ISP.

   encapsulation ppp 
   dialer pool 2 

   !--- Dialer profile 2. Remember that interface BRI 0 is a member of this profile.

   dialer remote-name remote 

   !--- Specifies the remote router name (remote).
   !--- This name must match that used by the remote router to authenticate itself.
   !--- Remember that we configured the router username and password earlier.

   dialer idle-timeout 180 
   dialer string 6121 

   !--- Number used to dial the remote office router.

   dialer-group 1 

   !--- Apply interesting traffic definition from dialer-list 1.

   no cdp enable 
   ppp authentication chap callin 
  ! 
  ip nat inside source list 101 interface Dialer1 overload 

  !--- Establishes dynamic source translation (with PAT) for addresses that are
  !--- identified by the access list 101.

  no ip http server 
  ip classless 
  ip route 0.0.0.0 0.0.0.0 Dialer1 

  !--- Default route. Such traffic will use dialer 1 to the ISP.

  ip route 10.2.0.0 255.255.255.0 Dialer2 

  !--- Route to remote router network. Traffic for 10.2.0.0/24 uses Dialer2.

  ! 
  access-list 101 permit ip 10.1.0.0 0.0.0.255 any 
  access-list 101 permit ip 10.2.0.0 0.0.0.255 any 
  access-list 101 permit ip 192.168.17.0 0.0.0.3 any 
  
!--- Defines an access list that permits the addresses to be translated.
  !--- Note that the Ethernet 0 network, the remote router network and the
  !--- BRI network (between this router and the remote one) will be translated.

  dialer-list 1 protocol ip permit 

  !--- Interesting traffic definition.
  !--- This definition is applied to both connections.
  !--- If you need to define different interesting traffic for each connection,
  !--- create two dialer-lists and apply one to each dialer profile with dialer-group.

  no cdp run 
  ! 
  line con 0 
   exec-timeout 3 0 
  line vty 0 4 
   exec-timeout 3 0 
  ! 
  !  
  end

удаленный
version 12.2 
  service timestamps debug datetime msec 
  service timestamps log datetime msec 
  ! 
  hostname remote 
  ! 
  username central password 0 remote 

  !--- Username and shared secret password for the router (central)
  !--- (used for CHAP authentication).
  !--- Shared secret must be the same on both sides. 

  ! 
  isdn switch-type basic-net3
  ! 
  interface Ethernet0 
   ip address 10.2.0.1 255.255.255.0 

   !--- Remember that this network is included in the NAT statements on central.

   no cdp enable 
  ! 
  interface BRI0 
    no ip address 
   encapsulation ppp 
   dialer pool-member 1 

   !--- Assign BRI0 as member of dialer pool 1.
   !--- Dialer pool 1 is specified in interface Dialer 1.

   isdn switch-type basic-net3 
   no cdp enable 
   ppp authentication chap 
  ! 
  interface Dialer1 
   ip address 192.168.17.1 255.255.255.252 
   encapsulation ppp 
   dialer pool 1 

   !--- Dialer profile 1. Remember that interface BRI 0 is a member of this profile.  

   dialer remote-name central 

   !--- Specifies the name of the other router (central).
   !--- This name must match that used by the remote router to authenticate itself.
   !--- Remember that we configured the router username and password earlier.

   dialer string 6131

   !--- The number used to dial the central router. 

   dialer-group 1 
   
!--- Apply interesting traffic definition from dialer-list 1.

   pulse-time 0 
   no cdp enable 
   ppp authentication chap callin 
  ! 
  ip classless 
  ip route 0.0.0.0 0.0.0.0 Dialer1 

  !--- Default route. Such traffic will use dialer 1 to the central router.

  no ip http server 
  ! 
  dialer-list 1 protocol ip permit

  !--- All IP traffic is interesting. 

  ! 
  line con 0 
   exec-timeout 3 0 
  line aux 0 
  line vty 0 4 
   exec-timeout 3 0 
  ! 
  end

Проверка.

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

  • show isdn active — показывает Номер "ISDN", вы использовали размещать вызов, и указывает, является ли вызов входящим или исходящим.

  • {\f3 show caller ip}–{\f3 показывает сводку источников вызовов для указанного IP-адреса.}

  • show ip interface dialer 1 | включает Интернет — перечисляет сводку IP - информации и статуса интерфейса номеронабирателя.

  • команда show dialer [номер_типа_интерфейса] отображает общие диагностические сведения для интерфейсов, настроенных на маршрутизацию DDR. Если номеронабиратель подошел должным образом, это сообщение появляется:

    Dialer state is data link layer up

    Если физический уровень появляется, он подразумевает, что протокол линии связи подошел, но Протокол управления сетью (NCP) не сделал. Исходный и конечный адреса пакета, инициировавшего вызов номера, показаны в строке причины вызова. Эта команда показа также отображает конфигурацию таймера, и время перед временами соединения.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем применять команды отладки, ознакомьтесь с разделом "Важные сведения о командах отладки".

  • debug dialer - вывод отладочных данных о пакетах или событиях в интерфейсе номеронабирателя.

  • "debug isdn q931" - отображение сведений об установлении соединения и освобождении канала в сети ISDN (третий уровень модели OSI) между локальным маршрутизатором (на стороне пользователя) и сетью.

  • debug ppp negotiation — отображает информацию на трафике Протокола PPP и обменах во время согласования компонентов PPP, и включает информацию о Протоколе управления каналом (LCP), Аутентификации и NCP. В успешных переговорах PPP сначала выясняется состояние LCP, затем проводится аутентификация и наконец выполняется согласование NCP.

  • debug ppp authenticaion — заставляет команду debug ppp отображать сообщения протокола аутентификации, включая обмены пакетами CHAP и обмены PAP.

  • debug ip peer — содержит информацию об узле.

Выходные данные отладки

Для устранения проблем конфигурации используйте эти отладки:

   central#debug isdn q931 
   ISDN Q931 packets debugging is on 
   
   central#debug dialer 
   Dial on demand events debugging is on 
   
   central#debug ppp negotiation 
   PPP protocol negotiation debugging is on 
   
   central#debug ppp authentication 
   PPP authentication debugging is on 
   
   central#debug ip peer 
   IP peer address activity debugging is on 

Маршрутизатор назвал центральным, инициирует вызов к Интернету: 198.133.219.25 - IP-адрес в Интернете.

   central#ping 198.133.219.25

   :.!!!! 
   Success rate is 80 percent (4/5), round-trip min/avg/max = 40/41/44 ms 

   *Mar 1 00:06:12.984: BR0 DDR: rotor dialout [priority] 
   *Mar 1 00:06:12.988: BR0 DDR: Dialing cause ip (s=172.17.243.115, 
    d=198.133.219.25)    
   *Mar 1 00:06:12.988: BR0 DDR: Attempting to dial 6122 
   *Mar 1 00:06:12.996: ISDN BR0: TX -> SETUP pd = 8 callref = 0x01 

   !--- central initiates the call to ISDN number 6122. 

   *Mar 1 00:06:13.000: Bearer Capability i = 0x8890 
   *Mar 1 00:06:13.008: Channel ID i = 0x83 
   *Mar 1 00:06:13.008: Called Party Number i = 0x80, '6122', Plan:Unknown,
   Type:Unknown 
   *Mar 1 00:06:13.088: ISDN BR0: RX <- CALL_PROC pd = 8 callref = 0x81 
   *Mar 1 00:06:13.092: Channel ID i = 0x89 
   *Mar 1 00:06:13.244: ISDN BR0: RX <- CONNECT pd = 8 callref = 0x81 

   !--- central receives a connect message : the ISDN B channel is established. 

   *Mar 1 00:06:13.252: ISDN BR0: TX -> CONNECT_ACK pd = 8 callref = 0x01 
   *Mar 1 00:06:13.260: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up 
   *Mar 1 00:06:13.268: BR0:1: interface must be fifo queue, force FIFO 
   *Mar 1 00:06:13.272: %DIALER-6-BIND: Interface BR0:1 bound to profile Di1 
   *Mar 1 00:06:13.280: BR0:1 PPP: Treating connection as a callout 
   *Mar 1 00:06:13.280: BR0:1 PPP: Phase is ESTABLISHING, Active Open 
   *Mar 1 00:06:13.284: BR0:1 PPP: No remote authentication for call-out 
   *Mar 1 00:06:13.284: BR0:1 LCP: O CONFREQ [Closed] id 1 len 10 
   *Mar 1 00:06:13.284: BR0:1 LCP: MagicNumber 0x108130DD (0x0506108130DD) 
   *Mar 1 00:06:13.300: BR0:1 LCP: I CONFREQ [REQsent] id 132 Len 15 
   *Mar 1 00:06:13.300: BR0:1 LCP: AuthProto CHAP (0x0305C22305) 

   !--- The ISP wants to use CHAP authentication. 

   *Mar 1 00:06:13.304: BR0:1 LCP: MagicNumber 0xE4225290 (0x0506E4225290) 
   *Mar 1 00:06:13.304: BR0:1 LCP: O CONFACK [REQsent] id 132 Len 15 
   *Mar 1 00:06:13.308: BR0:1 LCP: AuthProto CHAP (0x0305C22305) 
   *Mar 1 00:06:13.308: BR0:1 LCP: MagicNumber 0xE4225290 (0x0506E4225290) 
   *Mar 1 00:06:13.308: BR0:1 LCP: I CONFACK [ACKsent] id 1 Len 10 
   *Mar 1 00:06:13.312: BR0:1 LCP: MagicNumber 0x108130DD (0x0506108130DD) 
   *Mar 1 00:06:13.312: BR0:1 LCP: State is Open 
   *Mar 1 00:06:13.320: BR0:1 PPP: Phase is AUTHENTICATING, by the peer 
   *Mar 1 00:06:13.328: BR0:1 AUTH: Started process 0 pid 22 
   *Mar 1 00:06:13.328: BR0:1 CHAP: I CHALLENGE id 118 Len 27 from "posets"    
   *Mar 1 00:06:13.332: BR0:1 CHAP: Using alternate hostname XXXXX 
   *Mar 1 00:06:13.332: BR0:1 CHAP: Username posets not found 
   *Mar 1 00:06:13.336: BR0:1 CHAP: Using default password 
   *Mar 1 00:06:13.336: BR0:1 CHAP: O RESPONSE id 118 Len 26 from "XXXXX"    
   *Mar 1 00:06:13.360: BR0:1 CHAP: I SUCCESS id 118 Len 4 
   
!--- central receives a CHAP SUCCESS from ISP. 

   *Mar 1 00:06:13.360: BR0:1 PPP: Phase is UP 
   *Mar 1 00:06:13.364: BR0:1 IPCP: O CONFREQ [Not negotiated] id 1 Len 10 
   *Mar 1 00:06:13.364: BR0:1 IPCP: Address 0.0.0.0 (0x030600000000) 
   *Mar 1 00:06:13.368: BR0:1 IPCP: I CONFREQ [REQsent] id 108 Len 10 
   *Mar 1 00:06:13.368: BR0:1 IPCP: Address 194.183.201.1 (0x0306C2B7C901) 
   *Mar 1 00:06:13.368: BR0:1: IPPOOL: validate address = 194.183.201.1 
   *Mar 1 00:06:13.372: BR0:1 set_ip_peer(3): new address 194.183.201.1 
   *Mar 1 00:06:13.372: BR0:1 IPCP: O CONFACK [REQsent] id 108 Len 10 
   *Mar 1 00:06:13.376: BR0:1 IPCP: Address 194.183.201.1 (0x0306C2B7C901) 
   *Mar 1 00:06:13.380: BR0:1 IPCP: I CONFNAK [ACKsent] id 1 Len 10 
   *Mar 1 00:06:13.380: BR0:1 IPCP: Address 194.183.201.3 (0x0306C2B7C903) 

   !--- 194.183.201.3 is assigned by ISP to dialer 1 of central. 

   *Mar 1 00:06:13.384: BR0:1 IPCP: O CONFREQ [ACKsent] id 2 Len 10 
   *Mar 1 00:06:13.384: BR0:1 IPCP: Address 194.183.201.3 (0x0306C2B7C903) 
   *Mar 1 00:06:13.396: BR0:1 IPCP: I CONFACK [ACKsent] id 2 Len 10 
   *Mar 1 00:06:13.400: BR0:1 IPCP: Address 194.183.201.3 (0x0306C2B7C903) 
   *Mar 1 00:06:13.400: BR0:1 IPCP: State is Open 
   *Mar 1 00:06:13.400: Di1 IPCP: Install negotiated IP interface address
   194.183.201.3 
   *Mar 1 00:06:13.412: BR0:1 DDR: dialer protocol up 
   *Mar 1 00:06:13.416: Di1 IPCP: Install route to 194.183.201.1 
   *Mar 1 00:06:14.360: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI0:1,
   changed state to up 
   *Mar 1 00:06:19.276: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 6122
   unknown

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14562