Технологии коммутируемого доступа в сеть : "Технология ISDN, CAS"

Пример конфигурации ISDN - IP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для ISDN с использованием IP.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/14222/40.gif

Конфигурации

Эти конфигурации используются в данном документе:

C2503
C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

!--- See the username explanation in the 
!--- Explanation of the C2503 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 172.16.10.1 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.1 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155551234
dialer map ip 172.16.20.2 name C4000 speed 56 broadcast 14155556789
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 408555432101 5554321
isdn spid2 408555987601 5559876
ppp authentication chap
!
router igrp 1
network 172.16.0.0
!
ip route 192.168.24.0 255.255.255.0 172.16.20.2
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

C4000
C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

!--- See the username explanation in the 
!--- Explanation of the C4000 Configuration section of this document.

isdn switch-type basic-dms100
!
interface Ethernet0
ip address 192.168.24.65 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
interface BRI0
ip address 172.16.20.2 255.255.255.0
encapsulation ppp
bandwidth 56
dialer idle-timeout 300
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876
dialer hold-queue 5
dialer load-threshold 100
dialer-group 1
isdn spid1 415555123401 5551234
isdn spid2 415555678901 5556789
ppp authentication chap
!
router igrp 1
network 172.16.0.0
network 192.168.24.0
!
ip route 172.16.10.0 255.255.255.0 172.16.20.1
access-list 100 deny ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0
access-list 100 permit ip 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255
!
!
dialer-list 1 list 100
!
line con 0
line aux 0
line vty 0 4
password test
login
!
end

Пояснение конфигурации C2503

C2503#write terminal
######
Current configuration:
!
version 10.2
!
hostname C2503
!
enable password test
!
username C4000 password cisco

Имя пользователя C4000 является именем хоста удаленного маршрутизатора. Команда cхемы набора номеров, которую объясняет этот раздел, использует это имя пользователя. Имя пользователя не чувствительно к регистру во время аутентификации. Однако название , которое вы настраиваете с командой cхемы набора номеров, учитывает регистр. Необходимо точно совпасть с именем хоста удаленного маршрутизатора, который является "C4000".

Примечание: В маршрутизаторе C2503 название , которое вы настраиваете с командой имени пользователя, должно точно совпасть с названием , которое вы настраиваете с командой cхемы набора номеров. Вы выполняете команду имени пользователя в режиме глобальной конфигурации.

Процесс проверки подлинности Протокола аутентификации по квитированию вызова (CHAP) использует пароль. Пароль учитывает регистр и должен совпасть с паролем удаленного маршрутизатора точно.

Примечание: Во избежание беспорядка этот пример конфигурации использует незашифрованный вид пароля cisco. В фактической конфигурации пароль появляется в своей зашифрованной форме: 7 13061E010803. В этом пароле, 7 обозначает, что тип шифрования и 13061E010803 является зашифрованной формой пароля cisco. Когда вы выполняете или вносите изменения в команду имени пользователя, всегда вводите пароль в его незашифрованном виде и не вводите тип шифрования (7). Тип шифрования установлен автоматически.

  • основной dms100 switch-type ISDN — тип коммутатора ISDN должен совпасть с оборудованием носителя. При изменении типа коммутатора необходимо повторно загрузить маршрутизатор для нового типа коммутатора для вступления в силу.

    interface Ethernet0
    ip address 172.16.10.1 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.1 255.255.255.0
  • encapsulation ppp инкапсуляцию PPP вместо High-Level Data Link Control (HDLC) для разрешения использования Аутентификации CHAP.

  • пропускная способность 56 — параметр настройки пропускной способности по умолчанию для интерфейса BRI составляет 64 кбит/с. Если вы настраиваете инструкции схемы набора номеров со скоростью 56 опций, включаете инструкцию для пропускной способности.

    Примечание: Данная команда не управляет скоростью линии ISDN. Наборы команд корректная контрольная точка для:

    • Статистика show interface порта BRI

    • Команда dialer load-threshold

    • Протокол IGRP / Расширенный IGRP (EIGRP) метрики маршрутизации

  • номеронабиратель idle-timeout 300 — Это наборы команд кол-во секунд, что ISDN - подключение остается открытым, если не маршрутизируется никакой представляющий интерес трафик. Таймер перезагружен каждый раз, когда вызывающий интерес пакет передан.

  • ip cхемы набора номеров 172.16.20.2 скорости названия C4000 56 передавал 14155551234

    ip cхемы набора номеров 172.16.20.2 скорости названия C4000 56 передавал 14155556789

    Используйте команду cхемы набора номеров с Аутентификацией CHAP для размещения первоначального вызова в удаленный маршрутизатор, когда представляющий интерес трафик передан интерфейсу BRI. Когда соединение становится активным, команда dialer idle-timeout определяет промежуток времени для соединения, чтобы остаться активной. Инструкция схемы набора номеров необходима для каждого номера телефона ISDN, который вызовут. Однако знайте, что две инструкции схемы набора номеров, которые указывают к тому же местоположению, могут активировать оба канала B, когда можно только хотеть использовать один канал.

    Параметры команды для этого примера:

    • 172.16.20.2 — IP-адрес интерфейса BRI удаленного маршрутизатора

      Для определения этого адреса выполните команду show interface bri 0 в приглашении консоли удаленного маршрутизатора.

    • название C4000 — имя хоста удаленного маршрутизатора

      Название учитывает регистр и должно совпасть с названием, которое вы настраиваете для команды имени пользователя.

    • скорость 56 — Устанавливает скорость номеронабирателя в 56 кбит/с для цепей ISDN, которые не составляют 64 кбит/с End to End

      Включайте этот параметр в инструкции схемы набора номеров обоих маршрутизаторов. Большинство установок в Северной Америке должно быть настроено для 56 кбит/с.

    • широковещание — Позволяет передачу транслируемых пакетов

      Пока команда dialer-list не задает транслируемые пакеты как вызывающие интересы пакет, пакеты только переданы, когда соединение ISDN активно.

    • 14155551234 и 14155556789 — Телефонные номера ISDN удаленного маршрутизатора

  • dialer hold-queue 5 — Эта команда позволяет вызывающим интересам пакет быть помещенными в очередь до установления ISDN - подключения. В данном примере должны быть помещены в очередь пять вызывающих интересов пакет.

  • dialer load-threshold 100 — Эта команда настраивает полосу по требованию. Наборы команд максимальная загрузка перед номеронабирателем размещают другой вызов через второй канал B. Загрузка равна рассчитанному средневзвешенному значению для интерфейса, где 1 - не загружено и 255 - загружено полностью. Значение действующей нагрузки для настройки зависит от характеристик индивидуальной сети. В данном примере активирован второй канал B, когда загрузка достигает 39 процентов максимальной загруженности, которая равняется 100 разделенному на 255.

  • dialer-group 1 Команда dialer-group 1 включает список номеронабирателя 1 на интерфейсе BRI, который определяет, какие пакеты являются содержательными и активируют ISDN - подключение.

  • isdn spid1 408555432101 5554321

    isdn spid2 408555987601 5559876

    Используйте команды isdn spid, если носитель назначает идентификаторы профиля сервиса (SPID) на линии ISDN.

  • аутентификация ppp chap — Эта команда включает Аутентификацию CHAP.

    router igrp 1 
    network 172.16.0.0
  • ip route 192.168.24.0 255.255.255.0 172.16.20.2 — Эта команда ip route создает статический маршрут к сети удаленного маршрутизатора через интерфейс BRI удаленного маршрутизатора. Это - требование, потому что динамические маршруты потеряны, когда соединение ISDN не работает.

    Параметры команды для этого примера:

    • 192.168.24.0 — Целевая сеть

    • 255.255.255.0 — Маска целевой сети

      255 в позиции октета указывают, что полное соответствие для того октета необходимо. 0 в позиции октета указывает, что совпадает любое значение.

    • 172.16.20.2 — Адрес следующего перехода, который может использоваться для достижения целевой сети

  • запрет списка доступа 100 ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    ip разрешения на access-list 100 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 — Эта команда access-list определяет, какие пакеты IP являются содержательными и активируют соединение ISDN. Список доступа для создания зависит от конкретной сетевой структуры.

    access-list 100 запрещает ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0 — Эта команда access-list определяет все транслируемые пакеты как неинтересные.

    ip разрешения на access-list 100 0.0.0.0 255.255.255.255 0.0.0.0255.255.255.255 — Эта команда access-list определяет все другие пакеты IP как содержательные.

  • список dialer-list 1 100 — Эта команда указывает к списку доступа 100, который определяет, какие пакеты IP являются содержательными.

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

Пояснение конфигурации C4000

C4000#write terminal
######
Current configuration:
!
version 10.2
!
hostname C4000
!
enable password test
!
username C2503 password cisco

Имя пользователя C2503 является именем хоста удаленного маршрутизатора. Команда cхемы набора номеров, которую объясняет этот раздел, использует это имя пользователя. Имя пользователя не чувствительно к регистру во время аутентификации. Однако название то, что вы настраиваете с командой cхемы набора номеров, учитывает регистр. Необходимо точно совпасть с именем хоста удаленного маршрутизатора, который является "C2503".

Примечание: В маршрутизаторе C4000 название , которое вы настраиваете с именем пользователя, должно точно совпасть с названием , которое вы настраиваете с командой cхемы набора номеров. Вы выполняете команду имени пользователя в режиме глобальной конфигурации.

Процесс аутентификации CHAP использует пароль. Пароль учитывает регистр и должен совпасть с паролем удаленного маршрутизатора точно.

Примечание: Во избежание беспорядка этот пример конфигурации использует незашифрованный вид пароля cisco. В фактической конфигурации пароль появляется в своей зашифрованной форме: 7 13061E010803. В этом пароле, 7 обозначает, что тип шифрования и 13061E010803 является зашифрованной формой пароля cisco. Когда вы выполняете или вносите изменения в команду имени пользователя, всегда вводите пароль в его незашифрованном виде и не вводите тип шифрования (7). Тип шифрования установлен автоматически.

  • основной dms100 switch-type ISDN — тип коммутатора ISDN должен совпасть с оборудованием носителя. При изменении типа коммутатора необходимо повторно загрузить маршрутизатор для нового типа коммутатора для вступления в силу.

    interface Ethernet0
    ip address 192.168.24.65 255.255.255.0
    
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface BRI0
    ip address 172.16.20.2 255.255.255.0
    
    encapsulation ppp
  • encapsulation ppp инкапсуляцию PPP вместо HDLC для разрешения использования Аутентификации CHAP.

  • пропускная способность 56 — параметр настройки пропускной способности по умолчанию для интерфейса BRI составляет 64 кбит/с. Если вы настраиваете инструкции схемы набора номеров со скоростью 56 опций, включаете инструкцию для пропускной способности.

    Примечание: Данная команда не управляет скоростью линии ISDN. Наборы команд корректная контрольная точка для:

    • Статистика show interface порта BRI

    • Команда dialer load-threshold

    • Метрики маршрутизации IGRP/EIGRP

  • номеронабиратель idle-timeout 300 — Это наборы команд кол-во секунд, что ISDN - подключение остается открытым, если не маршрутизируется никакой представляющий интерес трафик. Таймер перезагружен каждый раз, когда вызывающий интерес пакет передан.

    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085554321
    dialer map ip 172.16.20.1 name C2503 speed 56 broadcast 14085559876 

    Используйте команду cхемы набора номеров с Аутентификацией CHAP для размещения первоначального вызова в удаленный маршрутизатор, когда представляющий интерес трафик передан интерфейсу BRI. Когда соединение становится активным, команда dialer idle-timeout определяет промежуток времени для соединения, чтобы остаться активной. Инструкция схемы набора номеров необходима для каждого номера телефона ISDN, который вызовут. Однако знайте, что две инструкции схемы набора номеров, которые указывают к тому же местоположению, могут активировать оба канала B, когда можно только хотеть использовать один канал.

    Параметры команды для этого примера:

    • 172.16.20.1 — IP-адрес интерфейса BRI удаленного маршрутизатора

      Для определения этого адреса выполните команду show interface bri 0 в приглашении консоли удаленного маршрутизатора.

    • название C2503 — имя хоста удаленного маршрутизатора

      Название учитывает регистр и должно совпасть с названием, которое вы настраиваете для команды имени пользователя.

    • скорость 56 — Устанавливает скорость номеронабирателя в 56 кбит/с для цепей ISDN, которые не составляют 64 кбит/с End to End

      Включайте этот параметр в инструкции схемы набора номеров обоих маршрутизаторов. Большинство установок в Северной Америке должно быть настроено для 56 кбит/с.

    • широковещание — Позволяет передачу транслируемых пакетов

      Пока команда dialer-list не задает транслируемые пакеты как вызывающие интересы пакет, пакеты только переданы, когда соединение ISDN активно.

    • 14085554321 и 14085559876 — Телефонные номера ISDN удаленного маршрутизатора

  • dialer hold-queue 5 — Эта команда позволяет вызывающим интересам пакет быть помещенными в очередь до установления ISDN - подключения. В данном примере должны быть помещены в очередь пять вызывающих интересов пакет.

  • dialer load-threshold 100 — Эта команда настраивает полосу по требованию. Наборы команд максимальная загрузка перед номеронабирателем размещают другой вызов через второй канал B. Загрузка равна рассчитанному средневзвешенному значению для интерфейса, где 1 - не загружено и 255 - загружено полностью. Значение действующей нагрузки для настройки зависит от характеристик индивидуальной сети. В данном примере активирован второй канал B, когда загрузка достигает 39 процентов максимальной загруженности, которая равняется 100 разделенному на 255.

  • dialer-group 1 Команда dialer-group 1 включает список номеронабирателя 1 на интерфейсе BRI, который определяет, какие пакеты являются содержательными и активируют ISDN - подключение.

  • isdn spid1 415555123401 5551234

    isdn spid2 415555678901 5556789

    Используйте команды isdn spid, если носитель назначает SPID на линии ISDN.

  • аутентификация ppp chap — Эта команда включает Аутентификацию CHAP.

    router igrp 1
    network 172.16.0.0
    network 192.168.24.0
  • ip route 172.16.10.0 255.255.255.0 172.16.20.1 — Эта команда ip route создает статический маршрут к сети удаленного маршрутизатора через интерфейс BRI удаленного маршрутизатора. Это - требование, потому что динамические маршруты потеряны, когда соединение ISDN не работает.

    Параметры команды для этого примера:

    • 172.16.0.0 — Целевая сеть

    • 255.255.0.0 — Маска целевой сети

      255 в позиции октета указывают, что полное соответствие для того октета необходимо. 0 в позиции октета указывает, что совпадает любое значение.

    • 172.16.20.1 — Адрес следующего перехода, который может использоваться для достижения целевой сети

  • запрет списка доступа 100 ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0.0

    ip разрешения на access-list 100 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 — Эта команда access-list определяет, какие пакеты IP являются содержательными и активируют соединение ISDN. Список доступа для создания зависит от конкретной сетевой структуры.

    access-list 100 запрещает ip 0.0.0.0 255.255.255.255 255.255.255.255 0.0.0 — Эта команда access-list определяет все транслируемые пакеты как неинтересные.

    ip разрешения на access-list 100 0.0.0.0 255.255.255.255 0.0.0.0 255.255.255.255 — Эта команда access-list определяет все другие пакеты IP как содержательные.

  • список dialer-list 1 100 — Эта команда указывает к списку доступа 100, который определяет, какие пакеты IP являются содержательными.

    line con 0
    line aux 0
    line vty 0 4
    password test
    login
    !
    end

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14222