Безопасность и VPN : Протоколы IPSec Negotiation/IKE

Настройка шифрования CET с туннелем GRE

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Cisco объявил об окончании срока службы для Технологии шифрования Cisco. Для получения дополнительных сведений см. уведомление End-of-Sales.


Содержание


Введение

Для настройки шифрования Технологии шифрования Cisco (CET) с туннелем необходимо настроить шифрование на интерфейсе туннеля. Кроме того, необходимо настроить шифрование на физическом интерфейсе, который возглавляет к возможному месту назначения туннеля.

Примечание: Шифрование CET является теперь поддержкой закончена. IPSec является рекомендуемой схемой шифрования для миграции.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/14120/13.gif

Примечания к сетевым диаграммам

  • 8.8.8.8 за r3-4k и 7.7.7.4 за R6-2500 являются конечными станциями. Когда они пропинговывают друг друга, трафик проходит через туннель.

  • Туннель с произвольной инкапсуляцией маршрутов (GRE) настроен на интерфейсах кольцевой проверки как исходная и конечная точка туннеля.

  • Трафик через туннель также шифруется. Реализация этой функции требует, чтобы для шифрования туннельного трафика криптокарта была присоединена и к туннельному интерфейсу и к физическому исходящему интерфейсу.

Конфигурации

Эти конфигурации используются в данном документе:

r3-4k
hostname r3-4k
  !
  crypto public-key r6-2500 02014544
   F3681B5D 32372A19 0C0CCC4B E707F829 D882CF30 A9B4DBE3 E1911E9C F6A9E162 
   732558DF A20FEFAD 2ACC400E 8DDB10B1 3566FA3A E55A9BBE 00916AAD 20A0C75C
   quit
  !
  crypto map my_crypto_map 10
   set algorithm 40-bit-des
   set peer r6-2500
   match address 128
  !
  interface Loopback0
   ip address 1.1.6.1 255.255.255.0
  !
  interface Tunnel0
   ip address 5.5.5.1 255.255.255.0
   tunnel source Loopback0
   tunnel destination 2.2.6.3
   crypto map my_crypto_map
  !
    interface Ethernet0
   ip address 1.1.1.1 255.255.255.0
   description inside interface
   media-type 10BaseT
   crypto map my_crypto_map
  !
  !
  interface Serial0
   encapsulation frame-relay
   no ip route-cache
  !
  interface Serial0.1 point-to-point
  description outside interface
   ip address 8.8.8.1 255.255.255.0
   frame-relay interface-dlci 100   
  !
  !ip classless
  ip route 0.0.0.0 0.0.0.0 1.1.1.2
  ip route 7.0.0.0 255.0.0.0 5.5.5.2
  
  access-list 128 permit gre host 1.1.6.1 host 2.2.6.3
  !

R1-AGS
!
  hostname R1-AGS
  !
  interface Ethernet0
   ip address 1.1.1.2 255.255.255.0
  !
  interface Serial1
   ip address 2.2.5.2 255.255.255.0
  !
  ip classless
  ip route 1.0.0.0 255.0.0.0 1.1.1.1
  ip route 2.0.0.0 255.0.0.0 2.2.5.3

R6-2500
hostname R6-2500
  !
  crypto public-key r3-4k 04D6265A
   512A7D84 43C348B7 959D2FE2 3122B285 FDA2A362 7272A835 84D03134 DB160DE1 
   27CA2D24 D6C23EFE 3BE25A95 D62EA30B 0F2C3BA8 9AB6DB82 D8127238 266AC987
   quit
  ! 
  crypto map my_crypto_map 10
   set algorithm 40-bit-des
   set peer r3-4k
   match address 128
  !
  interface Loopback0
   ip address 2.2.6.3 255.255.255.0
  !
  interface Tunnel0
   ip address 5.5.5.2 255.255.255.0
   tunnel source Loopback0
   tunnel destination 1.1.6.1
   crypto map my_crypto_map
  !
  interface Ethernet 0
  description inside interface
   ip address 7.7.7.3 255.255.255.0
  !
  interface Serial0
  description outside interface
   ip address 2.2.5.3 255.255.255.0
   crypto map my_crypto_map
  !
  ip classless
  ip route 0.0.0.0 0.0.0.0 2.2.5.2
  ip route 7.0.0.0 255.0.0.0 7.7.7.0
  ip route 8.0.0.0 255.0.0.0 5.5.5.1
  !
  access-list 128 permit gre host 2.2.6.3 host 1.1.6.1

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14120