Видео и доставка контента : Устройства защиты Cisco PIX серии 500

Настройка IPSec между двумя PIX с доступом VPN Client 4.x

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ иллюстрирует два устройства межсетевого экрана Cisco Secure PIX, которые выполняют простой VPN-туннель от PIX 1 до PIX 2 по открытой сети с помощью IPSec. Cisco VPN Client 4.x соединяется с PIX 1. Конфигурация использует предварительные общие ключи (подстановочные знаки для IPs клиентов), и конфигурация режима для клиентов.

Примечание: Клиент VPN может обратиться к LAN позади PIX 1, но не LAN позади PIX 2. PIX не перенаправляет трафик.

Предварительные условия

Требования

Для IPSec для работы вы, должно быть, установили подключение от оконечной точки туннеля до оконечной точки туннеля перед началом этой конфигурации.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Версия 6.3 (1) межсетевого экрана PIX

    Примечание: Команда Show version должна показать, что включено шифрование.

  • Версия 4.0.2 (A) клиента VPN

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

Этот раздел объясняет, как настроить PIX к PIX и Клиенту VPN 4. x .

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В настоящем документе используется следующая схема сети:

/image/gif/paws/14092/pixpixvpn-01.gif

Настройка PIX

Эти конфигурации используются в данном документе:

Конфигурация PIX 1
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix-1
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names

!--- Except traffic from the Network Address Translation (NAT) process.

access-list 100 permit ip 10.2.2.0 255.255.255.0 10.1.1.0 255.255.255.0
access-list 100 permit ip 10.2.2.0 255.255.255.0 192.168.1.0 255.255.255.0

!--- Include traffic in the encryption process.

access-list 110 permit ip 10.2.2.0 255.255.255.0 10.1.1.0 255.255.255.0 
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 172.18.124.154 255.255.255.0
ip address inside 10.2.2.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool test 192.168.1.1-192.168.1.25
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
pdm history enable
arp timeout 14400

!--- Except traffic from the NAT process.

nat (inside) 0 access-list 100
route outside 0.0.0.0 0.0.0.0 172.18.124.1 1
timeout xlate 3:00:00timeout conn 1:00:00 
   half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 
h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto dynamic-map dynmap 30 set transform-set myset

!--- Use the crypto-map sequence 10 command for PIX to PIX.

crypto map newmap 10 ipsec-isakmp
crypto map newmap 10 match address 110
crypto map newmap 10 set peer 172.18.124.153
crypto map newmap 10 set transform-set myset

!--- Use the crypto-map sequence 65000 command for PIX to VPN Client.

crypto map newmap 65000 ipsec-isakmp dynamic dynmap
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address 172.18.124.153 netmask 255.255.255.255 
   no-xauth no-config-mode
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5

!--- Internet Security Association and Key Management Protocol (ISAKMP) policy
!--- for a VPN Client running 3.x code and later needs to be Diffie-Hellman (DH)
!--- group 2 or above (group 1 is default).

isakmp policy 10 group 2
isakmp policy 10 lifetime 86400

!--- IPSec group configuration for VPN Client.

vpngroup vpn3000 address-pool test
vpngroup vpn3000 dns-server 10.2.2.2
vpngroup vpn3000 wins-server 10.2.2.2
vpngroup vpn3000 default-domain cisco.com
vpngroup vpn3000 idle-time 1800
vpngroup vpn3000 password ********
telnet timeout 5
ssh timeout 5
terminal width 80
Cryptochecksum:0527568558f8f0a4017a2db377a36cc2
: end
[OK]

Конфигурация PIX 2
PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix-2
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names

!--- Except traffic from the NAT process.

access-list 100 permit ip 10.1.1.0 255.255.255.0 10.2.2.0 255.255.255.0
pager lines 24
interface ethernet0 10baset
interface ethernet1 10full
mtu outside 1500
mtu inside 1500
ip address outside 172.18.124.153 255.255.255.0
ip address inside 10.1.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400

!--- Except traffic from the NAT process.

nat (inside) 0 access-list 100
route outside 0.0.0.0 0.0.0.0 172.18.124.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 
h323 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server RADIUS protocol radius 
aaa-server LOCAL protocol local 
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-3des esp-md5-hmac
crypto map newmap 10 ipsec-isakmp

!--- Include traffic in the encryption process.

crypto map newmap 10 match address 100
crypto map newmap 10 set peer 172.18.124.154
crypto map newmap 10 set transform-set myset
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address 172.18.124.154 netmask 255.255.255.255 
   no-xauth no-config-mode
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet timeout 5
ssh timeout 5
terminal width 80
Cryptochecksum:6d2f51a85d4f8a7991b62183fcc2836c
: end
[OK]

Выбор конфигурации VPN Client

Выполните эти шаги, чтобы настроить VPN-клиент:

  1. Запустите VPN Client, а затем нажмите кнопку New, чтобы создать новое соединение.

  2. Введите исходные данные для записи, такой как название, хост и пароль.

    • В поле "Connection Entry" (Название соединения) введите название этого соединения.

    • В поле Host введите IP-адрес открытого интерфейса PIX для соединений.

    • При Групповой аутентификации введите имя группы и пароль группы, и затем введите пароль снова для подтверждения его.

    Нажмите Save, когда вы будете закончены.

    /image/gif/paws/14092/pixpixvpn-02.gif

  3. Выберите соединение, которое вы создали, и затем нажмите Connect для соединения с PIX.

    /image/gif/paws/14092/pixpixvpn-03.gif

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Проверьте порядковые номера криптокарты

Если статические и динамические узлы настроены на той же криптокарте, заказ элементов криптокарты очень важен. Порядковый номер записи динамической криптокарты должен быть выше, чем все другие записи статической криптокарты. Если статические записи пронумерованы выше, чем динамическая запись, соединения с теми узлами сбой.

Это - пример должным образом пронумерованной криптокарты, которая содержит статическую запись и динамическую запись. Обратите внимание на то, что динамическая запись имеет самый высокий порядковый номер, и комнату покинули добавить дополнительные статические записи:

crypto dynamic-map dynmap 30 set transform-set myset
crypto map newmap 10 ipsec-isakmp
crypto map newmap 10 match address 110
crypto map newmap 10 set peer 172.18.124.153
crypto map newmap 10 set transform-set myset
crypto map newmap 65000 ipsec-isakmp dynamic dynmap

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.

Можно использовать эти команды на PIX с выполнением команд logging console debugging или logging monitor debugging:

  • debug crypto ipsec Обработка IPSEC Отладок.

  • debug crypto isakmp Обработка ISAKMP Отладок.

На Клиенте VPN переведите регистрационное окно в рабочее состояние в нижнем левый окне.

Очистка сопоставлений безопасности (SA)

В режиме конфигурации PIX используйте эти команды:

  • clear [crypto] ipsec sa — Удаляет сопоставления безопасности активного IPSec. Ключевое слово crypto является необязательным.

  • clear [crypto] isakmp sa — Удаляет сопоставления безопасности активного предложения IKE. Ключевое слово crypto является необязательным.

На Клиенте VPN можно выбрать вкладку Log для просмотра записей журнала.

Примечание: Для IPSec для работы оконечная точка туннеля к возможности подключения конечной точки туннеля требуется перед началом этой конфигурации.


Дополнительные сведения


Document ID: 14092