Голосовая связь : Digital CCS

VoIP с передачей сигналов по общему каналу (CCS)

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание

CCS
CAS

Введение

Этот документ иллюстрирует конфигурации, необходимые для этих двух маршрутизаторов в этом документе для передачи через Передачу голоса по IP (VoIP) и Сигнализация по общему каналу (CCS) по цифровому PRI.

Следует отметить, что в этой конфигурации, эти два маршрутизатора связаны встречно-параллельные по Сегменту IP. Тем не менее, в большинстве топологий маршрутизаторы с поддержкой передачи голоса могут быть установлены в любой зоне сети. Обычно голосовые маршрутизаторы подключаются через LAN подключаемость к другим маршрутизаторам, подключенным к WAN. Это важно для примечания, потому что, если голосовые маршрутизаторы не связаны по выделенной линии, все команды настройки возможности подключения к глобальной сети (WAN) настроены на тех маршрутизаторах, которые связаны с глобальной сетью (WAN), а не на голосовых маршрутизаторах, как они находятся в конфигурациях в этом документе.

В то время как Маршрутизатор Cisco 3640 и Маршрутизатор Cisco AS5300 используются в этом примере конфигурации, эти конфигурации могут также использоваться для Маршрутизаторов серии Cisco 2600.

Предварительные условия

Требования

Прежде чем можно будет настроить маршрутизатор Cisco для использования VoIP, лучше, если вы понимаете понятия функций Качества обслуживания (QoS) в Cisco программное обеспечение IOS�. Для узнавания больше о Характеристиках QoS обратитесь к Организации очереди, Формированию трафика, и фильтрации и QoS Signaling от страницы Cisco IOS QoS на Cisco.com.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco 2600 и маршрутизаторы серии "3640"

  • Cisco AS5300

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в Условные обозначения технических терминов Cisco.

Сигнализация t1: CAS и CCS

Когда вызов пытается соединиться и направляет и адресная информация, сигнализация в Мире телефонии предоставляет функции, такие как наблюдение и объявление статуса линии, вызывные устройства.

Существует два различных типа сигнальной информации в мире T1:

  • CCS

  • Сигнализация по выделенному каналу (CAS)

CCS

CCS является передачей сигнальной информации из информационной полосы. Самая известная и широко используемая форма этого типа передачи сигналов является ISDN. Один недостаток к использованию PRI ISDN является удалением одного DS0 или голосовым каналом. В этом случае, для сигнализации использования. Поэтому один T1 имел бы двадцать три Ds0, или B-каналы для пользовательских данных, и один DS0 или канал D для сигнализации. Возможно управлять множественными PRI с одиночным каналом D с каждой Связанной сигнализацией средства non (NFAS) использования. Поэтому можно настроить другие PRI в группе NFAS для использования всех двадцати четырех Ds0 в качестве B-каналов. Использование Передачи сигналов PRI гарантирует максимальные возможные скорости подключения, особенно с появлением 56 модемов K. Это иллюстрирует возможность очистки канала ISDN.

Другой недостаток использования CCS (как замечено в схеме сети) - то, что УАТС требует цифровой карты T1 PRI, которая является более дорогой, чем E&M сигнальная карта. Сигнальная карта E&M используется в той же схеме сети при выполнении CAS между AS5300 и УАТС.

CAS

CAS является передачей сигнальной информации в информационной полосе или внутриполосной передачей сигнала. Это означает, что голосовые сигналы перемещаются на тех же каналах как статус линии, адрес и предупреждающие сигналы. Как существует двадцать четыре канала на всей линии T1, пакетах сигнализации CAS interleaf в голосовых пакетах. Поэтому существуют полные двадцать четыре каналы для использования для голоса.

Различные типы сигнализации CAS доступны в мире T1. Наиболее распространенные формы сигнализации CAS являются петлевым стартом, groundstart и сигнализацией E&M. Самый большой недостаток сигнализации CAS то, что биты использований сети от информационных пакетов IP, таких как голосовые пакеты, для выполнения функций передачи сигналов. Сигнализация CAS таким образом часто упоминается как сигнализация бита, заменяющего младшего информационного бит.

CAS не является оптимальным выбором, когда каждый пытается достигнуть максимально возможных скоростей подключения с модемами. Большинство модемов может отрегулировать к качеству сигнала и все еще дать высокоскоростные надежные соединения. Однако использование 56 модемов K на линиях CAS отбрасывает скорости соединения почти на 2 K в нижележащем направлении связи через магистраль, которая использует сигнализацию CAS.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Дополнительные сведения о командах, используемых в данном документе, можно получить с помощью средства поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

/image/gif/paws/14079/voip_pri_cookbook_topo.gif

Конфигурации

Эти конфигурации используются в данном документе:

Cisco 3640 Сан-Хосе
sanjose3640A#show run
Building configuration...
 
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3640
!
logging buffered 60000 debugging
enable password cisco
!
no ip subnet-zero
!
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 3/0/0
 operation 4-wire
!
voice-port 3/0/1
 operation 4-wire
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer voice 1 pots     

!--- More on dial peers.

 destination-pattern 4552468
 port 1/0/1
!
dial-peer voice 2 voip
 destination-pattern 3006
 session target ipv4:10.2.1.2
!
dial-peer voice 3 pots
 destination-pattern 5551234
 port 1/0/0
!
dial-peer voice 4 voip
 destination-pattern 4005
 fax-rate 9600
 session target ipv4:10.2.1.2
!
interface Ethernet0/0
 ip address 10.2.1.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial2/0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
 no fair-queue
 clockrate 64000
!
interface Serial2/1
 no ip address
 no ip directed-broadcast
 shutdown
 clockrate 38000
!
interface Serial2/2
 no ip address
 no ip directed-broadcast
 shutdown
!
interface Serial2/3
 no ip address
 no ip directed-broadcast
 shutdown
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Cisco AS5300 Raleigh
AS5300#show run
Building configuration...
 
Current configuration:
!
version 11.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname AS5300
!
boot system flash c5300-js-mz_113-6_na2.bin
enable password cisco
!
isdn switch-type primary-dms100
!
!
controller T1 0
 framing esf
 clock source line primary
 linecode b8zs
 pri-group timeslots 1-24
!
controller T1 1
 clock source internal
!
controller T1 2
 clock source internal
!
controller T1 3
 clock source internal
!
!
dial-peer voice 1 voip           

!--- More on dial peers.

 destination-pattern 4552468
 session target ipv4:10.2.1.1
!
dial-peer voice 2 pots
 destination-pattern 3...
 direct-inward-dial
 port 0:D
 prefix 3
!
dial-peer voice 4 pots
 destination-pattern 4...
 direct-inward-dial
 port 0:D
 prefix 4
!
dial-peer voice 3 voip
 destination-pattern 5551234
 fax-rate 9600
 session target ipv4:10.2.1.1
!
!
voice-port 0:D
!
interface Ethernet0
 ip address 10.2.1.2 255.255.255.0
!
interface Serial0:23
 no ip address
 isdn switch-type primary-dms100
 isdn tei-negotiation first-call
 isdn incoming-voice modem
 no cdp enable
!
interface FastEthernet0
 no ip address
 shutdown
!
ip classless
!
logging buffered 60000 debugging
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Проверка.

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

В этом разделе описывается процесс устранения неполадок конфигурации.

Команды для устранения неполадок

Некоторые команды show поддерживаются Средством интерпретации выходных данных(только зарегистрированные клиенты), которое позволяет просматривать аналитику выходных данных команды show.

Примечание: Прежде чем вызывать команды debug, обратитесь к разделу Важные сведения о командах отладки.

  • debug voip ccapi inout для отслеживания пути выполнения через API управления вызовами, который служит интерфейсом между приложением сеанса вызова и базовым сетевым специфичным программным обеспечением. Можно использовать выходные данные от этой команды, чтобы понять, как вызовы обрабатываются маршрутизатором.

  • debug vpm all — Используемый для включения всех команд debug vpm: debug vpm spi, debug vpm signal и debug vpm dsp.

    Примечание: Эта отладка генерирует много выходных данных.

  • show call active voice для показа содержания таблицы активных вызовов, которая показывает все вызовы, в настоящее время связанные через маршрутизатор.

  • show call history voice — Используемый для показа таблицы истории вызовов. Таблица истории вызовов содержит распечатку всех вызовов, связанных через этот маршрутизатор в убывании упорядоченного по времени, так как был включен VoIP. Можно отобразить подмножества таблицы истории вызовов при помощи определенных ключевых слов.

  • show voice port для показа сведений о конфигурации об определенном голосовом порте.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14079