Голосовая связь и система унифицированных коммуникаций : Cisco Unified Communications Manager (CallManager)

Пример внедрения IP-телефонии: Национальный сингапурский информационный листок

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

Этот документ делает доступным для Клиента Cisco, партнеров и сотрудников опыт и уроки изученный из развертываний IP-телефонии в Национальном информационном листке (NB) в Сингапуре. Этот документ пытается:

  • Опишите и критикуйте дизайн развернутого решения.

  • Определите возможные усовершенствования к дизайну.

  • Выделите компромиссы в дизайне.

NB глобальное издательство. Сингапурское отделение состоит приблизительно из 6,000 продаж, печати и записи штата. NB штат находится во многих административных зданиях, расположенных в той же близости. В конце 2000, NB добавил другое здание, здание DBS, к их кампусу. Это дополнительное здание помещает 750 сотрудников. Вместо того, чтобы развертывать PrivateBranch Exchange (PBX) (внутренняя автоматическая телефонная станция) в новом здании, NB решенном для развертывания Решения IP-телефонии. Также, развертывание с нуля включает сетевой компонент.

NB Решение IP-телефонии является одиночным дизайном сайта. Все пользователи IP-телефонии расположены в здании DBS и распределены по пяти этажам. Сisco CallManager, шлюзы Открытой коммутируемой телефонной сети (PSTN) и голосовая почта также физически расположены в здании DBS.

Ссылка глобальной сети (WAN) подключает здание DBS со Структурой прикладной подсистемы B-узлов (NBAP) на расстоянии в меньше чем 1 км. Этот канал WAN переносит трафик Передачи речи по протоколу IP (VoIP) по к NBAP, где шлюз соединяется в глобальную сеть NB PBX. Эта схема показывает DBS и Структуры прикладной подсистемы B-узлов (NBAP).

/image/gif/paws/13968/65363.gif

Инфраструктура ЛВС колледжа

Инфраструктура LAN (локальной сети) DBS состоит из одного Коммутатора Catalyst 6509 в ядре и девяти коммутаторов Catalyst 4006 в коммутационных шкафах. Эта таблица показывает, как заполнен Коммутатор Catalyst 6509.

Слот Модуль Описание
1 WS-X6K-SUP1A-MSFC Супервизор с функциональной картой многоуровневого коммутатора (MSFC)
2 WS-X6K-S1A-MSFC2/2 Супервизор с MSFC
3 WS-X6416-GBIC Модуль GE с 16 портами
4 WS-X6408A-GBIC Модуль GE с 8 портами
5 WS-X6348-RJ21V 10/100 модуль с 48 портами со встроенным питанием
6 WS-X6608-E1 Шлюз E1 с 8 портами
7 FXS WS-X6624 Шлюз Станции внешнего обмена (FXS) с 24 портами
8 FXS WS-X6624 Шлюз FXS с 24 портами
9 Пустой

Эта таблица показывает, как заполнены коммутаторы Catalyst 4006.

Слот Модуль Описание
1 WS-X4013 Супервизор 2 с двумя портами Гигабитного Ethernet (GE)
2 WS-X4148-RJ45V 10/100 модуль с 48 портами со встроенным питанием
3 WS-X4148-RJ45V 10/100 модуль с 48 портами со встроенным питанием
4 WS-X4148-RJ45V 10/100 модуль с 48 портами со встроенным питанием
5 WS-X4148-RJ45V 10/100 модуль с 48 портами со встроенным питанием
6 WS-X4148-RJ45V 10/100 модуль с 48 портами со встроенным питанием

Общая емкость инфраструктуры LAN (локальной сети) должна соединиться и питание 2,160 IP-телефонов.

Catalyst 4006 переключает подключение назад к Catalyst 6509 посредством одного из портов GE на супервизоре чистой осевой формой. В то время как пятый этаж имеет один коммутатор Catalyst 4006, четыре из этих пяти этажей имеют два коммутатора Catalyst 4006. Эта схема иллюстрирует, как коммутаторы распространены по этажам и как они соединяются назад с Коммутатором Catalyst 6509.

/image/gif/paws/13968/65364.gif

Catalyst 6509 составляет серьезное единственное уязвимое звено. Важное улучшение в доступности может быть достигнуто путем добавления второго Catalyst 6509 и двойного подключения, которое Catalyst 4006 переключает на оба основных коммутатора с помощью запасного порта GE на супервизорах Catalyst 4006. С этим дизайном существует мало выравнивания для дублирования все модули в Catalyst 6509. Скорее модули, которые существуют (супервизоры, GE и модули FXS) могут быть разделены по двум шасси. Однако дополнительный восьмипортовый модуль E1 должен быть добавлен так, чтобы подключение PSTN могло также быть разделено по двум шасси. Этот дизайн также обеспечивает эти два Сisco CallManager, которые будут связаны с отдельными коммутаторами. Это гарантирует, что сбой Catalyst 6509 не делает абсолютно изолированный Сisco CallManager.

Второй Коммутатор Catalyst 6509 был частью первоначального предложения. Однако должный стоить факторов, NB выбрал одиночный Catalyst 6509.

NB придерживается рекомендаций по проектированию Cisco и имеет IP-телефоны и устройства обмена информацией в отдельных Виртуальных локальных сетях (VLAN). Каждый Catalyst 4006 имеет свой собственный голосовой VLAN. Поэтому существует два голосовых VLAN на пол для в общей сложности девяти голосовых VLAN. Каждый Catalyst 4006 имеет 240 портов. Поэтому каждый голосовой VLAN потенциально является родиной 240 IP-телефонов. Это - консервативный дизайн, но действительно имеет преимущество, что оно ограничивает влияние, если неисправное устройство лавинно рассылает VLAN с широковещательными сообщениями. Когда маршруты MSFC Семейства Catalyst 6000 между VLAN, скорость переадресации Уровня 3 не является проблемой.

65365.gif

Все устройства обмена информацией находятся в одиночной, большой VLAN. Это не соответствует рекомендациям по проектированию Cisco. Однако, это было дизайном, предпочтенным NB из-за их внутреннего в рабочем состоянии и требований к техническому обслуживанию. Поскольку этот одиночный VLAN для передачи данных охватывает все коммутаторы, широковещательный шторм Уровня 2 в этой VLAN имеет потенциал для воздействия на все IP-телефоны. Это делает качество обслуживания (QoS) на Коммутаторах Catalyst еще более важным. QoS обсуждено позже в этом документе.

Данный пример показывает типичного VLAN configuration для порта Catalyst 4006. Данный пример размещает все 48 портов в слот 5 в голосовом VLAN 110 и VLAN для передачи данных 11.

set port auxiliaryvlan 5/4-48 110 
set vlan 11 type ethernet state active 
set vlan 11 5/4-48

Сеть NB имеет эти три отдельных границы QoS trust:

  • Catalyst 4006 10/100 порт.

  • Catalyst 6509 10/100 порт, соединяющийся с Сisco CallManager.

  • Catalyst 6509 10/100 порт, соединяющийся с Маршрутизатором Cisco 7200.

Модули Catalyst 4000 10/100 в использовании имеют сингл, получают (RX) очередь (1q1 т) и две передачи (TX) очереди (2q1 т). Все порты настроены с командами в данном примере, чтобы включить вторую очередь TX и поместить кадры со значением класса обслуживания (CoS) между 2 и 7 во второй очереди. В то время как весь другой трафик входит в первую очередь, в результате все пакеты Протокола RTP (CoS=5) и все пакеты Skinny (CoS=3) входят во вторую очередь.

set qos enable
set qos map 2q1t 1 1 cos 0-1
set qos map 2q1t 2 1 cos 2-3
set qos map 2q1t 2 1 cos 4-5
set qos map 2q1t 2 1 cos 6-7

Обратите внимание на то, что Catalyst 4006 не поддерживает вида применения политик. Это доверяет Из-за любого кадра, принятого на его портах. Это не проблема, пока IP-телефон связан, так как поведение по умолчанию IP-телефона не должно доверять трафику, полученному на порту ПК, и переписать его с Из-за 0. Однако ПК, связанный непосредственно к порту Catalyst 4006, может потенциально использовать QoS, если это передает данные как 802.1p кадры. Это требует несколько сложного пользователя. Однако Windows 2000 и Network Interface Cards стандартного Ethernet (NIC) действительно поддерживают 802.1pq.

Конфигурация QoS на Catalyst 6509 немного более включена, так как порты на Catalyst 6509 имеют множество структур очереди, как показано в этой таблице.

Модуль Принимаемая очередь Передаваемая очередь
WS-X6K-SUP1A-MSFC 1p1q4 т 1p2q2 т
WS-X6416-GBIC 1q4 т 2q1 т
WS-X6408A-GBIC 1p1q4 т 1p2q2 т
WS-X6348-RJ21V 1p1q4 т 1p2q2 т

Любой порт, который имеет очередь строго по приоритету, помещает все кадры с CoS=5 в той очереди по умолчанию. Однако это предпочтено для имения всего трафика VoIP передача сигналов (кадры с CoS=3) во второй неприоритетная последовательности. Эта конфигурация включает это поведение.

set qos map 1p2q2t tx 2 1 cos 3
set qos map 2q2t tx 2 1 cos 3

Порты GE, соединяющиеся с коммутаторами Catalyst 4006, в нашей границе надежности. Обычно система доверяла бы Из-за полученных фреймов. Так как граница надежности Catalyst 4006 может поставиться под угрозу путем соединения ПК непосредственно с портом коммутатора, трафик от коммутаторов Catalyst 4006 обработан как недоверяемый, и охраняется Catalyst 6509. Применение политик сделано списком контроля доступа (ACL), который ищет RTP, Skinny, H.225 и пакеты H.245. В то время как все заголовки Пакета сигнализации VoIP переписаны с DSCP=26, заголовки пакета RTP переписаны с DSCP=46. ACL для этого, как показано в данном примере, сопоставлен со всеми портами GE.

set qos acl ip ACL_VOIP dscp 46 udp any any range 16384 32767
set qos acl ip ACL_VOIP dscp 46 udp any range 16384 32767 any
set qos acl ip ACL_VOIP dscp 26 tcp any any range 2000 2002
set qos acl ip ACL_VOIP dscp 26 tcp any range 2000 2002 any
set qos acl ip ACL_VOIP dscp 26 tcp any any eq 1720
set qos acl ip ACL_VOIP dscp 26 tcp any eq 1720 any
set qos acl ip ACL_VOIP dscp 26 tcp any any range 11000 11999
set qos acl ip ACL_VOIP dscp 26 tcp any range 11000 11999 any
set qos acl map ACL_VOIP 3/1-16,4/1-8,

Два из 10/100 портов на Catalyst 6509 используются для соединения с этими двумя Сisco CallManager. Это по существу надежные порты, но в сети NB они обработаны как недоверяемые, и Catalyst 6509 вызывает CoS=3 на полученных фреймах. Данный пример показывает конфигурацию порта.

set vlan 110 5/2-3
set port qos 5/2-3 cos 3

Альтернатива и более чистый подход, должны настроить Сisco CallManager для установки значения точки кода дифференцированных услуг (DSCP) IP во всех Пакетах сигнализации VoIP. Чтобы сделать это, установите параметры сервиса IpTosCm2Cm и IpTosCm2Dvce к 0x26 на Сisco CallManager. Catalyst 6509 может тогда быть настроен к trust DSCP для кадров, принятых на том порту, как показано в данном примере.

set port qos 5/2-3 trust trust-dscp

Этот подход имеет преимущество, что только управляемые VoIP кадры, и не каждый кадр от Сisco CallManager, получают хорошее QoS. Это важно, если образ Обновления Cisco CallManager загружен к Серверу CallManager, или если большие количества подробных записей о вызовах (КОМАНДИРЫ) обычно вытягивают от сервера. В настоящее время этот вид трафика также получает высокое QoS.

Наконец, один из 10/100 портов на Catalyst 6509 используется для соединения с Маршрутизатором глобальной сети Серии Cisco 7200. Это - также надежный порт, но текущий Cisco IOS� в использовании на Маршрутизаторе Cisco 7200 не копирует DSCP-значение к полю CoS. Для преодоления этого ограничения порт коммутатора обработан так же к портам GE (классифицируйте входящий трафик с помощью того же ACL), и выборочно предоставьте QoS на основе этого. Поэтому конфигурацию для порта коммутирующего маршрутизатора показывают в данном примере.

set vlan 10 5/1
set qos acl map ACL_VOIP 5/1

Инфраструктура WAN

Компонент WAN NB Сети для IP-телефонии является маленьким. Маршрутизатор Cisco серии 7200 в здании DBS имеет каналы WAN и к NBAP и к Прописным Башням. Однако только ссылка на NBAP переносит голос. Даже тогда существуют отдельные ссылки между DBS и NBAP для речи и данных. Проблемы качества голосовой связи были обнаружены во время ранних стадий развертываний, и было решено изменить кодек от G.729 до G.711. Эта требуемая дополнительная пропускная способность и речь и данные на глобальной сети (WAN) были поэтому разделены. Причина этих проблем, как позже находили, была с загрузкой IP-телефона в использовании в то время. Как консервативная мера, NB решенная, чтобы остаться с G.711 и разделить каналы WAN для речи и данных в ближайшей перспективе.

В настоящее время речевой канал WAN состоит из трех физических ссылок E1, которые связаны вместе Протоколом PPP (MLP). Из-за относительно высокой скорости ссылки не требуется никакая Фрагментация и чередование данных в канале (LFI). Единственная требуемая Характеристика QoS помещает в очередь. Предпочтительным механизмом организации очередей является Организация очереди с малой задержкой (LLQ). Однако это не работало из-за проблемы Cisco IOS с LLQ и MLP, где команда service-policy исчезла из конфигурации, если выключилась ссылка. Как временный обходной путь, использовалась Постановка в очередь с установлением приоритетa. Данный пример показывает текущую конфигурацию глобальной сети (WAN).

interface Multilink88
 ip address 10.104.209.73 255.255.255.248
 priority-group 1
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink interleave
 multilink-group 88

interface Serial4/0
 bandwidth 2000
 encapsulation ppp
 ppp multilink
 multilink-group 88

interface Serial4/1
 bandwidth 2000
 encapsulation ppp
 ppp multilink
 multilink-group 88

interface Serial4/2
 bandwidth 2000
 encapsulation ppp
 ppp multilink
 multilink-group 88

priority-list 1 protocol ip high list 121
priority-list 1 protocol ip medium list 122
priority-list 1 default low
priority-list 1 queue-limit 500 40 60 80

access-list 121 permit udp any any range 16384 32767
access-list 121 permit udp any range 16384 32767 any
access-list 122 permit tcp any any range 2000 2002
access-list 122 permit tcp any range 2000 2002 any
access-list 122 permit tcp any any eq 1720
access-list 122 permit tcp any eq 1720 any
access-list 122 permit tcp any any range 11000 11999
access-list 122 permit tcp any range 11000 11999 any

Текущая конфигурация глобальной сети (WAN) является компромиссом и не рекомендуется для использования в других развертываниях. Среднесрочный план состоит в том, чтобы консолидировать речь и данные на одиночном канале WAN, и заменять постановку в очередь с установлением приоритетa LLQ. Отдельные ссылки для речи и данных требуют статичной маршрутизации или маршрутизации на основе политик, и преимущества использования протокола динамической маршрутизации потеряны. Постановка в очередь с установлением приоритетa, даже с голосовыми пакетами, назначаемыми высокая очередь, не гарантирует, что строгий приоритет дан голосовым пакетам. Системный трафик, такой как обновления маршрута, пакеты Keepalive, и т.д. все еще берет предпочтение по голосовым пакетам в высокой очереди.

Это было проверено, что LLQ работает правильно в программном обеспечении Cisco IOS версии 12.2. Данный пример показывает QoS маршрутизатора после перемещения к LLQ. Пропускные способности основываются на 60 одновременных вызовах G.729 (RTP: 60 x 24 кбит/с = 1440 кбит/с и Сигнализация: 60 x 0.5 кбит/с = 30 кбит/с).

interface Multilink88
 service-policy output VoIP

class-map VoIP-RTP
 match access-group 121
class-map VoIP-Sig
 match access-group 122

policy-map VoIP
 class VoIP-RTP
  priority 1440
 class skinny
  bandwidth 30

access-list 121 permit udp any any range 16384 32767
access-list 121 permit udp any range 16384 32767 any
access-list 122 permit tcp any any range 2000 2002
access-list 122 permit tcp any range 2000 2002 any
access-list 122 permit tcp any any eq 1720
access-list 122 permit tcp any eq 1720 any
access-list 122 permit tcp any any range 11000 11999
access-list 122 permit tcp any range 11000 11999 any

IP-телефония

IP-телефоны и их подключение к коммутатору

Здание DBS имеет приблизительно 750 7960 IP-телефона. IP-телефоны соединяются с 10/100 портами на Catalyst 4006 и получают встроенное питание от коммутатора. PC соединяются с портами коммутатора позади IP-телефона, как изображено в этой схеме.

/image/gif/paws/13968/65373.gif

IP-телефоны и PC находятся на отдельных VLAN и IP-подсетях.

Планирование сайта

Все IP-телефоны получают встроенное питание от линейных карт Catalyst 4006. Сами коммутаторы приведены в действие тремя Источниками питания переменного тока в шасси. Встроенное питание, однако, получено внешне от Дополнительной стойки электропитания для Catalyst 4006 (WS-P4603). Полка питания имеет три источника питания. Каждый предоставляет 1050 Вт в - DC 52V. Это достаточно для включения полностью заполненного коммутатора Catalyst 4006 с 7960 Cisco IP Phone, связанными со всеми 240 портами.

/image/gif/paws/13968/65366.gif

Все коммутаторы Catalyst 4006 убегают Uninterrupted Power Supply (UPS). Это позволяет им продолжать операцию в течение двух часов в случае сбоя питания. Сisco CallManager соединяются с четырехчасовым ИБП.

Cisco CallManager

NB модель Установки CallManager является одиночным сайтом с централизованной обработкой вызовов. Можно утверждать, что модель фактически для нескольких местоположений из-за канала WAN к NBAP и cвязанному шлюзу, расположенному там. Но этот факт может (по большей части) быть проигнорирован, поскольку никакое Управление контролем доступа (CAC) не требуется по глобальной сети (WAN). Это вызвано тем, что количество вызовов по глобальной сети (WAN) неявно ограничено количеством транков, подключающих шлюз с УАТС.

NB Кластер Cisco CallManager состоит из двух 7835 Сервера медиа-конвергенции Cisco (MCS-7835). Один CallManager выполняет функцию публикации базы данных, и другой подписывается на базу данных. Все IP-телефоны регистрируются в абоненте как первичное Cisco CallManager, и используют издателя в качестве вторичного Сisco CallManager.

Настроены две области: NBAP и DBS. Шлюз в NBAP является единственным устройством в области NBAP, все другие устройства находятся в области DBS. Намеченный дизайн должен использовать G.711 для всех вызовов в здании DBS и G.729 использования только для вызовов по глобальной сети (WAN). В настоящее время, однако, вызовы по каналу WAN являются также G.711.

IP-телефоны в области DBS имеют пятизначное расширение в диапазоне 17000 - 17999. Существуют пять другие NB сайты в Сингапуре, которые имеют соединение четыре - и пятизначные расширения. Эта таблица показывает NB Сингапурские сайты.

Название сайта Код сайта Цифры
Департамент присвоения имен Сингапур DBS 5
NB печать Acme NBAP 5
Acme, создающий A ABA 4
Acme, создающий B ABB 5
Дуглас Принтинг DP 4
Печать предоставления GP 4

Расширения назначены так, чтобы первая цифра уникально определила, является ли расширение четырьмя или пятью цифрами. Пользователи IP-телефона могут набрать любого NB Сингапурское Расширение УАТС путем вызова номера четырех - или пятизначное расширение.

Как обсуждено позже в разделе Интеграции шлюза, существует три типа шлюзов:

  • Один шлюз H.323 Cisco 7200, который соединяется с устаревшей сетью NB PBX.

  • Три шлюза E1 Catalyst 6509 то подключение к PSTN.

  • Два Catalyst 6509 шлюзы FXS с 24 портами то подключение к голосовой почте.

Это отражено в конфигурации группы маршрутов Сisco CallManager. Одна группа маршрутов существует для каждого из этих трех типов шлюза. Эта таблица выделяет характеристики каждой группы маршрутов.

Группа маршрутов Платформа Слот/Порт Тип порта Приоритет
VM DBS Коммутатор Catalyst 6509 6/1-24 7/1-24 FXS FXS 1 2
PSTN DBS Коммутатор Catalyst 6509 8/1 8/2 8/3 PRI PRI PRI 1 2 3
Традиционный NBAP Маршрутизатор Cisco 7200 5/1-2 PRI 1

Вызовы различным назначениям направлены следующим образом:

  • Вызовы к PSTN используют группу маршрута тфоп DBS. Нет никакой резервной копии.

  • Вызовы к голосовой почте используют группу маршрутов VM DBS. Нет никакой резервной копии.

  • Вызовы к NB использованию Сервиса Telnet Группа маршрутов по устаревшему протоколу NBAP.

  • Вызовы к NB Сингапурскому использованию Расширения УАТС Группа маршрутов по устаревшему протоколу NBAP как основной, и группа маршрута тфоп DBS как группа дополнительного маршрута.

Все, что остается теперь, должно определить образцы соответствующего маршрута и связать их с группами маршрутов. Это прямо для первых трех упомянутых выше элементов, поскольку требуется только список одного маршрута. Вещи немного больше связываются с последним элементом из-за группы резервного маршрута. Предпочтительный путь для вызова от IP-телефона до Расширения УАТС через Группу маршрутов по устаревшему протоколу NBAP. Если этот шлюз недоступен, вызовы направлены через PSTN через группу маршрута тфоп DBS. Когда это происходит, цифры должны быть снабжены префиксом к набранному расширению для создания полного номера телефона PSTN. Снабженные префиксом цифры зависят от вызываемого сайта, следовательно, каждый сайт должен иметь другой список маршрутов. Поскольку существует пять NB сайты с PBXs и несколько префиксов PSTN на сайт, они заканчивают с десятью списками маршрутов.

Эта схема показывает всем NB списки маршрутов. Два - или трехзначное число, включенное от имени большинства списков маршрутов, отражают цифры, которые снабжены префиксом к вызываемому внутреннему абоненту, каждый раз, когда вызовы передаются группе маршрута тфоп DBS.

/image/gif/paws/13968/65367.gif

Определенный, некоторый NB Пользователи IP-телефона ограничены количество, которое они могут вызвать. Это управляется путем размещения шаблонов маршрута и расширений IP-телефона во многих отделениях. Отделения тогда группируются в пространство поиска вызова. IP-телефоны принадлежат пространству поиска вызова и могут только назвать количество содержавшимся в отделениях в том пространстве поиска. Эта таблица приводит NB пространства поиска Сisco CallManager и отделения.

Пространство поиска Отделения Описание
Гость Гость DBS пользователя DBS NB оператор - телефонист DBS SGP Обычное Лобби телефона пользователя DBS и другой телефон общественного пользования NB Сингапурский Регистратор Расширения УАТС
User Пользователь DBS NB GSDN NB гость DBS PSTN SGP Telnet NB оператор - телефонист DBS Idd SGP Обычный телефон пользователя DBS — Международные вызовы посредством глобальных Вызовов внутри страны сети NB в Сингапурском Лобби и других телефонах общественного пользования NB Сингапурский Регистратор Международных вызовов Расширения УАТС

Интеграция голосовой почты

DBS использует Систему голосовой почты Octel. Это было выбрано, потому что это - глобальное NB стандарт, и сетевая работа с голосовой почтой между различными системами требовалась.

Сisco CallManager соединяется с Системой голосовой почты Octel посредством двух карт FXS с 24 портами в Коммутаторе Catalyst 6509. Только 30 из доступных 48 портов используются. Ссылка Протокола SMDI на 9600 битов в секунду подключает первичное Cisco CallManager с Устройством Octel.

Система octel также связана с корпоративным NB сеть Octel. Это сделано посредством четырех отделений междугородной телефонной связи (FXO) порты на Устройстве Octel, которые соединяются со старой УАТС Definity Lucent. Эта схема показывает, как Система octel DBS соединяется и с новым и с предыдущим поколением.

/image/gif/paws/13968/65368.gif

Примечание: Исходное проектное решение не включало УАТС. Скорее идея состояла в том, чтобы передать голосовую почту по через карту FXS с 24 портами и Сеть VoIP. Но во время пилота, с проблемами встретились в способе, которым карта FXS обработала Двухтональные многочастотные (DTMF) тоны от Устройства Octel. Как обходной путь, карта FXS с 24 портами была заменена шлюзом Cisco IOS. Это хорошо работало, но NB предпочло основанное на УАТС решение.

Стоит обратить внимание на характеристики устойчивости решения для голосовой почты. В дополнение к системе голосовой почты существуют другие единственные уязвимые звенья:

  • Канал SMDI не избыточен: сбой первичного Cisco CallManager возьмет систему голосовой почты вне обслуживания. Если эта ситуация происходит, NB, стратегия состоит в том, чтобы вручную переместить кабель SMDI в резервный Cisco CallManager. Также сплиттер SMDI позволил бы и CallManagers быть связанным в то же время и обеспечил бы автоматическое аварийное переключение.

  • В настоящее время обе карты FXS с 24 портами находятся в том же шасси Catalyst 6509. Сбой Catalyst 6509 возьмет систему голосовой почты вне обслуживания. Как обсуждено ранее в этом документе, существует очень, чтобы быть полученным с точки зрения упругости путем добавления второго Catalyst 6509.

Интеграция шлюза

В следующей таблице перечислены три различных типа голосовых шлюзов в сети NB.

Платформа Тип интерфейса Number of Ports (Количество портов) Протокол Соединение с
Catalyst 6509 PRI/E1 8 x 30 каналов Skinny PSTN
Catalyst 6509 Аналоговый FXS 2 x 24 Skinny Voice Mail (Голосовая почта)
7206VXR PRI/CAS/E1 2 x 30 каналов H.323 Устаревшая УАТС

Catalyst 6509 держит одиночную восьмипортовую карту E1. Три из этих восьми портов соединяются с PSTN посредством PRI. Каждый порт E1 имеет собственный IP-адрес и его предназначения порта как независимые шлюзы. Маршрутизация вызова к и от шлюзов управляется Сisco CallManager посредством Облегченного протокола. Пользователи набирают номер PSTN путем вызова номера 0, придерживавшийся количеством PSTN. Входящим вызовам разделили ведущие цифры, и вызов направлен к вызванному IP-телефону на основе последних пяти цифр.

Пользователи набирают '9' для выбора внешней линии, и Сisco CallManager удаляет эту цифру прежде, чем представить вызов PSTN. NB попробованный два метода удаления цифры. Первый метод включает 'точку' в шаблон маршрута на Сisco CallManager, и от всех предточечных цифр сбрасывают прежде, чем представить его PSTN. Второе, и предпочтительный способ, должен настроить сброс как часть настройки шлюза на Сisco CallManager. Это сделано путем определения Номера цифр для разделения поля одному. Этот второй метод лучше, потому что он сохраняет продвижение '9', когда количество сохранено в Размещенном каталоге вызовов на IP-телефоне. Это означает, что пользователь может позже повторно набрать количество из каталога, не имея необходимость нажимать editdial и добавлять продвижение '9'.

Шлюзы FXS используются исключительно для голосовой почты. Эти шлюзы управляются Сisco CallManager посредством Skinny.

Шлюз Cisco 7200 предоставляет подключение между Сетью для IP-телефонии в DBS и глобальной сетью NB PBX. Этим шлюзом является единственный VoIP - устройство, не физически расположенный в здании DBS: Это расположено в Структуре прикладной подсистемы B-узлов (NBAP) и достигнуто посредством канала WAN.

Шлюз Cisco 7200 оснащен одиночным адаптером порта E1 с двумя портами и использует H.323, чтобы говорить с CallManager. Оба порта E1 соединяются с Nortel Meridian, расположенным в NBAP. Один QSIG портов использует и другая Сигнализация по выделенному каналу (CAS) использования, чтобы говорить с УАТС. В то время как международные вызовы, с помощью частной голосовой сети (Telnet), направлены через порт CAS, вызовы к Сингапурским Расширениям УАТС направлены вниз порт QSIG.

Соединение CAS и QSIG усложняет настройку. CAS требуется, чтобы предоставлять доступ к персональному идентификационному номеру (PIN) защищенный от кода международный набор посредством глобальной Сети для голосовых данных Telnet. Когда пользователь набирает этот сервис, они набирают 313xxxxxx, где xxxxxx является шестиразрядный PIN-код. Приложение Meridian, которое подтверждает подлинность этого PIN-кода, кажется, не поддерживается посредством PRI. Следовательно, потребность использовать CAS на одном из двух транков для этой цели.

Однако сигнализация CAS оказалась проще начаться, чем Магистраль QSIG. Среди проблем, с которыми встречаются, были временные интервалы, запирающиеся на Меридиане и разногласие по вопросам Нумерации B-каналов. Почти все проблемы имели отношение к несоответствию параметров конфигурации на стороне Cisco 7200 и Меридиана. Эти вопросы были решены после того, как Cisco IOS предоставила рабочую Конфигурацию Meridian.

Копия Конфигурации Meridian включена ниже. Эта конфигурация от параметра Meridian 11C, рабочий выпуск ПО 24.24. Придерживающиеся пакеты ПО требуются для активации этой конфигурации.

QSIG      263
QSIGGF    305
MASTER    309
QSIG-SS   316
ETSI-SS   323

Придерживающаяся конфигурация от Блока данных Маршрута конфигурации.

TYPE  RDB     (Route Data Block)
CUST  00      (Customer Number)
DMOD
ROUT  xx      (Route Number)
DES           (Trunk Description)
TKTP  TIE     (Trunk type - Tie Line or DID)
ESN   NO 
RPA   NO
CNVT  NO
SAT   NO
RCLS  INT     (Route Class - Internal or External)
DTRK  YES     (Digital Trunk - YES)
BRIP  NO
DGTP  PRI2    (Digital Group Type - PRI 30B + D)
ISDN  YES     (YES when DGTP is PRI or PRI2)
MODE  PRA     (ISDN/PRA Route)
IFC   ESGF    (ESGF req QSIG & QSIF GF Pkgs)
SBN   NO
PNI   00000
NCNA  NO
NCRD  NO
CTYP  UKWN
INAC  NO
ISAR  NO
CPFXS YES
DAPC  NO
INTC  NO
DSEL  VOD
PTYP  DTT
AUTO  NO
DNIS  NO
DCDR  NO
ICOG  IAO     (Bothway Trunk In and Out (IAO))
SRCH  RRB
TRMB  YES
STEP
ACOD  xxxx    (Trunk access code)
TCPP  NO
TARG  03
BILN  NO
OABS
INST
ANTK
SIGO  STD
MFC   NO
ICIS  YES
OGIS  YES
PTUT  0
TIMR  ICF     512
OGF   512
EOD   13952
NRD   10112
DDL   70
ODT   4096
RGV   640
GTO   896
GTI   896
SFB   3
NBS   2048
NBL   4096
IENB  5
TFD   0
VSS   0
VGD   6
DTD   NO
SCDT  NO
2 DT  NO
DRNG  NO
CDR   NO
NATL  YES
SSL
CFWR  NO
IDOP  NO
VRAT  NO
MUS   NO
PANS  YES
FRL   0 x
FRL   1 x
FRL   2 x
FRL   3 x
FRL   4 x
FRL   5 x
FRL   6 x
FRL   7 x
OHQ   NO
OHQT  00
CBQ   NO
AUTH  NO
TTBL  0
PLEV  2
OPR   NO
ALRM  NO
ART   0
PECL  NO
DCTI  0
TIDY  xx
SGRP  0
AACR

Эта конфигурация от канала D.

ADAN  DCH 12      (D-Channel Number assigned by programmer)
CTYP  MSDL        (D-Channel Card type) 
CARD  02          (Card Location)
PORT  1           (Port Number) 
DES   CISCO_5300  (Description)
USR   PRI         (User type - PRI for ISDN PRA only)
DCHL  2           (Loop the D-Channel will be associated with)
OTBF  32          (Output request buffer)
PARM  RS422 DTE   (Default)
DRAT  64KC        (64kb/s Clear - Don't change) 
CLOK  EXT         (Clock Source - External)
NASA  NO          (Default NO)
IFC   ESIG        (ETSI Q Reference Signaling - MSDL D-Channel ONLY) 
ISDN_MCNT  300    (Default)
CLID  OPT0        (Opt0 is default for ESIG and ISIG interfaces)
CO_TYPE  STD      (100% Compatible)
SIDE  NET         (Network or User Side)
CNEG  2           (2 = Channel is indicated - alternative is accepted)
RLS   ID  **      (Default)
RCAP  COLP        (COLP is default for ESIG, ISIG interfaces)
MBGA  NO          (Default)
OVLR  NO          (Default)
OVLS  NO          (Default)
T310  120         (Default)
T200  3           (Default)
T203  10          (Default)
N200  3           (Default)
N201  260         (Default)
K     7           (Default)

Это - конфигурация для таймеров петли для интерфейса tie-line PRI.

LOOP 2

MFF    AFF
ACRC   NO
ALRM   REG
RAIE   NO
G1OS   YES
SLP    5       24 H    30    1 H
BPV    128    122
CRC    201     97
FAP    28       1
RATS   10
GP2    20     100 S    12 S    12 S    4 S
MNG1   60 S
NCG1   60 S
OSG1   60 S
MNG2   15 S
NCG2   15 S
OSG2   15 S
PERS   50
CLRS   50
OOSC   0

Эта конфигурация от B-канала.

TN     00x 0x      (LEN, TN (Terminal Number))
TYPE   TIE         (Trunk Type - Tie Line)
CDEN   SD          (Single Density Card
CUST   0           (Customer 0)
TRK    PRI2        (Trunk Type)
PDCA   x           (Pad Category Table)
PCML   A           (A-law or Mu-Law)
NCOS   0           (Network Class of Service)
RTMB   x y         (Route Member- x is router no., y is member no.)
B-CHANNEL SIGNALING
TGAR   0           (TGAR Restricted Dialing Leave as 0)
AST    NO          (Default)
IAPG   0           (Default)
CLS    CTD DIP WTA LPR APN THFD XREP BARD
P10    VNL         (Class of services)
TKID

Конфигурацию шлюза для двух транков E1 показывают здесь. Заметьте, что шлюз действует как сетевая сторона, в то время как Меридиан является стороной пользователя.

controller E1 5/0
 pri-group timeslots 1-31

!-–– Defines PRI trunk.


controller E1 5/1
 framing NO-CRC4
 ds0-group 0 timeslots 1-15,17-31 type e&m-wink-start

!-–– CAS trunk.


interface Serial5/0:15
 isdn switch-type primary-qsig

!-–– Defines Q.SIG signaling.

 isdn protocol-emulate network

!-–– The network side.

 isdn incoming-voice voice
 isdn send-alerting
 isdn sending-complete

Шлюз имеет 15 узлов обычной телефонной сети. Большинство точек вызова указывает на Магистраль QSIG, отражая различные Расширения УАТС, которые достижимы на стороне УПАТС.

Остающиеся точки вызова указывают на магистральный канал CAS, направляя вызовы к Сети для голосовых данных Telnet. Также заметьте, что Магистраль QSIG настроена для включения Индикатора хода выполнения со значением 8, когда она передает сообщение Предупреждения обратно УАТС. Это говорит УАТС, что шлюз предоставляет внутриполосный сигнал обратного вызова, и УАТС открывает аудиопуть даже, прежде чем вызову ответит IP-телефон.

dial-peer voice 33 pots
 preference 1
 destination-pattern 33.......
 direct-inward-dial
 port 5/1:0

!-–– Calls routed out of the CAS trunk.

 forward-digits all
!
dial-peer voice 313 pots
 destination-pattern 313......
 direct-inward-dial
 port 5/1:0
 forward-digits all
!
dial-peer voice 40000 pots
 destination-pattern 4....
 progress_ind alert enable 8

!-–– Gateway to provide ringback.

 direct-inward-dial
 port 5/0:15

!-–– Calls routed out of the QSIG trunk.

 forward-digits all
!
dial-peer voice 8 pots
 destination-pattern 8T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 7 pots
 destination-pattern 7T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 6 pots
 destination-pattern 6T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 5 pots
 destination-pattern 5T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 16 pots
 destination-pattern 16...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 13 pots
 destination-pattern 13...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 2 pots
 destination-pattern 2T
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 1000 pots
 destination-pattern 1...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 10 pots
 destination-pattern 0...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 3 pots
 destination-pattern 3...
 progress_ind alert enable 8
 direct-inward-dial
 port 5/0:15
 forward-digits all
!
dial-peer voice 508200 pots
 destination-pattern 5082..
 progress_ind alert enable 8
 port 5/0:15
 forward-digits all

Существует только два VoIP одноранговых соединение, один указывающий на каждый Сisco CallManager. Точки вызова идентичны за исключением предпочтения, которое гарантирует, что вызовы направлены к первичному Cisco CallManager, когда доступный. Настройка progress_ind включает 3 говорит шлюзу сигнализировать к УАТС посредством Индикатора хода выполнения в сообщении SETUP, что вызывающая сторона не ISDN. Наконец, h225 timeout tcp establish 3 говорит шлюзу ждать максимум трех секунд при установлении сеанса H.225 с Сisco CallManager. Если Сisco CallManager не отвечает в течение трех секунд, шлюз пробует вторичный Сisco CallManager.

dial-peer voice 17000 voip
 preference 1

!-–– Route to primary Cisco CallManager is preferred.

destination-pattern 17...
 progress_ind setup enable 3

!-–– Progress indicator = non-ISDN.

 voice-class h323 10
 session target ipv4:10.66.184.13
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 codec g711ulaw
 ip precedence 5
 no vad
!
dial-peer voice 17001 voip
 preference 2
 destination-pattern 17...
 progress_ind setup enable 3
 voice-class h323 10
 session target ipv4:10.66.184.14
 dtmf-relay cisco-rtp h245-signal h245-alphanumeric
 codec g711ulaw
 ip precedence 5
 no vad

voice class h323 10
 h225 timeout tcp establish 3

Некоторые самые персистентные проблемы, с которыми встречаются во время развертывания NB Проекта IP-телефонии, принадлежали эху. Основные проблемы эха были испытаны Пользователями IP-телефона, когда они вызвали определенные числа через шлюз Cisco 7200. Усилие, которое вошло в попытку уменьшить эхо, было обширно, и следующая информация пытается перехватить части этого опыта, который может быть полезен для других развертываний.

Начальное ожидание командой Организации систем IP-телефонии было для шлюза Cisco 7200 для обеспечения подключения между стороной VoIP и одиночной УАТС в NBAP. Поскольку оказалось, что фактически предоставлялось, было подключение между стороной VoIP и очень большим, во всем мире NB голосовая сеть. NB голосовая сеть имеет собственное наследство, включая многие проблемы эхо. В прошлом NB предпринятый для настройки уровней мощности различных узлов в этой сети для уменьшения суммы эха. Сеть, с которой соединялся шлюз Cisco 7200, была сетью с существующими проблемами эхо. Это также имело переменные уровни мощности сигнала, в зависимости от назначения вызова. Это было сложной интеграцией.

Путем представления решения для речевых пакетов, с его дополнительными задержками, были усилены проблемы эхо. Чтобы обработать это, придерживающиеся корректировки были внесены.

  • Эхоподавители Cisco 7200 были отрегулированы к их самому агрессивному параметру.

  • Усиление входного сигнала было понижено.

  • Выходное затухание сигнала увеличилось на двух транках E1.

В то время как это уменьшило эхо, оно имело нежелательный побочный эффект, что уровни громкости, при призыве определенных, некоторый назначений NB голосовая сеть, были слишком низки, и пользователи жаловались. Из-за несоответствия уровней сигнала на устаревшей стороне, не было никакой комбинации усиления и затухания, которое удовлетворило вызовам и от всех назначений. То, что работало хорошо для вызовов в Гонконг, создало эхо на вызовах в Корею. То, что работало для Кореи, привело к проблемам низкого объема для Гонконга. Конфигурация ниже показов текущая компромиссная конфигурация для голосовых портов на шлюзе Cisco 7200.

voice-port 5/0:15
 input gain 0
 output attenuation 3
 echo-cancel coverage 32
 compand-type u-law
 cptone SG

voice-port 5/1:0
 input gain -2
 echo-cancel coverage 32
 compand-type u-law
 cptone SG
 timeouts interdigit 5
 timeouts wait-release infinity
 timing percentbreak 60

Конструирование в настоящее время работает на улучшение возможностей эхоподавления некоторых продуктов Cisco. NB ждет этих улучшений для дальнейшего сокращения эха.

Альтернативные решения были предложены NB, но клиент решил ждать усовершенствований Cisco. Два предложенных обходных пути обсуждены ниже в надежде, что другие проекты могут извлечь выгоду от них. Основной урок, изученный из NB, - то, что предупреждение сигнала тревоги должно быть выдано рано, если предложенное Решение IP-телефонии соединяется с большой частной прежней сетью телефонной связи. Путем выполнения этого эти обходные пути могут разрабатываться и стоиться в решение с начала.

  • Обходной путь 1 — Вводит эхоподавители третьей стороны между шлюзом Cisco и УАТС. Технология эхоподавления Cisco может в настоящее время отменять хвосты эха, которые задержаны менее тогда 32 мс. Отраженный сигнал должен подвергнуться Затуханию эха (erl) по крайней мере 6 дБ, т.е. полученный эхо-сигнал должен быть на по крайней мере 6 дБ ниже, чем первоначально переданный сигнал. Для него для стоения производительность компенсатора третьей стороны должна превысить вышеупомянутые значения.

  • Обходной путь 2 — Увеличивает число транков между шлюзом Cisco и УАТС. Это позволяет каждому транку быть настроенным с другими параметрами усиления и ослабления. Вызовы могут тогда быть направлены по транку с большинством подходящих характеристик эха. Например, в то время как вызовы в Корею проходят через транк 2, вызовы в Гонконг могут пройти через транк 1. УАТС также должна быть в состоянии направить вызовы по корректному транку, на основе того, где происходит вызов.

Обеспечение DSP для проведения конференций и перекодировки

Несмотря на то, что G.711 в настоящее время используется всюду по сети, намерение состоит в том, чтобы использовать G.729 по каналу WAN между DBS и NBAP. Дизайн принял это во внимание путем выделения аппаратных ресурсов для конференций цифрового процессора сигналов (DSP). Аппаратные ресурсы находятся на Catalyst 6509. Вспомните, что только три из этих восьми портов E1 используются для подключения PSTN. Три из оставления пятью портами используются для конференц-связи.

Существует два неиспользуемых порта на модуле E1 Catalyst 6509, которые установлены как ресурсы перекодировки. В настоящее время нет потребности в перекодировке, но потребность возникнет, если NB решит развернуть сервер интерактивного голосового ответа (IVR) IP.

Версии ПО

В следующей таблице перечислены версии программного обеспечения, используемые в сети NB в то время, когда был записан этот документ.

Устройство Version
Catalyst 6509 5.5 (3)
Catalyst 4006 6.1 (1)
Cisco 7260VXR 12.1 (3a) XI5
Cisco CallManager 3.0 (8)
IP-телефон 7960 P003Q301
WS-X6608-E1 C001W300
FXS WS-X6624 A002S300

Управление сетью

Средства управления сетью в настоящее время не используются для управления NB Сеть для IP-телефонии.

Изученные уроки

Обнаруженные отклонения, предупреждения и решения

Следующая таблица суммирует основные проблемы, с которыми встречаются во время развертываний. Подробные данные этих проблем обсуждены ранее в этом документе.

Предупреждение Разрешение
Эхо при установлении связи сети для речевых пакетов к большой прежней сети телефонной связи. Введите дополнительные транки в эксплуатацию и варьируйтесь усиление/затухание так, чтобы вызовы могли быть направлены по транку с подходящей настройкой. Разверните эхоподавители третьей стороны. Ждите улучшенной Технологии эхоподавления Cisco.
Несогласованные параметры QSIG на шлюзе и стороне УПАТС. Получите рабочие конфигурации УАТС из существующего узла с помощью подобной настройки.
Цифра для выбора внешней линии, не сохраненной в каталоге размещенных вызовов. Сбросьте от ведущей цифры в конфигурации шлюза и не используйте предточечное действие сброса в шаблоне маршрута.

Обращения в центр технической поддержки

В следующей таблице перечислены все проблемы, которые привели к кэйсу ТАС (Центра технической поддержки). Также включенный другие значительные проблемы, которые были решены локально группой развертывания.

CAS E Описание Статус и разрешение
B124306 Блокировка канала QSIG. Первоначально решенный путем реконфигурирования Согласования каналов LD17 (CNEG) параметр на УАТС Nortel от Опции (2) до Опции (1). Однако симптомы проблемы вновь появились через какое-то время. Впоследствии, поставщик УАТС изменил Настройку QSIG PRI на УАТС от ESIG (Настройка QSIG GF) к ESGF (европейская Настройка QSIG). После модификации блокировка канала прекратила происходить, но только верхние 15 каналов были функциональны. Для исправления проблемы команда ISDN contiguous-bchan была удалена из маршрутизатора VoIP.
A612818 Несоответствие B-канала, где УАТС Nortel использует канал 31 в качестве управляющего канал, в то время как PRI Голосового шлюза Cisco использует канал 16. Решенный путем настройки команды ISDN contiguous-bchan на интерфейсе QSIG PRI. Эта команда используется для определения непрерывной обработки несущего канала так, чтобы B-каналы 1 - 30 (пропуск канала 16) сопоставили с временными интервалами 1 - 31. Это доступно для интерфейсов PRI E1 только, когда основная-qsig опция типа коммутатора настроена при помощи команды isdn switch-type.
B124306 Эхо. Существует два сценария, в которых эти 7200 эхоподавителей могут не быть в состоянии уравновесить эхо. Сценарий 1: Эхо является слишком громким для компенсаторов для уравновешиваний. Сценарий 2: Эхо задержано больше чем на 32 мс, который является вне покрытия этих 7200 компенсаторов. Сценарий 1: Внесение изменений в выходное затухание сигнала и усиление входного сигнала на голосовом шлюзе и paddings на УАТС значительно улучшило ситуацию с эхом. Последние настройки:
  • Усиление входного сигнала PRI Cisco 7200 = 0
  • Выходное затухание сигнала Ciisco 7200 PRI = 3
  • Усиление входного сигнала CAS Cisco 7200 =-2
  • Выходное затухание сигнала CAS Cisco 7200 = 0
  • Затухание TX PRI УАТС = 2
  • Затухание RX PRI УАТС = 4
  • Затухание TX CAS УАТС = 0
  • Затухание RX CAS УАТС = 5
Остаточное эхо происходит как статический шум за первую 1 - 2 секунды потока RTP. Продолжительность неизбежна для адаптивного алгоритма, чтобы обучаться на аудиопотке и представить эффективное подавление. Сценарий 2: Хвост эха больше чем 32 мс маловероятен в аналоговой сети передачи голоса. Однако это может произойти в сети для речевых пакетов. Поскольку зона действия подавления эха в настоящее время максимум в 32 мс, техническая разработка идет полным ходом для создания кода, который интегрирует G.168 третьей стороны совместимый эхоподавитель (с хвостовой длиной по крайней мере 64 мс).
Шум взломщика, низкое качество голосовой связи (нагрузка телефона). Загруженное микропрограммное обеспечение P003Q301 в IP-телефон. Загрузка Q более устойчива к дрожанию и задержке.
Никакой обратный вызов к IP-телефону при вызове внешнего номера посредством QSIG. Шлюз не генерирует тон фонового сигнала вызова, пока Сообщение SETUP не содержит Индикатор хода выполнения (PI) 3 (исходный адрес не ISDN). Это вызвано тем, что шлюз предполагает, что без PI 3, исходный коммутатор является ISDN и ожидает, что коммутатор будет генерировать тон фонового сигнала вызова вместо этого. Без PI 3 установок шлюз ожидает, что коммутатор ISDN будет генерировать вызов, но коммутатор ISDN не генерирует вызов. Это может произойти из-за проблемы сетевых технологий ISDN. Чтобы позволить шлюзу генерировать тон фонового сигнала вызова, настройте progress_ind на VoIP одноранговом соединение.
dial-peer voice 1 voip
 destination-pattern 8...
  progress_ind setup enable 3
  session target ipv4:192.168.2.10
  dtmf-relay h245-alphanumeric
  codec g711ulaw
  ip precedence 5
Вышеупомянутое тогда вынудит шлюз предоставить тон фонового сигнала вызова для вызовов, прибывающих в ISDN что тандем тот VoIP одноранговый соединение.
A695422 Существует различие в длительности сигнала DTMF. Это может быть вызвано фактом, что catalyst правильно не распознает Тоны DTMF, передаваемые системой голосовой почты. При прибытии из карты Catalyst длительность сигнала DTMF составляет 300 мс по умолчанию. При прибытии из голосовой почты продолжительность составляет 130 мс. Спецификация Octel требует, чтобы по крайней мере пять цифр в секунду были необходимы для квитирования для работы должным образом. Сisco CallManager в настоящее время передает H245-SIGNALLING с продолжительностью 300 мс, делая в общей сложности 300*5 = 1.5 сек. В этой продолжительности испытает таймаут Голосовая почта Octel, прежде чем заголовки сетевой работы с голосовой почтой полностью получены. Обошедший модуль FXS с 24 портами (Облегченное устройство) со шлюзом Cisco 3640 (устройство H.323) загрузился с картой FXS.
Односторонняя передача аудиоданных для вызовов по голосовому шлюзу. Проблема вызвана шлюзом, выбирая IP-адрес кроме того из интерфейса обратной связи. Loopback является интерфейсом, от которого Трафик CallManager оставляет маршрутизатор. Поместите IP-адрес h323-gateway voip bind srcaddr на этот интерфейс, чтобы вынудить маршрутизатор использовать указанный IP - адрес в качестве адреса источника RTP.
interface Loopback0
 description ::: Loopback for BGP peering
 ip address 192.170.94.34 255.255.255.255
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 192.170.94.34
На Сisco CallManager измените устройство шлюза H.323 от названия до IP-адреса. Это также предотвращает любые нежелательные проблемы с обратными поисками DNS/хостов.
Сisco CallManager имеет известные неполадки, где ее сервисы медленно ухудшаются в течение долгого времени из-за утечки памяти. Временное приспособление должно было перезагрузить Сisco CallManager еженедельно. Установленный Windows 2000 Service Pack 1 и виртуальная память исправляют к Серверам CallManager. Как дополнительная мера предосторожности, NB советовался перезагрузить CallManagers еженедельно в течение последующих месяцев для обеспечения максимальной стабильности. NB должен решить остановить еженедельные перезагрузки когда считавший соответствующий.
A944914 WFQ не работает по Мульти-PPP по множественным ссылкам на 2 Мбит/с. Команда Service-policy для реализации LLQ исчезает, через некоторое время давая неопределенное поведение глобальной сети (WAN). Три опции доступны для обработки этой проблемы:
  • Для всех интерфейсов в связке (bundle) MPPP, набор пропускная способность на последовательных интерфейсах к по крайней мере 4800 (4/3 X 3600).
  • Обновление к 12.2.018, который является предварительным релизом 12.2. Это - DE (не TAC) поддерживаемый. Проблема устранена в этой версии.
  • Постановка в очередь с установлением приоритетa внедрения для другой разновидности QoS глобальной сети (WAN).
Кнопка сообщений по телефону не работала первоначально. Придерживающиеся параметры настройки требуются, чтобы включать Кнопку сообщений:
  • В обслуживании Параметры, введите внутренний номер речевой почты как значение для поля VoiceMailDN.
  • В Корпоративных параметрах введите внутренний номер речевой почты как значение для поля MessageDirectoryNumber.
Высокий уровень широковещательного трафика из карты E1 (WS-X6608) из-за дефекта в протоколе ARP кодирует на модуле Тонкого шлюза Catalyst 6509. Как обходной путь, карты E1 (WS-X6608) настроены в отдельной VLAN. Это уменьшает размер кэша ARP максимум к трех записей. В то же время новое Незначительное обновление микропрограммного обеспечения шлюза (D004R300) было загружено в модули для решения проблемы.
Потеря CoS по каналу WAN. Одна из новых характеристик в Cisco IOS Software Release 12.1 (5) T и позднее является сопоставлением ToS к CoS. С этим маршрутизатор может установить CoS=ToS прежде, чем передать что-либо к Catalyst 6509. Catalyst 6509 тогда настроен для trust-cos на порту маршрутизатора и берет внутреннее значение DSCP оттуда. QoS Cisco поддерживает ToS и значения CoS с помощью DSCP.
Таблица ARP была повреждена, приводя к потере аудиопотка при доступе к системе голосовой почты посредством карты WS-X6624. Как обходной путь, карты FXS (WS-X6624) настроены в отдельной VLAN. Это уменьшает размер кэша ARP максимум к трех записей. В то же время новое Незначительное обновление микропрограммного обеспечения шлюза (A002S300) было загружено в модули.
Частое зависание портов FXS соединилось с устройством Голосовой почты Octel. Эта проблема кажется распространенной с Системой голосовой почты Octel с аналогом (FXO) подключение. Когда устройство голосовой почты взаимодействуется с другими системами УАТС, количество "зависающих" портов может варьироваться. Традиционные PBXs обычно имеют возможность перезагрузить повешенные порты частного лица, не влияя на полную операцию голосовой почты. Cisco упростил утилиту DickTracy, которая позволяет пользователям перезагрузить и контролировать отдельные порты на карте FXS. Утилита DickTracy может быть установлена на любом ПК в сети. Выполните его и соединитесь с IP-адресом WS-X6624. После того, как связанный, нажмите Option. Начните регистрировать, затем введите следующие команды в поле командной строки: Для получения состояния порта введите 5 состояний показа (это предоставляет статус каждого порта. С DickTracy номера портов являются 0 основанными: Порт 1 на блейде является портом 0 в DickTracy). Для сброса порта введите придерживающееся:
4 set kill port[x] 

!--- Where x is the 0-based port number.

5 disable port x
5 enable port x
Никакой мониторинг, доступный для Многоканальной настройки. Отдельные последовательные соединения не могут быть включенным IP. Рекомендация состоит в том, чтобы использовать Протокол SNMP для опроса интерфейсного статуса. Это можно сделать несколькими способами. Протестированная опция должна создать сценарий UNIX для использования команды snmpget для сбора интерфейсного статуса тот же путь, как команда ping script делает. Другая опция должна расширить функцию MRTG (это - бесплатное программное средство SNMP к использованию collect interface) собирать интерфейсный статус. Опция должна использовать на основе SNMP приложение для управления сетью.
B300309 Маршрутизатор периодически перезагрузки из-за ошибки шины. Аномальное поведение обработчика пакетов было обнаружено в ранних пересмотрах аппаратных средств PA-2FEISL, как описано в CSCdm74172 проблемы идентификатора ошибки Cisco (только зарегистрированные клиенты). Проблемы были решены через изменение аппаратного обеспечения к Fast Ethernet с 2 портами / адаптеры портов ISL. На карты хх PA-2FEISL с номерами версии оборудования, равными или позже, чем упомянутые ниже проверки оборудования, не влияют. Проверка оборудования PA-2FEISL-TX и PA-2FEISL-FX 1.2 Проверки оборудования 2.0 нбар использовала проверку оборудования 1.1.
A953213 Неспособный обратиться к странице пользователя Сisco CallManager. Этот вопрос был решен с помощью следующей процедуры.
  1. Перейдите к странице CCMAdmin. Нажмите System на главном меню и затем нажмите Enterprise Parameters.
  2. От страницы Enterprise Parameter проверьте LDAP: Cisco Base и LDAP: параметры Пользовательской базы. (LDAP: Cisco Base должен быть o=cisco.com и LDAP: Пользовательская база должна быть ou=Users, o=cisco.com.)
После обновления этих параметров все пользователи смогли войти от страницы пользователя. Проблема была найдена в Сisco CallManager 3.0.4, где вышеупомянутые параметры были пустыми.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения